Шаблон чека для УТ 11.4

14.05.21

Учетные задачи - Кассовые операции

Доработка для отражения в чеке ККМ подробной информации о скидках/наценках для УТ 11.4.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Шаблон чека для УТ11.4:
.cfe 7,39Kb
25
25
3 SM
Скачать Купить за 2 450 руб.

Столкнулся со следующей ситуацией: при использовании УТ11 для розничных продаж потребовалось отразить информацию о скидках по акциям покупателю в чеке, но штатный функционал к сожалению весьма беден и ограничен, а шаблоны (как в РТ2) отсуствуют. Поиск ничего подходящего не дал (были варианты решения через нефискальный документ), пришлось мастерить костыль:

 
 Пример расшифровки скидок
 
 Код вывода акций в чек (для УТ11.4.1.хх-11.4.6.хх)
 
 Код вывода акций в чек (для УТ11.4.7.хх-11.4.12.хх)

Для удобства реализовано в виде расширения. Код открыт. Найдете ошибку - сообщите.

upd.20.05.19 - исправлена ошибка (комент#2)

upd.06.08.20 - изменение под версии 11.4.7 и выше (комент#7)

upd.14.05.21 - дополнение для скидки бонусом под версии 11.4.7 и выше (комент#23) - результат ниже

 
 пример отражения скидки бонусом

 

УТ11 торговля розница чек шаблон скидки акции отображение вывод информации о продаже

См. также

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    93392    119    40    

210

Оптовая торговля Розничная торговля Обмен с ГосИС Бухгалтер Платформа 1С v8.3 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полнофункциональное расширение (ранее известное как Модуль 1С-ЕГАИС) для взаимодействия типовых конфигураций 1С и ЕГАИС, предоставляющее максимум возможностей по работе с УТМ. Получение и отправка ТТН, отправка акта о постановке на баланс и акта о списании. Получение остатков. Загрузка и сопоставление номенклатуры и контрагентов. Оправка в ЕГАИС отчетов о производстве и импорте.

8970 руб.

15.12.2015    168496    755    364    

394

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия 1.6 1С:Бухгалтерия автономного учреждения 1С:CRM ПРОФ, КОРП Россия Платные (руб)

Универсальная обработка для обслуживания любых фискальных регистраторов (ККТ), в том числе Веб сервер АТОЛ. Работает в соответствии с 54-ФЗ. (ФФД 1.0, ФФД 1.05, ФФД 1.1). Подключайте любую онлайн кассу к практически любой конфигурации. Нет необходимости обновлять 1С. Можно бесплатно скачать и протестировать. Может работать одновременно с несколькими онлайн-кассами, либо одной с разных рабочих мест. (через RDP, TCP\IP или веб-сервер) Позволяет разделить один чек сразу на несколько ККТ или на несколько систем налогообложения. Поддерживает разрешительный режим. Можно настроить собственный шаблонов чека. Можно использовать эквайринг там, где он не поддерживается. Работает на LINUX и Windows ЭМУЛЯТОР + ЭКВАЙРИНГ + МАРКИРОВКА + ПОДДЕРЖКА ФФД 1.2

6000 руб.

27.02.2017    787312    4739    9507    

2812

Розничная торговля Маркетплейсы Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Платные (руб)

Модуль для интеграции 1С с сервисом СберМаркет/Купер. Предназначен для обмена данными из торговых точек розничных сетей из баз данных 1С в базы данных СберМаркет/Купер, для отображения информации по товарам, остаткам, ценам, заказам и статусам заказов. Позволяет оперативно начать работать с сервисом СберМаркет, существенно повысить продажи и лояльность клиентов.

35000 руб.

14.10.2022    8590    15    13    

10

Оптовая торговля Розничная торговля Обмен с ГосИС Программист Бухгалтер Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Платные (руб)

Данная публикация создана для помощи разработчикам, интеграторам и другим заинтересованным лицам по настройке системы маркировки обуви, одежды, лекарств, табака, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин. Смело задавайте вопросы по работе с ЦРПТ, GS1, ЭДО, Национальным каталогом, накопили достаточно большую базу знаний по данным темам и готовы ответить на все Ваши вопросы.

5000 руб.

18.03.2019    111713    28    114    

181

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия автономного учреждения Россия Платные (руб)

Обработка осуществляет обслуживание ККТ АТОЛ, Штрих и Меркурий для конфигураций "УТ 10.3", "КА 1.1", "УПП 1.3", "Розница 1.0", "БП 2.0" и других отраслевых решений, построенных на основе указанных выше конфигурациях. Поддерживает возможность параллельно пробития чеков на одной ККМ несколькими пользователями. Поддерживает Веб-сервер Атол. Соответствует требованиям 54-ФЗ. Поддерживает ФФД 1.0, 1.05, 1.1 и 1.2. Разделяет чеки по нескольким СНО. Поддерживает механизмы подключения ККТ по TCP/IP, для работы через RDP или интернет. Поддержка маркировки и разрешительного режима.

5400 руб.

25.05.2015    329237    1886    3030    

1014
Отзывы
4. Night_Trap 20.05.19 21:01 Сейчас в теме
Прилагаю дополнительный код вывода Ручной скидки при печати чека.
Автору БОЛЬШОЙ респект за материал!!!

Теперь ЧЕК под контролем!!!!

Функция Il_ПолучитьСтруктуруШаблонаЧека(ПараметрыШаблонаЧека, ДополнительныйТекст, ТипОборудования)
	ОбщиеПараметры = ПараметрыШаблонаЧека[0];
	строкМассива = ОбщиеПараметры.ПозицииЧека.Количество()-1;
	ИндексМассива=0;	КлючТовара=0;
	СуммаЧека = 0;	СуммаЧекаБезСкидки = 0;
	Пока ИндексМассива<=строкМассива Цикл
		ТекущаяПозиция = ОбщиеПараметры.ПозицииЧека[ИндексМассива];
		Если ТекущаяПозиция.Свойство("ФискальнаяСтрока") Тогда
			//ТекущаяПозиция.НомерСтрокиТовара = КлючТовара;
			СуммаЧека = СуммаЧека + ТекущаяПозиция.Сумма;
			СуммаЧекаБезСкидки = СуммаЧекаБезСкидки + ТекущаяПозиция.Цена*ТекущаяПозиция.Количество;
			Если не ТекущаяПозиция.Цена=ТекущаяПозиция.ЦенаСоСкидками Тогда
				cтрукОтбора = Новый Структура("КлючСвязи",КлючТовара+1);
				тчСкидки = ОбщиеПараметры.ДокументОснование.СкидкиНаценки.Выгрузить(cтрукОтбора, "СкидкаНаценка,Сумма");
//сначала выведем автоматические скидки по товару
				Для Каждого стрСК из тчСкидки Цикл
					струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
					струкСкидки.Текст = СтрШаблон("По акции <<%1>> скидка: %2",СокрЛП(стрСК.СкидкаНаценка),Формат(стрСК.Сумма,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
					ИндексМассива = ИндексМассива+1;
					ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
					строкМассива = строкМассива+1;
				КонецЦикла;
////////////////////////////////////////////////////////////­/////////
//мои_вставки
//далее выведем ручные скидки
				струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
				струкСкидки.Текст = "Сумма без скидки: "+Формат(ТекущаяПозиция.Цена*ТекущаяПозиция.Количество,"ЧЦ=15;ЧДЦ=2;ЧРД=,");
				ИндексМассива = ИндексМассива+1;
				ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
				строкМассива = строкМассива+1;

				струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
				ПроцентСкидки = Окр((1-ТекущаяПозиция.ЦенаСоСкидками/ТекущаяПозиция.Цена)*100,0);
				струкСкидки.Текст = "Скидка "+ПроцентСкидки+"%: "+Формат(ТекущаяПозиция.Цена-ТекущаяПозиция.ЦенаСоСкидками,"ЧЦ=15;ЧДЦ=2;ЧРД=,");
				ИндексМассива = ИндексМассива+1;
				ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
				строкМассива = строкМассива+1;
////////////////////////////////////////////////////////////­/////////
			КонецЕсли;
		КонецЕсли;
		ИндексМассива=ИндексМассива+1;
		КлючТовара=КлючТовара+1;
	КонецЦикла;
	Если не СуммаЧека=СуммаЧекаБезСкидки Тогда
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Выравнивание = "Центр";
		струкСкидки.Текст = "-------------------";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Текст = СтрШаблон("ИТОГО: %1",Формат(СуммаЧекаБезСкидки,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
		струкСкидки.Выравнивание = "Право";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Текст = СтрШаблон("ИТОГО скидка: %1",Формат(СуммаЧекаБезСкидки-СуммаЧека,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
		струкСкидки.Выравнивание = "Право";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
	КонецЕсли;
	Возврат Неопределено;
КонецФункции
Показать
Sombreone; abasovit; TerveRus; Monty_B; user689995_qalitek; independ; Il; +7 Ответить
Остальные комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Night_Trap 17.05.19 07:15 Сейчас в теме
Здравствуйте! Подскажите пожалуйста, как использовать вашу разработку?
После установки расширения скидки должны появиться в чеки автоматически или нужно что-то еще делать?
При ручных скидках в чеке данная доработка будет их отображать?
2. Night_Trap 19.05.19 21:36 Сейчас в теме
(1) Начал разбираться с доработкой.

Не перехватывает расширение обозначенные процедуры.
Чтобы заработало - комментируем или удаляем //&НаСервере

В МенеджерОборудованияКлиентПереопределяемый.
Должно получиться так

//&НаСервере
&Вместо("СформироватьШаблонЧека")
Функция Il_СформироватьШаблонЧека(ВходныеПараметры, ДополнительныйТекст, СтандартнаяОбработка, ТипОборудования)
	ШаблонЧека = МенеджерОборудованияВызовСервераПереопределяемый.ПолучитьСтруктуруШаблонаЧека(ВходныеПараметры, ДополнительныйТекст, ТипОборудования);
	Если ШаблонЧека <> Неопределено Тогда
		СтандартнаяОбработка = Ложь;
		Возврат ШаблонЧека;
	КонецЕсли;
КонецФункции
Показать


Автор молчит по моему вопросу ручной скидки. Если получиться - сделаю публикацию еще с ней :)
3. Il 30 20.05.19 02:32 Сейчас в теме
(1) как работает: при включении расширения - при наличии скидки в чеке будет расшифровка.
для ручной скидки расшифровки нет, только в общем итоге.
(2) спасибо за замечание! когда переносил из боевого расширения - ошибся... исправлю.
по поводу своей публикации - конечно можно.
4. Night_Trap 20.05.19 21:01 Сейчас в теме
Прилагаю дополнительный код вывода Ручной скидки при печати чека.
Автору БОЛЬШОЙ респект за материал!!!

Теперь ЧЕК под контролем!!!!

Функция Il_ПолучитьСтруктуруШаблонаЧека(ПараметрыШаблонаЧека, ДополнительныйТекст, ТипОборудования)
	ОбщиеПараметры = ПараметрыШаблонаЧека[0];
	строкМассива = ОбщиеПараметры.ПозицииЧека.Количество()-1;
	ИндексМассива=0;	КлючТовара=0;
	СуммаЧека = 0;	СуммаЧекаБезСкидки = 0;
	Пока ИндексМассива<=строкМассива Цикл
		ТекущаяПозиция = ОбщиеПараметры.ПозицииЧека[ИндексМассива];
		Если ТекущаяПозиция.Свойство("ФискальнаяСтрока") Тогда
			//ТекущаяПозиция.НомерСтрокиТовара = КлючТовара;
			СуммаЧека = СуммаЧека + ТекущаяПозиция.Сумма;
			СуммаЧекаБезСкидки = СуммаЧекаБезСкидки + ТекущаяПозиция.Цена*ТекущаяПозиция.Количество;
			Если не ТекущаяПозиция.Цена=ТекущаяПозиция.ЦенаСоСкидками Тогда
				cтрукОтбора = Новый Структура("КлючСвязи",КлючТовара+1);
				тчСкидки = ОбщиеПараметры.ДокументОснование.СкидкиНаценки.Выгрузить(cтрукОтбора, "СкидкаНаценка,Сумма");
//сначала выведем автоматические скидки по товару
				Для Каждого стрСК из тчСкидки Цикл
					струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
					струкСкидки.Текст = СтрШаблон("По акции <<%1>> скидка: %2",СокрЛП(стрСК.СкидкаНаценка),Формат(стрСК.Сумма,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
					ИндексМассива = ИндексМассива+1;
					ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
					строкМассива = строкМассива+1;
				КонецЦикла;
////////////////////////////////////////////////////////////­/////////
//мои_вставки
//далее выведем ручные скидки
				струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
				струкСкидки.Текст = "Сумма без скидки: "+Формат(ТекущаяПозиция.Цена*ТекущаяПозиция.Количество,"ЧЦ=15;ЧДЦ=2;ЧРД=,");
				ИндексМассива = ИндексМассива+1;
				ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
				строкМассива = строкМассива+1;

				струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
				ПроцентСкидки = Окр((1-ТекущаяПозиция.ЦенаСоСкидками/ТекущаяПозиция.Цена)*100,0);
				струкСкидки.Текст = "Скидка "+ПроцентСкидки+"%: "+Формат(ТекущаяПозиция.Цена-ТекущаяПозиция.ЦенаСоСкидками,"ЧЦ=15;ЧДЦ=2;ЧРД=,");
				ИндексМассива = ИндексМассива+1;
				ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
				строкМассива = строкМассива+1;
////////////////////////////////////////////////////////////­/////////
			КонецЕсли;
		КонецЕсли;
		ИндексМассива=ИндексМассива+1;
		КлючТовара=КлючТовара+1;
	КонецЦикла;
	Если не СуммаЧека=СуммаЧекаБезСкидки Тогда
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Выравнивание = "Центр";
		струкСкидки.Текст = "-------------------";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Текст = СтрШаблон("ИТОГО: %1",Формат(СуммаЧекаБезСкидки,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
		струкСкидки.Выравнивание = "Право";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Текст = СтрШаблон("ИТОГО скидка: %1",Формат(СуммаЧекаБезСкидки-СуммаЧека,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
		струкСкидки.Выравнивание = "Право";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
	КонецЕсли;
	Возврат Неопределено;
КонецФункции
Показать
Sombreone; abasovit; TerveRus; Monty_B; user689995_qalitek; independ; Il; +7 Ответить
6. independ 1540 07.08.19 11:32 Сейчас в теме
(4) хорошее решение, УТ 11 - 1 ККТ Штрих + несколько РМК, без проблем по просьбе заказчика сделал вывод в чеке номер/наименования кассы
5. Il 30 26.06.19 07:30 Сейчас в теме
вот хорошая статья про внешний вид чеков: public/680200/
7. kovv 4 05.08.20 14:29 Сейчас в теме
Установила расширение и не работает! Даже если сделать, как советуют (Чтобы заработало - комментируем или удаляем //&НаСервере), все равно не срабатывает ((
8. Il 30 05.08.20 14:36 Сейчас в теме
(7) версия конфигурации какая?
9. Il 30 05.08.20 15:26 Сейчас в теме
(7) проверьте, что на товары из чека есть действующие скидки
10. kovv 4 05.08.20 17:17 Сейчас в теме
версия 11.4.11.104, платформа 8.3.16. Скидка есть, все проверила. Расширение не срабатывает ((
11. Il 30 06.08.20 02:20 Сейчас в теме
(10) Проверил. Действительно ошибка. Начиная примерно с вер.11.4.7.хх функция "СформироватьШаблонЧека" переехала из клиентского модуль в серверный. А "ПолучитьСтруктуруШаблонаЧека" убрали. Чуть позже выложу рабочий код. Спасибо за помощь!
12. kovv 4 06.08.20 07:04 Сейчас в теме
Вам спасибо, что вовремя откликаетесь! Очень жду рабочий вариант!
13. Il 30 06.08.20 17:38 Сейчас в теме
(12) выложил исправление под свежие версии (код есть в описании)
14. kovv 4 06.08.20 19:38 Сейчас в теме
Спасибо!!! Проверила, все работает!!! Отдельное спасибо за оперативность!
15. Mobile888 10.02.21 17:48 Сейчас в теме
Цена товара: 145 руб.
Скидка - 3% за наличный расчет.

145 - 3% = 140,65 руб.

Но на чеке ошибки.
1. Сумма без скидки должна быть 145 руб, а пишет 136,30 руб, т.е. скидка сделалась 2 раза.
2. Итоговая сумма неверна - 136,30 руб.
3. Добавляется символ "F" в конце строки позиции.

УТ 11.4.13.103
Прикрепленные файлы:
16. Il 30 11.02.21 06:30 Сейчас в теме
(15) Действительно в этом релизе УТ ошибка.
Попробуйте пока так:
Прикрепленные файлы:
17. Il 30 11.02.21 07:58 Сейчас в теме
В общем модуле РозничныеПродажи есть ошибка
- попробуйте расширение из сообщения. Должно помочь. Или поискать оф.исправление от 1С
Прикрепленные файлы:
2_5271665223005113432.cfe
18. Il 30 12.02.21 03:16 Сейчас в теме
(15) по букве F вроде из-за шаблона (глянь тут public/1135271)
Также проверил на версии УТ11.4.13.119 - ошибку не исправили.
Mobile888; +1 Ответить
19. Sapofsky 05.03.21 14:37 Сейчас в теме
Здравствуйте. Можно приобрести не за СМ?
20. Il 30 05.03.21 15:24 Сейчас в теме
(19) Весь код в публикации - скачивать необязательно. Только проверьте версию УТ при выборе.
21. nz 07.05.21 09:10 Сейчас в теме
Добрый день. Подскажите пожалуйста как вы вывели сумму и цену без скидки?
Не получается вывести всегда со скидкой. УТ 11.4.10.75.
Спасибо.
22. Il 30 08.05.21 03:13 Сейчас в теме
(21) В чеке есть авто или ручные скидки?
проверьте в отладчике
23. nz 11.05.21 05:50 Сейчас в теме
(22) в чеке есть авто и скидка бонусами. Но насколько я понимаю у вас тоже есть.
24. Il 30 14.05.21 16:56 Сейчас в теме
(23) дополнил код для отражения скидки бонусом
25. nz 17.05.21 06:33 Сейчас в теме
(24) Наверное не могу объяснить правильно... скидки текстом вывести могу. Не получается указать цену и сумму без скидки.Хотелось получить как в файле. Спасибо.
Прикрепленные файлы:
26. Il 30 18.05.21 01:35 Сейчас в теме
(25) Понял. Но увы - так не получится. Это фискальные данные и их менять нельзя. Поэтому в моем варианте и сделана расшифровка через нефискальные строки.
27. nz 18.05.21 07:55 Сейчас в теме
Поняла... спасибо что помогли разобраться.
28. DragonAgo 16 05.03.22 11:50 Сейчас в теме
Добрый день, для ПКО будет отображать скидки?
29. Il 30 05.03.22 11:56 Сейчас в теме
(28) нет, это только для розничных продаж.
Оставьте свое сообщение