Шаблон чека для УТ 11.4

Публикация № 977982 01.03.19

Учет и отчетность - Кассовые операции

УТ11 торговля розница чек шаблон скидки акции отображение вывод информации о продаже

Доработка для отражения в чеке ККМ подробной информации о скидках/наценках для УТ 11.4.

Столкнулся со следующей ситуацией: при использовании УТ11 для розничных продаж потребовалось отразить информацию о скидках по акциям покупателю в чеке, но штатный функционал к сожалению весьма беден и ограничен, а шаблоны (как в РТ2) отсуствуют. Поиск ничего подходящего не дал (были варианты решения через нефискальный документ), пришлось мастерить костыль:

 
 Пример расшифровки скидок
 
 Код вывода акций в чек (для УТ11.4.1.хх-11.4.6.хх)
 
 Код вывода акций в чек (для УТ11.4.7.хх-11.4.12.хх)

Для удобства реализовано в виде расширения. Код открыт. Найдете ошибку - сообщите.

upd.20.05.19 - исправлена ошибка (комент#2)

upd.06.08.20 - изменение под версии 11.4.7 и выше (комент#7)

upd.14.05.21 - дополнение для скидки бонусом под версии 11.4.7 и выше (комент#23) - результат ниже

 
 пример отражения скидки бонусом

 

Скачать файлы

Наименование Файл Версия Размер
Шаблон чека для УТ11.4:

.cfe 7,39Kb
13
.cfe 2.0 7,39Kb 13 Скачать

Специальные предложения

Лучшие комментарии
4. Night_Trap 20.05.19 21:01 Сейчас в теме
Прилагаю дополнительный код вывода Ручной скидки при печати чека.
Автору БОЛЬШОЙ респект за материал!!!

Теперь ЧЕК под контролем!!!!

Функция Il_ПолучитьСтруктуруШаблонаЧека(ПараметрыШаблонаЧека, ДополнительныйТекст, ТипОборудования)
	ОбщиеПараметры = ПараметрыШаблонаЧека[0];
	строкМассива = ОбщиеПараметры.ПозицииЧека.Количество()-1;
	ИндексМассива=0;	КлючТовара=0;
	СуммаЧека = 0;	СуммаЧекаБезСкидки = 0;
	Пока ИндексМассива<=строкМассива Цикл
		ТекущаяПозиция = ОбщиеПараметры.ПозицииЧека[ИндексМассива];
		Если ТекущаяПозиция.Свойство("ФискальнаяСтрока") Тогда
			//ТекущаяПозиция.НомерСтрокиТовара = КлючТовара;
			СуммаЧека = СуммаЧека + ТекущаяПозиция.Сумма;
			СуммаЧекаБезСкидки = СуммаЧекаБезСкидки + ТекущаяПозиция.Цена*ТекущаяПозиция.Количество;
			Если не ТекущаяПозиция.Цена=ТекущаяПозиция.ЦенаСоСкидками Тогда
				cтрукОтбора = Новый Структура("КлючСвязи",КлючТовара+1);
				тчСкидки = ОбщиеПараметры.ДокументОснование.СкидкиНаценки.Выгрузить(cтрукОтбора, "СкидкаНаценка,Сумма");
//сначала выведем автоматические скидки по товару
				Для Каждого стрСК из тчСкидки Цикл
					струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
					струкСкидки.Текст = СтрШаблон("По акции <<%1>> скидка: %2",СокрЛП(стрСК.СкидкаНаценка),Формат(стрСК.Сумма,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
					ИндексМассива = ИндексМассива+1;
					ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
					строкМассива = строкМассива+1;
				КонецЦикла;
////////////////////////////////////////////////////////////­/////////
//мои_вставки
//далее выведем ручные скидки
				струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
				струкСкидки.Текст = "Сумма без скидки: "+Формат(ТекущаяПозиция.Цена*ТекущаяПозиция.Количество,"ЧЦ=15;ЧДЦ=2;ЧРД=,");
				ИндексМассива = ИндексМассива+1;
				ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
				строкМассива = строкМассива+1;

				струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
				ПроцентСкидки = Окр((1-ТекущаяПозиция.ЦенаСоСкидками/ТекущаяПозиция.Цена)*100,0);
				струкСкидки.Текст = "Скидка "+ПроцентСкидки+"%: "+Формат(ТекущаяПозиция.Цена-ТекущаяПозиция.ЦенаСоСкидками,"ЧЦ=15;ЧДЦ=2;ЧРД=,");
				ИндексМассива = ИндексМассива+1;
				ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
				строкМассива = строкМассива+1;
////////////////////////////////////////////////////////////­/////////
			КонецЕсли;
		КонецЕсли;
		ИндексМассива=ИндексМассива+1;
		КлючТовара=КлючТовара+1;
	КонецЦикла;
	Если не СуммаЧека=СуммаЧекаБезСкидки Тогда
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Выравнивание = "Центр";
		струкСкидки.Текст = "-------------------";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Текст = СтрШаблон("ИТОГО: %1",Формат(СуммаЧекаБезСкидки,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
		струкСкидки.Выравнивание = "Право";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Текст = СтрШаблон("ИТОГО скидка: %1",Формат(СуммаЧекаБезСкидки-СуммаЧека,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
		струкСкидки.Выравнивание = "Право";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
	КонецЕсли;
	Возврат Неопределено;
КонецФункции
Показать
i_a; Terve!R; Monty_B; user689995_qalitek; independ; Il; +6 Ответить
Остальные комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Night_Trap 17.05.19 07:15 Сейчас в теме
Здравствуйте! Подскажите пожалуйста, как использовать вашу разработку?
После установки расширения скидки должны появиться в чеки автоматически или нужно что-то еще делать?
При ручных скидках в чеке данная доработка будет их отображать?
2. Night_Trap 19.05.19 21:36 Сейчас в теме
(1) Начал разбираться с доработкой.

Не перехватывает расширение обозначенные процедуры.
Чтобы заработало - комментируем или удаляем //&НаСервере

В МенеджерОборудованияКлиентПереопределяемый.
Должно получиться так

//&НаСервере
&Вместо("СформироватьШаблонЧека")
Функция Il_СформироватьШаблонЧека(ВходныеПараметры, ДополнительныйТекст, СтандартнаяОбработка, ТипОборудования)
	ШаблонЧека = МенеджерОборудованияВызовСервераПереопределяемый.ПолучитьСтруктуруШаблонаЧека(ВходныеПараметры, ДополнительныйТекст, ТипОборудования);
	Если ШаблонЧека <> Неопределено Тогда
		СтандартнаяОбработка = Ложь;
		Возврат ШаблонЧека;
	КонецЕсли;
КонецФункции
Показать


Автор молчит по моему вопросу ручной скидки. Если получиться - сделаю публикацию еще с ней :)
3. Il 25 20.05.19 02:32 Сейчас в теме
(1) как работает: при включении расширения - при наличии скидки в чеке будет расшифровка.
для ручной скидки расшифровки нет, только в общем итоге.
(2) спасибо за замечание! когда переносил из боевого расширения - ошибся... исправлю.
по поводу своей публикации - конечно можно.
4. Night_Trap 20.05.19 21:01 Сейчас в теме
Прилагаю дополнительный код вывода Ручной скидки при печати чека.
Автору БОЛЬШОЙ респект за материал!!!

Теперь ЧЕК под контролем!!!!

Функция Il_ПолучитьСтруктуруШаблонаЧека(ПараметрыШаблонаЧека, ДополнительныйТекст, ТипОборудования)
	ОбщиеПараметры = ПараметрыШаблонаЧека[0];
	строкМассива = ОбщиеПараметры.ПозицииЧека.Количество()-1;
	ИндексМассива=0;	КлючТовара=0;
	СуммаЧека = 0;	СуммаЧекаБезСкидки = 0;
	Пока ИндексМассива<=строкМассива Цикл
		ТекущаяПозиция = ОбщиеПараметры.ПозицииЧека[ИндексМассива];
		Если ТекущаяПозиция.Свойство("ФискальнаяСтрока") Тогда
			//ТекущаяПозиция.НомерСтрокиТовара = КлючТовара;
			СуммаЧека = СуммаЧека + ТекущаяПозиция.Сумма;
			СуммаЧекаБезСкидки = СуммаЧекаБезСкидки + ТекущаяПозиция.Цена*ТекущаяПозиция.Количество;
			Если не ТекущаяПозиция.Цена=ТекущаяПозиция.ЦенаСоСкидками Тогда
				cтрукОтбора = Новый Структура("КлючСвязи",КлючТовара+1);
				тчСкидки = ОбщиеПараметры.ДокументОснование.СкидкиНаценки.Выгрузить(cтрукОтбора, "СкидкаНаценка,Сумма");
//сначала выведем автоматические скидки по товару
				Для Каждого стрСК из тчСкидки Цикл
					струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
					струкСкидки.Текст = СтрШаблон("По акции <<%1>> скидка: %2",СокрЛП(стрСК.СкидкаНаценка),Формат(стрСК.Сумма,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
					ИндексМассива = ИндексМассива+1;
					ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
					строкМассива = строкМассива+1;
				КонецЦикла;
////////////////////////////////////////////////////////////­/////////
//мои_вставки
//далее выведем ручные скидки
				струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
				струкСкидки.Текст = "Сумма без скидки: "+Формат(ТекущаяПозиция.Цена*ТекущаяПозиция.Количество,"ЧЦ=15;ЧДЦ=2;ЧРД=,");
				ИндексМассива = ИндексМассива+1;
				ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
				строкМассива = строкМассива+1;

				струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
				ПроцентСкидки = Окр((1-ТекущаяПозиция.ЦенаСоСкидками/ТекущаяПозиция.Цена)*100,0);
				струкСкидки.Текст = "Скидка "+ПроцентСкидки+"%: "+Формат(ТекущаяПозиция.Цена-ТекущаяПозиция.ЦенаСоСкидками,"ЧЦ=15;ЧДЦ=2;ЧРД=,");
				ИндексМассива = ИндексМассива+1;
				ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
				строкМассива = строкМассива+1;
////////////////////////////////////////////////////////////­/////////
			КонецЕсли;
		КонецЕсли;
		ИндексМассива=ИндексМассива+1;
		КлючТовара=КлючТовара+1;
	КонецЦикла;
	Если не СуммаЧека=СуммаЧекаБезСкидки Тогда
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Выравнивание = "Центр";
		струкСкидки.Текст = "-------------------";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Текст = СтрШаблон("ИТОГО: %1",Формат(СуммаЧекаБезСкидки,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
		струкСкидки.Выравнивание = "Право";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Текст = СтрШаблон("ИТОГО скидка: %1",Формат(СуммаЧекаБезСкидки-СуммаЧека,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
		струкСкидки.Выравнивание = "Право";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
	КонецЕсли;
	Возврат Неопределено;
КонецФункции
Показать
i_a; Terve!R; Monty_B; user689995_qalitek; independ; Il; +6 Ответить
6. independ 1341 07.08.19 11:32 Сейчас в теме
(4) хорошее решение, УТ 11 - 1 ККТ Штрих + несколько РМК, без проблем по просьбе заказчика сделал вывод в чеке номер/наименования кассы
5. Il 25 26.06.19 07:30 Сейчас в теме
вот хорошая статья про внешний вид чеков: public/680200/
7. kovv 4 05.08.20 14:29 Сейчас в теме
Установила расширение и не работает! Даже если сделать, как советуют (Чтобы заработало - комментируем или удаляем //&НаСервере), все равно не срабатывает ((
8. Il 25 05.08.20 14:36 Сейчас в теме
(7) версия конфигурации какая?
9. Il 25 05.08.20 15:26 Сейчас в теме
(7) проверьте, что на товары из чека есть действующие скидки
10. kovv 4 05.08.20 17:17 Сейчас в теме
версия 11.4.11.104, платформа 8.3.16. Скидка есть, все проверила. Расширение не срабатывает ((
11. Il 25 06.08.20 02:20 Сейчас в теме
(10) Проверил. Действительно ошибка. Начиная примерно с вер.11.4.7.хх функция "СформироватьШаблонЧека" переехала из клиентского модуль в серверный. А "ПолучитьСтруктуруШаблонаЧека" убрали. Чуть позже выложу рабочий код. Спасибо за помощь!
12. kovv 4 06.08.20 07:04 Сейчас в теме
Вам спасибо, что вовремя откликаетесь! Очень жду рабочий вариант!
13. Il 25 06.08.20 17:38 Сейчас в теме
(12) выложил исправление под свежие версии (код есть в описании)
14. kovv 4 06.08.20 19:38 Сейчас в теме
Спасибо!!! Проверила, все работает!!! Отдельное спасибо за оперативность!
15. Mobile888 10.02.21 17:48 Сейчас в теме
Цена товара: 145 руб.
Скидка - 3% за наличный расчет.

145 - 3% = 140,65 руб.

Но на чеке ошибки.
1. Сумма без скидки должна быть 145 руб, а пишет 136,30 руб, т.е. скидка сделалась 2 раза.
2. Итоговая сумма неверна - 136,30 руб.
3. Добавляется символ "F" в конце строки позиции.

УТ 11.4.13.103
Прикрепленные файлы:
16. Il 25 11.02.21 06:30 Сейчас в теме
(15) Действительно в этом релизе УТ ошибка.
Попробуйте пока так:
Прикрепленные файлы:
17. Il 25 11.02.21 07:58 Сейчас в теме
В общем модуле РозничныеПродажи есть ошибка
- попробуйте расширение из сообщения. Должно помочь. Или поискать оф.исправление от 1С
Прикрепленные файлы:
2_5271665223005113432.cfe
18. Il 25 12.02.21 03:16 Сейчас в теме
(15) по букве F вроде из-за шаблона (глянь тут public/1135271)
Также проверил на версии УТ11.4.13.119 - ошибку не исправили.
Mobile888; +1 Ответить
19. Sapofsky 05.03.21 14:37 Сейчас в теме
Здравствуйте. Можно приобрести не за СМ?
20. Il 25 05.03.21 15:24 Сейчас в теме
(19) Весь код в публикации - скачивать необязательно. Только проверьте версию УТ при выборе.
21. nz 07.05.21 09:10 Сейчас в теме
Добрый день. Подскажите пожалуйста как вы вывели сумму и цену без скидки?
Не получается вывести всегда со скидкой. УТ 11.4.10.75.
Спасибо.
22. Il 25 08.05.21 03:13 Сейчас в теме
(21) В чеке есть авто или ручные скидки?
проверьте в отладчике
23. nz 11.05.21 05:50 Сейчас в теме
(22) в чеке есть авто и скидка бонусами. Но насколько я понимаю у вас тоже есть.
24. Il 25 14.05.21 16:56 Сейчас в теме
(23) дополнил код для отражения скидки бонусом
25. nz 17.05.21 06:33 Сейчас в теме
(24) Наверное не могу объяснить правильно... скидки текстом вывести могу. Не получается указать цену и сумму без скидки.Хотелось получить как в файле. Спасибо.
Прикрепленные файлы:
26. Il 25 18.05.21 01:35 Сейчас в теме
(25) Понял. Но увы - так не получится. Это фискальные данные и их менять нельзя. Поэтому в моем варианте и сделана расшифровка через нефискальные строки.
27. nz 18.05.21 07:55 Сейчас в теме
Поняла... спасибо что помогли разобраться.
Оставьте свое сообщение

См. также

Расход с розничных складов в ценах АТТ с колонкой Штрихкод

Печатные формы документов Розничная торговля Учет ТМЦ v8 v8::ОУ УТ10 УУ Абонемент ($m)

Обработка позволяет формировать печатную форму расхода с розничных складов в ценах АТТ с добавленной колонкой Штрихкод. Позволяет удобнее комплектовать товар по накладной или при работе загрузки из Excel.

1 стартмани

14.10.2021    542    0    tatoshka0403    0    

Накладная на перемещение с розничными ценами для УТ 11

Розничная торговля Печатные формы документов Учет ТМЦ v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Внешняя печатная форма: "Накладная на перемещение", дополнительно содержащая колонки розничной цены и суммы.

1 стартмани

08.09.2021    512    0    Anna_arbuz    0    

Журнал документов по контрагенту (УТ 11.4)

Оптовая торговля Розничная торговля v8 v8::ОУ v8::УФ v8::СКД УТ11 УУ Абонемент ($m)

Отчет формирует журнал всех документов по определенному контрагенту. Для конфигурации Управление торговлей 11.4

1 стартмани

10.08.2021    842    4    Ant10    0    

Анализ активности продавцов для УТ 11 Промо

Управленческие Розничная торговля Розничная торговля v8 v8::ОУ v8::СКД УТ11 Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Отчет позволяет проанализировать качество работы продавцов, а также сравнить показатели розничных точек продаж (магазинов).

5 стартмани

26.11.2018    18840    6    Zalipaka    0    

Остатки товара на складах с ценами номенклатуры (УТ 11.4)

Оптовая торговля Розничная торговля Ценообразование, анализ цен Учет ТМЦ v8 v8::ОУ v8::УФ v8::СКД УТ11 УУ Абонемент ($m)

Внешний отчет по остаткам товара на складах с ценами номенклатуры. Для конфигурации Управление Торговлей 11.4.

1 стартмани

22.07.2021    1443    4    Ant10    0    

Отчет по продажам за день в УТ 11.4

Розничная торговля Кассовые операции v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Продажи в Управлении торговлей. В отчет попадают все документы приходов и расходов.

2 стартмани

20.07.2021    1128    7    LemO_on    4    

Отчет по среднему чеку в торговле УТ 11; КА 2 Промо

Управленческие Розничная торговля Розничная торговля v8::ОУ v8::УФ УТ11 УУ Абонемент ($m)

Данный отчет позволяет посмотреть средние чеки в разрезе продавцов, магазинов и ККМ в конфигурации "Управление торговлей 11". Данный отчет был протестирован на конфигурации Управление торговлей 11.4.12.91.

3 стартмани

15.03.2018    24930    47    zaika007    23    

Отчет о розничных продажах с закупочной ценой для УТ 11.4

Печатные формы документов Розничная торговля v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Печатная форма с подключением "Отчет о розничных продажах" с закупочной ценой.

1 стартмани

11.04.2021    1447    5    Makyrka    2    

Отчет по чекам ККМ, по продавцам, по дням, по видам оплаты для УТ 10.3

Кассовые операции Розничная торговля v8 v8::ОУ v8::СКД УТ10 Россия УУ Абонемент ($m)

Отчет показывает чеки ККМ по продавцам за каждый день торговли. Или чеки по видам оплаты.

1 стартмани

08.04.2021    2222    2    archi517    0    

Оборачиваемость товаров на складах (неликвиды)

Оптовая торговля Розничная торговля Ценообразование, анализ цен v8 v8::ОУ v8::СКД УТ10 Россия УУ Абонемент ($m)

Залежалый товар - враг торговли. Занимает место, затрачены деньги. Выявить такой товар как на оптовых, так и розничных складах помогут эти отчеты для конфигурации Управление торговлей 10.3. Продать товар поможет уценка.

3 стартмани

30.03.2021    1978    0    Ликреонский    0    

Время продаж чеков по магазинам в УТ 11, КА. Аналитический отчет + Диаграмма Промо

Управленческие Розничная торговля Розничная торговля v8 v8::ОУ УТ10 УТ11 КА2 Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

Отчет "Диаграмма по времени продаж чеков" предназначен для планирования графиков работы продавцов-менеджеров, для планирования маркетинговых мероприятий.

2 стартмани

16.03.2018    28447    29    zaika007    19    

Печать контрагента в товарном чеке, Чеке ККМ, РМК, Реестре торговых документов

Розничная торговля Кассовые операции Печатные формы документов v8 v8::ОУ УТ11 БУ Абонемент ($m)

Печатная форма для товарного чека ККМ, в которой отображается Контрагент (покупатель) из-под РМК. Добавлен выбор контрагента на форме документа Чек ККМ и из РМК. А также позволяет вести Учет контрагентов в товарном чеке (Чек ККМ). Для УТ 11 4.13.103 / 119.

2 стартмани

12.02.2021    1890    2    user1479207    1    

Скидки по чекам для УТ 11

Розничная торговля Ценообразование, анализ цен v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Это внешний отчет. Выводит информацию о скидках по чекам.

1 стартмани

17.12.2020    2093    8    ismashik    0    

Формирование кассовой книги по подразделению за период. УТ 11.4 и Розница 2.3

Кассовые операции v8 v8::ОУ УТ11 Россия БУ Абонемент ($m)

Обработка предназначена для следующих целей: 1. Автоматического формирования листов кассовой книги по дням по существующим ПКО, РКО за выбранный период по подразделению. 2. Вывода на печать комплекта документов (лист кассовой книги, ПКО, РКО) за выбранный период. 3. Подстановки в печатные формы (лист кассовой книги, ПКО, РКО) в строки «кассир», «бухгалтер», «главный бухгалтер», «руководитель организации» ФИО ответственного лица по обособленному подразделению.

5 стартмани

23.11.2020    2589    7    user620742_mister.tda    2    

Валовая прибыль (1С: Розница 2.3) Управляемые формы Промо

Управленческие Учет доходов и расходов Розничная торговля Учет доходов и расходов Розничная торговля v8::ОУ v8::УФ Розница Россия УУ Абонемент ($m)

Отчет позволяет проанализировать продажи. Пригодится тем, кому не подходит или неудобен стандартный функционал расчета себестоимости в рознице 2.2 и 2.3.

3 стартмани

26.04.2017    52948    196    cezarj    55    

Расширение: отчет "Кассовая книга" - сортировка по номерам документов. Бух.3.0

Кассовые операции v8::ОУ БП3.0 Россия БУ Абонемент ($m)

Расширение содержит доработанный отчет "Кассовая книга" - доработана сортировка документов по номерам документов. Проверено на версиях Бух.3.0.78.69, 3.0.80.36, 3.0.81.23.

1 стартмани

12.08.2020    2299    1    user_2010    0    

Скорость продаж для УТ 11 с учетом наличия товаров

Оптовая торговля Розничная торговля v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Отчет для типовой конфигурации "Управление торговлей" 11.х. Платформа 8.3.17.1386. Выводит дни наличия и отсутствия, остатки на начало, конец периода и средние, продажи, приход, расход, скорость продаж, оборачиваемость товаров за период и оборачиваемость на конец периода. Предназначен для оптимизации складской логистики (уменьшения затрат) и устранения дефектуры товара (упущенной прибыли). Встраивается в дополнительные отчеты.

1 стартмани

28.07.2020    5794    27    yc_2011    8    

Ведомость по партиям регистра Себестоимость с разбиением оборотов. УТ 11.4

Оптовая торговля Розничная торговля Учет ТМЦ Управленческие v8 v8::ОУ УТ11 УУ Абонемент ($m)

Аналог отчета "Ведомость по партиям товаров" с разбиением показателей Приход/Расход на пункты: -Поступления-Продажи-Сборка-Оприходование/списание-Перемещения-Корректировки-Внутреннее товародвижение-Прочие обороты. Строится на основании регистра "Себестоимость товаров"

1 стартмани

27.04.2020    4876    21    user834357    0    

Неликвиды на складе: Pro и Lite версия. Редактирование реквизита в таблице документа. Для конфигурации УТ 11.х, ERP 2.x, КА 2.х 1С Предприятие 8.3 Промо

Управленческие Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8 v8::ОУ ERP2 УТ11 КА2 Оптовая торговля, дистрибуция, логистика УУ Абонемент ($m)

Внешний отчет для анализа товаров, находящихся на складе без движения. Работает для конфигураций 1С УТ 11.х, ERP 2.x, КА 2.х. Отчет отображает товары на складах, движения по которым не производились в течении заданного периода дней. Подключается как внешний отчет в конфигурации 1С Управление торговлей 11. В Pro версии можно установить общий реквизит номенклатуры, для дальнейшего включения в отбор в установке цен номенклатуры. Редактирование в табличном документе ускоряет процесс работы с неликвидами номенклатуры на складах. Отчет можно использовать для стоимостной оценки товаров на складах. Полный доступ к тексту модулей и СКД.

1 стартмани

17.06.2016    45529    66    Ликреонский    2    

Чек ККМ для УТ 10.3

Печатные формы документов Розничная торговля v8 v8::ОУ УТ10 Россия БУ Абонемент ($m)

Стандартная форма чека ККМ, сделанная как внешняя печатная форма с целью внесения произвольных изменений, чтобы не трогать саму конфигурацию.

2 стартмани

14.04.2020    3662    4    kubatay    0    

Товарный чек для УТ 10.3 из документа "Реализация товаров и услуг", товары и услуги

Печатные формы документов Розничная торговля v8 v8::ОУ УТ10 Россия БУ Абонемент ($m)

Внешняя печатная форма "Товарный чек" для конфигурации УТ 10.3 из документа "Реализация", по товарам и услугам.

1 стартмани

08.04.2020    3482    3    TuristDR    0    

Товары без движения. Отчет для УТ 11.4

Оптовая торговля Розничная торговля Управленческие v8 v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика УУ Абонемент ($m)

Отчет показывает стоимость товаров на складе по любому из доступных видов цен, количество дней с момента последнего прихода и продажи, а также даты последних прихода, продажи и переоценки.

1 стартмани

04.04.2020    5973    53    ErAK    13    

Отчет мерчендайзера Промо

Оптовая торговля Розничная торговля Управленческие Оптовая торговля Розничная торговля v8::ОУ УТ10 Оптовая торговля, дистрибуция, логистика УУ Абонемент ($m)

Итак, отчет для мерчендайзера. Разрабатывался для Управления торговлей 10.3, и предназначен для формирования бланков отчета мерчендайзера на день или за период. Теперь не нужно открывать Excel, заполнять по памяти список торговых точек и номенклатуры, путаясь в том - кому какая поставлялась. Все это подбирается и может быть отредактировано, сохранено и распечатано из данного отчета. В справке описан порядок работы с отчетом.

1 стартмани

08.09.2013    33317    48    Krasnyj    11    

Повторная печать кодов маркировки, автоматическое заполнение реквизитов в УТ 11.4

Оптовая торговля Розничная торговля Ценники v8 v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Легкая промышленность, мода и одежда Россия Абонемент ($m)

Расширение для конфигурации "Управление торговлей 11.4.11.67", позволяющее повторно распечатывать коды маркировки, полученные через СУЗ. Также расширение оптимизирует работу с помощью автоматического заполнения реквизитов. В релизе 11.4.11.84 повторная печать кодов маркировки работает без дополнения. Выкладываю расширение с оставшимися функциями. Дополнительно исправлена ошибка при подборе маркированной продукции.

1 стартмани

21.02.2020    7496    18    boba13    10    

ABC анализ продаж

Оптовая торговля Розничная торговля v8 v8::ОУ УТ11 УУ Абонемент ($m)

В отчете ведется динамический расчет Категорий "АВС" по сумме и по количеству, которое было продано.

1 стартмани

20.02.2020    4230    16    M_A_D    11    

Рабочее место кассира с возможностью работы с "заказами". УТ 11.4

Рабочее место Розничная торговля v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Расширение добавляет выбор заказа в РМК УТ 11.4.

1 стартмани

11.02.2020    5395    17    Makyrka    6    

Автоматические скидки в розничной торговле без карт лояльности (дисконтных карт). УТ 11

Розничная торговля v8 v8::ОУ ERP2 УТ11 КА2 УУ Абонемент ($m)

В УТ 11, КА 2, ERP 2 можно настроить работу с автоматическими скидками без использования карт лояльности. Скидки предоставляются непосредственно клиенту. Есть только небольшая проблемка: Рабочее Место Кассира (РМК) работает только с картами лояльности, а ввести клиента (партнера) нельзя. Данное расширение модифицирует РМК для ввода клиента - получателя скидки. Проверено на УТ 11.4.11.55, КА 2.4.11.63, ERP 2.4.11.63

1 стартмани

27.01.2020    5774    5    pparshin    0    

Стоимостная оценка склада в ценах номенклатуры для НТТ

Учет ТМЦ Ценообразование, анализ цен Розничная торговля v8::ОУ УПП1 Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Внешний отчет для УПП 1.3 формируется не только по складам, но и по НТТ. Результат выгружается в *.txt файл(ы).

1 стартмани

21.01.2020    3451    1    FullMoon    0    

Розничные продажи со скидками по чекам ККМ и возвраты (ERP 2.4, УТ 11.4, КА 2.4)

Розничная торговля Управленческие v8::ОУ v8::УФ ERP2 УТ11 КА2 Россия УУ Абонемент ($m)

Внешний отчет "Розничные продажи со скидками по чекам ККМ и возвраты" для ERP 2.4, УТ 11.4, КА 2.4 для вывода информации о предоставляемых скидках. Отчет необходим для анализа какой предоставляется процент скидки и сколько делается возвратов по чекам ККМ. Отчет по розничным продажам берет данные с проведенных документов "Чек ККМ" и "ЧекККМВозврат".

2 стартмани

18.12.2019    6070    10    SergAl    7    

Остатки и цены в справочнике Номенклатура для 1С:Розница 2.3 (расширение)

Розничная торговля v8::ОУ Розница Россия УУ Абонемент ($m)

Расширение показывает остатки и цены в форме справочника номенклатура, по аналогии как это было в УТ 10.3.

1 стартмани

10.12.2019    10786    81    Dilovar9    20    

Расширение для РМК с отображением остатка и редактированием цены. УТ 11

Розничная торговля Рабочее место v8 v8::ОУ УТ11 Россия Абонемент ($m)

Расширение для РМК УТ 11 будет полезно как на начальном этапе автоматизации торгового предприятия, когда не внесены еще все цены и весь ассортимент, а продажа уже осуществляется , так и полностью автоматизированному объекту, когда при продаже нужен остаток на складе.

1 стартмани

23.11.2019    5951    23    Oleg_46    3    

Анализ остатков и продаж, План закупок на основании остатков и продаж для 1С:Розница 2.3 и 1С:Управление торговлей 11.4

Розничная торговля Учет ТМЦ Управленческие Оптовая торговля Управление торговлей v8::ОУ v8::СПР v8::УФ v8::СКД Розница УТ11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Отчет "Анализ остатков и продаж" позволяет в одном отчете видеть одновременно текущую цену, остатки товаров и сумму остатков в выбранном типе цен на конечную дату, а также среднюю цену по которой был продан товар, количество и сумму продажи товаров за период. Отчет "План закупок на основании остатков и продаж" позволяет сформировать остатки и продажи за период и на основании этих данных с учетом расчета количества месяцев на перед рассчитать потребность в товаре и вычислить план необходимой закупки.

5 стартмани

29.09.2019    12351    45    globarh    10    

Рабочий стол директора розничного магазина для УТ 11.4

Рабочее место Розничная торговля Внешние источники данных Розничная торговля v8 v8::ОУ УТ11 Молдова Россия УУ Абонемент ($m)

Понадобилось ускорить типовую выгрузку из 1С во Фронтол, т.к. в компании установки цен проводятся ежедневно на разные группы товаров и заведующие устали выгружать каждый раз по несколько десятков минут, иные и свыше 1-го часа. Родилась обработка сначала для выгрузки товаров на кассы, а затем понемногу обросло всем остальным. Делалось и тестировалось на УТ 11.4.9.70. Также будет полезно тем, кто выгружает скидки во Фронтол.

1 стартмани

10.09.2019    5076    4    BelikJan    2    

Расширение для печати этикеток в командном режиме

Ценники Розничная торговля Розничная торговля v8::ОУ ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Решение проблемы при невозможности считывания этикеток сканером штрих-кода из-за плохого качества печати. Печать этикеток и ценников для товаров, на принтер этикеток, подключенный через драйвер производителя. Новая форма редактирования шаблонов для принтера этикеток.

5 стартмани

09.08.2019    5882    7    prof-it60    19    

Повторное использование подарочных сертификатов. Управление торговлей 11.4. Расширение

Рабочее место Розничная торговля Розничная торговля v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

В конфигурации «Управление торговлей» отсутствует механизм «повторного» использования подарочных сертификатов. Предлагается один из возможных вариантов реализации данного функционала расширением 1С.

5 стартмани

31.07.2019    9613    21    VsHome    13    

Анализ товарооборота по торговым точкам для УТ, КА, УПП

Розничная торговля Управленческие Розничная торговля v8::ОУ УТ10 УПП1 Россия УУ Абонемент ($m)

Отчет предназначен для анализа наличия избытка или недостатка того или иного товара в торговых точках предприятия. Тестировался на УТ 10.3 "Управление торговлей", редакция 10.3 (10.3.45.3) и УПП 1.3 Управление производственным предприятием, редакция 1.3 (1.3.96.1) /обычное приложение/, но должен работать и на КА обычное приложение.

1 стартмани

29.07.2019    5204    3    vik2006    0    

Этикетка Номенклатура+Серия на типовых шаблонах 1С

Ценники Розничная торговля Розничная торговля v8::ОУ ERP2 КА2 Россия УУ Абонемент ($m)

Сдвоенная этикетка номенклатура +серия с использованием типовых шаблонов этикеток. Два штрихкода на одной этикетке. Этикетки печатаются прямо из документов.

2 стартмани

25.07.2019    7957    16    kwazi    0    

Анализ доступности товаров с количеством дней без расхода, продажи, нулевого остатка и со стоимостными показателями

Оптовая торговля Розничная торговля Управленческие Оптовая торговля Розничная торговля v8 v8::ОУ УТ10 УПП1 УУ Абонемент ($m)

Добавляем в отчет доступности товаров на складах очевидные для руководителей, закупщиков и аналитиков показатели.

1 стартмани

26.06.2019    5436    9    psih12    0    

Отчет за смену из РМК для УТ 11

Управленческие Розничная торговля Розничная торговля v8 v8::ОУ УТ11 УУ Абонемент ($m)

Краткий отчет о продажах за смену из режима РМК (рабочее место кассира) для УТ 11

1 стартмани

19.06.2019    9863    21    kassbar    11    

Печать ценников с двойной ценой (скидка) для УТ 11.4

Ценники Розничная торговля Розничная торговля v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Обработка печати ценников со скидкой и выбором макета ценника.

1 стартмани

04.06.2019    8541    48    Makyrka    12    

Отчет по чекам с разбивкой чеков по типам оплаты

Управленческие Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Отчет по чекам ККМ с отбором по периоду и выводом данных по типу оплаты.

1 стартмани

30.05.2019    4129    6    Makyrka    4