Шаблон чека для УТ 11.4

Публикация № 977982

Учет и отчетность - Кассовые операции

УТ11 торговля розница чек шаблон скидки акции отображение вывод информации о продаже

Доработка для отражения в чеке ККМ подробной информации о скидках/наценках для УТ 11.4.

Столкнулся со следующей ситуацией: при использовании УТ11 для розничных продаж потребовалось отразить информацию о скидках по акциям покупателю в чеке, но штатный функционал к сожалению весьма беден и ограничен, а шаблоны (как в РТ2) отсуствуют. Поиск ничего подходящего не дал (были варианты решения через нефискальный документ), пришлось мастерить костыль:

 
 Пример расшифровки скидок
 
 Код вывода акций в чек (для УТ11.4.1.хх-11.4.6.хх)
 
 Код вывода акций в чек (для УТ11.4.7.хх-11.4.12.хх)

Для удобства реализовано в виде расширения. Код открыт. Найдете ошибку - сообщите.

upd.20.05.19 - исправлена ошибка (комент#2)

upd.06.08.20 - изменение под версии 11.4.7 и выше (комент#7)

Скачать файлы

Наименование Файл Версия Размер
Шаблон чека для УТ11.4:

.cfe 7,39Kb
06.08.20
3
.cfe 2.0 7,39Kb 3 Скачать

Специальные предложения

Лучшие комментарии
4. Night_Trap 20.05.19 21:01 Сейчас в теме
Прилагаю дополнительный код вывода Ручной скидки при печати чека.
Автору БОЛЬШОЙ респект за материал!!!

Теперь ЧЕК под контролем!!!!

Функция Il_ПолучитьСтруктуруШаблонаЧека(ПараметрыШаблонаЧека, ДополнительныйТекст, ТипОборудования)
	ОбщиеПараметры = ПараметрыШаблонаЧека[0];
	строкМассива = ОбщиеПараметры.ПозицииЧека.Количество()-1;
	ИндексМассива=0;	КлючТовара=0;
	СуммаЧека = 0;	СуммаЧекаБезСкидки = 0;
	Пока ИндексМассива<=строкМассива Цикл
		ТекущаяПозиция = ОбщиеПараметры.ПозицииЧека[ИндексМассива];
		Если ТекущаяПозиция.Свойство("ФискальнаяСтрока") Тогда
			//ТекущаяПозиция.НомерСтрокиТовара = КлючТовара;
			СуммаЧека = СуммаЧека + ТекущаяПозиция.Сумма;
			СуммаЧекаБезСкидки = СуммаЧекаБезСкидки + ТекущаяПозиция.Цена*ТекущаяПозиция.Количество;
			Если не ТекущаяПозиция.Цена=ТекущаяПозиция.ЦенаСоСкидками Тогда
				cтрукОтбора = Новый Структура("КлючСвязи",КлючТовара+1);
				тчСкидки = ОбщиеПараметры.ДокументОснование.СкидкиНаценки.Выгрузить(cтрукОтбора, "СкидкаНаценка,Сумма");
//сначала выведем автоматические скидки по товару
				Для Каждого стрСК из тчСкидки Цикл
					струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
					струкСкидки.Текст = СтрШаблон("По акции <<%1>> скидка: %2",СокрЛП(стрСК.СкидкаНаценка),Формат(стрСК.Сумма,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
					ИндексМассива = ИндексМассива+1;
					ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
					строкМассива = строкМассива+1;
				КонецЦикла;
////////////////////////////////////////////////////////////­/////////
//мои_вставки
//далее выведем ручные скидки
				струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
				струкСкидки.Текст = "Сумма без скидки: "+Формат(ТекущаяПозиция.Цена*ТекущаяПозиция.Количество,"ЧЦ=15;ЧДЦ=2;ЧРД=,");
				ИндексМассива = ИндексМассива+1;
				ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
				строкМассива = строкМассива+1;

				струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
				ПроцентСкидки = Окр((1-ТекущаяПозиция.ЦенаСоСкидками/ТекущаяПозиция.Цена)*100,0);
				струкСкидки.Текст = "Скидка "+ПроцентСкидки+"%: "+Формат(ТекущаяПозиция.Цена-ТекущаяПозиция.ЦенаСоСкидками,"ЧЦ=15;ЧДЦ=2;ЧРД=,");
				ИндексМассива = ИндексМассива+1;
				ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
				строкМассива = строкМассива+1;
////////////////////////////////////////////////////////////­/////////
			КонецЕсли;
		КонецЕсли;
		ИндексМассива=ИндексМассива+1;
		КлючТовара=КлючТовара+1;
	КонецЦикла;
	Если не СуммаЧека=СуммаЧекаБезСкидки Тогда
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Выравнивание = "Центр";
		струкСкидки.Текст = "-------------------";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Текст = СтрШаблон("ИТОГО: %1",Формат(СуммаЧекаБезСкидки,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
		струкСкидки.Выравнивание = "Право";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Текст = СтрШаблон("ИТОГО скидка: %1",Формат(СуммаЧекаБезСкидки-СуммаЧека,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
		струкСкидки.Выравнивание = "Право";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
	КонецЕсли;
	Возврат Неопределено;
КонецФункции
Показать
Terve!R; Monty_B; user689995_qalitek; independ; Il; +5 Ответить
Остальные комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Night_Trap 17.05.19 07:15 Сейчас в теме
Здравствуйте! Подскажите пожалуйста, как использовать вашу разработку?
После установки расширения скидки должны появиться в чеки автоматически или нужно что-то еще делать?
При ручных скидках в чеке данная доработка будет их отображать?
2. Night_Trap 19.05.19 21:36 Сейчас в теме
(1) Начал разбираться с доработкой.

Не перехватывает расширение обозначенные процедуры.
Чтобы заработало - комментируем или удаляем //&НаСервере

В МенеджерОборудованияКлиентПереопределяемый.
Должно получиться так

//&НаСервере
&Вместо("СформироватьШаблонЧека")
Функция Il_СформироватьШаблонЧека(ВходныеПараметры, ДополнительныйТекст, СтандартнаяОбработка, ТипОборудования)
	ШаблонЧека = МенеджерОборудованияВызовСервераПереопределяемый.ПолучитьСтруктуруШаблонаЧека(ВходныеПараметры, ДополнительныйТекст, ТипОборудования);
	Если ШаблонЧека <> Неопределено Тогда
		СтандартнаяОбработка = Ложь;
		Возврат ШаблонЧека;
	КонецЕсли;
КонецФункции
Показать


Автор молчит по моему вопросу ручной скидки. Если получиться - сделаю публикацию еще с ней :)
3. Il 24 20.05.19 02:32 Сейчас в теме
(1) как работает: при включении расширения - при наличии скидки в чеке будет расшифровка.
для ручной скидки расшифровки нет, только в общем итоге.
(2) спасибо за замечание! когда переносил из боевого расширения - ошибся... исправлю.
по поводу своей публикации - конечно можно.
4. Night_Trap 20.05.19 21:01 Сейчас в теме
Прилагаю дополнительный код вывода Ручной скидки при печати чека.
Автору БОЛЬШОЙ респект за материал!!!

Теперь ЧЕК под контролем!!!!

Функция Il_ПолучитьСтруктуруШаблонаЧека(ПараметрыШаблонаЧека, ДополнительныйТекст, ТипОборудования)
	ОбщиеПараметры = ПараметрыШаблонаЧека[0];
	строкМассива = ОбщиеПараметры.ПозицииЧека.Количество()-1;
	ИндексМассива=0;	КлючТовара=0;
	СуммаЧека = 0;	СуммаЧекаБезСкидки = 0;
	Пока ИндексМассива<=строкМассива Цикл
		ТекущаяПозиция = ОбщиеПараметры.ПозицииЧека[ИндексМассива];
		Если ТекущаяПозиция.Свойство("ФискальнаяСтрока") Тогда
			//ТекущаяПозиция.НомерСтрокиТовара = КлючТовара;
			СуммаЧека = СуммаЧека + ТекущаяПозиция.Сумма;
			СуммаЧекаБезСкидки = СуммаЧекаБезСкидки + ТекущаяПозиция.Цена*ТекущаяПозиция.Количество;
			Если не ТекущаяПозиция.Цена=ТекущаяПозиция.ЦенаСоСкидками Тогда
				cтрукОтбора = Новый Структура("КлючСвязи",КлючТовара+1);
				тчСкидки = ОбщиеПараметры.ДокументОснование.СкидкиНаценки.Выгрузить(cтрукОтбора, "СкидкаНаценка,Сумма");
//сначала выведем автоматические скидки по товару
				Для Каждого стрСК из тчСкидки Цикл
					струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
					струкСкидки.Текст = СтрШаблон("По акции <<%1>> скидка: %2",СокрЛП(стрСК.СкидкаНаценка),Формат(стрСК.Сумма,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
					ИндексМассива = ИндексМассива+1;
					ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
					строкМассива = строкМассива+1;
				КонецЦикла;
////////////////////////////////////////////////////////////­/////////
//мои_вставки
//далее выведем ручные скидки
				струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
				струкСкидки.Текст = "Сумма без скидки: "+Формат(ТекущаяПозиция.Цена*ТекущаяПозиция.Количество,"ЧЦ=15;ЧДЦ=2;ЧРД=,");
				ИндексМассива = ИндексМассива+1;
				ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
				строкМассива = строкМассива+1;

				струкСкидки = Новый Структура("ТекстоваяСтрока,Текст");
				ПроцентСкидки = Окр((1-ТекущаяПозиция.ЦенаСоСкидками/ТекущаяПозиция.Цена)*100,0);
				струкСкидки.Текст = "Скидка "+ПроцентСкидки+"%: "+Формат(ТекущаяПозиция.Цена-ТекущаяПозиция.ЦенаСоСкидками,"ЧЦ=15;ЧДЦ=2;ЧРД=,");
				ИндексМассива = ИндексМассива+1;
				ОбщиеПараметры.ПозицииЧека.Вставить(ИндексМассива,струкСкидки);
				строкМассива = строкМассива+1;
////////////////////////////////////////////////////////////­/////////
			КонецЕсли;
		КонецЕсли;
		ИндексМассива=ИндексМассива+1;
		КлючТовара=КлючТовара+1;
	КонецЦикла;
	Если не СуммаЧека=СуммаЧекаБезСкидки Тогда
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Выравнивание = "Центр";
		струкСкидки.Текст = "-------------------";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Текст = СтрШаблон("ИТОГО: %1",Формат(СуммаЧекаБезСкидки,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
		струкСкидки.Выравнивание = "Право";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
		струкСкидки = Новый Структура("ТекстоваяСтрока,Текст,Выравнивание");
		струкСкидки.Текст = СтрШаблон("ИТОГО скидка: %1",Формат(СуммаЧекаБезСкидки-СуммаЧека,"ЧЦ=15;ЧДЦ=2;ЧРД=."));
		струкСкидки.Выравнивание = "Право";
		ОбщиеПараметры.ПозицииЧека.Добавить(струкСкидки);
	КонецЕсли;
	Возврат Неопределено;
КонецФункции
Показать
Terve!R; Monty_B; user689995_qalitek; independ; Il; +5 Ответить
6. independ 1152 07.08.19 11:32 Сейчас в теме
(4) хорошее решение, УТ 11 - 1 ККТ Штрих + несколько РМК, без проблем по просьбе заказчика сделал вывод в чеке номер/наименования кассы
5. Il 24 26.06.19 07:30 Сейчас в теме
вот хорошая статья про внешний вид чеков: public/680200/
7. kovv 4 05.08.20 14:29 Сейчас в теме
Установила расширение и не работает! Даже если сделать, как советуют (Чтобы заработало - комментируем или удаляем //&НаСервере), все равно не срабатывает ((
8. Il 24 05.08.20 14:36 Сейчас в теме
(7) версия конфигурации какая?
9. Il 24 05.08.20 15:26 Сейчас в теме
(7) проверьте, что на товары из чека есть действующие скидки
10. kovv 4 05.08.20 17:17 Сейчас в теме
версия 11.4.11.104, платформа 8.3.16. Скидка есть, все проверила. Расширение не срабатывает ((
11. Il 24 06.08.20 02:20 Сейчас в теме
(10) Проверил. Действительно ошибка. Начиная примерно с вер.11.4.7.хх функция "СформироватьШаблонЧека" переехала из клиентского модуль в серверный. А "ПолучитьСтруктуруШаблонаЧека" убрали. Чуть позже выложу рабочий код. Спасибо за помощь!
12. kovv 4 06.08.20 07:04 Сейчас в теме
Вам спасибо, что вовремя откликаетесь! Очень жду рабочий вариант!
13. Il 24 06.08.20 17:38 Сейчас в теме
(12) выложил исправление под свежие версии (код есть в описании)
14. kovv 4 06.08.20 19:38 Сейчас в теме
Спасибо!!! Проверила, все работает!!! Отдельное спасибо за оперативность!
Оставьте свое сообщение

См. также

Формирование кассовой книги по подразделению за период. УТ 11.4

Кассовые операции v8 v8::ОУ УТ11 Россия БУ Абонемент ($m)

Обработка предназначена для следующих целей: 1. Автоматического формирования листов кассовой книги по дням по существующим ПКО, РКО за выбранный период по подразделению. 2. Вывода на печать комплекта документов (лист кассовой книги, ПКО, РКО) за выбранный период. 3. Подстановки в печатные формы (лист кассовой книги, ПКО, РКО) в строки «кассир», «бухгалтер», «главный бухгалтер», «руководитель организации» ФИО ответственного лица по обособленному подразделению.

10 стартмани

23.11.2020    352    0    user620742_mister.tda    0    

Расширение: отчет "Кассовая книга" - сортировка по номерам документов. Бух.3.0

Кассовые операции v8::ОУ БП3.0 Россия БУ Абонемент ($m)

Расширение содержит доработанный отчет "Кассовая книга" - доработана сортировка документов по номерам документов. Проверено на версиях Бух.3.0.78.69, 3.0.80.36, 3.0.81.23.

1 стартмани

12.08.2020    910    0    user_2010    0    

Скорость продаж для УТ 11 с учетом наличия товаров

Оптовая торговля Розничная торговля v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Отчет для типовой конфигурации "Управление торговлей" 11.х. Платформа 8.3.17.1386. Выводит дни наличия и отсутствия, остатки на начало, конец периода и средние, продажи, приход, расход, скорость продаж, оборачиваемость товаров за период и оборачиваемость на конец периода. Предназначен для оптимизации складской логистики (уменьшения затрат) и устранения дефектуры товара (упущенной прибыли). Встраивается в дополнительные отчеты.

1 стартмани

28.07.2020    2085    10    yc_2011    2    

Расширение "Интерфейс Плюс" Промо

Розничная торговля Рабочее место Розничная торговля v8 v8::ОУ Розница УТ11 Россия УУ Абонемент ($m)

Расширение для 1С:Розница 2.2/2.3 и 1С:Управление Торговлей 11, которое позволит повысить удобство работы!

1 стартмани

22.09.2018    26977    127    RocKeR_13    119    

Ведомость по партиям регистра Себестоимость с разбиением оборотов. УТ 11.4

Оптовая торговля Розничная торговля Учет ТМЦ Управленческие v8 v8::ОУ УТ11 УУ Абонемент ($m)

Аналог отчета "Ведомость по партиям товаров" с разбиением показателей Приход/Расход на пункты: -Поступления-Продажи-Сборка-Оприходование/списание-Перемещения-Корректировки-Внутреннее товародвижение-Прочие обороты. Строится на основании регистра "Себестоимость товаров"

1 стартмани

27.04.2020    2025    11    user834357    0    

Чек ККМ для УТ 10.3

Печатные формы документов Розничная торговля v8 v8::ОУ УТ10 Россия БУ Абонемент ($m)

Стандартная форма чека ККМ, сделанная как внешняя печатная форма с целью внесения произвольных изменений, чтобы не трогать саму конфигурацию.

2 стартмани

14.04.2020    1974    2    kubatay    0    

Товарный чек для УТ 10.3 из документа "Реализация товаров и услуг", товары и услуги

Печатные формы документов Розничная торговля v8 v8::ОУ УТ10 Россия БУ Абонемент ($m)

Внешняя печатная форма "Товарный чек" для конфигурации УТ 10.3 из документа "Реализация", по товарам и услугам.

1 стартмани

08.04.2020    1594    2    TuristDR    0    

Анализ активности продавцов для УТ 11 Промо

Управленческие Розничная торговля Розничная торговля v8 v8::ОУ v8::СКД УТ11 Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Отчет позволяет проанализировать качество работы продавцов, а также сравнить показатели розничных точек продаж (магазинов).

5 стартмани

26.11.2018    12900    2    Zalipaka    0    

Товары без движения. Отчет для УТ 11.4

Оптовая торговля Розничная торговля Управленческие v8 v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика УУ Абонемент ($m)

Отчет показывает стоимость товаров на складе по любому из доступных видов цен, количество дней с момента последнего прихода и продажи, а также даты последних прихода, продажи и переоценки.

1 стартмани

04.04.2020    2758    25    ErAK    7    

ABC анализ продаж

Оптовая торговля Розничная торговля v8 v8::ОУ УТ11 УУ Абонемент ($m)

В отчете ведется динамический расчет Категорий "АВС" по сумме и по количеству, которое было продано.

1 стартмани

20.02.2020    2171    11    M_A_D    11    

Рабочее место кассира с возможностью работы с "заказами". УТ 11.4

Рабочее место Розничная торговля v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Расширение добавляет выбор заказа в РМК УТ 11.4.

1 стартмани

11.02.2020    2903    11    Makyrka    5    

Отчет по среднему чеку в торговле УТ 11; КА 2 Промо

Управленческие Розничная торговля Розничная торговля v8::ОУ v8::УФ УТ11 УУ Абонемент ($m)

Данный отчет позволяет посмотреть средние чеки в разрезе продавцов, магазинов и ККМ в конфигурации "Управление торговлей 11". Данный отчет был протестирован на всех версиях конфигурации Управление торговлей 11*Х. и КА 2*Х

3 стартмани

15.03.2018    20166    38    zaika007    15    

Автоматические скидки в розничной торговле без карт лояльности (дисконтных карт). УТ 11

Розничная торговля v8 v8::ОУ ERP2 УТ11 КА2 УУ Абонемент ($m)

В УТ 11, КА 2, ERP 2 можно настроить работу с автоматическими скидками без использования карт лояльности. Скидки предоставляются непосредственно клиенту. Есть только небольшая проблемка: Рабочее Место Кассира (РМК) работает только с картами лояльности, а ввести клиента (партнера) нельзя. Данное расширение модифицирует РМК для ввода клиента - получателя скидки. Проверено на УТ 11.4.11.55, КА 2.4.11.63, ERP 2.4.11.63

1 стартмани

27.01.2020    3101    2    pparshin    0    

Стоимостная оценка склада в ценах номенклатуры для НТТ

Учет ТМЦ Ценообразование, анализ цен Розничная торговля v8::ОУ УПП1 Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Внешний отчет для УПП 1.3 формируется не только по складам, но и по НТТ. Результат выгружается в *.txt файл(ы).

1 стартмани

21.01.2020    1834    1    FullMoon    0    

Время продаж чеков по магазинам в УТ 11, КА. Аналитический отчет + Диаграмма Промо

Управленческие Розничная торговля Розничная торговля v8 v8::ОУ УТ10 УТ11 КА2 Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

Отчет "Диаграмма по времени продаж чеков" предназначен для планирования графиков работы продавцов-менеджеров, для планирования маркетинговых мероприятий.

2 стартмани

16.03.2018    21937    18    zaika007    12    

Розничные продажи со скидками по чекам ККМ и возвраты (ERP 2.4, УТ 11.4, КА 2.4)

Розничная торговля Управленческие v8::ОУ v8::УФ ERP2 УТ11 КА2 Россия УУ Абонемент ($m)

Внешний отчет "Розничные продажи со скидками по чекам ККМ и возвраты" для ERP 2.4, УТ 11.4, КА 2.4 для вывода информации о предоставляемых скидках. Отчет необходим для анализа какой предоставляется процент скидки и сколько делается возвратов по чекам ККМ. Отчет по розничным продажам берет данные с проведенных документов "Чек ККМ" и "ЧекККМВозврат".

2 стартмани

18.12.2019    3705    3    SergAl    1    

Остатки и цены в справочнике Номенклатура для 1С:Розница 2.3 (расширение)

Розничная торговля v8::ОУ Розница Россия УУ Абонемент ($m)

Расширение показывает остатки и цены в форме справочника номенклатура, по аналогии как это было в УТ 10.3.

1 стартмани

10.12.2019    5135    42    Dilovar9    9    

Валовая прибыль (1С: Розница 2.2) Управляемые формы Промо

Управленческие Учет доходов и расходов Розничная торговля Учет доходов и расходов Розничная торговля v8::ОУ v8::УФ Розница Россия УУ Абонемент ($m)

Отчет позволяет проанализировать продажи. Пригодится тем, кому не подходит или неудобен стандартный функционал расчета себестоимости в рознице 2.2.

3 стартмани

26.04.2017    43814    167    cezarj    46    

Расширение для РМК с отображением остатка и редактированием цены. УТ 11

Розничная торговля Рабочее место v8 v8::ОУ УТ11 Россия Абонемент ($m)

Расширение для РМК УТ 11 будет полезно как на начальном этапе автоматизации торгового предприятия, когда не внесены еще все цены и весь ассортимент, а продажа уже осуществляется , так и полностью автоматизированному объекту, когда при продаже нужен остаток на складе.

1 стартмани

23.11.2019    3783    13    Oleg_46    3    

Возможность поиска дисконтной карты по номеру телефона / ФИО для УТ 11.4.x

Розничная торговля v8::ОУ УТ11 УУ Абонемент ($m)

Доработка конфигурации с помощью расширения.

2 стартмани

02.10.2019    4679    12    nomad_irk    2    

Анализ остатков и продаж, План закупок на основании остатков и продаж для 1С:Розница 2.3 и 1С:Управление торговлей 11.4

Розничная торговля Учет ТМЦ Управленческие Оптовая торговля Управление торговлей v8::ОУ v8::СПР v8::УФ v8::СКД Розница УТ11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Отчет "Анализ остатков и продаж" позволяет в одном отчете видеть одновременно текущую цену, остатки товаров и сумму остатков в выбранном типе цен на конечную дату, а также среднюю цену по которой был продан товар, количество и сумму продажи товаров за период. Отчет "План закупок на основании остатков и продаж" позволяет сформировать остатки и продажи за период и на основании этих данных с учетом расчета количества месяцев на перед рассчитать потребность в товаре и вычислить план необходимой закупки.

5 стартмани

29.09.2019    6766    26    globarh    7    

Неликвиды на складе: Pro и Lite версия. Редактирование реквизита в таблице документа. Для конфигурации УТ 11.х, ERP 2.x, КА 2.х 1С Предприятие 8.3 Промо

Управленческие Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8 v8::ОУ ERP2 УТ11 КА2 Оптовая торговля, дистрибуция, логистика УУ Абонемент ($m)

Внешний отчет для анализа товаров, находящихся на складе без движения. Работает для конфигураций 1С УТ 11.х, ERP 2.x, КА 2.х. Отчет отображает товары на складах, движения по которым не производились в течении заданного периода дней. Подключается как внешний отчет в конфигурации 1С Управление торговлей 11. В Pro версии можно установить общий реквизит номенклатуры, для дальнейшего включения в отбор в установке цен номенклатуры. Редактирование в табличном документе ускоряет процесс работы с неликвидами номенклатуры на складах. Отчет можно использовать для стоимостной оценки товаров на складах. Полный доступ к тексту модулей и СКД.

1 стартмани

17.06.2016    35508    49    Ликреонский    2    

Рабочий стол директора розничного магазина для УТ 11.4

Рабочее место Розничная торговля Внешние источники данных Розничная торговля v8 v8::ОУ УТ11 Молдова Россия УУ Абонемент ($m)

Понадобилось ускорить типовую выгрузку из 1С во Фронтол, т.к. в компании установки цен проводятся ежедневно на разные группы товаров и заведующие устали выгружать каждый раз по несколько десятков минут, иные и свыше 1-го часа. Родилась обработка сначала для выгрузки товаров на кассы, а затем понемногу обросло всем остальным. Делалось и тестировалось на УТ 11.4.9.70. Также будет полезно тем, кто выгружает скидки во Фронтол.

1 стартмани

10.09.2019    3285    3    BelikJan    2    

Расширение для печати этикеток в командном режиме

Ценники Розничная торговля Розничная торговля v8::ОУ ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Решение проблемы при невозможности считывания этикеток сканером штрих-кода из-за плохого качества печати. Печать этикеток и ценников для товаров, на принтер этикеток, подключенный через драйвер производителя. Новая форма редактирования шаблонов для принтера этикеток.

5 стартмани

09.08.2019    3815    5    prof-it60    19    

Повторное использование подарочных сертификатов. Управление торговлей 11.4. Расширение

Рабочее место Розничная торговля Розничная торговля v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

В конфигурации «Управление торговлей» отсутствует механизм «повторного» использования подарочных сертификатов. Предлагается один из возможных вариантов реализации данного функционала расширением 1С.

5 стартмани

31.07.2019    5952    16    VsHome    10    

Отчет мерчендайзера Промо

Оптовая торговля Розничная торговля Управленческие Оптовая торговля Розничная торговля v8::ОУ УТ10 Оптовая торговля, дистрибуция, логистика УУ Абонемент ($m)

Итак, отчет для мерчендайзера. Разрабатывался для Управления торговлей 10.3, и предназначен для формирования бланков отчета мерчендайзера на день или за период. Теперь не нужно открывать Excel, заполнять по памяти список торговых точек и номенклатуры, путаясь в том - кому какая поставлялась. Все это подбирается и может быть отредактировано, сохранено и распечатано из данного отчета. В справке описан порядок работы с отчетом.

1 стартмани

08.09.2013    30913    5    Krasnyj    11    

Анализ товарооборота по торговым точкам для УТ, КА, УПП

Розничная торговля Управленческие Розничная торговля v8::ОУ УТ10 УПП1 Россия УУ Абонемент ($m)

Отчет предназначен для анализа наличия избытка или недостатка того или иного товара в торговых точках предприятия. Тестировался на УТ 10.3 "Управление торговлей", редакция 10.3 (10.3.45.3) и УПП 1.3 Управление производственным предприятием, редакция 1.3 (1.3.96.1) /обычное приложение/, но должен работать и на КА обычное приложение.

1 стартмани

29.07.2019    3695    3    vik2006    0    

Этикетка Номенклатура+Серия на типовых шаблонах 1С

Ценники Розничная торговля Розничная торговля v8::ОУ ERP2 КА2 Россия УУ Абонемент ($m)

Сдвоенная этикетка номенклатура +серия с использованием типовых шаблонов этикеток. Два штрихкода на одной этикетке. Этикетки печатаются прямо из документов.

2 стартмани

25.07.2019    5389    7    kwazi    3    

Анализ доступности товаров с количеством дней без расхода, продажи, нулевого остатка и со стоимостными показателями

Оптовая торговля Розничная торговля Управленческие Оптовая торговля Розничная торговля v8 v8::ОУ УТ10 УПП1 УУ Абонемент ($m)

Добавляем в отчет доступности товаров на складах очевидные для руководителей, закупщиков и аналитиков показатели.

1 стартмани

26.06.2019    3934    7    psih12    0    

Отчет за смену из РМК для УТ 11

Управленческие Розничная торговля Розничная торговля v8 v8::ОУ УТ11 УУ Абонемент ($m)

Краткий отчет о продажах за смену из режима РМК (рабочее место кассира) для УТ 11

1 стартмани

19.06.2019    6270    14    kassbar    10    

Печать ценников с двойной ценой (скидка) для УТ 11.4

Ценники Розничная торговля Розничная торговля v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Обработка печати ценников со скидкой и выбором макета ценника.

1 стартмани

04.06.2019    5587    28    Makyrka    12    

Отчет по чекам с разбивкой чеков по типам оплаты

Управленческие Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Отчет по чекам ККМ с отбором по периоду и выводом данных по типу оплаты.

1 стартмани

30.05.2019    2809    4    Makyrka    0    

Цены и остатки в справочнике Номенклатура

Оптовая торговля Розничная торговля Ценообразование, анализ цен Обработка справочников Оптовая торговля Розничная торговля Ценообразование, анализ цен v8 v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Расширение, позволяющее оперативно выводить информацию по ценам и остаткам товара на складах по номенклатуре в справочнике (списке) Номенклатура.

5 стартмани

14.05.2019    4996    4    user938418    3    

ABC-XYZ анализ продаж с остатками на складах для УТ 11.4

Оптовая торговля Розничная торговля Управленческие Оптовая торговля Розничная торговля v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Отчет выводит показатели ABC-XYZ анализа продаж с остатками на складах для УТ 11.4.

1 стартмани

13.05.2019    8865    83    artfa    16    

Отчет по оплатам для кассы ККМ. УТ 11.4, КА 2.4 (внешняя печатная форма документа "Отчёт о розничных продажах")

Печатные формы документов Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::ОУ v8::УФ УТ11 КА2 УУ Абонемент ($m)

Позволяет сверить кассиру, бухгалтеру и руководству выручку по кассе ККМ по видам оплат чеков ККМ. На печатной форме видно, какой чек как оплачен (сколько наличными, картой, сертификатом), возвраты наличными, картой; сколько применено скидок бонусами, автоматических, ручных; на сколько продано подарочных сертификатов наличными, картой, на сколько возвращено подарочных сертификатов наличными, картой. В итоге подсчитывается сколько должно быть наличных в кассе ККМ за кассовые смены. Отчёт удобен для проверки, особенно если на одну кассу ККМ печатаются чеки ККМ с нескольких рабочих мест кассиров (например, при использовании разработки https://infostart.ru/public/892765/).

1 стартмани

11.05.2019    5895    21    AlexandrN    0    

Отчет по чекам ККМ с разделением по продавцам - пользователям УТ 11.4

Бухгалтерские Управленческие Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::ОУ v8::СКД УТ11 Россия БУ УУ Абонемент ($m)

Дописанный типовой отчет, выводит список чеков продаж и возвратов по продавцам, то есть пользователям базы. Предназначена для конфигурации УТ 11.4.

10 стартмани

25.04.2019    4107    5    mp40    0    

Печать штрих-этикеток. УТ 11.4. Внешняя обработка для конфигураций на управляемых формах. Легко дорабатывается для других конфигураций

Ценники Розничная торговля Розничная торговля v8 v8::ОУ v8::УФ УТ11 Россия Абонемент ($m)

Внешняя обработка для печати штрих-этикеток. Пригодится тем, кого не устраивает типовая печать этикеток. Также будет полезна разработчикам ПО на платформе 1С 8.3.

1 стартмани

04.04.2019    6794    25    likov2001    3    

Посещаемость торговой точки по дням и часам

Управленческие Розничная торговля Розничная торговля v8 v8::ОУ УТ10 УУ Абонемент ($m)

Отчет для формирования статистики и наглядных графиков по посещаемости торговой точки в разрезе дней недели и часов в течение дня. Анализируются документы Чек ККМ.

1 стартмани

02.04.2019    3615    7    Miket78    0    

hotfix: Розница, редакция 2.2 (2.2.11.29) в расширении, инкассация по новым купюрам 200руб., 2000 руб.

Печатные формы документов Кассовые операции Кассовые операции v8 v8::ОУ Розница Россия БУ Абонемент ($m)

hotfix: Розница, редакция 2.2 (2.2.11.29) в расширении, инкассация по новым купюрам 200руб., 2000 руб. Исправлена печатная форма "Квитанция к сумке" к документу РКО

1 стартмани

29.03.2019    4142    1    NN2P    0    

Отчет по оптовым и розничным продажам со скидками для ERP 2.4, УТ 11.4, КА 2

Управленческие Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 v8::ОУ v8::СКД ERP2 УТ11 КА2 Россия УУ Абонемент ($m)

Внешний отчет "Продажи со скидками" для ERP 2.4, УТ 11.4, КА 2 для вывода информации о предоставляемых скидках. Отчет необходим для анализа, какой менеджер, закрепленный за партнером, предоставляет процент скидки. Отчет по оптовым продажам берет данные с проведенных документов "Реализация товаров и услуг", по розничным продажам данные берутся с проведенных документов "Чек ККМ".

1 стартмани

25.03.2019    6655    71    SergAl    32    

Печать товарного чека (внешняя форма) для УТ 11 из документа Реализация товаров и услуг

Печатные формы документов Розничная торговля Розничная торговля v8 v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Внешняя форма печати Товарного чека для ПП Управление Торговлей 11.4.6.166 из документа Реализация товаров и услуг.

1 стартмани

19.03.2019    2697    10    alexmz    0    

Рейтинг продаж двух периодов (УТ 11.4)

Управленческие Финансовый учет и бюджетирование (FRP) Оптовая торговля Розничная торговля Финансовый учет и бюджетирование (FRP) Оптовая торговля Розничная торговля v8 v8::ОУ УТ11 УУ Абонемент ($m)

Отчет сравнивает группировки отчета по рейтингу (месту по сумме выручки за выбранные два периода) и если рейтинг вырос, то выделяет его зеленым, если уменьшился, то красным.

1 стартмани

18.03.2019    5893    16    user834357    3    

КМ-3, КМ-6, Отчет о розничных продажах, Отчет о розничных продажах в ценах АТТ для УТ 10.3 / УТ 11

Печатные формы документов Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 v8::ОУ УТ10 УТ11 БУ УУ Абонемент ($m)

Внешние печатные формы: КМ-3 (о возврате денежных сумм покупателями по неиспользованным кассовым чекам) , КМ-6 (Справка отчет кассира операциониста), Отчет о розничных продажах, Отчет о розничных продажах в ценах АТТ для УТ 10.3 / УТ 11 к документу Отчет о розничных продажах

1 стартмани

16.03.2019    4625    3    prime9    3    

М-4, Накладная, Приход на розничные склады, Расход с розничных складов, ТОРГ-13 для УТ 10.3

Печатные формы документов Розничная торговля Учет ТМЦ Розничная торговля Учет ТМЦ v8 v8::ОУ УТ10 БУ УУ Абонемент ($m)

Внешние печатные формы: М-4, Накладная, Приход на розничные склады, Расход с розничных складов, ТОРГ-13 для УТ 10.3 к документу Перемещение товаров.

1 стартмани

15.03.2019    5611    3    prime9    0