Генерация структуры склада для мест хранения

01.09.15

Учетные задачи - Логистика, склад и ТМЦ

Обработка обычно используется разово на проекте, поэтому не оформляю соответствующе.
Кому что надо - тот поправит.

А времени немного сэкономить поможет.

Скачать исходный код

Наименование Файл Версия Размер
Обработка
.epf 7,03Kb
10
.epf 7,03Kb 10 Скачать

Процедура КнопкаВыполнитьНажатие(Кнопка)
// Вставить содержимое обработчика.

СпрТов=Справочники.Номенклатура;
МестаХранения=Справочники.МестаХранения;
КоличествоПомещений=7;
КоличествоСтеллажей=7;
КоличествоЛиний=7;
КоличествоМест=25;
Ячейка=0;

Для
Скл=1 По 2 Цикл
Склады=Скл;
Если
Склады=1 Тогда
СпрСклад=Справочники.Склады.НайтиПоКоду("00002");
Иначе
СпрСклад=Справочники.Склады.НайтиПоКоду("00001");
КонецЕсли;

Для
сч=0 По КоличествоПомещений Цикл
Помещение=сч;
//********Помещения
НовМестоП=МестаХранения.НайтиПоНаименованию("Помещение"+Строка(Помещение),,,СпрСклад);

Если
НовМестоП=МестаХранения.ПустаяСсылка() Тогда

НовМестоП=МестаХранения.СоздатьГруппу();
НовМестоП.Владелец =СпрСклад;
НовМестоП.Наименование="Помещение"+Строка(Помещение);
НовМестоП.Записать();

КонецЕсли;
//*****************

Для Ст=1 По КоличествоСтеллажей Цикл
Стеллаж=Ст;
//********Стеллаж
НовМестоСт=МестаХранения.НайтиПоНаименованию("Стеллаж"+Строка(Стеллаж),,НовМестоП.Ссылка,СпрСклад);

Если
НовМестоСт=МестаХранения.ПустаяСсылка() Тогда

НовМестоСт=МестаХранения.СоздатьГруппу();
НовМестоСт.Владелец =СпрСклад;
НовМестоСт.Родитель =НовМестоП.Ссылка;
НовМестоСт.Наименование="Стеллаж"+Строка(Стеллаж);
НовМестоСт.Записать();

КонецЕсли;
//*****************

Для Л=1 По КоличествоЛиний Цикл
Линия=Л;
//********Линия
НовМестоЛ=МестаХранения.НайтиПоНаименованию("Линия"+Строка(Линия),,НовМестоСт.Ссылка,СпрСклад);

Если
НовМестоЛ=МестаХранения.ПустаяСсылка() Тогда

НовМестоЛ=МестаХранения.СоздатьГруппу();
НовМестоЛ.Владелец=СпрСклад;
НовМестоЛ.Родитель =НовМестоСт.Ссылка;
НовМестоЛ.Наименование="Линия"+Строка(Линия);
НовМестоЛ.Записать();

КонецЕсли;
//*****************

Для М=1 По КоличествоМест Цикл
Место=М;
Состояние("Скл"+Строка(Склады)+"-"+"П"+Строка(Помещение)+"-"+"Ст"+Строка(Стеллаж)+"-"+"Л"+Строка(Линия)+"-"+"М"+Строка(Место)+"-"+"Я0");

СтрокаХранения="П"+Строка(Помещение)+"-Ст"+Строка(Стеллаж)+"-Л"+Строка(Линия)+"-М"+Строка(Место)+"-Я"+Строка(Ячейка) ;


//********Место
НовМестоМ=МестаХранения.НайтиПоНаименованию("Место"+Строка(Место),,НовМестоЛ.Ссылка,СпрСклад);

Если
НовМестоМ=МестаХранения.ПустаяСсылка() Тогда

НовМестоМ=МестаХранения.СоздатьГруппу();
НовМестоМ.Владелец =СпрСклад;
НовМестоМ.Родитель =НовМестоЛ.Ссылка;
НовМестоМ.Наименование="Место"+Строка(Место);
НовМестоМ.Записать();

КонецЕсли;
//*****************
//********Ячейка
НовМестоЯ=МестаХранения.НайтиПоНаименованию("Ячейка"+Строка(Ячейка),,НовМестоМ.Ссылка,СпрСклад);

Если
НовМестоЯ=МестаХранения.ПустаяСсылка() Тогда

НовМестоЯ=МестаХранения.СоздатьГруппу();
НовМестоЯ.Владелец =СпрСклад;
НовМестоЯ.Родитель =НовМестоМ.Ссылка;
НовМестоЯ.Наименование="Ячейка"+Строка(Ячейка);
НовМестоЯ.Записать();

КонецЕсли;
//*****************

НовМесто=МестаХранения.НайтиПоНаименованию(СтрокаХранения,,НовМестоЯ.Ссылка,СпрСклад);

Если
НовМесто=МестаХранения.ПустаяСсылка() Тогда

НовМесто=МестаХранения.СоздатьЭлемент();
НовМесто.Владелец =СпрСклад;
НовМесто.Родитель=НовМестоЯ.Ссылка;
НовМесто.Наименование=СтрокаХранения;
НовМесто.Записать();

КонецЕсли;
//Вырезан нижестоящий фрагмент

КонецЦикла;

КонецЦикла;
КонецЦикла;
КонецЦикла;

КонецЦикла;

Сообщить("Обработка закончена !");
КонецПроцедуры


Иполнитель: 2012 г. www.rt-finance.ru

См. также

Автоматический заказ поставщику в 1С: загрузка прайсов и анализ цен поставщиков для УТ 10.3, УТ 11, КА2, УНФ, УПП, ERP, Розница 2

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    92056    116    40    

206

Программа для фулфилмента (FBS / FBO): модуль "Ответственное хранение" в 1С:УТ 11.5, КА 2.5, ERP 2.5

Логистика, склад и ТМЦ Бухгалтер Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Оптовая торговля, дистрибуция, логистика Управленческий учет Платные (руб)

Программа для фулфилмента: модуль "Ответственное хранение" для 1С (УТ 11.5, КА 2.5, ERP 2.5) позволяет организовать учет ответственного хранения товаров с весовыми характеристиками, в том числе со сроком годности и личным кабинетом Поклажедателя. Модуль реализован в виде расширения конфигурации, устанавливается в режиме 1С:Предприятие 8 за 5 минут по инструкции, что позволяет оставить конфигурацию 1С на стандартной поддержке и продолжать получать стандартные обновления от фирмы "1С".

60000 руб.

09.06.2020    35643    30    59    

58

Загрузка номенклатуры в УТ11, КА 2, ERP 2, Розница 2 из Excel. Дополнительные реквизиты и сведения, характеристики, картинки, цены, остатки

Загрузка и выгрузка в Excel Розничная торговля Логистика, склад и ТМЦ Ценообразование, анализ цен Прайсы Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Загрузка номенклатуры из файлов Excel (xls, xlsx, ods, csv, mxl) в УТ11, КА 2, ERP 2, Розница 2. Задействованы все возможности конфигурации - заполнение реквизитов номенклатуры, дополнительных реквизитов и сведений, характеристики, доп.реквизиты и сведения характеристик. Дополнительные обработки для расширения возможностей.

10560 руб.

29.10.2014    212937    635    526    

448

Загрузка номенклатуры c картинками (несколько потоков одновременно) и сопутствующими данными в базу и любые документы из yml, xls, xlsx, xlsm, ods, ots, csv для УТ 10.3, УТ 11 (все), БП 3, КА 2, ERP 2, УНФ 1.6/3.0, Розница 2

Загрузка и выгрузка в Excel Логистика, склад и ТМЦ Ценообразование, анализ цен Файловый обмен (TXT, XML, DBF), FTP Бухгалтер Пользователь Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Платные (руб)

Эволюция не стоит на месте - новая удобная версия функциональной обработки для Вашего бизнеса! Что же Вы получаете? Удобный и интуитивно понятный интерфейс с 3-мя этапами работы. 2 режима - автоматический и ручной. Чтение XLSX, XLSM, CSV, XML/YML форматов без офиса, на любом сервере! Визуальное связывание колонок файла и реквизитов простым перетаскиванием колонок. Создание или обновление номенклатуры с иерархией, характеристик, доп. реквизитов, упаковок, загрузка практически неограниченного количества картинок на одну номенклатуру (с возможностью загрузки в несколько потоков одновременно), с хранением в томах или в базе. Загрузка номенклатуры поставщиков или поиск по их данным номенклатуры. Загрузка доп. реквизитов в характеристики. Загрузка штрихкодов с генерацией новых. Создание элементов справочников и ПВХ "на лету" для выбранных реквизитов. (Обновление от 09.04.2024, версия 9.9 - 9.10)

14400 руб.

20.11.2015    152615    370    376    

505

Перенос данных из УТ 10.3 в УТ 11 / КА 2 / ERP 2. Переносятся документы, справочники и остатки

Перенос данных 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

45650 руб.

24.04.2015    191684    135    239    

270
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. V.Nikonov 120 16.08.12 13:06 Сейчас в теме
А более подробно описать реализуемый сценарий можно?
Предпочтительнее в анотации описать Сценарий генерации, а примечания о черновом характере спустить в текст.

В противном случае, пока не разберёшь код, ни фига не понятно...
Оставьте свое сообщение