Расчет квартальной премии для ЗУП 3.1

16.11.22

Учетные задачи - Зарплата

Массовый расчет квартальной премии для ЗУП для всех сотрудников организации и (или) подразделений. НЕ нашел на Инфостарте пример (только для ЗКГУ, но они не подходят) пришлось писать самому. Все написано на вызовах программных интерфейсов (без привязки к регистрам), код открыт, формулу начисления можно менять под себя. Создание списка сотрудников, подсчет дней в квартале и подсчет выходов по каждому автоматизирован - достаточно нажать кнопку "Заполнить" и, по желанию, подправить проценты или удалить из списка. Выполнено в виде расширения.

Скачать исходный код

Наименование Файл Версия Размер
Расчет квартальной премии для ЗУП 3.1.22:
.cfe 19,70Kb
8
.cfe 19,70Kb 8 Скачать

Перво-наперво надо убедиться, что ЗУП поддерживает расчет квартальных премий. Проверяем: Функции для технического специалиста - обработка "Начальная настройка программы" - смотрим на картинку.

Появится Начисление: Премия за квартал (процентом) ПРКП. Заходим в него и ставим Расчетная база=Текущий квартал
Также появится Показатель - Процент квартальной премии

Создать самим 2 показателя (настройки на скриншотах) :
Показатель - Норма дней в квартале
Показатель - Отработано дней в квартале

Подключаем расширение стандартным способом и в разделе Дополнительно находим документ "Квартальная премия"

Критика приветствуется, все-таки я делаю первые шаги в ЗУП )

Написано на платформе 1С:Предприятие 8.3 (8.3.18.1520) под конфигурацию Зарплата и управление персоналом, редакция 3.1 (3.1.22.86), но уверен, будет работать и на более высоких. 

 

Код модуля Объекта

Процедура ОбработкаПроведения(Отказ, РежимПроведения)
	
	// Проведение документа
	ПроведениеСервер.ПодготовитьНаборыЗаписейКРегистрацииДвижений(ЭтотОбъект);
	
	ЗаписатьЗначенияПоказателейРасчетаЗарплаты(Движения, Отказ);
	
КонецПроцедуры


Процедура ЗаписатьЗначенияПоказателейРасчетаЗарплаты(Движения, Отказ)
	
	ЗначенияПоказателей = Новый ТаблицаЗначений;
	ЗначенияПоказателей.Колонки.Добавить("ПериодДействия", Новый ОписаниеТипов("Дата"));
	ЗначенияПоказателей.Колонки.Добавить("Сотрудник", Новый ОписаниеТипов("СправочникСсылка.Сотрудники"));
	ЗначенияПоказателей.Колонки.Добавить("Показатель", Новый ОписаниеТипов("СправочникСсылка.ПоказателиРасчетаЗарплаты"));
	ЗначенияПоказателей.Колонки.Добавить("Значение", Новый ОписаниеТипов("Число"));
	
	ПериодДействия = НачалоМесяца(КонецКвартала(Дата));
	
	Для каждого СтрокаТЧ Из СписокСотрудников Цикл   		
		НоваяСтрока = ЗначенияПоказателей.Добавить();
		НоваяСтрока.ПериодДействия = ПериодДействия;
		НоваяСтрока.Сотрудник = СтрокаТЧ.Сотрудник;
		НоваяСтрока.Показатель = Справочники.ПоказателиРасчетаЗарплаты.НайтиПоНаименованию("Процент квартальной премии");
		НоваяСтрока.Значение = СтрокаТЧ.ПроцентКвартальнойПремии;
		
		НоваяСтрока = ЗначенияПоказателей.Добавить();
		НоваяСтрока.ПериодДействия = ПериодДействия;
		НоваяСтрока.Сотрудник = СтрокаТЧ.Сотрудник;
		НоваяСтрока.Показатель = Справочники.ПоказателиРасчетаЗарплаты.НайтиПоНаименованию("Норма дней в квартале");
		НоваяСтрока.Значение = СтрокаТЧ.НормаДнейВКвартале;

		НоваяСтрока = ЗначенияПоказателей.Добавить();
		НоваяСтрока.ПериодДействия = ПериодДействия;
		НоваяСтрока.Сотрудник = СтрокаТЧ.Сотрудник;
		НоваяСтрока.Показатель = Справочники.ПоказателиРасчетаЗарплаты.НайтиПоНаименованию("Отработано дней в квартале");
		НоваяСтрока.Значение = СтрокаТЧ.ОтработаноДнейВКвартале;
	КонецЦикла; 		
	
	РасчетЗарплатыРасширенный.ЗарегистрироватьЗначенияРазовыхПоказателейСотрудников(Движения, Организация, ЗначенияПоказателей);
	
КонецПроцедуры

ЗУП квартальная премия расширение

См. также

Обновление для КА 1.1, ЗУП 2.5, БУХ 2.0: НДС, ЕФС-1, Расчет страховых взносов, Мобилизация, Статистика, Электронные трудовые книжки, 2-НДФЛ, Регламентированная отчетность, Кадровый учет, Прослеживаемость импортных товаров

Зарплата Регламентированный учет и отчетность Кадровый учет Обновление 1С Платформа 1С v8.3 Сложные периодические расчеты 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Зарплата и Управление Персоналом 2.5 Бухгалтерский учет Налоговый учет Управленческий учет Акцизы ЕНВД ЕСН Земельный налог ИП, ПБОЮЛ, КФХ Налог на имущество Налог на прибыль НДС НДФЛ ФОМС, ЕФС Транспортный налог УСН ПСН (патентная система налогообложения) Платные (руб)

Обновления для конфигураций: КА 1.1; ЗУП 2.5; БУХ 2.0; КА 1.1 Комплексная автоматизация торговли алкогольной продукцией; КА 1.1 Комплексный учет сельскохозяйственного предприятия

19900 руб.

01.04.2020    141824    667    352    

233

Перенос данных из Парус 8 в ЗГУ 3

Зарплата Внешние источники данных Бюджетный учет Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 Государственные, бюджетные структуры Россия Бухгалтерский учет Бюджетный учет Платные (руб)

Обработка позволяет перенести кадровую информацию и данные по заработной плате, фактических удержаниях, НДФЛ, вычетах, страховых взносах из базы Парус 8 учреждений в конфигурацию 1С:Зарплата и кадры государственного учреждения ред. 3 (ЗГУ) и начать с ней работать с любого месяца года.

84000 руб.

19.08.2020    22827    19    1    

22

Перенос данных из Камин 3.5 (5.5) в ЗиКГУ 3.х

Перенос данных 1C Зарплата Бюджетный учет Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 1С:Зарплата и Управление Персоналом 3.x Государственные, бюджетные структуры Россия Бюджетный учет Платные (руб)

Обработки для быстрого перехода с конфигураций «КАМИН:Расчет зарплаты для бюджетных учреждений 3.5» и «КАМИН:Зарплата для бюджетных учреждений 5.5» на конфигурацию «Зарплата и кадры государственного учреждения».

12000 руб.

28.07.2016    57630    143    141    

120

Устранение начислений прошлых периодов из ведомостей: в банк, в кассу, на счета в ЗУП 3.1, КА, ЗиКГУ 3.1

Зарплата Платформа 1С v8.3 1С:Зарплата и кадры государственного учреждения 3 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Платные (руб)

При заполнении ведомости на выплату зарплаты вылазят задолженности прошлых периодов, которых быть не должно? Наша обработка позволяется убрать эти доходы прошлых периодов за пару секунд. Больше не нужно тратить часы на анализ каждого такого случая.

15600 руб.

14.09.2022    13353    64    26    

66

Табличная часть в доп. реквизитах и формирование таблиц в шаблоне docx для 1С:ДО 3.0

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    4836    10    5    

19

Перенос данных из Парус 7.хх в ЗГУ ред.3

Внешние источники данных Зарплата Бюджетный учет Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 Государственные, бюджетные структуры Россия Бухгалтерский учет Бюджетный учет Платные (руб)

Обработка позволяет перенести кадровую информацию и данные по заработной плате, фактических удержаниях, НДФЛ, вычетах, страховых взносах из базы Парус 7.хх учреждений в конфигурацию 1С:Зарплата и кадры государственного учреждения ред. 3 (ЗГУ) и начать с ней работать с любого месяца года.

24000 руб.

24.04.2017    49054    97    163    

87

Исправление в 1С:ЗУП/ЗКГУ ошибок по НДФЛ и взаиморасчетам с сотрудниками на начало расчетного года.

Корректировка данных Зарплата Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет НДФЛ Платные (руб)

Обработка исправляет технические ошибки по НДФЛ, взаиморасчетам с сотрудниками в 1С:ЗУП (1С:ЗКГУ) на начало года. Фактически все ошибки, которые проявляются в ведомостях на выплату, расчетных листках, при заполнении ведомостей на выплату и отчетах 6-НДФЛ и т.д. нужно начинать исправлять с начала расчетного года. Это позволит быть уверенными, что после завершения расчетов предыдущего года, начали работать с «чистого листа» без ошибочных остатков.

4800 руб.

06.10.2023    2911    31    15    

38
Оставьте свое сообщение