Исправление регистра "Партии на складах (бухгалтерский учет)" для Комплексной автоматизации

19.03.15

Учетные задачи - Логистика, склад и ТМЦ

Не секрет, что многие сталкиваются с проблемой расхождения регистров накопления в Комплексной автоматизации, каждый может выбрать свой вариант, но я пошел по следующему. Одним документом "Корректировка записи регистров" привожу регистр к нулю, а вторым на основании данных регистра "Товары организации" и данным по бух. учету ввожу новые партии. Может быть, кому-то пригодится данный метод или он его как-то расширит.

Скачать исходный код

Наименование Файл Версия Размер
ЗакрытиеПартийБУНаСкладеВручную.epf
.epf 8,36Kb
13
.epf 8,36Kb 13 Скачать
Расхождения остатков по регистрам.erf
.erf 23,67Kb
16
.erf 23,67Kb 16 Скачать
Корректировка свободные остатки.epf
.epf 9,85Kb
8
.epf 9,85Kb 8 Скачать

 Обработка корректировки регистра накопления партии товаров на складах (бух. учет)

Процедура КнопкаВыполнитьНажатие(Кнопка)

ДатаЗакрытия = КонецДня(ДатаЗакрытия);

Запрос = Новый Запрос;
Запрос.Текст = 
"ВЫБРАТЬ
| ПартииТоваровНаСкладахБухгалтерскийУчетОстатки.Организация,
| ПартииТоваровНаСкладахБухгалтерскийУчетОстатки.Номенклатура,
| ПартииТоваровНаСкладахБухгалтерскийУчетОстатки.СчетУчета,
| ПартииТоваровНаСкладахБухгалтерскийУчетОстатки.Склад,
| ПартииТоваровНаСкладахБухгалтерскийУчетОстатки.ДокументОприходования,
| ПартииТоваровНаСкладахБухгалтерскийУчетОстатки.ХарактеристикаНоменклатуры,
| ПартииТоваровНаСкладахБухгалтерскийУчетОстатки.СерияНоменклатуры,
| ПартииТоваровНаСкладахБухгалтерскийУчетОстатки.Заказ,
| ПартииТоваровНаСкладахБухгалтерскийУчетОстатки.Качество,
| ПартииТоваровНаСкладахБухгалтерскийУчетОстатки.КоличествоОстаток,
| ПартииТоваровНаСкладахБухгалтерскийУчетОстатки.СтоимостьОстаток
|ИЗ
| РегистрНакопления.ПартииТоваровНаСкладахБухгалтерскийУчет.Остатки(
| &Дата,
| Организация = &Организация
| И Склад = &Склад) КАК ПартииТоваровНаСкладахБухгалтерскийУчетОстатки";

Запрос.УстановитьПараметр("Дата", ДатаЗакрытия);
Запрос.УстановитьПараметр("Организация", Организация);
Запрос.УстановитьПараметр("Склад", Склад);

Результат = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = Результат.Выбрать();

Регистр = РегистрыНакопления.ПартииТоваровНаСкладахБухгалтерскийУчет.СоздатьНаборЗаписей();

Регистр.Отбор.Регистратор.Установить(ДокументЗакрытия);

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
Запись = Регистр.Добавить();
Запись.Активность = Истина;
Запись.ВидДвижения = ВидДвиженияНакопления.Расход;
Запись.Период = КонецДня(ДатаЗакрытия);
Запись.Регистратор = ДокументЗакрытия;
Запись.Организация = ВыборкаДетальныеЗаписи.Организация;
Запись.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;
Запись.СчетУчета = ВыборкаДетальныеЗаписи.СчетУчета;
Запись.Склад = ВыборкаДетальныеЗаписи.Склад;
Запись.ДокументОприходования = ВыборкаДетальныеЗаписи.ДокументОприходования;
Запись.ХарактеристикаНоменклатуры = ВыборкаДетальныеЗаписи.ХарактеристикаНоменклатуры;
Запись.СерияНоменклатуры = ВыборкаДетальныеЗаписи.СерияНоменклатуры;
Запись.Заказ = ДокументЗакрытия;
Запись.Качество = ВыборкаДетальныеЗаписи.Качество;
Запись.Количество = ВыборкаДетальныеЗаписи.КоличествоОстаток;
Запись.Стоимость = ВыборкаДетальныеЗаписи.СтоимостьОстаток;

КонецЦикла;

Регистр.Записать(Истина);



КонецПроцедуры

Процедура ОсновныеДействияФормыСоздатьПартии(Кнопка)

ДатаЗакрытия = КонецДня(ДатаЗакрытия);
СчетУчета = ПланыСчетов.Хозрасчетный.СпецоснасткаИСпецодеждаНаСкладе;

Запрос = Новый Запрос;

Запрос.Текст = 
"ВЫБРАТЬ
| ТоварыОрганизацийОстатки.Организация,
| ТоварыОрганизацийОстатки.Номенклатура,
| ТоварыОрганизацийОстатки.Качество,
| ТоварыОрганизацийОстатки.Склад,
| СУММА(ТоварыОрганизацийОстатки.КоличествоОстаток) КАК КоличествоОстаток,
| СУММА(ХозрасчетныйОстатки.СуммаОстатокДт) КАК СуммаОстатокДт
|ИЗ
| РегистрНакопления.ТоварыОрганизаций.Остатки(
| &Дата,
| Организация = &Организация
| И Склад = &Склад) КАК ТоварыОрганизацийОстатки
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрБухгалтерии.Хозрасчетный.Остатки(&Дата, Счет = &Счет, , Организация = &Организация) КАК ХозрасчетныйОстатки
| ПО ТоварыОрганизацийОстатки.Организация = ХозрасчетныйОстатки.Организация
| И ТоварыОрганизацийОстатки.Номенклатура = ХозрасчетныйОстатки.Субконто1
| И ТоварыОрганизацийОстатки.Склад = ХозрасчетныйОстатки.Субконто2
|
|СГРУППИРОВАТЬ ПО
| ТоварыОрганизацийОстатки.Организация,
| ТоварыОрганизацийОстатки.Номенклатура,
| ТоварыОрганизацийОстатки.Качество,
| ТоварыОрганизацийОстатки.Склад";

Запрос.УстановитьПараметр("Дата", ДатаЗакрытия);
Запрос.УстановитьПараметр("Организация", Организация);
Запрос.УстановитьПараметр("Склад", Склад);
Запрос.УстановитьПараметр("Счет", СчетУчета);

Результат = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = Результат.Выбрать();

Регистр = РегистрыНакопления.ПартииТоваровНаСкладахБухгалтерскийУчет.СоздатьНаборЗаписей();

Регистр.Отбор.Регистратор.Установить(ДокументЗакрытия);

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
Запись = Регистр.Добавить();
Запись.Активность = Истина;
Запись.ВидДвижения = ВидДвиженияНакопления.Приход;
Запись.Период = КонецДня(ДатаЗакрытия);
Запись.Регистратор = ДокументЗакрытия;
Запись.Организация = ВыборкаДетальныеЗаписи.Организация;
Запись.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;
Запись.СчетУчета = СчетУчета;
Запись.Склад = ВыборкаДетальныеЗаписи.Склад;
Запись.ДокументОприходования = ДокументЗакрытия;
Запись.Заказ = ДокументЗакрытия;
Запись.Качество = ВыборкаДетальныеЗаписи.Качество;
Запись.Количество = ВыборкаДетальныеЗаписи.КоличествоОстаток;
Запись.Стоимость = ВыборкаДетальныеЗаписи.СуммаОстатокДт;

КонецЦикла;

Регистр.Записать(Истина);


КонецПроцедуры

 

Также прикладываю отчет, который сравнивает регистры и выводит расхождения по ним.

Также прикладываю обработку для перезаполнения регистров "Свободные остатки", которые выравниваются в соответствии с бухгалтерским учетом. Для корректировки лучше использовать два документа "Корректировка записей регистров", в одном делаете обнуление, а в другом заполняете данные регистра по данным бух учета.

Регистр накопления

См. также

Автоматический заказ поставщику в 1С: загрузка прайсов и анализ цен поставщиков для УТ 10.3, УТ 11, КА2, УНФ, УПП, ERP, Розница 2

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    91967    116    40    

206

Программа для фулфилмента (FBS / FBO): модуль "Ответственное хранение" в 1С:УТ 11.5, КА 2.5, ERP 2.5

Логистика, склад и ТМЦ Бухгалтер Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Оптовая торговля, дистрибуция, логистика Управленческий учет Платные (руб)

Программа для фулфилмента: модуль "Ответственное хранение" для 1С (УТ 11.5, КА 2.5, ERP 2.5) позволяет организовать учет ответственного хранения товаров с весовыми характеристиками, в том числе со сроком годности и личным кабинетом Поклажедателя. Модуль реализован в виде расширения конфигурации, устанавливается в режиме 1С:Предприятие 8 за 5 минут по инструкции, что позволяет оставить конфигурацию 1С на стандартной поддержке и продолжать получать стандартные обновления от фирмы "1С".

60000 руб.

09.06.2020    35609    30    59    

58

Загрузка номенклатуры в УТ11, КА 2, ERP 2, Розница 2 из Excel. Дополнительные реквизиты и сведения, характеристики, картинки, цены, остатки

Загрузка и выгрузка в Excel Розничная торговля Логистика, склад и ТМЦ Ценообразование, анализ цен Прайсы Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Загрузка номенклатуры из файлов Excel (xls, xlsx, ods, csv, mxl) в УТ11, КА 2, ERP 2, Розница 2. Задействованы все возможности конфигурации - заполнение реквизитов номенклатуры, дополнительных реквизитов и сведений, характеристики, доп.реквизиты и сведения характеристик. Дополнительные обработки для расширения возможностей.

10560 руб.

29.10.2014    212878    635    526    

448

Анализ расхождений выручки НДС и Налога на прибыль в декларациях (БП 3.0 ПРОФ и КОРП, КА 2, ЕRP)

Анализ учета Закрытие периода Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Налоговый учет Налог на прибыль НДС Платные (руб)

Каждый бухгалтер не раз сталкивался с требованием от налоговой инспекции пояснить расхождения в показателях декларации по Налогу на прибыль («Доходы от реализации» + «Внереализационные доходы») и налоговой базой по НДС за год. Являются ли ошибкой подобные расхождения? Как пояснить налоговой их причину? Отчет «Анализ расхождений выручки НДС и Налога на прибыль в декларациях» поможет найти все расхождения.

7200 руб.

21.10.2017    84723    266    171    

262

Загрузка номенклатуры c картинками (несколько потоков одновременно) и сопутствующими данными в базу и любые документы из yml, xls, xlsx, xlsm, ods, ots, csv для УТ 10.3, УТ 11 (все), БП 3, КА 2, ERP 2, УНФ 1.6/3.0, Розница 2

Загрузка и выгрузка в Excel Логистика, склад и ТМЦ Ценообразование, анализ цен Файловый обмен (TXT, XML, DBF), FTP Бухгалтер Пользователь Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Платные (руб)

Эволюция не стоит на месте - новая удобная версия функциональной обработки для Вашего бизнеса! Что же Вы получаете? Удобный и интуитивно понятный интерфейс с 3-мя этапами работы. 2 режима - автоматический и ручной. Чтение XLSX, XLSM, CSV, XML/YML форматов без офиса, на любом сервере! Визуальное связывание колонок файла и реквизитов простым перетаскиванием колонок. Создание или обновление номенклатуры с иерархией, характеристик, доп. реквизитов, упаковок, загрузка практически неограниченного количества картинок на одну номенклатуру (с возможностью загрузки в несколько потоков одновременно), с хранением в томах или в базе. Загрузка номенклатуры поставщиков или поиск по их данным номенклатуры. Загрузка доп. реквизитов в характеристики. Загрузка штрихкодов с генерацией новых. Создание элементов справочников и ПВХ "на лету" для выбранных реквизитов. (Обновление от 09.04.2024, версия 9.9 - 9.10)

14400 руб.

20.11.2015    152575    370    376    

505

Перенос данных из УТ 10.3 в УТ 11 / КА 2 / ERP 2. Переносятся документы, справочники и остатки

Перенос данных 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

45650 руб.

24.04.2015    191648    135    239    

270
Оставьте свое сообщение