Расчетные листки организации с рассылкой по почте. Вариант 2

07.05.24

Учетные задачи - Зарплата

Расчетные листки организации с рассылкой по почте. Вызывается стандартный отчет и анализируется для формирования рассылки расчетных листков в формате xls на почтовые ящики сотрудников.

Скачать исходный код

Наименование Файл Версия Размер
РасчетныеЛисткиОрганизаций.epf
.epf 22,30Kb
605
.epf 22,30Kb 605 Скачать

Решил адаптировать отчет для УПП и пришел к идее что лучше будет не копировать стандартный отчет и адаптировать, а вызвать его и проанализировать результаты. В общих чертах: из обработки открывается форма отчета "РасчетныеЛисткиОрганизаций", к ней присоединяется форма формирования рассылки.

Тестировалось в УПП 1.2.25.1 и ЗУП 2.5.17.8 и 2.5.18.2

07.05.2024: тестировалось в УПП 1.3 (1.3.227.1) 

Проверено на следующих конфигурациях и релизах:

  • Управление производственным предприятием, редакция 1.3, релизы 1.3.227.1

См. также

Обновление для КА 1.1, ЗУП 2.5, БУХ 2.0: НДС, ЕФС-1, Расчет страховых взносов, Мобилизация, Статистика, Электронные трудовые книжки, 2-НДФЛ, Регламентированная отчетность, Кадровый учет, Прослеживаемость импортных товаров

Зарплата Регламентированный учет и отчетность Кадровый учет Обновление 1С Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Зарплата и Управление Персоналом 2.5 Бухгалтерский учет Налоговый учет Управленческий учет Акцизы ЕНВД ЕСН Земельный налог ИП, ПБОЮЛ, КФХ Налог на имущество Налог на прибыль НДС НДФЛ ФОМС, ЕФС Транспортный налог УСН ПСН (патентная система налогообложения) Платные (руб)

Обновления для конфигураций: КА 1.1; ЗУП 2.5; БУХ 2.0; КА 1.1 Комплексная автоматизация торговли алкогольной продукцией; КА 1.1 Комплексный учет сельскохозяйственного предприятия

19900 руб.

01.04.2020    141940    668    352    

233

Перенос данных из Парус 8 в ЗГУ 3

Зарплата Внешние источники данных Бюджетный учет Системный администратор Программист Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 Государственные, бюджетные структуры Россия Бухгалтерский учет Бюджетный учет Платные (руб)

Обработка позволяет перенести кадровую информацию и данные по заработной плате, фактических удержаниях, НДФЛ, вычетах, страховых взносах из базы Парус 8 учреждений в конфигурацию 1С:Зарплата и кадры государственного учреждения ред. 3 (ЗГУ) и начать с ней работать с любого месяца года.

84000 руб.

19.08.2020    22891    19    1    

22

Перенос данных из Камин 3.5 (5.5) в ЗиКГУ 3.х

Перенос данных 1C Зарплата Бюджетный учет Программист Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 1С:Зарплата и Управление Персоналом 3.x Государственные, бюджетные структуры Россия Бюджетный учет Платные (руб)

Обработки для быстрого перехода с конфигураций «КАМИН:Расчет зарплаты для бюджетных учреждений 3.5» и «КАМИН:Зарплата для бюджетных учреждений 5.5» на конфигурацию «Зарплата и кадры государственного учреждения».

12000 руб.

28.07.2016    57679    146    141    

122

"Акты сверки +" Групповая подготовка и рассылка актов сверки для Бухгалтерии 3.0.

Взаиморасчеты Email рассылки Акт сверки Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Платные (руб)

Внешняя обработка для Бухгалтерии 3.0 - позволяет автоматически формировать документы «Акт сверки расчетов» с контрагентами за выбранный период с последующей фоновой отправкой на почту контрагента.

3000 руб.

25.11.2020    22731    186    7    

167

Устранение начислений прошлых периодов из ведомостей: в банк, в кассу, на счета в ЗУП 3.1, КА, ЗиКГУ 3.1

Зарплата Программист Бизнес-аналитик Бухгалтер Платформа 1С v8.3 1С:Зарплата и кадры государственного учреждения 3 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Платные (руб)

При заполнении ведомости на выплату зарплаты вылазят задолженности прошлых периодов, которых быть не должно? Наша обработка позволяется убрать эти доходы прошлых периодов за пару секунд. Больше не нужно тратить часы на анализ каждого такого случая.

15600 руб.

14.09.2022    13422    64    26    

66

Перенос данных из Парус 7.хх в ЗГУ ред.3

Внешние источники данных Зарплата Бюджетный учет Программист Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 Государственные, бюджетные структуры Россия Бухгалтерский учет Бюджетный учет Платные (руб)

Обработка позволяет перенести кадровую информацию и данные по заработной плате, фактических удержаниях, НДФЛ, вычетах, страховых взносах из базы Парус 7.хх учреждений в конфигурацию 1С:Зарплата и кадры государственного учреждения ред. 3 (ЗГУ) и начать с ней работать с любого месяца года.

24000 руб.

24.04.2017    49084    97    163    

87
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. gutentag 253 03.11.09 21:29 Сейчас в теме
2. rabanik 2 17.11.09 19:08 Сейчас в теме
3. ctankina 04.12.09 11:32 Сейчас в теме
4. MOPC 24 19.05.10 09:10 Сейчас в теме
Спасибо.

Модифицировал - добавил получение адреса электронной почты из AD.

Функция ПолучитьАдресЭлектроннойПочтыИзActiveDirectory(Объект) Экспорт
//
Адр = "";
АдоСоед = новый ComObject("ADODB.Connection");
АдоСоед.Provider = "ADSDSOObject";
АдоСоед.Open("ADs Provider");

query = "SELECT ADsPath FROM 'LDAP://DC=ВашДомен,DC=ru' WHERE objectClass='user' AND objectCategory='person' AND name = '"+Объект.Сотрудник.Наименование+"'";

Cmd = Новый ComObject("ADODB.Command");
Cmd.ActiveConnection = АдоСоед;
Cmd.CommandType = 1;
Cmd.CommandText= query;

Rs = новый ComObject("ADODB.RecordSet");

попытка
Rs = Cmd.Execute();

Rs.MoveFirst();
Пока Rs.EOF() = 0 do
Value1 = ПолучитьCOMОбъект(Rs.Fields("ADsPath").Value);
Адр = Value1.Mail;
Rs.MoveNext();
КонецЦикла;
исключение
Сообщить("Почтовый адрес в AD для сотрудника "+Объект.Сотрудник.Наименование+" не найден!");
конецпопытки;
Rs.Close();
Rs = NULL;
Cmd = NULL;
АдоСоед.Close();
АдоСоед = NULL;

возврат Адр;
конецфункции

//////////////////////////////////

Использование:

Процедура СформироватьТаблицуСотрудников(ТабличныйДокумент,ДанныеРасшифровки) Экспорт
...
Для каждого СтрокаТабл Из ТаблицаСотрудников Цикл
СтрокаТабл.Адрес=ПолучитьАдресЭлектроннойПочтыИзActiveDirectory(СтрокаТабл);
если ПустаяСтрока(СтрокаТабл.Адрес) тогда
СтрокаТабл.Адрес=ПолучитьАдресЭлектроннойПочтыИзКонтактнойИнформации(СтрокаТабл.Сотрудник.Физлицо);
конецесли;
Если ПустаяСтрока(СтрокаТабл.Адрес) Тогда
СтрокаТабл.Пометка=Ложь;
возврат;
КонецЕсли;
...
5. kate_kate 07.06.10 17:38 Сейчас в теме
Спасибо большое, очень помог этот отчетик
6. Anna_Vl 18.11.10 10:48 Сейчас в теме
Спасибо огромное, отличный отчет!
7. sound 535 29.12.10 00:03 Сейчас в теме
Ай маладца! Хотел уже сам писать. Лови жЫрный плюс!
8. nicon1984 02.02.11 23:19 Сейчас в теме
Отличная вещь=) попробовал на 2.5.31 все прекрасно работает, респект.
9. Lo1jke 05.07.11 14:19 Сейчас в теме
Спасибо, очень полезно!
10. vlasov 20.07.11 17:36 Сейчас в теме
11. amalisheva 15.09.11 14:51 Сейчас в теме
хорошая вешь! огромное спасибо
12. aqua22 25.09.11 22:35 Сейчас в теме
Спасибо! Очень полезная обработка!
13. e_kazakova 80 23.11.11 11:49 Сейчас в теме
А для ЗУП 8.2 эта обработка будет работать?
14. oaizatulin@yahoo.com 28.12.11 13:17 Сейчас в теме
Супер! Большое спасибо. Надесь быстро врубиться и внедрить до НГ
15. oaizatulin@yahoo.com 28.12.11 13:18 Сейчас в теме
Скажите пож.
Модифицировал - добавил получение адреса электронной почты из AD.

Функция ПолучитьАдресЭлектроннойПочтыИзActiveDirectory(Объект) Экспорт
//
Адр = "";
АдоСоед = новый ComObject("ADODB.Connection");
АдоСоед.Provider = "ADSDSOObject";
АдоСоед.Open("ADs Provider");

query = "SEL ECT ADsPath FR OM 'LDAP://DC=ВашДомен,DC=ru' WHERE objectClass='user' AND objectCategory='person' AND name = '"+Объект.Сотрудник.Наименование+"'";

Cmd = Новый ComObject("ADODB.Command");
Cmd.ActiveConnection = АдоСоед;
Cmd.CommandType = 1;
Cmd.CommandText= query;

Rs = новый ComObject("ADODB.RecordSet");

попытка
Rs = Cmd.Execute();

Rs.MoveFirst();
Пока Rs.EOF() = 0 do
Value1 = ПолучитьCOMОбъект(Rs.Fields("ADsPath").Value);
Адр = Value1.Mail;
Rs.MoveNext();
КонецЦикла;
исключение
Сообщить("Почтовый адрес в AD для сотрудника "+Объект.Сотрудник.Наименование+" не найден!");
конецпопытки;
Rs.Close();
Rs = NULL;
Cmd = NULL;
АдоСоед.Close();
АдоСоед = NULL;

возврат Адр;
конецфункции

//////////////////////////////////
Показать


Использование:

Процедура СформироватьТаблицуСотрудников(ТабличныйДокумент,ДанныеРасшифровки) Экспорт
...
Для каждого СтрокаТабл Из ТаблицаСотрудников Цикл
СтрокаТабл.Адрес=ПолучитьАдресЭлектроннойПочтыИзActiveDirecto­ry(СтрокаТабл);
если ПустаяСтрока(СтрокаТабл.Адрес) тогда
СтрокаТабл.Адрес=ПолучитьАдресЭлектроннойПочтыИзКонтактнойИнф­ормации(СтрокаТабл.Сотрудник.Физлицо);
конецесли;
Если ПустаяСтрока(СтрокаТабл.Адрес) Тогда
СтрокаТабл.Пометка=Ложь;
возврат;
КонецЕсли;

а этот код как использовать?
16. Alltruist 114 28.12.11 13:23 Сейчас в теме
(15) oaizatulin@yahoo.com, я не понял о каком именно коде идет речь?
17. kit 74 26.01.12 01:07 Сейчас в теме
Отчет пригодился, спасибо!
18. Andryuha83 16.02.12 13:42 Сейчас в теме
А там код открытый?
Нужно сделать такой отчет, жаль скачать пока не могу(
20. Alltruist 114 16.02.12 14:36 Сейчас в теме
19. Мать Тереза 16.02.12 13:58 Сейчас в теме
Расчетные листки-хорошая вещь,частенько народ просит, а тут рассылкой-экономит время, особенно у кого штат большой.
21. lira_nk 16.02.12 14:47 Сейчас в теме
Полезная вещица,забираю :)
22. Gonza1978 20.02.12 11:10 Сейчас в теме
Отличная вещь!!! Самому поставили задачу доработать программу, чтобы можно было рассылать расчетные листки сотрудникам. Подумал, может есть что-то уже готовое. И точно - есть!
Реализовано лучше не придумаешь! В список рассылки попадают только те, у которых заполнено поле E-mail. Тема письма формируется автоматически и сразу понятная пользователям.
В ЗУП под 1С8.2 великолепно работает после стандартной конвертации. Единственное, у меня ранее встроенная учетная запись была настроена без реальной настройки пользователя POP3, а при рассылке расчетных листков почему то стала ругаться, что нет такого пользователя. Ну это мелочи, да и ругается скорее всего сам стандартный модуль рассылки.
23. festiv1 07.03.12 19:21 Сейчас в теме
А можно отправить по e-mail altress@yandex.ru? не получается скачать
24. iran3 05.04.12 13:12 Сейчас в теме
Пожалуйста, скиньте этот отчетик на irbor@mail.ru. Очень нужно и время не терпит. Заранее большое спасибо!
25. necropunk 9 05.06.12 13:09 Сейчас в теме
Жирный плюс. Хорошая реализация. Переписал под себя, все замечательно.
26. Pavel777777 69 19.07.12 20:29 Сейчас в теме
27. Mixailo333 19.09.12 22:54 Сейчас в теме
Скажите, а как проверить корректность работы, если всем сотрудникам уже забит свой и-мейл? Не переделывать же вручную для каждого сотрудника на тестовый адрес...
28. RakovskiyK 21.11.12 22:52 Сейчас в теме
великолепно! как раз то, что нужно. пробовал другие, но здесь есть выборочная рассылка. работает великолепно.
29. Zhilyakovdr 142 11.03.13 17:47 Сейчас в теме
Отличная штука! Работает на Комплексной.
30. Baksheev-Nikita 586 29.05.13 11:20 Сейчас в теме
Хорошая публикация. Большой плюс в том, что вызывается стандартный типовой отчет, а на его основе формируются письма. Таким образом обновления типовых конфигураций не влияют на работоспособность данной обработки.
31. Lo1jke 03.08.13 16:47 Сейчас в теме
Изменил Вашу обработку и использую каждый месяц при рассылке расчеток. Спасибо большое за труды!
32. Mila81 34 04.12.13 15:34 Сейчас в теме
спасибо, пригодилось :)
33. sergio199 17 21.07.14 08:24 Сейчас в теме
Интересная. Замечание хотелось бы добавить - желательно добавить проверку на наличие каталога и вообще поле для хранения файлов с расчетными листами вывести на форму. ну а так - респект за обработку!
34. stroga 85 29.07.16 16:31 Сейчас в теме
Обработка проработала несколько лет. Сейчас выдает ошибку:
Обработка.РасчетныеЛисткиОрганизацийПоПочте.МодульОбъекта(515)}: Значение, соответствующее ключу, не задано
Сотрудник = ДанныеРасшифровки.Элементы[ИдентификаторРасшифровки].ПолучитьПоля()[0].Значение;
Причем только в клиент-серверном варианте работы 1С (УПП). В файловом варианте БД, локально без ошибок.
35. Alltruist 114 29.07.16 20:24 Сейчас в теме
(34) stroga, а версия УПП какая?
36. itriot11 95 29.12.16 12:10 Сейчас в теме
(35) столкнулся с тем же, что и (34)

1С:Предприятие 8.3 (8.3.9.1818)
Управление производственным предприятием, редакция 1.3 (1.3.85.2)

Правится изменением в двух местах этого:

ИдентификаторРасшифровки=ТабличныйДокумент.Область(НомерСтрокиНачалаРЛ+3,1 , НомерСтрокиНачалаРЛ+3,1 ).Расшифровка;
Сотрудник = ДанныеРасшифровки.Элементы[ИдентификаторРасшифровки].ПолучитьПоля()[0].Значение;

на это

Сотрудник = ТабличныйДокумент.Область(НомерСтрокиНачалаРЛ+3,1 , НомерСтрокиНачалаРЛ+3,1 ).Расшифровка;

Спасибо за разработку!
rkozom; Dionis; +2 Ответить
42. rkozom 25.05.21 10:29 Сейчас в теме
(36)
Сотрудник = ТабличныйДокумент.Область(НомерСтрокиНачалаРЛ+3,1 , НомерСтрокиНачалаРЛ+3,1 ).Расшифровка;

(36)

Спасибо большое за подсказку! Все заработало на версии 2.5.161.1.
43. it-volna.com 19 27.03.22 13:45 Сейчас в теме
Проверено на УПП 1.3 (1.3.176.2) работает надо только внести изменения из
(36)
Сотрудник = ТабличныйДокумент.Область(НомерСтрокиНачалаРЛ+3,1 , НомерСтрокиНачалаРЛ+3,1 ).Расшифровка;
37. user752987 30.05.17 11:44 Сейчас в теме
Добрый день, скачали обработку, но при формировании списка выдает ошибку (во вложении). Как исправить ошибку?
Прикрепленные файлы:
ошибка расч.листки.docx
38. user817736 12.02.18 12:45 Сейчас в теме
Спасибо большое! Отлично работает и выручает.
39. sound 535 13.02.18 10:32 Сейчас в теме
Проверил еще раз, все работает
40. Alltruist 114 13.02.18 13:53 Сейчас в теме
Кто бы мог подумать! Написал эту обработку в 2009 году, а до сих пор живет...
41. alo2012 23 02.03.18 11:23 Сейчас в теме
44. user1997820 24.04.24 09:48 Сейчас в теме
Добрый день! Нажимаю на кнопку Сформировать список

Получаю ошибку
Значение, соответствующее ключу, не задано
{ВнешняяОбработка.РасчетныеЛисткиОрганизаций.МодульОбъекта(515)}: Сотрудник = ДанныеРасшифровки.Элементы[ИдентификаторРасшифровки].ПолучитьПоля()[0].Значение;
{ВнешняяОбработка.РасчетныеЛисткиОрганизаций.Форма.ФормаОтправкиПочты.Форма(149)}: СформироватьТаблицуСотрудников(ТабличныйДокумент,ВладелецФормы.ДанныеРасшифровки);

Управление производственным предприятием, редакция 1.3 (1.3.225.1)
1С:Предприятие 8.3 (8.3.24.1467)
45. Alltruist 114 25.04.24 11:43 Сейчас в теме
(44) Добрый день! Этой обработке уже много лет и уже даже успел забыть про ее существование. Постараюсь на майских праздниках посмотреть по вашей ошибке.
46. user1997820 02.05.24 16:36 Сейчас в теме
Добрый день. Получилось исправить?
47. Alltruist 114 07.05.24 16:46 Сейчас в теме
(46) Добрый день. Исправил. Проверил на УПП 1.3 (1.3.227.1)
Оставьте свое сообщение