Генератор штрихкода SSСС или GS1 для типовых конфигурация на управляемом приложении

20.07.17

Учетные задачи - Розничная торговля

Обработка формирует и печатает штрих код SSCC. Обработка будет работать в любой типовой конфигурации под управляемым приложением. Для печати используются стандартные средства типовых конфигураций. Подключение внешних библиотек не требуется.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Генератор штрих кода SSСС или GS1 для типовых конфигурация на управляемом приложении:
.epf 9,21Kb
116
116
1 SM
Скачать Купить за 1 850 руб.

Пример демонстрирует формирование штрих кода SSCC по стандарту GS1 для палеты. Формат штрих кода соответствуе требованиям сети X5.

Код генерации штрих кода:

#Область Алгоритм_Формирования_ШтрихКода// Функция формирует контрольный символ

// ==Параметры ================================
//** ШтрихДляОбработки - в этот параметр передается штрих код формата SSCC GS1 подмножество формата EAN-128
//** КоличествоРазрядов - передается чмсло разрядом для расчета контрольного символа для GS1 значение равно 17
&НаСервере
Функция Сформировать_КонтрольныйСимвол(ШтрихДляОбработки,КоличествоРазрядов)
    СтрокаДляОбработки=Прав(СокрЛП(Строка(ШтрихДляОбработки)),КоличествоРазрядов);
    КонтрольнаяСумма=0;
    Для ц=1 по КоличествоРазрядов Цикл 
        ЧислоДляАнализа=Число(Сред(СтрокаДляОбработки,ц,1));
        ОстатокОтДеления=ц/2 -Цел(ц/2);
        Если ОстатокОтДеления=0 Тогда
            КонтрольнаяСумма=КонтрольнаяСумма+ ЧислоДляАнализа;
        Иначе
            КонтрольнаяСумма=КонтрольнаяСумма+ ЧислоДляАнализа*3;
        КонецЕсли;    
    КонецЦикла;    
    КонтрольныйСимвол=Окр(КонтрольнаяСумма,-1)-КонтрольнаяСумма;
    Если КонтрольныйСимвол<0 Тогда
        КонтрольныйСимвол=КонтрольныйСимвол+10;
    КонецЕсли;    
    Возврат КонтрольныйСимвол
КонецФункции    
//********************************************************************************


//Функция формируем первичный штрих код в формате SSCC или GS1 
// Состав шрих кода можно менять
&НаСервере
Функция Сформировать_ШтрихSSCC(КодУпаковки,ГЛН,НомерПаллеты)
    Штрих=""+КодУпаковки+Лев(СокрЛП(Строка(ГЛН)),9)+Строка(Формат(НомерПаллеты,"ЧЦ=7; ЧРГ=' '; ЧВН=; ЧГ=0"));
    Штрих=Штрих+Сформировать_КонтрольныйСимвол(Штрих,17);
    Возврат Штрих
КонецФункции    
//*************************************************************************

#КонецОбласти


В 

Процедуру печати штрих кода можно будет посмотреть в самой обработке 

Удачи всем!!!!

Генератор штрих код SSСС GS1 EAN-128 EAN

См. также

Оптовая торговля Розничная торговля Обмен с ГосИС Бухгалтер Платформа 1С v8.3 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полнофункциональное расширение (ранее известное как Модуль 1С-ЕГАИС) для взаимодействия типовых конфигураций 1С и ЕГАИС, предоставляющее максимум возможностей по работе с УТМ. Получение и отправка ТТН, отправка акта о постановке на баланс и акта о списании. Получение остатков. Загрузка и сопоставление номенклатуры и контрагентов. Оправка в ЕГАИС отчетов о производстве и импорте.

8970 руб.

15.12.2015    168645    795    364    

394

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия 1.6 1С:Бухгалтерия автономного учреждения 1С:CRM ПРОФ, КОРП Россия Платные (руб)

Универсальная обработка для обслуживания любых фискальных регистраторов (ККТ), в том числе Веб сервер АТОЛ. Работает в соответствии с 54-ФЗ. (ФФД 1.0, ФФД 1.05, ФФД 1.1). Подключайте любую онлайн кассу к практически любой конфигурации. Нет необходимости обновлять 1С. Можно бесплатно скачать и протестировать. Может работать одновременно с несколькими онлайн-кассами, либо одной с разных рабочих мест. (через RDP, TCP\IP или веб-сервер) Позволяет разделить один чек сразу на несколько ККТ или на несколько систем налогообложения. Поддерживает разрешительный режим. Можно настроить собственный шаблонов чека. Можно использовать эквайринг там, где он не поддерживается. Работает на LINUX и Windows ЭМУЛЯТОР + ЭКВАЙРИНГ + МАРКИРОВКА + ПОДДЕРЖКА ФФД 1.2

6000 руб.

27.02.2017    787974    4749    9507    

2816

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    93608    119    40    

210

Розничная торговля Маркетплейсы Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Платные (руб)

Модуль для интеграции 1С с сервисом СберМаркет/Купер. Предназначен для обмена данными из торговых точек розничных сетей из баз данных 1С в базы данных СберМаркет/Купер, для отображения информации по товарам, остаткам, ценам, заказам и статусам заказов. Позволяет оперативно начать работать с сервисом СберМаркет, существенно повысить продажи и лояльность клиентов.

35000 руб.

14.10.2022    8698    15    14    

11

Оптовая торговля Розничная торговля Обмен с ГосИС Программист Бухгалтер Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Платные (руб)

Данная публикация создана для помощи разработчикам, интеграторам и другим заинтересованным лицам по настройке системы маркировки обуви, одежды, лекарств, табака, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин. Смело задавайте вопросы по работе с ЦРПТ, GS1, ЭДО, Национальным каталогом, накопили достаточно большую базу знаний по данным темам и готовы ответить на все Ваши вопросы.

5000 руб.

18.03.2019    111813    29    114    

182

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия автономного учреждения Россия Платные (руб)

Обработка осуществляет обслуживание ККТ АТОЛ, Штрих и Меркурий для конфигураций "УТ 10.3", "КА 1.1", "УПП 1.3", "Розница 1.0", "БП 2.0" и других отраслевых решений, построенных на основе указанных выше конфигурациях. Поддерживает возможность параллельно пробития чеков на одной ККМ несколькими пользователями. Поддерживает Веб-сервер Атол. Соответствует требованиям 54-ФЗ. Поддерживает ФФД 1.0, 1.05, 1.1 и 1.2. Разделяет чеки по нескольким СНО. Поддерживает механизмы подключения ККТ по TCP/IP, для работы через RDP или интернет. Поддержка маркировки и разрешительного режима.

5400 руб.

25.05.2015    330408    1898    3031    

1013
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Smikle 54 20.07.17 12:41 Сейчас в теме
Спасибо!
Нужная штука!
2. Nemo 16.08.17 16:18 Сейчас в теме
А какой тип штрихкода вы выводите на печать? 1С же не поддерживает печать GS1-128
.
3. DimonYarkin 27 18.08.17 11:18 Сейчас в теме
в 1с это CODE-128. GS1-128 это подмножество CODE-128. Просто в GS1 есть идентификаторы применения например (00)+штрих код паллеты по стандарту SSCC. А для вывода на печать это обычный CODE-128. Обработка читаного щтрихкода ведется в програмном обеспечении терминалов сбора данных.
4. DimonYarkin 27 18.08.17 11:19 Сейчас в теме
Идентификаторы применения это просто маркеры для разбора штрихкода и не более того
5. Ulus 291 07.09.17 10:20 Сейчас в теме
это GS1-128
на нас вышла пятерочка требуют GSI DataBar Expanded Stacked (расширенный многострочный) эту тему не изучали?
6. пользователь 16.09.17 17:56
Сообщение было скрыто модератором.
...
7. rudsergo 31.10.17 14:43 Сейчас в теме
Добрый день всем! Так вопрос остался открытым можно ли как то формировать в 1с GS1 DataBar Expanded Stacked по требования торговых сетей?
8. DimonYarkin 27 01.11.17 09:03 Сейчас в теме
(7) я уже отвечал на этот вопрос

в 1с это CODE-128. GS1-128 это подмножество CODE-128. Просто в GS1 есть идентификаторы применения например (00)+штрих код паллеты по стандарту SSCC. А для вывода на печать это обычный CODE-128. Обработка читаного щтрихкода ведется в програмном обеспечении терминалов сбора данных.
9. rudsergo 01.12.17 09:20 Сейчас в теме
Скачал обработку. Так и не пойму как напечатать ШК GS1 Databar Stacked
anri123; stilet; toliman; +3 Ответить
10. пользователь 24.04.18 13:17
Сообщение было скрыто модератором.
...
Оставьте свое сообщение