Генератор штрихкода SSСС или GS1 для типовых конфигурация на управляемом приложении

Обработки - Универсальные обработки

Обработка формирует и печатает штрих код SSCC. Обработка будет работать в любой типовой конфигурации под управляемым приложением. Для печати используются стандартные средства типовых конфигураций. Подключение внешних библиотек не требуется.

Пример демонстрирует формирование штрих кода SSCC по стандарту GS1 для палеты. Формат штрих кода соответствуе требованиям сети X5.

Код генерации штрих кода:

#Область Алгоритм_Формирования_ШтрихКода// Функция формирует контрольный символ

// ==Параметры ================================
//** ШтрихДляОбработки - в этот параметр передается штрих код формата SSCC GS1 подмножество формата EAN-128
//** КоличествоРазрядов - передается чмсло разрядом для расчета контрольного символа для GS1 значение равно 17
&НаСервере
Функция Сформировать_КонтрольныйСимвол(ШтрихДляОбработки,КоличествоРазрядов)
    СтрокаДляОбработки=Прав(СокрЛП(Строка(ШтрихДляОбработки)),КоличествоРазрядов);
    КонтрольнаяСумма=0;
    Для ц=1 по КоличествоРазрядов Цикл 
        ЧислоДляАнализа=Число(Сред(СтрокаДляОбработки,ц,1));
        ОстатокОтДеления=ц/2 -Цел(ц/2);
        Если ОстатокОтДеления=0 Тогда
            КонтрольнаяСумма=КонтрольнаяСумма+ ЧислоДляАнализа;
        Иначе
            КонтрольнаяСумма=КонтрольнаяСумма+ ЧислоДляАнализа*3;
        КонецЕсли;    
    КонецЦикла;    
    КонтрольныйСимвол=Окр(КонтрольнаяСумма,-1)-КонтрольнаяСумма;
    Если КонтрольныйСимвол<0 Тогда
        КонтрольныйСимвол=КонтрольныйСимвол+10;
    КонецЕсли;    
    Возврат КонтрольныйСимвол
КонецФункции    
//********************************************************************************


//Функция формируем первичный штрих код в формате SSCC или GS1 
// Состав шрих кода можно менять
&НаСервере
Функция Сформировать_ШтрихSSCC(КодУпаковки,ГЛН,НомерПаллеты)
    Штрих=""+КодУпаковки+Лев(СокрЛП(Строка(ГЛН)),9)+Строка(Формат(НомерПаллеты,"ЧЦ=7; ЧРГ=' '; ЧВН=; ЧГ=0"));
    Штрих=Штрих+Сформировать_КонтрольныйСимвол(Штрих,17);
    Возврат Штрих
КонецФункции    
//*************************************************************************

#КонецОбласти


В 

Процедуру печати штрих кода можно будет посмотреть в самой обработке 

Удачи всем!!!!

Скачать файлы

Наименование Файл Версия Размер
Генератор штрих кода SSСС или GS1 для типовых конфигурация на управляемом приложении:
.epf 9,21Kb
20.07.17
57
.epf 9,21Kb 57 Скачать

См. также

Комментарии
1. Михаил S (Smikle) 20.07.17 12:41 Сейчас в теме
2. Nemo (Nemo) 16.08.17 16:18 Сейчас в теме
А какой тип штрихкода вы выводите на печать? 1С же не поддерживает печать GS1-128
.
3. Dmitry Yarkin (DimonYarkin) 14 18.08.17 11:18 Сейчас в теме
в 1с это CODE-128. GS1-128 это подмножество CODE-128. Просто в GS1 есть идентификаторы применения например (00)+штрих код паллеты по стандарту SSCC. А для вывода на печать это обычный CODE-128. Обработка читаного щтрихкода ведется в програмном обеспечении терминалов сбора данных.
4. Dmitry Yarkin (DimonYarkin) 14 18.08.17 11:19 Сейчас в теме
Идентификаторы применения это просто маркеры для разбора штрихкода и не более того
5. Сергей Козынкин (Ulus) 248 07.09.17 10:20 Сейчас в теме
это GS1-128
на нас вышла пятерочка требуют GSI DataBar Expanded Stacked (расширенный многострочный) эту тему не изучали?
7. Сергей Руднев (rudsergo) 31.10.17 14:43 Сейчас в теме
Добрый день всем! Так вопрос остался открытым можно ли как то формировать в 1с GS1 DataBar Expanded Stacked по требования торговых сетей?
8. Dmitry Yarkin (DimonYarkin) 14 01.11.17 09:03 Сейчас в теме
(7) я уже отвечал на этот вопрос

в 1с это CODE-128. GS1-128 это подмножество CODE-128. Просто в GS1 есть идентификаторы применения например (00)+штрих код паллеты по стандарту SSCC. А для вывода на печать это обычный CODE-128. Обработка читаного щтрихкода ведется в програмном обеспечении терминалов сбора данных.
9. Сергей Руднев (rudsergo) 01.12.17 09:20 Сейчас в теме
Скачал обработку. Так и не пойму как напечатать ШК GS1 Databar Stacked
Оставьте свое сообщение