Восстановление учета затрат (41 счет) и состояния расчетов с контрагентами (УПП ред. 1.3)

23.11.18

Учетные задачи - Взаиморасчеты

В типовой механизм обработки "Восстановление состояний расчетов с контрагентами" встроена возможность восстанавливать последовательность проведения документов по учету затрат (регистр накопления "Учет затрат (бухгалтерский и налоговый учет)"), на основании которого, определяется себестоимость товаров на 41 счете бухгалтерского учета. Поскольку, очень часто документы по приходу, перемещению, комплектации или реализации товаров вводятся задним числом, в программе происходит некорректное формирование себестоимости товаров. В связи, с чем, необходимо осуществлять последовательное перепроведение документов в расчетном периоде, что позволяет сделать данная обработка.

Скачать исходный код

Наименование Файл Версия Размер
Восстановление учета затрат (41 счет) и состояния расчетов с контрагентами (УПП ред. 1.3):
.epf 28,45Kb
4
.epf 28,45Kb 4 Скачать

Суть обработки такова: в конфигураторе создается последовательность документов (В неё включаются документы, которые делают движения в регистр накопления "Учет затрат (бухгалтерский и налоговый учет)"). Точка актуальности данной последовательности будет отображать последний проведенный документ по этой последовательности.

Обработка состоит из 3 (трёх) шагов (см. скриншоты):

Шаг 1: На закладке "Анализ проведения в Бух. учете (Шаг1)" можно проанализировать документы за выбранный период,  которые проведены только по управленческому учету и возможно их нужно провести и по бухгалтерскому учету, если вдруг пользователь забыл это сделать.

Шаг 2: На закладке "Установка начальных границ (Шаг2)" можно сдвинуть начальную границу последовательности на нужную - по выбранной организации.

Шаг 3: На закладке "Регламент (Шаг 3)" необходимо сперва восстановить последовательность документов по "Учету затрат" до заданной даты "Актуальности" по  выбранным организациям (т.е.перепровести все документы данной последовательности). Поскольку, при проведении, документы встают на регистрацию в планах обмена, обработка проанализирует: если документ до проведения не был на регистрации в узле обмена, то обработка его не поставит на обмен, а если был, то она его оставит в обмене (Анализ происходит по всем имеющимся в базе обменам). Только после восстановления последовательности по учету затрат, можно использовать восстановление последовательности расчетов по приобретению и расчетов по реализации - это типовой механизм.  

Для использования данной обработки необходимо внести 2(два) изменения в конфигуратор:

 1. Создать последовательность "РасчетыПоУчетуЗатрат" и добавить в неё измерение "Организация", а так же виды документов, которые являются регистраторами по регистру накопления "Учет затрат (бухгалтерский и налоговый учет)" см. приложенный скриншот - так же для роли "Пользователь" дать права на "Чтение" и "Изменение" этой последовательности.

2. Добавить программный код в конец процедуры "РасширеннаяАналитикаЗапасовИзменениеСостояния" общего модуля "УправлениеЗапасамиРасширеннаяАналитика" (см. приложеный скриншот или текст кода ниже) - для регистрации проводимого документа в последовательности:

    

//Добавил+
    ИмяПоследовательностиДляРегистрации = "РасчетыПоУчетуЗатрат";
    // Регистрация в последовательности при необходимости
    МассивТипов = Новый Массив;
    Для Каждого ТекСтрока Из Метаданные.Документы Цикл
        Если Не Метаданные.ПодпискиНаСобытия.ПриПроведенииРасширеннаяАналитикаЗапасовИзменениеСостояния.Источник.Типы().Найти(Тип("ДокументОбъект." + ТекСтрока.Имя)) = Неопределено Тогда
            МассивТипов.Добавить(Тип("ДокументСсылка." + ТекСтрока.Имя))
        КонецЕсли;
    КонецЦикла;
    
    Если Не Источник.Ссылка.Метаданные().Реквизиты.Найти("Организация") = Неопределено и Не МассивТипов.Найти(ТипЗнч(Источник.Ссылка))=Неопределено Тогда
            //Непосредственная регистрация в последовательности
            ПоследовательностьДляРегистрации = Последовательности.РасчетыПоУчетуЗатрат.СоздатьНаборЗаписей();
            ПоследовательностьДляРегистрации.Отбор.Регистратор.Установить(Источник.Ссылка);
            ПоследовательностьДляРегистрации.Прочитать();
            Если ПоследовательностьДляРегистрации.Количество()>0 Тогда
                ПоследовательностьДляРегистрации.Очистить();
            КонецЕсли; 
            
            ЗаписьРегистрации = ПоследовательностьДляРегистрации.Добавить();
            ЗаписьРегистрации.Регистратор = Источник.Ссылка;
            ЗаписьРегистрации.Период       = Источник.Дата;
            ЗаписьРегистрации.Организация = Источник.Ссылка.Организация;
            // При этом должна соответствующим образом подвинуться граница (выполняется средствами платформы)
            
            Если ПоследовательностьДляРегистрации.Модифицированность() Тогда
                ПоследовательностьДляРегистрации.Записать();
            КонецЕсли;
            
            // В неоперативном режиме границы последовательностей сдвигаются назад, если они позже документа.
            Если РежимПроведения = РежимПроведенияДокумента.Неоперативный Тогда
                БухгалтерскийУчетРасчетовСКонтрагентами.СдвигГраницыПоследовательностиНазад(ИмяПоследовательностиДляРегистрации, Новый МоментВремени(Источник.Дата,Источник.Ссылка), 
                Новый Структура("Организация",Источник.Ссылка.Организация));
            КонецЕсли;
    КонецЕсли;
    //Добавил-

Как показывает практика, такое перепроведение документов последовательности за месяц лучше запускать на ночь (чтобы не нагружать базу в рабочее время). В случае, если по каким-либо причинам, документ не будет перепроведен, после выполнения обработки - пользователю будет выдано сообщение: по каким документам не удалось перепровести. (В случае проблемы перепроведения документа (взаимоблокировки) - обработка делает до 10 попыток перепроведения документа увеличивая интервал попытки на 1, 2, 3 и т.д, до 10 секунд).

Тестировалось не релизе УПП 1.3.112.4.

учет затрат (41 счет) расчеты с контрагентами

См. также

Учет по проектам в 1С:Бухгалтерии 3.0

Учет доходов и расходов Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Расширение "Проекты" добавляет в типовую конфигурацию управленческий учет по проектам: позволяет вести список проектов, привязывать проекты к документам, подсчитывать доходы и расходы в разрезе проектов в 1С.

15000 руб.

30.11.2021    21630    95    48    

79

Модуль Фонды: Простое управление финансами для УНФ, УТ 10/11, КА, УПП / ERP, КА, БП

Учет доходов и расходов БДР, БДДС Бюджетный учет Бизнес-аналитик Пользователь Руководитель проекта 8.3.14 Конфигурации 1cv8 1С:Управление торговлей 11 Беларусь Россия Казахстан Бюджетный учет Управленческий учет Платные (руб)

Как держать деньги под контролем с помощью 1С УНФ, УТ, КА, ERP или БП и 2 часов в неделю без внедрения бюджетирования и найма финансиста. Дополнение для 1С 8.3 Модуль реализован в виде конфигурации и рассчитан для собственников компаний с чистой прибылью до 10 млн руб. / мес. То есть, пока вам не рентабельно вести сложные модули типа «Бюджетирование», «Казначейство», но нужно знать, сколько платить на этой неделе и хватит ли средств, чтобы отложить в дивиденды, обучение сотрудников, закупку и ремонт оборудования

45000 руб.

20.07.2023    4108    7    0    

36

SALE! 50%

Отчет "Полный анализ себестоимости выпущенной продукции" для 1С:ERP (ЕРП), 1С:КА, 1С:ERP УХ

Производство готовой продукции (работ, услуг) Учет доходов и расходов Бухгалтер Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление холдингом 1С:Комплексная автоматизация 2.х Бухгалтерский учет Управленческий учет Платные (руб)

Данный отчет показывает себестоимость выпущенной продукции с разузлованием полуфабрикатов любых уровней, входящих в ее состав, до статей затрат и материалов. Отчет работает независимо от метода оценки стоимости товаров и подходит для любых производственных компаний с многопередельным производством. Отчет можно использовать как в типовой 1С:ERP, так и в отраслевых решениях на ее базе (например, 1С:ERP Управление птицеводческим предприятием и т.д.). Отчет подходит для анализа затрат на гособоронзаказы ГОЗ.

70000 35000 руб.

08.12.2021    24786    18    72    

30

Перенос данных из УТ 10.3 в УТ 11 / КА 2 / ERP 2. Переносятся документы, справочники и остатки

Перенос данных 1C Взаиморасчеты Оптовая торговля Логистика, склад и ТМЦ Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Управленческий учет Платные (руб)

Можно проверить до покупки, оставьте заявку! Воспользовались более 268 компаний! Перенос в продаже с 2015г., и мы постоянно работаем над его развитием. Перенос данных из УТ 10.3 в УТ 11 | из УТ 10.3 в КА 2 | из УТ 10.3 в ERP. Предлагаем качественное и проверенное временем решение для перехода с УТ 10.3. Можно перенести начальные остатки, нормативно-справочную информацию и все возможные документы. При выгрузке можно установить отбор по периоду, организациям и складам. При выходе новых релизов конфигураций 1C оперативно выпускаем обновление переноса данных.

45650 руб.

24.04.2015    191843    135    240    

270

SALE! 50%

Отчет "Полный анализ себестоимости реализованной продукции" для 1С:ERP (ЕРП), 1С:КА, 1С:ERP УХ

Производство готовой продукции (работ, услуг) Учет доходов и расходов Бухгалтер Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление холдингом 1С:Комплексная автоматизация 2.х Бухгалтерский учет Налоговый учет Платные (руб)

Данный отчет показывает себестоимость реализованной продукции в разузлованном виде, как с выделением входящих в нее полуфабрикатов любых уровней, так и свернутый до статей затрат и материалов, видов работ. Отчет работает независимо от метода оценки стоимости товаров и подходит для любых производственных компаний с многопередельным производством. Отчет можно использовать как в типовой 1С:ERP, так и в отраслевых решениях на ее базе (например, 1С:ERP Управление птицеводческим предприятием, Молокозавод и т.д.).Отчет подходит для анализа затрат на гособоронзаказы ГОЗ.

70000 35000 руб.

30.11.2022    12161    14    24    

20

"Акты сверки +" Групповая подготовка и рассылка актов сверки для Бухгалтерии 3.0.

Взаиморасчеты Email рассылки Акт сверки Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Платные (руб)

Внешняя обработка для Бухгалтерии 3.0 - позволяет автоматически формировать документы «Акт сверки расчетов» с контрагентами за выбранный период с последующей фоновой отправкой на почту контрагента.

3000 руб.

25.11.2020    22943    189    7    

169

УТ 11, КА 2, ERP 2: Настраиваемые под каждую организацию печать и подпись ответственных лиц в печатных формах (ТОРГ-12, Счёт-фактура, УПД, УКД, Заказ клиента, Акт сверки, М-15 и др.)

Печатные формы Взаиморасчеты Оптовая торговля Производство готовой продукции (работ, услуг) Акт сверки Бухгалтер Пользователь Оперативный учет Управляемые формы 1С:Управление торговлей 11 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Задайте для каждой организации свою печать и для каждого физического лица свою подпись. Выберите в документе печатную форму "... с печатью и подписью" - и автоматически сформируется табличный документ с печатью и подписями той организации и ответственных лиц, которые указаны в документе.

12000 руб.

13.03.2018    57575    190    76    

117

Дебиторская задолженность по срокам долга

Взаиморасчеты Бухгалтер Пользователь Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Бухгалтерский учет Управленческий учет Платные (руб)

Один из лучших вариантов отчета по дебиторской задолженности. Отображает сроки возникновения задолженности, просроченной задолженности с точностью до регистратора, а также многое другое, вне зависимости от схемы взаиморасчетов (online / offline) и объекта расчетов (УТ 11.3, 11.4, 11.5, КА 2.4, 2.5, ERP 2.4, 2.5), состояния флажка "по документам расчета" ( УТ 10, КА 1.1, УПП 1.3) в договоре. Группирует задолженность по интервалам. Имеет большое количество настроек. Не требует доработок конфигурации.

15120 руб.

28.09.2012    95451    592    281    

143
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. spectre1978 60 23.11.18 12:36 Сейчас в теме
А чем это принципиально лучше штатного механизма восстановления последовательности документов по поступлению и реализации, кроме того, что ваша обработка позволяет двигать границу?
2. Олег 34 23.11.18 12:47 Сейчас в теме
Восстановление последовательностей по поступлению и реализации ни как не влияют на движения документов по регистру "Учет затрат (бухгалтерский и налоговый учет)", они выравнивают взаиморасчеты с контрагентом.
Оставьте свое сообщение