Напоминалка дня рождения по ИНН

Отчеты - Разное

2
Используя конфигурацию для сельского хозяйства в Украине, понадобилась напоминалка о днях рождения сотрудников. В самой конфигурации не предусмотрено поле "День рождения", но зато есть ИНН, который и был использован для этой цели. Не судите строго, это первая разработка, выложенная мной на Ваш сайт.

Используя конфигурацию для сельского хозяйства в Украине, понадобилась напоминалка о днях рождения сотрудников. В самой конфигурации не предусмотрено поле "День рождения", но зато есть ИНН, который и был использован для этой цели.

Не судите строго, это первая разработка, выложенная мной на Ваш сайт.

2

Скачать файлы

Наименование Файл Версия Размер
Напоминалка об именинниках
.1238583304 40,50Kb
25.09.09
114
.1238583304 40,50Kb 114 Скачать бесплатно

См. также

Комментарии
Избранное Подписка Сортировка: Древо
1. Serj1C 472 02.04.09 07:40 Сейчас в теме
7.7 у меня нету, но как можно было использовать ИНН, когда в нем данные хранятся?
2. AVARY 174 02.04.09 08:56 Сейчас в теме
to (1) Там вот такой алгоритм
Код
   НомерДня = Число(Лев(Сотрудник.ИНН,5)); ДатаРождения="";
   Для н = 1900 По Число(Прав(Формат(Дата1,"ДДДММГГГГ"),4)) Цикл
      Ном = НомерДня - НомерДняГода("31.12."+Строка(н));
      Если Ном > 0 Тогда
         НомерДня = Ном;
      Иначе
         Для ч = 1 По 12 Цикл
            НомерДняМес = ДатаЧисло(КонМесяца("01."+Прав("0"+Строка(ч),2)+"."+н));
            Если НомерДня > НомерДняМес Тогда
               НомерДня = НомерДня - НомерДняМес;
            Иначе
               ДатаРождения=строка(Прав("0"+НомерДня,2)+"."+Прав("0"+ч,2));   
               ГодРождения = Число(н);
               Прервать;
            КонецЕсли;
         КонецЦикла;
         Прервать;
      КонецЕсли;
   КонецЦикла;          
Показать полностью
3. Noy 1059 02.04.09 09:51 Сейчас в теме
(2) Замени на
ДатаРождения=Дата("01.01.1900")+Число(Лев(Сотрудник.ИНН),5);
4. Vladal 02.04.09 10:00 Сейчас в теме
(0) - Взгляните сюда:
Проверка данных сотрудников (пол, дата рождения) по ИНН (для Украины)
http://www.infostart.ru/projects/3680/

Проверка ИНН для Украины
http://www.infostart.ru/projects/1573/

С первой обработкой Вы можете еще и пол проверить, и корректность введенного ИНН
5. alexqc 146 02.04.09 12:35 Сейчас в теме
Алгоритм ИНН - 5 первых цифр дата начиная с 01/01/1900, 4 следующих - порядковый номер, при чем четный для Ж и нечетный для М - это известно еще со времени введения ИНН, и так сказать в открытом доступе. Гораздо интереснее 10-я цифра, контрольная. Вот она считается по "секретному" алгоритму, который никто не знает :). Хотя лично мне, например, это странно: таким образом что, хотят от каких-то мошенников защитится? Так это довольно спорная защита: во-первых, "кому надо - тот знает", во-вторых - могут просто надыбать базу с готовыми ИННами.

Так вот, может кто знает алгоритм контрольной суммы?
sergeante; +1 Ответить
6. Noy 1059 02.04.09 12:41 Сейчас в теме
Присоединяюсь к вопросу в (5)
7. sergeante 02.04.09 15:07 Сейчас в теме
8. alexqc 146 02.04.09 15:58 Сейчас в теме
(7) ....Во блин, какой я идиот, пояндексить не додумался...

На самом деле, тут не рулит ни яндекс, ни гугль :) . Это распространенное заблуждение: спрашиваешь про ИНН _физлица в Украине_ - а тебе в ответ - ИНН _организации в России_.
Оставьте свое сообщение