IE2017

Работа с журналом документов (или как боролся за вывод комментария в журнале операций)

Программирование - Практика программирования

Буквально сегодня столкнулся с проблемой. Конфигурация - последняя на сегодняшний день Бухгалтерия государственного учреждения 2.0.36.19. После обновления из журнала документов "Журнал операций" у пользователя пропало поле "комментарий".

 

В динамическом списке оно есть, а при формировании формы в подчиненных элементах нет.



Заметил, что у пользователя с полными правами однако поле отображается.

В журнале регистрации пусто.

Начал с того, что выполнил запрос динамического списка через консоль запросов. Запрос отработал нормально, и комментарии отобразились в колонке. В запросе присутствовало ключевое слово РАЗРЕШЕННЫЕ.

Увренность, что-то не так с правами, стала сильнее.

Установки видимости элемента по ролям ничего не дали (по умолчанию были отключены вообще). Просмотр РЛС для журнала тоже был безрезультатным.

Тогда заметил, что поле "Комментарий" присутствует еще и в графах журнала. И есть огромный список докуметов в параметре "Ссылка", которые отображает журнал. Тут появилось подозрение, что, возможно, у пользователя не хватает прав на какой-то из типов документа.




Написал простенькую обработку с таким кодом, которая выводит список документов в сообщения, на которые у пользователя нет прав:

&НаСервереБезКонтекста
Процедура ВыбратьНаСервере()
	Для каждого Элемент из Метаданные.Документы Цикл
		Попытка
			Выборка = Документы[Элемент.Имя].Выбрать();
		Исключение
			Сообщить(Элемент.Имя);
		КонецПопытки;			
	КонецЦикла;		
КонецПроцедуры

&НаКлиенте
Процедура Выбрать(Команда)
	ВыбратьНаСервере();
КонецПроцедуры

После выполнения вывалился список документов, и один из них действительно был в списке поля "Ссылка" графы "Комментарий" журнала операций. Это был "Расчет расходов на ОС и НМА (УСН)", на который по умолчанию были права только у роли "ПолныеПрава" и "УдаленныйДоступСтандартныйИнтерфейсOData". После выставления прав на документ "комментарий" появился:

Может, кто-то столкнется с подобным, и данная заметка будет полезна.

См. также

Комментарии
1. Александр Воронов (ya.Avoronov) 103 17.09.15 15:25 Сейчас в теме
Кликаете на Роли правой мышкой -> "Все роли" -> выбрали нужный документ( список их вам же известен, в журнале документов перечислено) -> выбрали нужный реквизит -> смотрим кто, какие права на него имеет.

Или я что-то не так понял?
2. uri1978 uri1978 (uri1978) 107 18.09.15 08:49 Сейчас в теме
(1) ya.Avoronov,
И есть огромный список докуметов в параметре "Ссылка", которые отображает журнал.
Оставьте свое сообщение