Доработка ERP 2 для отражения акциза при реализации подакцизных товаров (табачной продукции)

Публикация № 707345

Разработка - Практика программирования

Акциз Проводки Колонка ЕРП2

5
При внедрении ЕРП2.4 на нашем табачном производственном предприятии встал вопрос учета в 1С ЕРП2.2 акциза с продажи табачных изделий. Компания 1С категорически игнорирует учет акцизов в 1С, а занимается только алкогольным ЕГАИС. Что ж, будем реализовывать самостоятельно.

Опираясь на опыт реализации учета акцизов в УПП, решили реализовывать как можно меньшим изменением кода конфигурации.

Задание:

При продаже подакцизных товаров рассчитывать и накапливать суммы акцизов, отражая их печатных формах СЧЕТ-ФАКТУРА и ТОРГ-12(особая форма). В дальнейшем собирать эти сведения для заполнения Налоговой декларации по акцизам на табачные изделия.

План решения:

В документе РеализацияТоваровУслуг добавить колонку «Акциз» в таблице "Товары", проработать ее заполнение. Сформировать проводку по акцизу. Изменить печатные формы.

Итак, приступим.

1. Создание и вывод столбца "Акциз" в закладке «Товары» на форме документа.

Снимаем с поддержки только корень документа «РеализацияТоваровУслуг»

Добавляем реквизит «Акциз» в табличную часть «Товары». На форму его будем выводить программным способом, благо 1С позаботилась и добавила специальный общий модуль для шаловливых ручек, вроде наших.

Снимаем с поддержки общий модуль «МодификацияКонфигурацииПереопределяемый». В нем в процедуру «ПриСозданииНаСервере» добавляем код вызова нашей процедуры для модернизации формы документа:

Процедура ПриСозданииНаСервере(Форма, Отказ, СтандартнаяОбработка) Экспорт
Если Форма.ИмяФормы = "Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента" Тогда
ИТ_РаботаСДиалогами.РеализацияТоваровУслуг_ПриСозданииНаСервере_ФормаДокумента(Форма, Отказ, СтандартнаяОбработка);
КонецЕсли;
КонецПроцедуры

Создаем общий модуль «ИТ_РаботаСДиалогами» с флагами «Сервер», «ВызовСервера».
Добавляем в него процедуру:

Процедура РеализацияТоваровУслуг_ПриСозданииНаСервере_ФормаДокумента(Форма, Отказ, СтандартнаяОбработка) Экспорт
Элемент = Форма.Элементы.Добавить("ТоварАкциз", Тип("ПолеФормы"), Форма.Элементы.Товары);
Элемент.Вид = ВидПоляФормы.ПолеВвода;
Элемент.ПутьКДанным = "Объект.Товары.Акциз";
КонецПроцедуры

2. Расчет и заполнение поля «Акциз» при работе на форме документа с табличной частью «Товары».

Согласно правилам расчета акцизов на табачные изделия, сумма акциза в каждой строке зависит от вида товара и его количества. В прошлой раз, при внедрении учета акцизов в 1С УПП, мы ввели регистр сведений для сохранения суммы акциза на единицу номенклатуры. Как показал практика, это было хоть и гибкое, но ошибочное решение. В этот раз пойдем другим путем, сумма акциза будет вычисляется «с нуля» каждый раз по законодательно определенным правилам уже на общее количество товара в строке. 

Приступаем к форме документа «РеализацияТоваровУслуг».
Нужно выявить события, которые вызываются при изменении в табличной части «Товары», а вернее ее реквизитов: «Номенклатура», «Характеристика», «Количество упаковок», «Единица упаковки». Разбор полетов показал, что 1С нам приготовила всего два переопределяемых обработчика событий, это «НоменклатураПриИзмененииПереопределяемый» и  «ХарактеристикаПриИзмененииПереопределяемый». К сожалению я не нашел никаких переопределяемых процедур для перехвата события при изменений упаковки или количества упаковок (если я неправ, поправите меня в комментариях). Значит придется снимать с поддержки форму документа и вставлять вызов функции  пересчета акциза в каждое из четырех событий формы:
 

&НаКлиенте
Процедура ТоварыНоменклатураПриИзмененииВопросПользователюЗавершение(Результат, ДополнительныеПараметры) Экспорт
//…
ИТ_АкцизКлиент.ПересчитатьАкцизВСтрокеТЧ(ТекущаяСтрока, Объект.Дата); 
КонецПроцедуры

&НаКлиенте
Процедура ТоварыХарактеристикаПриИзмененииВопросПользователюЗавершение(Результат, ДополнительныеПараметры) Экспорт
//…
ИТ_АкцизКлиент.ПересчитатьАкцизВСтрокеТЧ(ТекущаяСтрока, Объект.Дата); 
КонецПроцедуры

&НаКлиенте
Процедура ТоварыУпаковкаПриИзменении(Элемент)
//…
ИТ_АкцизКлиент.ПересчитатьАкцизВСтрокеТЧ(ТекущаяСтрока, Объект.Дата); 
КонецПроцедуры

&НаКлиенте
Процедура ТоварыКоличествоУпаковокПриИзменении(Элемент)
//…
ИТ_АкцизКлиент.ПересчитатьАкцизВСтрокеТЧ(ТекущаяСтрока, Объект.Дата); 
КонецПроцедуры

Теперь пропишем функции, которую мы вызываем из формы документа, для расчета акциза. Для этого в глобальном модуле создаем «ИТ_АкцизКлиент». В свойствах модуля ставим флаг «Клиент (управляемое приложение)». Создаем процедуру:

Процедура ПересчитатьАкцизВСтрокеТЧ(ТекущаяСтрока, Дата) Экспорт
	 Если ТекущаяСтрока = Неопределено Тогда
		 Возврат;
	 КонецЕсли;
	 ТекущаяСтрока.Акциз = 0;
	 ОНоменклатуре = ИТ_АкцизСервер.СведенияОПодакцизнойНоменклатуре(ТекущаяСтрока.Номенклатура,ТекущаяСтрока.Характеристика); 
	 Если НЕ ОНоменклатуре.ЕстьСведенияОНоменклатуре Тогда
		 Возврат;
	 ИначеЕсли НЕ ОНоменклатуре.ПодакцизныйТовар Тогда
		 Возврат;
	 ИначеЕсли ПустаяСтрока(ОНоменклатуре.КодОКП) Тогда   
		 //не определен ОКП номенклатуры, нельзя понять по какому способу расчитывать акциз.
		 Сообщить("У номенклатуры "+ТекущаяСтрока.Номенклатура+" установлен флаг ""Подакцизный товар"", но не определен код ОКП, расчет акциза невозможен.");
		 Возврат;
	 КонецЕсли;
	 
	 //Расчет акциза
	 //Определяем вид товара
	 Если ОНоменклатуре.КодОКП="919024" Тогда   //Сигареты с фильтром
		  Если НЕ ОНоменклатуре.ЕстьСведенияОХарактеристике Тогда
			Сообщить("У номенклатуры "+ТекущаяСтрока.Номенклатура+" не выбрана характеристика для выделения МРЦ.");
			Возврат;
		  Иначе
		  	РазмерМРЦ = ВытащитьМРЦИзХарактеристикиНоменклатуры(ОНоменклатуре.НаименованиеХарактеристика,Истина);
		  КонецЕсли;
		  АкцизТНС   = ПолучитьТвердуюСтавкуДляСигарет(Дата) * (ТекущаяСтрока.Количество*20/1000);
		  АкцизАНС   = РазмерМРЦ * (ПолучитьАдвалорнуюСтавкуДляСигарет(Дата)/100) * ТекущаяСтрока.Количество;
		  АкцизСумма = АкцизТНС+АкцизАНС;
		  АкцизМин   = ПолучитьМинимальнуюСтавкуДляСигарет(Дата) * (ТекущаяСтрока.Количество*20/1000);
		  
		  ТекущаяСтрока.Акциз = МАКС(АкцизСумма,АкцизМин);
	//ИначеЕсли ОНоменклатуре.КодОКП="…" для других видов подакцизных товаров
 КонецЕсли;
КонецПроцедуры

Дополнительные функции «ПолучитьТвердуюСтавкуДляСигарет», «ПолучитьАдвалорнуюСтавкуДляСигарет», «ПолучитьМинимальнуюСтавкуДляСигарет», «СведенияОПодакцизнойНоменклатуре» и «ВытащитьМРЦИзХарактеристикиНоменклатуры» описывать в этой статье не буду. По их названию и так понятно что они делают.

3. Формирование дополнительной проводки Дт 90.04 Кт 68.03 в документе РеализацияТоваровУслуг на сумму акциза.

Все проводки в ЕРП2 формируются при помощи запроса.

Любой документ в ЕРП, генерирующий проводки, в модуле менеджера содержит экспортную функцию «ТекстОтраженияВРеглУчете()» . Эта функция всегда возвращает текст запроса, который при выполнении должен вернуть таблицу проводок.

Формат запроса можно подглядеть вот здесь: РеглУчетВыборкиСерверПовтИсп .ТекстИнициализации()

Более того, формируя запрос для проводок, можно обращаться к разным данным во временных таблицах.  Они формируются в РеглУчетВыборкиСерверПовтИсп.ЗапросДанных(). Если быть честным, то именно эта процедура вызывается при проведении документа, а уже она собирает все необходимые данные для отражения проводок в виде запроса. (Советую посмотреть ее содержимое).

 Возвращаемся к нашей функции «ТекстОтраженияВРеглУчете()» в менеджере документа «РеализацияТоваровУслуг». Добавляем строку:

ТекстыОтражения.Добавить(ИТ_АкцизСервер.ТекстАкцизСРеализации());

В общий модуль «ИТ_АкцизСервер»  добавляем функцию формирования текста запроса для нашей проводки.

Функция ТекстАкцизСРеализации() Экспорт 
	
	ТекстАкцизСРеализации = "
	|ВЫБРАТЬ  //// Акциз с релизации (Дт 90.04 :: Кт 68.03)  
	|	Операция.Ссылка КАК Ссылка,
	|	Операция.Дата КАК Период,
	|	Операция.Организация КАК Организация,
	|	НЕОПРЕДЕЛЕНО КАК ИдентификаторСтроки,
	|
	|	СтрокиТовары.Акциз КАК Сумма,
	|	СтрокиТовары.Акциз / КурсВалютыУпрУчета.Курс КАК СуммаУУ,
	|
	|	ЗНАЧЕНИЕ(Перечисление.ВидыСчетовРеглУчета.ПустаяСсылка) КАК ВидСчетаДт,
	|	Аналитика.Номенклатура.ГруппаФинансовогоУчета  КАК АналитикаУчетаДт,
	|	Аналитика.Склад КАК МестоУчетаДт,
	|
	|	ЗНАЧЕНИЕ(Справочник.Валюты.ПустаяСсылка) КАК ВалютаДт,
	|	Операция.Подразделение КАК ПодразделениеДт,
	|	Операция.НаправлениеДеятельности КАК НаправлениеДеятельностиДт,
	|
	|	ЗНАЧЕНИЕ(ПланСчетов.Хозрасчетный.Продажи_Акцизы) КАК СчетДт,
	|
	|	Аналитика.Номенклатура.ГруппаФинансовогоУчета КАК СубконтоДт1,
	|	НЕОПРЕДЕЛЕНО КАК СубконтоДт2,
	|	НЕОПРЕДЕЛЕНО КАК СубконтоДт3,
	|
	|	0 КАК ВалютнаяСуммаДт,
	|	0 КАК КоличествоДт,
	|	0 КАК СуммаНУДт,
	|	0 КАК СуммаПРДт,
	|	0 КАК СуммаВРДт,
	|
	|	НЕОПРЕДЕЛЕНО КАК ВидСчетаКт,
	|	НЕОПРЕДЕЛЕНО КАК АналитикаУчетаКт,
	|	НЕОПРЕДЕЛЕНО КАК МестоУчетаКт,
	|
	|	&ВалютаРеглУчета КАК ВалютаКт,
	|	ЗНАЧЕНИЕ(Справочник.СтруктураПредприятия.ПустаяСсылка) КАК ПодразделениеКт,
	|	ЗНАЧЕНИЕ(Справочник.НаправленияДеятельности.ПустаяСсылка) КАК НаправлениеДеятельностиКт,
	|
	|	ЗНАЧЕНИЕ(ПланСчетов.Хозрасчетный.Акцизы) КАК СчетКт,
	|
	|	ЗНАЧЕНИЕ(Перечисление.ВидыПлатежейВГосБюджет.Налог) КАК СубконтоКт1,
	|	Операция.Организация.РегистрацияВНалоговомОргане КАК СубконтоКт2,
	|	НЕОПРЕДЕЛЕНО КАК СубконтоКт3,
	|
	|	СтрокиТовары.Акциз КАК ВалютнаяСуммаКт,
	|	0 КАК КоличествоКт,
	|	0 КАК СуммаНУКт,
	|	0 КАК СуммаПРКт,
	|	0 КАК СуммаВРКт,
	|	""Акциз с релизации"" КАК Содержание
	|
	|ИЗ
	|	ДокументыКОтражению КАК ДокументыКОтражению
	|	
	|	ВНУТРЕННЕЕ СОЕДИНЕНИЕ
	|		Документ.РеализацияТоваровУслуг КАК Операция
	|	ПО
	|		ДокументыКОтражению.Ссылка = Операция.Ссылка
	|
	|	ВНУТРЕННЕЕ СОЕДИНЕНИЕ
	|		Документ.РеализацияТоваровУслуг.Товары КАК СтрокиТовары
	|	ПО
	|		(СтрокиТовары.Ссылка = Операция.Ссылка)
	|
	|	ВНУТРЕННЕЕ СОЕДИНЕНИЕ
	|		РегистрСведений.АналитикаУчетаНоменклатуры КАК Аналитика
	|	ПО
	|		СтрокиТовары.АналитикаУчетаНоменклатуры = Аналитика.КлючАналитики
	|
	|	ЛЕВОЕ СОЕДИНЕНИЕ
	|		КурсыВалют КАК КурсВалютыУпрУчета
	|	ПО
	|		КурсВалютыУпрУчета.Валюта = &ВалютаУпрУчета
	|		И КурсВалютыУпрУчета.Дата = НАЧАЛОПЕРИОДА(Операция.Дата, День)
	|
	|ГДЕ
	|	СтрокиТовары.Акциз > 0
	|	И Операция.Статус <> ЗНАЧЕНИЕ(Перечисление.СтатусыРеализацийТоваровУслуг.КПредоплате)
	|	И Операция.ХозяйственнаяОперация В (
	|		ЗНАЧЕНИЕ(Перечисление.ХозяйственныеОперации.РеализацияКлиенту),
	|		ЗНАЧЕНИЕ(Перечисление.ХозяйственныеОперации.РеализацияКлиентуРеглУчет))
	|	И (
	|		ВЫБОР КОГДА Операция.ВернутьМногооборотнуюТару ТОГДА
	|			Аналитика.Номенклатура.ТипНоменклатуры <> ЗНАЧЕНИЕ(Перечисление.ТипыНоменклатуры.МногооборотнаяТара)
	|		ИНАЧЕ
	|			ИСТИНА
	|		КОНЕЦ)
	|";
	Возврат ТекстАкцизСРеализации;
	
КонецФункции

Все, проводка готова.

4. Дорабатываем печатную форму С/Ф.

Такие печатные формы как Счет-Фактура или Торг-12 вынесены в отдельную обработку «ПечатьОбщихФорм». Для ее доработки снимаем ее корень с поддержки.

Находим в модуле менеджера процедуру «ЗаполнитьТабличныйДокументСчетФактура()». Там ищем часть кода, где заполняется параметр печатной формы «акциз» примерно такой:

СтруктураПараметров.Вставить("Акциз", НСтр("ru='без акциза'"));

и меняем участок кода на:

Акциз = ИТ_АкцизСервер.ПолучитьСуммуАкцизаСтрокиДокумента(СтрокаТовары,НомерСтроки);     // Получение акциза из документа основания
Если Не НаборыСервер.ВыводитьТолькоЗаголовок(СтрокаТовары, ИспользоватьНаборы) Тогда
	Если ДействующиеПостановления.Постановление914 
		ИЛИ ОпцииПечатиСчетаФактуры.СчетФактураНаАванс
		ИЛИ ОпцииПечатиСчетаФактуры.СчетФактураНалоговыйАгент Тогда
		СтруктураПараметров.Вставить("Акциз", Формат(Акциз,"ЧЦ=15; ЧДЦ=2; ЧН='--'")); //Подстановка акциза
	Иначе
		СтруктураПараметров.Вставить("Акциз", Формат(Акциз,"ЧЦ=15; ЧДЦ=2; ЧН='без акциза'")); //Подстановка акциза 
	КонецЕсли;
КонецЕсли;

И тут есть небольшая проблема. В качестве передаваемой переменной «СтрокаТовары» передается не строка из табличной части «Товары», а строка результата запроса с выборкой из табличной части «ВидыЗапасов».

Сначала я хотел вклиниться в этот запрос, формирующий список строк, но этот запрос использовался во многих местах и количество вмешательств в конфигурацию было слишком велико.  Решил эту проблему путем преобразования строки «ВидыЗапасов» в строку «Товары» в своей процедуре. Уверен, что так делать не правильно, но нашу задачу это решило. Итак, добавляем в наш общий модуль «ИТ_АкцизСервер» функцию:

Функция ПолучитьСуммуАкцизаСтрокиДокумента(СтрокаТовары,НомерСтроки)   Экспорт
	 СсылкаНаДокументСАкцизом = СтрокаТовары.Ссылка;
	 Если СсылкаНаДокументСАкцизом.Ссылка.Метаданные().ПолноеИмя()="Документ.СчетФактураВыданный" Тогда
	 	СсылкаНаДокументСАкцизом = СтрокаТовары.Ссылка.ДокументОснование;
	 КонецЕсли;
	 Если НЕ СсылкаНаДокументСАкцизом.Ссылка.Метаданные().ПолноеИмя()="Документ.РеализацияТоваровУслуг" Тогда
		 Возврат 0;
	 КонецЕсли;
	 Если СсылкаНаДокументСАкцизом.Пустая()
		 ИЛИ СтрокаТовары.Номенклатура.Пустая()
		 ИЛИ СтрокаТовары.ЭтоКомплектующие Тогда
		 Возврат 0;
	 КонецЕсли;
	 
	 //Поскольку 1С передает в строку не таблицу товаров а таблицу видов товаров приходится находить соответствия в нужой нам табличной части.
	 Отбор = Новый Структура;
	 Отбор.Вставить("Номенклатура",СтрокаТовары.Номенклатура.Ссылка);
	 Отбор.Вставить("Характеристика",СтрокаТовары.Характеристика.Ссылка);

	 МассивСНоменклатурой = СсылкаНаДокументСАкцизом.Товары.НайтиСтроки(Отбор);
	 ИтогоАкциз = 0;
	 ИтогоКоличествоАкциз = 0;
	 Для Каждого СтрокаМассива Из МассивСНоменклатурой Цикл
		 Если СтрокаМассива.Количество = СтрокаТовары.Количество
			  И СтрокаМассива.СуммаСНДС = СтрокаТовары.СуммаСНДС Тогда
			 	Возврат СтрокаМассива.Акциз;
		 КонецЕсли;
		 ИтогоАкциз=ИтогоАкциз+СтрокаМассива.Акциз;	
		 ИтогоКоличествоАкциз=ИтогоКоличествоАкциз+СтрокаМассива.Количество;
	 КонецЦикла;
	 Если ИтогоКоличествоАкциз=СтрокаТовары.Количество Тогда
		 Возврат ИтогоАкциз;
	 ИначеЕсли ИтогоКоличествоАкциз>0 Тогда
		Возврат ИтогоАкциз/ИтогоКоличествоАкциз*СтрокаТовары.Количество; 
	 КонецЕсли;
	 Возврат 0;
 КонецФункции

Аналогичным способом меняет ТОРГ-12., правда в унифицированной форме акциза нет, пришлось дорисовывать в отдельный макет.

Задача решена.

5

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. teller 09.12.17 09:19 Сейчас в теме
У вас кол-во сигарет в пачке прописано явно в коде?
АкцизТНС   = ПолучитьТвердуюСтавкуДляСигарет(Дата) * (ТекущаяСтрока.Количество*20/1000);
		  АкцизАНС   = РазмерМРЦ * (ПолучитьАдвалорнуюСтавкуДляСигарет(Дата)/100) * ТекущаяСтрока.Количество;
		  АкцизСумма = АкцизТНС+АкцизАНС;
		  АкцизМин   = ПолучитьМинимальнуюСтавкуДляСигарет(Дата) * (ТекущаяСтрока.Количество*20/1000);
		  
2. dima_home 107 15.12.17 12:00 Сейчас в теме
У нас количество всегда в пачках, и только в пачках (единицы хранения товара).
Упаковки так же имеются.
Тут надо пояснить:
В ЕРП на форме нет поля "Количество" и "Единица", вернее они есть на форме, только на самом деле это "Количество упаковок" и "Единица упаковки".
Когда на форме документа вы меняете "Количество" (вы на самом деле меняете "Количество упаковок"), а уже в коде документа происходит автоматический пересчет по коэффициенту из количества упаковок в количество для хранения и запоминается в скрытом столбце данных "Количество". К нему я и обращаюсь.

Конечно, правильно было поступить так: проверить что единица - это пачка, но у нас ВСЯ номенклатура в пачках, и я это пропустил.
PS/ Акциз для сигарет рассчитывается тоже исходя из единицы "пачка", поскольку МРЦ определяется только на пачку.


Раз такая пьянка, вот вам еще несколько курьезов из табачной промышленности:
1. На конференции по ЕРП в 2017 году сотрудник компании 1С заявил что в России нет табачной промышленности, по этому они не реализуют решения по табачному акцизу. А как же мы? ))
2. Регламент производства и реализации табачных изделий четко описывает, что сигареты должны продаваться только в "ПАЧКАХ"!!!!! по 20 штук сигарет внутри. Тогда как в классификаторе единиц измерений (ОКЕИ) существуют только либо "штуки", либо "тысячи пачек". И все бы ничего, да вот некоторые покупатели обязательно требуют указание кода ОКЕИ для единиц товаров (это особенно касается крупных сетей).. все время приходится разъяснять.
3. 1С не разрешает в ГТД указывать страну происхождения "РОССИЯ" мотивируя тем, что в счетах фактурах, для Российских товарах ставится в ГТД прочерк. Хочется задать вопрос сотрудникам 1С: "А ничего, что при производстве продукции на территории Калининградской области и вывозе ее на большую землю, при перемещении (продажи) необходимо в документах указывать ГТД, где страна происхождения РОССИЯ?"
4. В расчетных документах, в том числе в реестрах чеков и реестрах на получение средств с аккредитива, первичных учетных документах и счетах-фактурах соответствующая сумма акциза выделяется отдельной строкой! Приходится самим лепить в унифицированные формы, такие как ТОРГ-12 строки (столбцы) с суммой акциза.
3. *Svetlana* 02.02.18 18:16 Сейчас в теме
Добрый вечер! Большое спасибо за статью. Не подскажете по такому вопросу: если мне нужно добавить свою проводку по забалансу к типовому документу - я добавила тоже текст запроса по шаблону (с Вашей помощью разобралась в шаблоне). Но есть сложность - мне надо получить стоимость товара на забалансе при проведении, а для этого надо как минимум дату в параметры передать как-то в запрос.... Или временную таблицу с этой забалансовой себестоимостью организовать... не понимаю, как это в данной конфигурации реализовать...
4. dima_home 107 09.02.18 23:19 Сейчас в теме
Если вы обратили внимание, в запросе уже существуют разного рода временные таблицы с данными, например "ДокументыКОтражению", они формируются в начале запроса.
Через их можно выдернуть любой реквизит документа через внутреннее соединение.
Посмотрите как в примере табличная часть присоединяется внутренним соединением. Получите табличную часть документа, а к нему левым соединением получайте остатки по забалансовым счетам (в статье есть пример как курс валюты присоединяется).
5. corbenSG 12 20.11.18 06:13 Сейчас в теме
Спасибо огромное за статью! Многое в ней мне помогло. Особенно что касается проводки.

Вставлю свои пять копеек.
в процедуру ПересчитатьАкцизВСтрокеТЧ я бы добавил еще условие
Если ТекущаяСтрока = Неопределено или не ТекущаяСтрока.Количество>0 Тогда
	 Возврат;
КонецЕсли;

Что бы при первом добавлении товара не гонять на сервер.
И еще у вас не где не написано что у общего модуля ИТ_АкцизСервер должны стоять галки "Сервер" и "Вызов сервера"

Еще хотел уточнить у вас, а как вы уменьшаете НУ Кт 90.01.1 на сумму акциза?
6. dima_home 107 29.11.18 13:17 Сейчас в теме
Для решения вопроса с доходами пришлось переделать регистр:
Регистр накопления "Выручка и себестоимость продаж".

Для решения задач по отделению НДС с акциза от обычного НДС пришлось задеть
Регистр накопления "НДС Продажи"

Хотя соблазн просто прикрутить проводку, не задевая регистры был велик, но все же склонились к добавлению ресурса "Акциз" в эти регистры. Это нужно, чтобы в управленческих отчетах мы видели нормальную прибыльность.

Извините что долго не отвечал, занят работай на маркировкой табачной продукции, передаваемые в ЦРПТ.
corbenSG; +1 Ответить
Оставьте свое сообщение

См. также

Оповещения боту из 1С за 31 минуту 121

Статья Программист Нет файла v8::УФ 1cv8.cf Бесплатно (free) Практика программирования Интеграция

Поделюсь опытом, как быстро сделать бота с оповещениями в Телеграмм из 1С без лишних затрат.

18.09.2019    8593    4    feva    31       

Агрегатные функции СКД, о которых мало кто знает 321

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    10282    ids79    42       

Три костыля. Сказ про фокусы в коде 122

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    7893    YPermitin    68       

Отслеживание выполнения фонового задания 134

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    8476    ids79    14       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 244

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    10686    ids79    24       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 126

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    9578    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 136

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования Разработка

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    8877    ids79    24       

"Меньше копипаста!", или как Вася универсальную процедуру писал 170

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    6282    SeiOkami    48       

Создание отчетов с помощью СКД - основные понятия и элементы 193

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    17669    ids79    17       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 176

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    11615    dmurk    134       

Регистры накопления. Структура хранения в базе данных 174

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    17350    YPermitin    27       

Выполнение внешней обработки в фоновом задании 147

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    9955    Eret1k    22       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    4885    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7429    m-rv    16       

О расширениях замолвите слово... 192

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    16465    ellavs    122       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 200

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    12808    ellavs    83       

Трюки с внешними источниками данных 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    12913    YPermitin    52       

Добавление отчетов в типовые конфигурации 1С 201

Статья Программист Нет файла v8::УФ v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем)

Описание различных способов добавления общих и контекстных отчетов в конфигурации 1С, построенные на базе БСП. Основные моменты и нюансы.

07.03.2019    23434    ids79    32       

Функциональные опции 1С 8.3 – все возможные варианты использования 170

Статья Программист Нет файла v8::УФ 1cv8.cf Бесплатно (free) Практика программирования Разработка

Примеры использования функциональных опций для управления интерфейсом и элементами управляемых форм, с различными вариантами хранения значений: константа, реквизит справочника, ресурс регистра сведений.

22.02.2019    15905    ids79    5       

Информирование пользователя. Работа с объектом «СообщениеПользователю» 249

Статья Программист Нет файла v8::УФ 1cv8.cf Бесплатно (free) Практика программирования Разработка

Различные варианты и нюансы использования объекта СообщениеПользователю и другие способы информирования пользователя: без привязки к какой-либо форме и с выводом сообщения в отдельном окне.

15.02.2019    17128    ids79    34       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 163

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    15627    ids79    9       

EnterpriseData – часть 2. Процесс выгрузки данных 127

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    12787    ids79    27       

Новый подход к обмену данными EnterpriseData 203

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    21573    ids79    72       

Программное заполнение пользовательских параметров и отборов СКД 135

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    19850    Unk92    18       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 126

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    20941    ids79    40       

Вспомогательные инструкции в коде 1С 104

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    20548    tormozit    100       

Произвольный код в фоновом режиме 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    14647    nikita0832    41       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 144

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    21394    Rain88    42       

Повышаем эффективность разработки правил обмена 124

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19367    olegtymko    47       

Введение в механизм представлений в ЗУП ред. 3 153

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    24502    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    21252    m-rv    21       

Строим графы средствами 1С (без GraphViz) 42

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    17036    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11397    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 126

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    24554    avfed@rambler.ru    19       

Минимализмы 3 352

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    35722    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 109

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    25910    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    21361    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 722

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    138009    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    22761    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 67

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    21120    unichkin    18       

Разбираемся с настройками компоновки данных 159

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    24097    json    9       

Работа с Excel 289

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    24865    arakelyan    39       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35) 143

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    46966    bugtester    43       

Отказ от работы с временными файлами при работе с двоичными данными или Потоки как простая замена ADODB.Stream и временным файлам 127

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования

В платформе начиная с версии 3.8.9 (как я понял по документации) появился расширенный функционал средств работы с двоичными данными. Если раньше простой и очевидный способ преобразования данных строился на использовании временных файлов, то теперь благодаря новым средствам можно уйти от их использования.

12.09.2017    18297    vardeg    31