INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Захаренков Николай | Главный эксперт отдела перспективных разработок | Банк России

«Совершенствование бизнес-процессов предприятия за счет внедрения передовых технологий»

Торговые и производственные информационные технологии в своем развитии прошли несколько стадий: от простейших систем, которые упростили ручной труд до систем ERP, позволяющих планировать и контролировать деятельность всего предприятия. С другой стороны, мы живем в век нейронных сетей, big data, блокчейн, интернета вещей, причем данные технологии вплотную подобрались к производственной деятельности. Учитывая то, что компания 1С является лидером на рынке использования программ автоматизации предприятий, означает, что мимо 1С конфигураций указанные технологии не пройдут. А это значит, что в ближайшее время учетные системы потребуют нового уровня автоматизации и что бы соответствовать этим требованиям в 1С платформе непременно добавятся объекты для создания и управления современными технологиями, а для программистов 1С они станут новыми инструментами. Именно поэтому тему влияния технологий 4 промышленной революции надо обсуждать, делать выводы, строить прогнозы. Своим докладом хотел бы внести маленькую лепту в большое дело и продемонстрировать свое видение работы систем планирования производства 21 века, в едином симбиозе передовых технологий. Тезисы доклада: - Вспомним историю промышленных революций, стандартов производства (от MPS до ERP-2) и их влияние на работу предприятий и эволюцию конфигураций 1С; - Рассмотрим текущие технологии взглядом обывателя, их совместимость, возможность реализации в платформе 1С; - Выявим временные издержки текущей деятельности предприятий при В2В (бизнес для бизнеса) и B2C (бизнес для потребителей) транзакциях; - Попробуем оптимизировать участки производства за счет использования современных технологий и посмотрим к чему это в итоге приведет.

Личная карточка Т2 (Т-2). ЗУП 3.1

Печать - Печатные формы документов

2
Внешняя печатная форма карточки Т2 с возможностью редактирования.

Создано частично с помощью обработки //infostart.ru/public/535969.

Проверена на ЗУП 3.1 (3.1.6.37).

Можно добавить во внешние отчеты/обработки для печати из карточки Сотрудника.

UPD: В обработку вынесены некоторые функции и процедуры из общих модулей (для возможности изменения кода прямо в обработке),
Доступны ДокументПриема, ДокументУвольнения (переменные), Стажи считаются на дату приема сотрудника, а не на текущий день, выводится срок работы, статус работника (при добавлении доп. реквизита в физ.лицо).

2

Скачать файлы

Наименование Файл Версия Размер
Личная карточка Т2 (Т-2) внешняя печатная форма
.epf 38,21Kb
04.06.18
26
.epf 38,21Kb 26 Скачать
Личная карточка Т2 (Т-2) v. 2.0 с доработками
.epf 40,42Kb
04.06.18
13
.epf 2.0 40,42Kb 13 Скачать

См. также

Комментарии
Сортировка: Древо
2. Hla 64 24.05.18 12:40 Сейчас в теме
Добрый день, Владимир! Скачала вашу обработку. Мне надо каким-то образом обратиться к ресурсу РабочееМесто.ПриказОбУвольнении. Подскажите это реально сделать? И в какую сторону двигаться?
Прикрепленные файлы:
3. VovkaPutin 23 24.05.18 15:16 Сейчас в теме
(2), Добрый день. В коде доступны переменные СтрокаДанных.РабочееМестоПриказОбУвольненииДата, СтрокаДанных.РабочееМестоПриказОбУвольненииНомер, также можно через код:

// ++Владимир //вв начало // 11.05.2018 16:24:36
перем КомпоновщикНастроек;
перем СхемаКомпоновкиДанных;
перем ДокПриема;
перем ДокУвольнения;
// --Владимир // конец 11.05.2018 16:24:36

// Обозначим начало вывода
			ПроцессорВывода.Вывести(ПроцессорКомпоновки, Истина);
			
			// ++Владимир //вв начало // 14.05.2018 15:58:00
			Свойства = РегистрыСведений.КадроваяИсторияСотрудниковИнтервальный.СоздатьНаборЗаписей();
			Свойства.Отбор.ФизическоеЛицо.Установить(Данные.Строки[0].ЛичныеДанныеФизическоеЛицо);
			Свойства.Прочитать();
			
			Если Свойства.Количество() > 0 Тогда
				
				Для каждого Стр Из Свойства Цикл
					Если типзнч(Стр.РегистраторЗаписи) = тип("ДокументСсылка.ПриемНаРаботу") Тогда						
						ДокПриема = Стр.РегистраторЗаписи;
					ИначеЕсли  типзнч(Стр.РегистраторЗаписи) = тип("ДокументСсылка.НачальнаяШтатнаяРасстановка") Тогда
						ДокПриема = Стр.РегистраторЗаписи;
					ИначеЕсли типзнч(Стр.РегистраторЗаписи) = тип("ДокументСсылка.Увольнение") Тогда	
						ДокУвольнения = Стр.РегистраторЗаписи;
					КонецЕсли;
				КонецЦикла;				
			КонецЕсли;	
			// --Владимир // конец 14.05.2018 15:58:00
			
			Группировки = ЗарплатаКадрыОтчеты.ПолучитьПоляГруппировок(КомпоновщикНастроек);
Показать

Это и кое-что другое добавлено в файлах - карточка Т2 2.0, доступно для скачивания.
4. Hla 64 25.05.18 07:46 Сейчас в теме
(3) Спасибо огромное! Вы мне очень помогли!
5. papami 17 04.06.18 08:20 Сейчас в теме
Добрый день! Подскажите, что изменено или добавлено в форме с доработками?
6. VovkaPutin 23 04.06.18 10:54 Сейчас в теме
(5), Добрый день, в обработку вынесены некоторые функции и процедуры из общих модулей (для возможности изменения кода прямо в обработке),
Доступны ДокументПриема, ДокументУвольнения (переменные),
Стажи считаются на дату приема сотрудника, а не на текущий день,
Выводится срок работы, статус работника (при добавлении доп. реквизита в физ.лицо).
7. user976620 02.08.18 15:19 Сейчас в теме
Добрый день! Как поменять название печатной формы (печать Т2 булгарпиво), которое после загрузки формы выбираем по кнопке печать из карточки сотрудника?
8. VovkaPutin 23 03.08.18 13:03 Сейчас в теме
(7), Добрый день. В коде найти эти слова и поменять.
9. user976620 03.08.18 13:37 Сейчас в теме
Оставьте свое сообщение