JavascriptEditorSimple - замена NicEdit и whizzywig html editor

20.03.23

Разработка - Инструментарий разработчика

JavsscriptEditorSimple - HTML редактор для базовой замены форматированного документа.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?]
JavascriptEditorSimple - замена NicEdit и whizzywig html editor:
.epf 13,73Kb
12
12
0 SM
Скачать

Введение

Используя стандартный визуальный  whizzywig HTML редактор, который можно интегрировать на JS, столкнулся с одной маленькой проблемой - слишком глючит HTML поле при работе с этим редактором на платформе 8.2. NicEdit - напротив, много требует за свой слишком маленький функционал (jquery для такого количества команд и интерфейса это излишество). Поэтому для своего helpdesk решил создать собственный html редактор, который был бы лишен слишком больших недостатков, характерных для своих предшественников. 

Отличия от  других редакторов - NicEdit и whizzywig

Разработка ведется на языке JS версии 1.2 - эта версия входит в состав Netscape Navigator 4.0 и в целом даже IE 4.01 16 bit. Используемые методы разработки также тестировались на последних версиях Webkit браузеров. Минимальные требования к браузеру: 

  1. 1С хотя бы 8.0 и новее (тестировалось под 8.0.34.19, 8.2.12, 8.3.13, 8.3.14 (первая версия WebKit), 8.3.20).Возможно и поддержка 7.7. версии - тестировать html возможности не было. 
  2. IE, начиная с 4.01 16 bit (должна поддерживаться русская локализация). 
  3. Opera 9.x 
  4. Safari  3.x 
  5. Edge - все версии без исключения.

Во всех указанных браузерах есть поддержка desing mode

Функционал: 

  1. Поддержка вставки спецсимволов и математических символов.
  2. Поддержка тэгов вставки code. 
  3. Базовая вставка таблиц (пока работа с колонками добавление и удаления не реализована). 
  4. Стандартный базовый функционал 

Пока проект находится на betta версии. Пока предварительный релиз можно скачать здесь бесплатно с github - Javascript editor simple

Интеграция редактора (09.08.2022). 

Требуются 2 вида форм: 

  1. Обычные.
  2. Управляемые.

var iHTML="<'html><'head><'meta http-equiv=\"Content-Type\" content=\"text/html; charset=utf-8\"/><'/head><'body> test456<'/body><'/html>" -Содержимое макета ШаблонСтроки.

МакетTeст - взят с git-hub.

 

Для обычных форм код интеграции выглядит таким образом: 

Процедура ПриОткрытии()
	// Вставить содержимое обработчика.    
		
    //Тащим сам редактор (html содержимое файла редактора):
	ДокументHTML=Обработки.РедакторHTML.ПолучитьМакет("МакетTeст").ПолучитьТекст();

    //Заполняем содержимое Iframe:
	Если ЗначениеЗаполнено(Объект.Ссылка) Тогда
		
		//Шаблон строки замены: 
		СТР_ЗАМЕНА=Обработки.РедакторHTML.ПолучитьМакет("ШаблонСтроки").ПолучитьТекст();
		
        //Содержимое HTML документа из базы:
        СтрокаHTML=РаботаСФайламиСервер.ПолучитьТекстИЗаполнитьВложения(Объект.Ссылка,ЭтаФорма.СписокКартинок,ЭтаФорма.СписокКартинокВБазе);
		
        //Осуществляем сборку редактора: 
		СтрокаHTML=СтрЗаменить(СтрокаHTML,Символы.ПС,"");
		СтрокаHTML=СтрЗаменить(СтрокаHTML,Символы.ВК,""); 
		СтрокаHTML=СтрЗаменить(СтрокаHTML,"""","\"""); 
		СтрокаHTML=СтрЗаменить(СтрокаHTML,"'","\'"); 
		СтрокаHTML=СтрЗаменить(СтрокаHTML,"<","<'");
		СтрокаHTML="var iHTML ="" "+СтрокаHTML+"""";
		ДокументHTML=СтрЗаменить(ДокументHTML,СТР_ЗАМЕНА,СтрокаHTML);

	КонецЕсли;
    
    //Устанавливаем итоговый текст поля HTML документа:
    ЭлементыФормы.ДокументHTML.УстановитьТекст(ДокументHTML);
	

КонецПроцедуры

Процедура ПередЗаписью(Отказ)
	// Вставить содержимое обработчика.  
		
    ДокументПервогоБраузера = ЭлементыФормы.ДокументHTML.Документ;
	ОкноПервогоБраузера     = ДокументПервогоБраузера.parentWindow; // IE
	Если ОкноПервогоБраузера = Неопределено Тогда
		ОкноПервогоБраузера = ДокументПервогоБраузера.defaultView; // Прочие браузеры
	КонецЕсли;
		                      
	//Save To textarea:                          
	ОкноПервогоБраузера.VisibleHTML();
	//Return HTML code from textarea:
	Объект.ОписаниеHTML=ЭлементыФормы.ДокументHTML.document.forms["HTML_CODE"].codetext1.value;
    //Hide html code on redaktor:
    ОкноПервогоБраузера.VisibleHTML();
		
КонецПроцедуры      

Для Управляемых форм код будет почти таким же: 

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	//Вставить содержимое обработчика           

   //Тащим редактор 	
   ЭтаФорма.ДокументHTML=Обработки.РедакторHTML.ПолучитьМакет("МакетTeст").ПолучитьТекст();

   //Если у нас уже есть данные - тогда собираем из них итоговый документ:
   Если ЗначениеЗаполнено(Объект.Ссылка) Тогда
		
		
		СТР_ЗАМЕНА=Обработки.РедакторHTML.ПолучитьМакет("ШаблонСтроки").ПолучитьТекст();
		//Получаем HTML строку из базы: 
        СтрокаHTML=РаботаСФайламиСервер.ПолучитьТекстИЗаполнитьВложения(Объект.Ссылка,ЭтаФорма.СписокКартинок,ЭтаФорма.СписокКартинокВБазе);
		//Собираем редактор:
        СтрокаHTML=СтрЗаменить(СтрокаHTML,Символы.ПС,"");
		СтрокаHTML=СтрЗаменить(СтрокаHTML,Символы.ВК,"");

		 
		СтрокаHTML=СтрЗаменить(СтрокаHTML,"""","\"""); 
		СтрокаHTML=СтрЗаменить(СтрокаHTML,"'","\'"); 
		СтрокаHTML=СтрЗаменить(СтрокаHTML,"<","<'");
		СтрокаHTML="var iHTML ="" "+СтрокаHTML+"""";
        //Итоговая сборка:
		ЭтаФорма.ДокументHTML=СтрЗаменить(ЭтаФорма.ДокументHTML,СТР_ЗАМЕНА,СтрокаHTML);

	КонецЕсли;
	
КонецПроцедуры

&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
	//Вставить содержимое обработчика 
	
    //Получаем доступ к скриптам:	
	ДокументПервогоБраузера = Элементы.ДокументHTML.Документ;
	ОкноПервогоБраузера     = ДокументПервогоБраузера.parentWindow; // IE
	Если ОкноПервогоБраузера = Неопределено Тогда
		ОкноПервогоБраузера = ДокументПервогоБраузера.defaultView; // Прочие браузеры
	КонецЕсли;

    //Вытаскиваем код из редактора для сохранения базы:
	//Save To textarea:                          
	ОкноПервогоБраузера.VisibleHTML();
	//Return HTML code from textarea:
	Объект.ОписаниеHTML=Элементы.ДокументHTML.document.forms["HTML_CODE"].codetext1.value;
	ОкноПервогоБраузера.VisibleHTML();
	
КонецПроцедуры   

Предупреждение: редактор пока в режиме бетта версии, поэтому возможны глюки. Также обратите внимание, что каждый браузер имеет свой способ выполнения комманд.

whising html editor 1C Webkit Trident

См. также

Инструментарий разработчика Роли и права Запросы СКД Программист Платформа 1С v8.3 Управляемые формы Запросы Система компоновки данных Конфигурации 1cv8 Платные (руб)

Набор инструментов программиста и специалиста 1С для всех конфигураций на управляемых формах. В состав входят инструменты: Консоль запросов, Консоль СКД, Консоль кода, Редактор объекта, Анализ прав доступа, Метаданные, Поиск ссылок, Сравнение объектов, Все функции, Подписки на события и др. Редактор запросов и кода с раскраской и контекстной подсказкой. Доработанный конструктор запросов тонкого клиента. Продукт хорошо оптимизирован и обладает самым широким функционалом среди всех инструментов, представленных на рынке.

10000 руб.

02.09.2020    140915    772    391    

803

Пакетная печать Печатные формы Инструментарий разработчика Программист Платформа 1С v8.3 Запросы 1С:Зарплата и кадры бюджетного учреждения 1С:Конвертация данных 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Платные (руб)

Инструмент, позволяющий абсолютно по-новому взглянуть на процесс разработки печатных форм. Благодаря конструктору можно значительно снизить затраты времени на разработку печатных форм, повысить качество и "прозрачность" разработки, а также навести порядок в многообразии корпоративных печатных форм.

18000 руб.

06.10.2023    11613    31    6    

61

Инструментарий разработчика Программист Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Инструмент для написания и отладки кода в режиме «1С:Предприятие». Представляет собой консоль кода с возможностью пошаговой отладки, просмотра значений переменных любых типов, использования процедур и функций, просмотра стека вызовов, вычисления произвольных выражений на встроенном языке в контексте точки останова, синтаксического контроля и остановки по ошибке. В консоли используется удобный редактор кода с подсветкой, контекстной подсказкой, возможностью вызова конструкторов запроса и форматной строки.

5400 руб.

17.05.2024    14100    33    27    

77

Инструменты администратора БД Инструментарий разработчика Роли и права Программист Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Расширение позволяет без изменения кода конфигурации выполнять проверки при вводе данных, скрывать от пользователя недоступные ему данные, выполнять код в обработчиках. Не изменяет данные конфигурации, легко устанавливается практически на любую конфигурацию на управляемых формах.

10000 руб.

10.11.2023    7319    27    4    

51

SALE! %

Инструментарий разработчика Инструменты администратора БД Системный администратор Программист Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Платные (руб)

Универсальный инструмент программиста для администрирования конфигураций. Сборник наиболее часто используемых обработок под единым интерфейсом.

3600 2880 руб.

14.01.2013    181979    1104    0    

876

Инструментарий разработчика Программист Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Восстановление партий или взаиморасчетов, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

5000 руб.

07.02.2018    101165    242    97    

304

Инструментарий разработчика Перенос данных 1C Программист Платформа 1С v8.3 Платные (руб)

В процессе работы в 1С часто возникает потребность получить данные из другой базы. Обычно это делается через COM-соединение, и время выполнения запроса при этом оставляет желать лучшего. В данной публикации представлено универсальное решение для 1С, позволяющее практически моментально выполнить произвольный код или запрос с параметрами в другой информационной базе через Web-сервис.

2400 руб.

24.09.2019    24523    17    15    

34

Инструментарий разработчика Программист Платформа 1С v8.3 Управляемые формы Платные (руб)

"Фреймворк для Расширений 1С" это универсальное и многофункциональное решение, упрощающее разработку и поддержку создаваемых Расширений. Поставляется в виде комплекта из нескольких Расширений с открытым исходным кодом. Работает в любых Конфигурациях в режиме Управляемого приложения с режимом совместимости 8.3.12 и выше без необходимости внесения изменений в Конфигурацию.

3000 руб.

27.08.2019    19456    7    8    

42
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. leosoft 166 08.08.22 10:22 Сейчас в теме
Добрый день!
А как его интегрировать (запустить) в 1С? Может примерчик?
2. user1206119 86 09.08.22 22:20 Сейчас в теме
(1) Обновил статью и редактор.
4. leosoft 166 09.08.22 22:45 Сейчас в теме
5. user1206119 86 10.08.22 10:48 Сейчас в теме
(4)И ещё будет одна просьба - по результатам отписаться каких функций не будет хватать. Планирую создать новый релиз.
3. user1206119 86 09.08.22 22:22 Сейчас в теме
(1) В целом методика интеграции мало чем отличалась от моей статьи, которую я написал по редакторам. https://infostart.ru/1c/articles/1640671/
6. triviumfan 95 15.08.22 21:26 Сейчас в теме
3 раза перечитал и только с третьего раза нашёл ссылку на гитхаб) Посмотрим, что это за рыба.
Оставьте свое сообщение