Подключение сканера штрихкода к Бухгалтерии 3.0

Публикация № 948435

Учет и отчетность - Оптовая торговля

БП 3.0 Бухгалтерия 3.0 сканер шк штрихкод

Возникла потребность обеспечить идентификацию номенклатуры по штрихкоду. На складе уже было рабочее место с Бухгалтерией 3.0. Поиск по ключевой фразе «сканер ШК БП 3.0» выдал не так много результатов. На ИС была обнаружена статья от 2013 года, которая сейчас несколько устарела. В 2018 году процесс подключения сканера штрихкода стал существенно проще.

Ссылка на статью //infostart.ru/public/203591/ (сейчас она несколько устарела).

В 2018 году процесс подключения сканера штрихкода стал существенно проще.

В разделе «Администрирование» есть пункт «Подключаемое оборудование» и в ней есть закладка «Сканеры штрихкода». Тут все просто. Нажимаем «Создать», выбираем тип оборудования «Сканеры штрихкоды» и драйвер. Например, «1С:Сканеры штрихкода (NativeApi)». Если драйвер еще не установлен будет выдано предложение сделать это сейчас и база сама зарегистрирует нужную компоненту.

Для проверки нажимаем (в этой же форме) «Настроить» и «Тест устройства». Сканер я предварительно перевел в режим virtual COM и установил драйвер виртуального COM порта. В окне теста сразу видно, что доступен порт COM3. После считывания штрихкода данные отображаются в окне. Значит, 1С получает событие от сканера.

Следующий шаг — описать, как база должна реагировать на событие сканирования штрихкода.

Коротко напомню как все устроено в типовых конфигурациях.

У форм документов нет обработчика события «Внешнее событие». Все реализовано через событие управляемого приложения.

Его обработчик получает все события, определяет от какого оборудования они пришли.

Передача управления обработчикам формы выполняется через механизм оповещения.

Реакция системы на штрихкод описывается уже в модуле формы в обработчике события ОбработкаОповещения.

Поиск по конфигурации не порадовал. «Из коробки» штрих код работает только в трех видах документов.

Поскольку конфигурация на поддержке изменения будем вносить через расширение.

Реализуем 2 сценария — привязка штрихкода к карточке номенклатуры и обработка считывания штрихкода для длокумента «Перемещение товаров».

Начнем с номенклатуры.

Чтобы форма элемента получала оповещения от драйвера подключаемого оборудования необходимо добавить обработчики событий ПриОткрытии и ПриЗакрытии (оба с вызовом После).

&НаКлиенте
Процедура Расш1_ПриОткрытииПосле(Отказ)
	
	ТипыПО = Новый Массив();
	ТипыПО.Добавить("СканерШтрихкода");
	
	ОповещениеПриПодключении = Новый ОписаниеОповещения("ПодключениеОборудованияЗавершено", ЭтотОбъект);
	
	МенеджерОборудованияКлиент.НачатьПодключениеОборудованиеПоТипу(ОповещениеПриПодключении, УникальныйИдентификатор, ТипыПО);
	
КонецПроцедуры

&НаКлиенте
Процедура ПодключениеОборудованияЗавершено(РезультатВыполнения, Параметры) Экспорт
	
	Если Не РезультатВыполнения.Результат Тогда
		ТекстСообщения = НСтр( "ru = 'При подключении оборудования произошла ошибка:""%ОписаниеОшибки%"".'");
		ТекстСообщения = СтрЗаменить(ТекстСообщения, "%ОписаниеОшибки%" , РезультатВыполнения.ОписаниеОшибки);
		Сообщить(ТекстСообщения);
	Иначе
		ТекстСообщения = НСтр("ru = 'Оборудование подключено.'" );
	КонецЕсли;
	
КонецПроцедуры

&НаКлиенте
Процедура Расш1_ПриЗакрытииПосле(ЗавершениеРаботы)
	
	ТипыПО = Новый Массив();
	ТипыПО.Добавить("СканерШтрихкода");
	
	ОповещениеПриОтключении = Новый ОписаниеОповещения("ОтключениеОборудованияЗавершено", ЭтотОбъект);
	
	МенеджерОборудованияКлиент.НачатьОтключениеОборудованиеПоТипу(ОповещениеПриОтключении, УникальныйИдентификатор, ТипыПО);
	
КонецПроцедуры

&НаКлиенте
Процедура ОтключениеОборудованияЗавершено(РезультатВыполнения, Параметры) Экспорт

	Если Не РезультатВыполнения.Результат Тогда
		ТекстСообщения = НСтр( "ru = 'При отключении оборудования произошла ошибка:""%ОписаниеОшибки%"".'");
		ТекстСообщения = СтрЗаменить(ТекстСообщения, "%ОписаниеОшибки%" , РезультатВыполнения.ОписаниеОшибки);
		Сообщить(ТекстСообщения);
	Иначе
		ТекстСообщения = НСтр("ru = 'Оборудование подключено.'" );
	КонецЕсли;

КонецПроцедуры

Если код вызывает вопросы — напишите в комментарии — отвечу.

Далее создадим обработчик события ОбработкаОповещения (вызов также После).

&НаКлиенте
Процедура Расш1_ОбработкаОповещенияПосле(ИмяСобытия, Параметр, Источник)
	
	Если Источник = "ПодключаемоеОборудование" Тогда
		
		Если ИмяСобытия = "ScanData" Тогда
			
			Если Параметр[1] = Неопределено Тогда
				ТекущийКод = Параметр[0];
			Иначе
				ТекущийКод = Параметр[1][1];
			КонецЕсли;
			
			Номенклатура = "";
			Если ЕстьНоменклатураПоШтрихкоду(ТекущийКод, Номенклатура) Тогда
				ТекстСообщения = НСтр("ru = 'Штрихкоду %Штрихкод% уже сопоставлена номенклатура %Номенклатура%'" );
				ТекстСообщения = СтрЗаменить(ТекстСообщения, "%Штрихкод%" , ТекущийКод);
				ТекстСообщения = СтрЗаменить(ТекстСообщения, "%Номенклатура%" , Номенклатура);
				СообщениеПользователю = Новый СообщениеПользователю;
				СообщениеПользователю.Текст = ТекстСообщения;
				СообщениеПользователю.Сообщить();
			Иначе
				ВопросСоздатьНоменклатуруЗавершение = Новый ОписаниеОповещения("ПривязатьШтрихкодКНоменклатуреПослеВопроса", ЭтаФорма, ТекущийКод);
				ТекстСообщения = НСтр("ru = 'Привязать штрихкод %Штрихкод% к номенклатуре %Номенклатура%?'" );
				ТекстСообщения = СтрЗаменить(ТекстСообщения, "%Штрихкод%" , ТекущийКод);
				ТекстСообщения = СтрЗаменить(ТекстСообщения, "%Номенклатура%" , Объект.Наименование);
				ПоказатьВопрос(ВопросСоздатьНоменклатуруЗавершение, ТекстСообщения, РежимДиалогаВопрос.ДаНет, 30, КодВозвратаДиалога.Нет);
			КонецЕсли;
			
		КонецЕсли;
			
	КонецЕсли;
	
КонецПроцедуры

&НаСервере
Функция ЕстьНоменклатураПоШтрихкоду(Штрихкод, Номенклатура)
	
	Рез = Ложь;
	
	ТаблицаНоменклатурыПоШтрихкоду = РегистрыСведений.ШтрихкодыНоменклатуры.НоменклатураПоШтрихкоду(Штрихкод);
	
	Если ТаблицаНоменклатурыПоШтрихкоду.Количество() > 0 Тогда
		Номенклатура = ТаблицаНоменклатурыПоШтрихкоду[0].Номенклатура;
		Рез = Истина;
	КонецЕсли;
	
	Возврат Рез;
	
КонецФункции

&НаКлиенте
Процедура ПривязатьШтрихкодКНоменклатуреПослеВопроса(Результат, Параметры) Экспорт
	
	Если Результат = КодВозвратаДиалога.Да Тогда
		ПривязатьШтрихкодКНоменклатуре(Параметры);
	КонецЕсли;
	
КонецПроцедуры

&НаСервере
Процедура ПривязатьШтрихкодКНоменклатуре(Штрихкод) Экспорт
	
	НовыйШК = РегистрыСведений.ШтрихкодыНоменклатуры.СоздатьМенеджерЗаписи();
	НовыйШК.Штрихкод = Штрихкод;
	НовыйШК.Номенклатура = Объект.Ссылка;
	НовыйШК.Записать();
	
КонецПроцедуры

Обработчик проверяет, что пришло событие именно со сканера штрихкода. Далее выполняется поиск номенклатуры по штрихкоду. Если номенклатура найдена выдается сообщение пользователю, что штрихкод уже сопоставлен с другой номенклатурой. В противном случае создается запись в регистре сведений ШтрихкодыНоменклатуры (после уточняющего вопроса пользователю).

Со справочником на этом все.

Переходим к документу.

Аналогично добавляем код для событий ПриОткрытии и ПриЗакрытии для подключения (и отключения) подписки на получение событий от подключаемого оборудования.

В обработчике ОбработкаОповещения размещаем код

&НаКлиенте
Процедура Расш1_ОбработкаОповещенияПосле(ИмяСобытия, Параметр, Источник)
	
	Если Источник = "ПодключаемоеОборудование" И ВводДоступен() Тогда
		Если ИмяСобытия = "ScanData" Тогда
			Если Параметр[1] = Неопределено Тогда
				ТекущийКод = Параметр[0];
			Иначе
				ТекущийКод = Параметр[1][1];
			КонецЕсли;
			ДобавитьПоШтрихкодуНаСервере(ТекущийКод);
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры

Процедура ДобавитьПоШтрихкодуНаСервере выполняет поиск номенклатуры сопоставленной с штрихкодов. Если номенклатура не найдена выдает сообщение пользователю. Иначе — добавляет строку в документ. Добавление строки реализовано по аналогии с документом ПоступлениеТоваровУслуг.

&НаСервере
Функция ДобавитьПоШтрихкодуНаСервере(Штрихкод)
	ТаблицаНоменклатурыПоШтрихкоду = РегистрыСведений.ШтрихкодыНоменклатуры.НоменклатураПоШтрихкоду(Штрихкод);
	
	Если ТаблицаНоменклатурыПоШтрихкоду.Количество() = 1 Тогда
		ДобавитьНоменклатуруНаСервере(ТаблицаНоменклатурыПоШтрихкоду[0].Номенклатура);
	Иначе
		ТекстСообщения = НСтр("ru = 'Штрихкоду %Штрихкод% не сопоставлена ни одна номенклатура'" );
		ТекстСообщения = СтрЗаменить(ТекстСообщения, "%Штрихкод%" , Штрихкод);
		СообщениеПользователю = Новый СообщениеПользователю;
		СообщениеПользователю.Текст = ТекстСообщения;
		СообщениеПользователю.Сообщить();
	КонецЕсли;
	
КонецФункции

&НаСервере
Процедура ДобавитьНоменклатуруНаСервере(Номенклатура)
	
	ПараметрыОтбора = Новый Структура("Номенклатура", Номенклатура);
	
	мСтрок = Объект.Товары.НайтиСтроки(ПараметрыОтбора);
	Если мСтрок.Количество() = 0 Тогда
	
		ТаблицаТовары = Новый ТаблицаЗначений;
		ТаблицаТовары.Колонки.Добавить("Номенклатура");
		ТаблицаТовары.Колонки.Добавить("Количество");
		ТаблицаТовары.Колонки.Добавить("Цена");
		
		
		СтрокаТаблицаТовары = ТаблицаТовары.Добавить();
		
		СтрокаТаблицаТовары.Номенклатура = Номенклатура;
		СтрокаТаблицаТовары.Количество = 1;
		СтрокаТаблицаТовары.Цена = 0;
		
		Значение = Новый Структура("АдресПодобраннойНоменклатурыВХранилище, КоличествоДобавленныхСтрок", ПоместитьВоВременноеХранилище(ТаблицаТовары, УникальныйИдентификатор));
		
		ОбработкаВыбораПодборВставкаИзБуфераНаСервере(Значение, "Товары");
		
	Иначе
		
		СтрокаТовары = мСтрок[0];
		СтрокаТовары.Количество = СтрокаТовары.Количество + 1;
		
	КонецЕсли;

КонецПроцедуры

На этом всё.

Взаимодействие сканера с другими документами выполняется аналогичным образом.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. muskul 23.11.18 05:08 Сейчас в теме
Разве по умолчанию ШК в БП 3.0 не работает во всех местах в которых должен по логике?
2. Dem1urg 322 23.11.18 07:15 Сейчас в теме
(1) Я же специально сделал скриншот с результатом поиска текста ScanData.
Работает в двух местах - поступление и розничная продажа.
Можете сами проверить.
3. muskul 23.11.18 08:54 Сейчас в теме
(2)Проверил, действительно, логика и 1с теперь редко пересекаются.
4. k0pai22 23.11.18 18:02 Сейчас в теме
(3) Нельзя просто взять и оптимизировать БП для всех видов торговли. Может кануть в лету немалая часть продаж УТ. Сам когда писал ШК для реализации в БП 3.0 был в недоумении, потом понял.
5. kembrik 3 23.11.18 18:47 Сейчас в теме
Ничто так не печалит меня, как штрихкод в Измерениях
6. Dem1urg 322 23.11.18 19:25 Сейчас в теме
(5) Почему? Это ж по сути вспомогательный регистр.
7. kembrik 3 24.11.18 14:13 Сейчас в теме
(6) Потому что мы не можем хранить в таком случае одинаковый штрихкод у разной номенклатуры. А это сплошь и рядом. У производителя иной раз сменилась упаковка, состав и комплектация изделия, а штрихкод там один и тот же. И без самостоятельной принудительной маркировки это потом не разгрести. Речь понятно не только про бухгалтерию, скорее про УТ. Вот и приходится хранить в допреквизите и перепиливать процедуру поиска.
8. Rustig 1611 27.11.18 18:48 Сейчас в теме
(7)
У производителя иной раз сменилась упаковка, состав и комплектация изделия, а штрихкод там один и тот же.

а как вам поможет допреквизит? и что за допреквизит вы добавляете?
пока не понятно, как в ситуации Товар1+ШК1 и Товар2+ШК1 - однозначно идентифицировать по ШК1 нужный Товар?...даже без учета конфигурации, на пальцах алгоритм расскажите
10. kembrik 3 03.12.18 12:40 Сейчас в теме
(8) 1. Штрихкод с коробки бьётся в допреквизит "Штрихкод производителя"
2. У номенклатуры жесткая иерархия в зависимости от сезона поставки
3. Периодически запускается регламентная обработка, которая сигнализирует, что у нескольких позиций одинаковый штрихкод у разных поставок, а собственный штрихкод ещё не присвоен
4. Присваивается собственный штрихкод каждой из задвоившейся номенклатуры, если ещё нет, после визуального контроля, отличается ли состав, комплектация товара и т.д. Если не отличается то такой же, как у прошлой поставки, если отличается - то новый. Как то так

Соответственно типовое "пиканье" учим искать и в регистре сведений номенклатуры и в допреквизитах, и отображать все варианты, а не единственное
11. Rustig 1611 03.12.18 18:54 Сейчас в теме
(10)
1. Штрихкод с коробки бьётся в допреквизит "Штрихкод производителя"

этот ШК к новой номенклатуре привязывается или к имеющейся старой?
по моему уже на этом этапе происходит визуальный контроль - отличается ли состав, комплектация товара и т.д

(10)
2. У номенклатуры жесткая иерархия в зависимости от сезона поставки

иерархия в зависимости от срока поставки - не хочу вас судить, но, имхо, в целом это плохая идея, плохо решенная задача - это первое мое мнение не видя решения и причин...


(10)
Периодически запускается регламентная обработка, которая сигнализирует, что у нескольких позиций одинаковый штрихкод у разных поставок, а собственный штрихкод ещё не присвоен

если в регистре сведений использовать только типовые измерения Товар + ШК, то регламентная процедура для разных позиций нормально отработает - и определит что у нескольких позиций одинаковый шк...
13. kembrik 3 04.12.18 14:43 Сейчас в теме
(11)
этот ШК к новой номенклатуре привязывается или к имеющейся старой?
по моему уже на этом этапе происходит визуальный контроль - отличается ли состав, комплектация товара и т.д


К новой. Товар ещё на таможне, но производитель уже прислал "Баркоды". Визуальный осмотр товара в контейнере особо не произведёшь, а приходовать уже пора


(11)
иерархия в зависимости от срока поставки - не хочу вас судить, но, имхо, в целом это плохая идея, плохо решенная задача - это первое мое мнение не видя решения и причин...


Сроки поставки укрупненные, например сейчас идёт поступление товара на сезон "Весна-лето 2019", чуть позже начнется "Осень-зима 2019-2020". Кроме иерархии справочника ессно заводится допреквизит сезона и т.д. Это новый товар, произведенный специально для этого сезона.


(11)
если в регистре сведений использовать только типовые измерения Товар + ШК, то регламентная процедура для разных позиций нормально отработает - и определит что у нескольких позиций одинаковый шк...


Я не знаю про какие вы конфигурации говорите - в последних типовых штрихкод это ЕДИНСТВЕННОЕ измерение. В том то и дело, отсюда и корень проблем
Прикрепленные файлы:
15. Rustig 1611 04.12.18 14:56 Сейчас в теме
(13) ясно, понял вас, спасибо за картинку - лучше один раз увидеть, чем сто раз услышать.
я привык, что в ут 10.3 несколько измерений : Номенклатура, Штрихкод, Серия, Тип ШК и еще какой-то....
12. Rustig 1611 03.12.18 18:55 Сейчас в теме
(10) в целом, непонятно все-таки за что вы критикуете "Штрихкод" в измерении...
14. kembrik 3 04.12.18 14:44 Сейчас в теме
(12) За то что кроме "Штрихкода" в измерении больше ничего нет. См. выше
9. Rustig 1611 27.11.18 18:49 Сейчас в теме
(0) интересная тема. спасибо!
16. user619273_alevtina 30.12.18 17:22 Сейчас в теме
Статья интересная, спасибо.
17. Xershi 1046 12.02.19 16:27 Сейчас в теме
Добрый день, пытаюсь завести сканер ШК, но не выходит. https://forum.infostart.ru/forum72/topic210249/
Вы писали:
Для проверки нажимаем (в этой же форме) «Настроить» и «Тест устройства». Сканер я предварительно перевел в режим virtual COM и установил драйвер виртуального COM порта.

Но не написали как это сделать, если это скрин, с оборудованием в справочнике, то это сделано!
18. Dem1urg 322 12.02.19 21:07 Сейчас в теме
(17) Процедуры настройки сканера лежат за рамками публикации.
В каком режиме у вас сейчас работает сканер? Если запустить Блокнот и попытаться считать штрихкод что-нибудь происходит?
19. Xershi 1046 12.02.19 21:13 Сейчас в теме
(18) это сразу работало. В теме уже нашли решение!
Можете почитать последние ответы. Там остались не понятки почему оно криво работало.
20. Dreary 24.03.20 14:58 Сейчас в теме
Подскажите, статья еще актуальна?
Что-то не получается( БП 3.0.75.93
21. Dreary 24.03.20 15:41 Сейчас в теме
Сорян, все работает. Это я затупил. Спасибо за статью!
22. Dreary 24.03.20 16:48 Сейчас в теме
Есть у кого-нибудь мысли, как это реализовать в документе "Отчет производства за смену"?
23. Dem1urg 322 30.03.20 19:08 Сейчас в теме
(22) А в чем суть вопроса? Если взять код из публикации для документа "Перемещение" в использовать его. Заменив, при необходимости, имена табличных частей и реквизитов.
Оставьте свое сообщение

См. также

Принципы учета номенклатуры в конфигурациях УТ11 и ERP. Ошибки расчета себестоимости Промо

Управленческий учет (прочее) Бухгалтерский учет Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 ERP2 УТ11 КА2 УУ Бесплатно (free)

Основные регистры, используемые для учета номенклатуры в конфигурациях УТ11, КА2, ERP. Для чего используются все эти регистры, какие из них основные и какие вспомогательные. Основные ошибки в учете товаров и расчет себестоимости. Как проще находить и исправлять ошибки в учете.

06.01.2016    156511    ekaruk    79    

Сравнение мобильных технологий сканирования штрихкодов

Сканер штрих-кода Мобильная разработка v8 Бесплатно (free)

В статье приведены результаты тестирования и сравнение популярных мобильных технологий сканирования штрихкодов

23.11.2020    565    MaramOyka    1    

"Особенности" коэффициентов единиц измерения в 1С: Управление нашей фирмой

Учет ТМЦ v8 УНФ УУ Бесплатно (free)

«Особенности» использования коэффициентов в единицах измерения в в 1С: Управление нашей фирмой. Можно ли их изменить после ведения учета? И к чему это может привести.

09.11.2020    617    Torin    5    

Как в 1С: Бухгалтерии предприятия 8 правильно вести учет горючего по путевым листам

Учет ТМЦ v8 1cv8.cf УУ Бесплатно (free)

В статье мы проанализируем вынесенную в заголовок проблему, рассмотрев все нюансы учета горючего по путевым листам на реальном примере в программе 1С: Бухгалтерия Предприятия 8.

06.11.2020    548    Koder_Line    1    

Будни автоматизации или "мне нужна программка для 3D упаковки" Промо

Практика программирования Математика и алгоритмы Оптовая торговля Оптовая торговля v8 1cv8.cf УУ Бесплатно (free)

Автоматизация отечественных предприятий, которой приходиться заниматься, это нужная и высокооплачиваемая, но довольно нервная работа. Выручает юмор. Например, при общении с требовательным клиентом можно вспомнить анекдот: "Держась руками за стену, на ногах еле стоит мужик. К нему пристает ребенок: "Ну, папа, пожалуйста, сделай мне кораблик!", папа отвечает: "Ага! - Сейчас все брошу и пойду делать тебе кораблик!". Про один такой сделанный для клиента "кораблик" и хочется рассказать. Надеюсь, совместное погружение в теплое ламповое (то есть клиентоориентированное) программирование доставит Вам положительные эмоции, да и задача попалась интересная. Поплыли?

24.03.2014    45525    ildarovich    116    

Акт о расхождениях в 1С: Бухгалтерии 3.0

Учет ТМЦ v8 v8::БУ БП3.0 Бесплатно (free)

В этой статье поговорим о ситуации, когда приобретаем по документу одно количество товара, а на поверку оказывается совсем другое. В такой ситуации нам требуется оформить разницу между фактическим поступлением и документом на поступление товара. Для отображения таких операций в программе 1С: Бухгалтерия 8.3 предусмотрен документ «Акт о расхождениях». Такой функционал в конфигурации 1С 8.3 появился с обновлением 3.0.76.61.

30.09.2020    487    Koder_Line    0    

Несколько групп для одной номенклатуры в УТ 11

Механизмы оперативного учета Учет ТМЦ v8 v8::ОУ УТ11 Россия УУ Бесплатно (free)

В статье опишу вариант доработки УТ 11 для использования нескольких групп для одной номенклатуры.

23.09.2020    700    malikov_pro    2    

Team: Торговля + Склад + Производство (Мобильное приложение на платформе 1С)

Мобильная разработка Производство готовой продукции (работ, услуг) Учет ТМЦ Управление торговлей v8::Mobile УУ Бесплатно (free)

TEAM - управленческий учет для любого бизнеса: склад; деньги, мультивалютность; продажи - покупки товаров, услуг; заказы и долги клиентов, поставщиков и других партнеров; учет производства, сборки комплектов; доходы и расходы, прибыль и финансовый результат. Приложение будет развиваться с учетом Ваших пожеланий и предложений.

14.09.2020    773    naypak    5    

Выборочное списание партий товаров в "Управление торговлей" редакции 10 Промо

Учет ТМЦ Учет и отчетность v8 УТ10 Россия УУ Бесплатно (free)

Реализация выборочного списания партий товаров в "Управление торговлей" редакции 10

01.10.2011    44858    GreenLab    33    

Настройка сканера для маркировки обуви в УТ 10.3 по RDP

Сканер штрих-кода v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Россия Бесплатно (free)

Реально ли настроить без костылей работу сканера для маркировки обуви в УТ 10.3? Делюсь личным опытом.

21.08.2020    1174    yarrr    6    

Тестовая отгрузка/приемка маркированного лекарственного препарата в песочнице ИС Честный знак

Учет ТМЦ Пользователю системы v8 Здравоохранение, медицина, стоматология Бесплатно (free)

Последовательность действий для тестирования отгрузки/приемки ЛП в ИС Честный знак и дальнейшая приемка в любой поддерживающей МДЛП конфигурации 1С

07.08.2020    2543    RPGrigorev    0    

Учет вспомогательного инструмента с учетом изностойкости

Учет ТМЦ v8 УПП1 Россия УУ Бесплатно (free)

В компании при производстве продукции используются вспомогательные инструменты (пресс-формы, ножи, сверла и т.п.). Необходимо учитывать движение и использование всех видов инструментов, контролировать срок износа для планирования и контроля обеспечения производства инструментом в достаточном количестве для выполнения производственного плана. В статье расскажем, как организовать учет вспомогательного инструмента с учетом износостойкости.

01.07.2020    1259    Aprsoft    0    

Варианты автоматизации закупок в 1С

Оптовая торговля v8 УТ11 УУ Бесплатно (free)

Уходим от работы на коленке, жмем на кнопки. Как торговым компаниям среднего размера автоматизировать отдел закупок.

25.06.2020    2534    min-max_pro    5    

Мобильный клиент для сканирования QR-кодов и штрих-кодов и отправки их на сервер

Сканер штрих-кода v8::Mobile Бесплатно (free)

В статье рассмотрены варианты реализации мобильного сканера.

10.06.2020    4355    MaramOyka    5    

Счета-фактуры за период до ввода начальных остатков. Корректировочные и не только. Часть вторая.

Бухгалтерский учет Оптовая торговля v8 ERP2 КА2 Россия БУ НДС Бесплатно (free)

На партнерском форуме очень много запросов, и обширная история переписки, по созданию корректировок и возвратов за период до ввода начальных остатков. И, если с релиза 2.4.11… с возвратами покупателя за период до ввода начальных остатков вопрос более-менее решен, то с возвратами поставщику и корректировками приобретения ситуация так и не решилась.

02.06.2020    1627    n.saltsina    2    

Пример решения задачи по автоматизации учета штучных изделий и возможному браку. Промо

Учет ТМЦ Учет и отчетность v8 КА1 УТ10 УПП1 Россия УУ Бесплатно (free)

Пример решения задачи по автоматизации учета штучных изделий и возможному браку. Начал объяснять клиенту решение его проблемы, но встретившись с непониманием элементарных для меня вещей, решил, что это может быть полезно и другим

26.04.2011    26372    milkers    11    

Состояния заказов клиентов

Оптовая торговля Монитор заказов v8::ОУ УТ11 Россия УУ Бесплатно (free)

Конфигурация «Управление торговлей, редакция 11 (11.4.11.104)». Регистр сведений «Состояния заказов клиентов». Описание и устройство.

27.05.2020    3871    totchaz    15    

Инвентаризация весового товара терминалом сбора данных+ ERP 2.4

Сканер штрих-кода Терминал сбора данных v8 ERP2 Россия УУ Бесплатно (free)

Цель - печать этикеток на Штрих Принт (весы с печатью этикеток) весового товара и сбор штрихкодов на ТСД Cipher Lab CP55 в Mobile Smart Магазин 15.

15.05.2020    1701    dy4amaks    0    

Как в 1С отражаются товары "в пути"

Оптовая торговля Учет ТМЦ v8 ERP2 УТ11 КА2 УУ Бесплатно (free)

При ведении бизнеса на предприятиях любого профиля, размера и форм собственности часто возникает следующая ситуация. 1. Предприятие закупает некую номенклатуру у поставщика для дальнейшей перепродажи или собственного использования. 2. Номенклатура относится к категории материальных объектов, которые можно транспортировать. Понятно, что под это определение попадают товары, материалы, сырье, полуфабрикаты, но не услуги, работы и объекты недвижимости. 3. Имеется «временной разрыв в 1С» между моментом перехода прав собственности на товар (так будем называть упомянутую в пункте 2 номенклатуру) и поступлением товара на склад предприятия. 4. Правила и политика учета на предприятии диктуют необходимость отразить «временной разрыв в 1С» в учетной системе. Строго говоря, такой «временной разрыв в 1С» между моментом подписания накладной (переход права собственности) и моментом физического поступления товара на склад существует всегда. Но не всегда имеет смысл отражать «временной разрыв в 1С» в учетной системе.

09.05.2020    4225    Koder_Line    0    

Как разрешить продажу по нулевой цене, или 100%-ная скидка. Простые примеры (КА 2.4, а также ERP 2.2 и УТ 11.4)

Практика программирования Оптовая торговля Розничная торговля Ценообразование, анализ цен v8 ERP2 УТ11 КА2 Россия УУ Бесплатно (free)

Акции, бонусы, подарки, бесплатные буклеты... Это ограничено 1С и НК, но это очень хочется иметь в управленческой базе. При этом не хочется снимать программу с поддержки. Легко.

06.05.2020    3747    ne_en    18    

НДС предъявленный. Возмещение НДС при смене режима налогообложения

Учет ТМЦ v8 ERP2 Россия ЕНВД НДС Бесплатно (free)

Мы недавно внедрили финансовый учет на ERP в крупном холдинге и готовы поделиться всеми выползшими проблемами, от ввода начальных остатков до закрытия месяца. Вот первая статья на эту тему.

16.04.2020    1234    n.saltsina    1    

Партионный учет по двум количественным показателям

Математика и алгоритмы Учет ТМЦ v8 1cv8.cf Оптовая торговля, дистрибуция, логистика Россия УУ Бесплатно (free)

Особенности учета партионной системы при наличии двух количественных показателей.

26.03.2020    3520    lastcontra    5    

1С Переучет Android Промо

Сканер штрих-кода v8 1cv8.cf Бесплатно (free)

Приложение создано для удобного переучета товаров с помощью Android устройств с выгрузкой в 1С

31.08.2012    44303    bosterua    90    

5 шагов по изменению резервирования товаров в УТ 11.4

Оптовая торговля Практика программирования v8::ОУ v8::УФ УТ11 Россия УУ Бесплатно (free)

Планируйте, меняйте подходы, делайте качественно и регулярно, и получите результат.

19.03.2020    4716    Igorro82IT    16    

Удаление ошибки Неоднозначное имя характеристики в дополнительных реквизитах номенклатуры

Учет ТМЦ v8 v8::ПВХ ERP2 Россия УУ Бесплатно (free)

При отборе номенклатуры по видам и свойствам возникает ошибка Неоднозначное имя характеристики, здесь объясняется, что нужно сделать.

12.03.2020    2411    Katerpal    0    

Как продавать маркируемый товар (обувь) из 1С:Розница + сканер для маркировки

Розничная торговля Сканер штрих-кода v8 Розница Розничная и сетевая торговля (FMCG) Россия Бесплатно (free)

Маркировка обуви в нашей стране началась с 1 июля 2019 года. Но если в 2019м году от участников рынка требовалось только зарегистрироваться в системе «Честный знак», то теперь уже совсем не за горами дата, когда необходимо будет в обязательном порядке передавать данные о проданных единицах обуви. По графику этот судный день назначен на 1 марта 2020 года. Как все знают, русский человек всегда надеется на лучшее (или на авось, кому как нравится), надеется что правительство передумает. Сейчас в сети ходит информация о возможных сроках переноса судного дня на 1 июля, или, даже, 1 сентября 2020 года, это лишь отсрочки, но никак не отмена обязательной маркировки. В дополнении ко всему вышесказанному надо отметить, что самая популярная программа для розничной торговли, а именно 1С:Розница, как и ее пользователи не смогла заранее подготовиться к нововведениям. Обновление, в котором система стала работать более-менее корректно, вышло лишь 6 февраля 2020 года (менее чем за месяц до судного дня)

22.02.2020    3980    VCPro    8    

Интеркампани в УТ 3.0 для Украины Промо

Комиссионная торговля Оптовая торговля Розничная торговля Бухгалтерский учет Комиссионная торговля Оптовая торговля Розничная торговля v8 УТ10 Украина УУ Бесплатно (free)

Вот, вот уже скоро выйдет долгожданная конфигурация «Управление торговлей для Украины» третьей редакции. Одной из фишек, которую ждут пользователи версии 2.3, является интеркампани, которую и будем обсуждать в нижележащей статье. Господа, кому интересно - прошу под кат.

31.01.2013    24873    akomar    10    

Учет многолетних трав в 1С: ЕРП АПК

Учет ТМЦ Производство готовой продукции (работ, услуг) Бухгалтерия v8 ERP2 Сельское хозяйство и рыболовство Россия БУ УУ Бесплатно (free)

Одним из самых длительных процессов производства в полеводстве является выращивание многолетних трав. Ключевой особенностью учета себестоимости в данном случае является распределение затрат первого года (как правило, это все затраты до первого укоса в год посева, либо полностью все затраты в год посева, если в этом году не было укоса). И распределяются они согласно документу "Методические рекомендации по бухгалтерскому учету затрат и выхода продукции в растениеводстве" (утв. Минсельхозом РФ 22.10.2008) равными долями на все годы использования данных посевов.

19.01.2020    2893    AXoxol    6    

Виды запасов: что это, и что делать, чтобы все было хорошо

Учет ТМЦ v8 ERP2 УТ11 КА2 Россия УУ Бесплатно (free)

Учет товаров по видам запасов, особенности его реализации в программах 1C:Управление торговлей 11, Комплексная автоматизация 2 и 1C^ERP, а также отличия от "традиционного" партионного учета.

25.11.2019    10105    user1114962    12    

Как подключить сканер штрихкода

Сканер штрих-кода v8 Розница Розничная и сетевая торговля (FMCG) Россия Бесплатно (free)

Собственно, решил написать все, что знаю про подключение сканера штрих-кода. На первый взгляд кажется все просто, а на итог можно долго провозиться. Особенно когда до этого имел дело только с 1С и не имел опыта работы с торговым оборудованием.

11.11.2019    37808    VachKirp    53    

Легкий способ подключения сканера штрих-кодов без установки драйвера Промо

Сканер штрих-кода v8 1cv8.cf Россия Бесплатно (free)

Предлагаемое описание позволит подключить сканер штрих-кодов к любому решению на платформе 8.x - короткая подготовка и быстрое подключение.

21.08.2012    141443    bforce    74    

Управление запасами в 1C:УНФ. Ордерная схема. Складские ордера. Плюсы и минусы. Для чего она нужна?

Управление торговлей Учет ТМЦ v8 УНФ Бесплатно (free)

Ордерная схема. Плюсы и минусы Давайте сразу же зададимся вопросами: Что такое ордерная схема и для чего она нужна? А в конце статьи попытаемся ответить на главный вопрос: Нужна ли ордерная схема вашему предприятию? Ордерная схема это прежде всего разделение операций по движению товаров на Финансовые и Складские. Ещё называют "двухфазная" схема товародвижения.

14.10.2019    8555    funtik135    14    

Описание функционала отраслевой конфигурации 1С: Управление ветеринарными сертификатами

Оптовая торговля Пользователю системы Бухгалтерский учет Оптовая торговля v8 1С:УВС Сельское хозяйство и рыболовство Оптовая торговля, дистрибуция, логистика Пищевая промышленность Россия БУ УУ Бесплатно (free)

Данная статья представляет краткое описание функционала конфигурации 1С: Управление ветеринарными сертификатами. Судьба свела меня с данным программным продуктом не так давно, поэтому опыт общения с ним не сильно богатый. Но, с одной стороны, какие-то "шишки" я в этом вопросе уже "набил", а с другой - внятной документации или описания на данное творение, как говорится, "днем с огнем". Самое полезное, что я смог найти - это серия видеороликов от самих "АСБК Софт" (https://www.asbc.ru/catalog/vsd3428new/). В совокупности эти 2 обстоятельства наталкивают меня на мысль о том, что можно написать некоторое подобие общего описания программы. Искренне надеюсь, что кому-то мои творческие потуги принесут пользу.

07.09.2019    5839    Астиг    8    

Дополнение к контролю остатков

Учет ТМЦ Учет ТМЦ v8 ERP2 УТ11 КА2 БУ УУ Бесплатно (free)

Огорчает один момент в типовых решениях, когда проводится документ, ругаясь на нехватку остатков, система не сообщает, по какому именно регистру проблема. Дополнив сообщения контроля названием регистра, можно уменьшить время расследования проблемы (исключив из процесса необходимость запуска программистом отладки в конфигураторе для выявления имени проблемного регистра).

15.08.2019    15934    sapervodichka    17    

Выбор вариантов отчета в "Управление торговлей" ред. 11 Промо

Работа с интерфейсом Учет ТМЦ Учет ТМЦ v8 УТ10 Россия БУ Бесплатно (free)

В УТ 11 в свойствах конфигурации задано хранилище вариантов отчетов. Исходя из этого, все отчеты будут использовать для своих вариантов именно это хранилище (если, конечно, в свойствах самого отчета не задано другое хранилище). По сути, все варианты для отчетов находятся в справочнике "Варианты отчетов", который заполняется при первом запуске системы. Вполне очевидно, что если Вы создаете свой отчет (внешний или внутренний) с несколькими вариантами, у Вас не будет возможности выбирать нужный вариант (переключаться между вариантами), т.к. в выше указанном справочнике нет никакой информации о вариантах созданного Вами отчета. В этой небольшой статье я покажу один из способов решения данной проблемы.

27.05.2012    47004    1cUserAndrew    25    

Чеки ККМ для расчетов с ИП по безналу. Новые обязательные реквизиты в чеке

Практика программирования ККМ Оптовая торговля Оптовая торговля Разработка v8 v8::ОУ УТ11 УУ Бесплатно (free)

Новые требования законодательства по пробитию чеков ККМ при расчетах с индивидуальными предпринимателями по безналу. Нюансы подключения интеграционной компоненты ДТО 10.5.0 на примере кассы ККТ АТОЛ 11Ф и конфигурации 1С УТ 11.4. Необходимые доработки типовой конфигурации УТ 11.4 для вывода на печать новых обязательных реквизитов: покупатель, ИНН, ГТД, страна происхождения.

22.07.2019    16121    ids79    16    

Управление обеспечением товаров в 1С: Управление торговлей 11 (автоматические закупки)

Оптовая торговля Бухгалтерский учет Оптовая торговля v8::ОУ УТ11 Оптовая торговля, дистрибуция, логистика УУ Бесплатно (free)

Настраиваем автоматическое обеспечение товарами в 1С Управление торговлей 11 стандартными средствами.

22.05.2019    13025    ogre2007    13    

Первоначальная настройка программы 1С:Управление ветеринарными сертификатами

Бухгалтерский учет Оптовая торговля Оптовая торговля v8 1С:УВС Сельское хозяйство и рыболовство Оптовая торговля, дистрибуция, логистика Пищевая промышленность Россия УУ Бесплатно (free)

В данной статье я хочу изложить порядок подготовки программы "1С:Управление ветеринарными сертификатами. Интеграция с ФГИС Меркурий" к работе.

17.04.2019    7218    Астиг    3    

Сложное ранжирование клиентов по классам Промо

Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Розничная торговля Управленческие Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Розничная торговля v8 УТ10 Россия УУ Бесплатно (free)

Пример реализации усложненной ABC-классификации клиентов. Данная статья написана для конфигурации "1С: Управление торговлей, ред. 10.3", но, я думаю, предложенный метод подойдет и для других конфигураций, имеющих механизм ABC-классификации.

28.03.2012    23459    charushkin    9    

1С + TecDoc + CMS Битрикс. Трудности перевода

Интеграция Оптовая торговля Оптовая торговля v8 1cv8.cf Автомобили, автосервисы Россия УУ Бесплатно (free)

Варианты подключения номенклатурных данных базы TecDoc, если у вас автобизнес.

12.04.2019    7203    n.saltsina    11    

Справочник "Номенклатура": технические характеристики, учет аналогов, контроль уникальности и многое другое…

Пользователю системы Бухгалтерский учет Учет ТМЦ Учет ТМЦ v8 1cv8.cf Россия Бесплатно (free)

Отражение отраслевых особенностей и особенностей регламента ведения базовых справочников в справочнике Номенклатуры конфигураций на платформе 8.3.

05.04.2019    7491    n.saltsina    4    

Объектный учёт материалов при производстве рулонов основы для печати

Производство готовой продукции (работ, услуг) Учет ТМЦ Практика программирования Бухгалтерский учет Производство готовой продукции (работ, услуг) Учет ТМЦ v8 v8::ПВХ КА1 УТ10 УПП1 Издательство, полиграфия, упаковка УУ Бесплатно (free)

Рулоны из Бумаги и Плёнки в полиграфии составляют существенную часть затрат на выпуск готовой продукции Как проследить историю каждого рулона от прихода до выпуска готовой продукции ?

25.03.2019    5158    Designer1C    0    

AltLinux + ККТ Атол 30Ф (55Ф) + сканер штрих-кода

Администрирование данных 1С ККМ Сканер штрих-кода Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 Розница Россия Бесплатно (free)

Описание опыта настройки контура AltLinux + платформа 1С 8.3 + Розница 2.2 базовая + сканер штрих-кода + ККТ 30Ф (55Ф).

14.02.2019    6397    Ceboo    4    

Отражение корректировки реализации или поступления при переходе на новую базу

Бухгалтерский учет Оптовая торговля Оптовая торговля v8::БУ БП3.0 Россия БУ Бесплатно (free)

Для корректировки реализации/поступления необходимо выбрать документ-основание. Данная инструкция подходит для тех ситуаций, когда дата документа-основания меньше, чем дата ввода остатков.

06.02.2019    12185    malikova_julia    8    

Расширение конструктора мобильного рабочего места для варианта "клиент 1С+RDP" (для любых wi-fi терминалов). Экосистема решений Simple WMS

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Универсальные функции Мобильная разработка Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8::УФ УУ Бесплатно (free)

Развитие проекта «Конструктор мобильного клиента на Android» https://infostart.ru/public/976636/ для устройств не на Андроиде (работающих в режиме RDP). В отличие от варианта Android работа на терминалах происходит в режиме 1С:Предприятие через RDP а конфигурации мобильных клиентов полностью совместимы для обоих версий. Т.е. конфигурация единая, создается один раз и ее может читать как Android -устройство, так и 1С-клиент на RDP без необходимости какой либо переделки.

05.02.2019    13224    informa1555    10    

Исправление отрицательных остатков по организациям в УТ 11.4, КА 2.4, ЕРП 2.4. Интеркампани, механизм формирования резервов

Практика программирования Адаптация типовых решений Учет ТМЦ Учет ТМЦ v8 v8::УФ ERP2 УТ11 КА2 УУ Бесплатно (free)

Подробно рассмотрены два способа исправления отрицательных остатков по организациям без использования подсистемы Интеркампани и с использованием. Описан механизм формирования резервов на уровне процедур общего модуля. Доработки механизма и исправление ошибок.

29.01.2019    31309    ids79    35    

Настройка отражения документов в регламентированном учете при установленном учете себестоимости по видам запасов (ЕРП)

Бухгалтерский учет Учет ТМЦ Учет ТМЦ v8 ERP2 КА2 Россия БУ Бесплатно (free)

Настройка отражения документов в регламентированном учете при установленном учете себестоимости по видам запасов. Это особый случай и есть особенности настройки. По результатам одного исследования, которое я повторил дважды. Но теперь записал себе на память, чтоб не искать решение третий раз.

15.01.2019    8562    rokhin    13    

Сложные схемы поступления товаров в УТ 11.4, КА 2.4, ЕРП 2.4

Бухгалтерский учет Учет ТМЦ Управленческий учет (прочее) Учет ТМЦ v8 v8::УФ ERP2 УТ11 КА2 БУ УУ Бесплатно (free)

Поступление товаров по схеме «Товары в пути», поступление неотфактурованного товара, настройки системы учета, новые объекты конфигурации, последовательность ввода документов, движения по регистрам накопления

31.12.2018    37975    ids79    41