Подключение сканера штрихкода к Бухгалтерии 3.0

Публикация № 948435

Учет и отчетность - Оптовая торговля

БП 3.0 Бухгалтерия 3.0 сканер шк штрихкод

17
Возникла потребность обеспечить идентификацию номенклатуры по штрихкоду. На складе уже было рабочее место с Бухгалтерией 3.0. Поиск по ключевой фразе «сканер ШК БП 3.0» выдал не так много результатов. На ИС была обнаружена статья от 2013 года, которая сейчас несколько устарела. В 2018 году процесс подключения сканера штрихкода стал существенно проще.

Ссылка на статью //infostart.ru/public/203591/ (сейчас она несколько устарела).

В 2018 году процесс подключения сканера штрихкода стал существенно проще.

В разделе «Администрирование» есть пункт «Подключаемое оборудование» и в ней есть закладка «Сканеры штрихкода». Тут все просто. Нажимаем «Создать», выбираем тип оборудования «Сканеры штрихкоды» и драйвер. Например, «1С:Сканеры штрихкода (NativeApi)». Если драйвер еще не установлен будет выдано предложение сделать это сейчас и база сама зарегистрирует нужную компоненту.

Для проверки нажимаем (в этой же форме) «Настроить» и «Тест устройства». Сканер я предварительно перевел в режим virtual COM и установил драйвер виртуального COM порта. В окне теста сразу видно, что доступен порт COM3. После считывания штрихкода данные отображаются в окне. Значит, 1С получает событие от сканера.

Следующий шаг — описать, как база должна реагировать на событие сканирования штрихкода.

Коротко напомню как все устроено в типовых конфигурациях.

У форм документов нет обработчика события «Внешнее событие». Все реализовано через событие управляемого приложения.

Его обработчик получает все события, определяет от какого оборудования они пришли.

Передача управления обработчикам формы выполняется через механизм оповещения.

Реакция системы на штрихкод описывается уже в модуле формы в обработчике события ОбработкаОповещения.

Поиск по конфигурации не порадовал. «Из коробки» штрих код работает только в трех видах документов.

Поскольку конфигурация на поддержке изменения будем вносить через расширение.

Реализуем 2 сценария — привязка штрихкода к карточке номенклатуры и обработка считывания штрихкода для длокумента «Перемещение товаров».

Начнем с номенклатуры.

Чтобы форма элемента получала оповещения от драйвера подключаемого оборудования необходимо добавить обработчики событий ПриОткрытии и ПриЗакрытии (оба с вызовом После).

&НаКлиенте
Процедура Расш1_ПриОткрытииПосле(Отказ)
	
	ТипыПО = Новый Массив();
	ТипыПО.Добавить("СканерШтрихкода");
	
	ОповещениеПриПодключении = Новый ОписаниеОповещения("ПодключениеОборудованияЗавершено", ЭтотОбъект);
	
	МенеджерОборудованияКлиент.НачатьПодключениеОборудованиеПоТипу(ОповещениеПриПодключении, УникальныйИдентификатор, ТипыПО);
	
КонецПроцедуры

&НаКлиенте
Процедура ПодключениеОборудованияЗавершено(РезультатВыполнения, Параметры) Экспорт
	
	Если Не РезультатВыполнения.Результат Тогда
		ТекстСообщения = НСтр( "ru = 'При подключении оборудования произошла ошибка:""%ОписаниеОшибки%"".'");
		ТекстСообщения = СтрЗаменить(ТекстСообщения, "%ОписаниеОшибки%" , РезультатВыполнения.ОписаниеОшибки);
		Сообщить(ТекстСообщения);
	Иначе
		ТекстСообщения = НСтр("ru = 'Оборудование подключено.'" );
	КонецЕсли;
	
КонецПроцедуры

&НаКлиенте
Процедура Расш1_ПриЗакрытииПосле(ЗавершениеРаботы)
	
	ТипыПО = Новый Массив();
	ТипыПО.Добавить("СканерШтрихкода");
	
	ОповещениеПриОтключении = Новый ОписаниеОповещения("ОтключениеОборудованияЗавершено", ЭтотОбъект);
	
	МенеджерОборудованияКлиент.НачатьОтключениеОборудованиеПоТипу(ОповещениеПриОтключении, УникальныйИдентификатор, ТипыПО);
	
КонецПроцедуры

&НаКлиенте
Процедура ОтключениеОборудованияЗавершено(РезультатВыполнения, Параметры) Экспорт

	Если Не РезультатВыполнения.Результат Тогда
		ТекстСообщения = НСтр( "ru = 'При отключении оборудования произошла ошибка:""%ОписаниеОшибки%"".'");
		ТекстСообщения = СтрЗаменить(ТекстСообщения, "%ОписаниеОшибки%" , РезультатВыполнения.ОписаниеОшибки);
		Сообщить(ТекстСообщения);
	Иначе
		ТекстСообщения = НСтр("ru = 'Оборудование подключено.'" );
	КонецЕсли;

КонецПроцедуры

Если код вызывает вопросы — напишите в комментарии — отвечу.

Далее создадим обработчик события ОбработкаОповещения (вызов также После).

&НаКлиенте
Процедура Расш1_ОбработкаОповещенияПосле(ИмяСобытия, Параметр, Источник)
	
	Если Источник = "ПодключаемоеОборудование" Тогда
		
		Если ИмяСобытия = "ScanData" Тогда
			
			Если Параметр[1] = Неопределено Тогда
				ТекущийКод = Параметр[0];
			Иначе
				ТекущийКод = Параметр[1][1];
			КонецЕсли;
			
			Номенклатура = "";
			Если ЕстьНоменклатураПоШтрихкоду(ТекущийКод, Номенклатура) Тогда
				ТекстСообщения = НСтр("ru = 'Штрихкоду %Штрихкод% уже сопоставлена номенклатура %Номенклатура%'" );
				ТекстСообщения = СтрЗаменить(ТекстСообщения, "%Штрихкод%" , ТекущийКод);
				ТекстСообщения = СтрЗаменить(ТекстСообщения, "%Номенклатура%" , Номенклатура);
				СообщениеПользователю = Новый СообщениеПользователю;
				СообщениеПользователю.Текст = ТекстСообщения;
				СообщениеПользователю.Сообщить();
			Иначе
				ВопросСоздатьНоменклатуруЗавершение = Новый ОписаниеОповещения("ПривязатьШтрихкодКНоменклатуреПослеВопроса", ЭтаФорма, ТекущийКод);
				ТекстСообщения = НСтр("ru = 'Привязать штрихкод %Штрихкод% к номенклатуре %Номенклатура%?'" );
				ТекстСообщения = СтрЗаменить(ТекстСообщения, "%Штрихкод%" , ТекущийКод);
				ТекстСообщения = СтрЗаменить(ТекстСообщения, "%Номенклатура%" , Объект.Наименование);
				ПоказатьВопрос(ВопросСоздатьНоменклатуруЗавершение, ТекстСообщения, РежимДиалогаВопрос.ДаНет, 30, КодВозвратаДиалога.Нет);
			КонецЕсли;
			
		КонецЕсли;
			
	КонецЕсли;
	
КонецПроцедуры

&НаСервере
Функция ЕстьНоменклатураПоШтрихкоду(Штрихкод, Номенклатура)
	
	Рез = Ложь;
	
	ТаблицаНоменклатурыПоШтрихкоду = РегистрыСведений.ШтрихкодыНоменклатуры.НоменклатураПоШтрихкоду(Штрихкод);
	
	Если ТаблицаНоменклатурыПоШтрихкоду.Количество() > 0 Тогда
		Номенклатура = ТаблицаНоменклатурыПоШтрихкоду[0].Номенклатура;
		Рез = Истина;
	КонецЕсли;
	
	Возврат Рез;
	
КонецФункции

&НаКлиенте
Процедура ПривязатьШтрихкодКНоменклатуреПослеВопроса(Результат, Параметры) Экспорт
	
	Если Результат = КодВозвратаДиалога.Да Тогда
		ПривязатьШтрихкодКНоменклатуре(Параметры);
	КонецЕсли;
	
КонецПроцедуры

&НаСервере
Процедура ПривязатьШтрихкодКНоменклатуре(Штрихкод) Экспорт
	
	НовыйШК = РегистрыСведений.ШтрихкодыНоменклатуры.СоздатьМенеджерЗаписи();
	НовыйШК.Штрихкод = Штрихкод;
	НовыйШК.Номенклатура = Объект.Ссылка;
	НовыйШК.Записать();
	
КонецПроцедуры

Обработчик проверяет, что пришло событие именно со сканера штрихкода. Далее выполняется поиск номенклатуры по штрихкоду. Если номенклатура найдена выдается сообщение пользователю, что штрихкод уже сопоставлен с другой номенклатурой. В противном случае создается запись в регистре сведений ШтрихкодыНоменклатуры (после уточняющего вопроса пользователю).

Со справочником на этом все.

Переходим к документу.

Аналогично добавляем код для событий ПриОткрытии и ПриЗакрытии для подключения (и отключения) подписки на получение событий от подключаемого оборудования.

В обработчике ОбработкаОповещения размещаем код

&НаКлиенте
Процедура Расш1_ОбработкаОповещенияПосле(ИмяСобытия, Параметр, Источник)
	
	Если Источник = "ПодключаемоеОборудование" И ВводДоступен() Тогда
		Если ИмяСобытия = "ScanData" Тогда
			Если Параметр[1] = Неопределено Тогда
				ТекущийКод = Параметр[0];
			Иначе
				ТекущийКод = Параметр[1][1];
			КонецЕсли;
			ДобавитьПоШтрихкодуНаСервере(ТекущийКод);
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры

Процедура ДобавитьПоШтрихкодуНаСервере выполняет поиск номенклатуры сопоставленной с штрихкодов. Если номенклатура не найдена выдает сообщение пользователю. Иначе — добавляет строку в документ. Добавление строки реализовано по аналогии с документом ПоступлениеТоваровУслуг.

&НаСервере
Функция ДобавитьПоШтрихкодуНаСервере(Штрихкод)
	ТаблицаНоменклатурыПоШтрихкоду = РегистрыСведений.ШтрихкодыНоменклатуры.НоменклатураПоШтрихкоду(Штрихкод);
	
	Если ТаблицаНоменклатурыПоШтрихкоду.Количество() = 1 Тогда
		ДобавитьНоменклатуруНаСервере(ТаблицаНоменклатурыПоШтрихкоду[0].Номенклатура);
	Иначе
		ТекстСообщения = НСтр("ru = 'Штрихкоду %Штрихкод% не сопоставлена ни одна номенклатура'" );
		ТекстСообщения = СтрЗаменить(ТекстСообщения, "%Штрихкод%" , Штрихкод);
		СообщениеПользователю = Новый СообщениеПользователю;
		СообщениеПользователю.Текст = ТекстСообщения;
		СообщениеПользователю.Сообщить();
	КонецЕсли;
	
КонецФункции

&НаСервере
Процедура ДобавитьНоменклатуруНаСервере(Номенклатура)
	
	ПараметрыОтбора = Новый Структура("Номенклатура", Номенклатура);
	
	мСтрок = Объект.Товары.НайтиСтроки(ПараметрыОтбора);
	Если мСтрок.Количество() = 0 Тогда
	
		ТаблицаТовары = Новый ТаблицаЗначений;
		ТаблицаТовары.Колонки.Добавить("Номенклатура");
		ТаблицаТовары.Колонки.Добавить("Количество");
		ТаблицаТовары.Колонки.Добавить("Цена");
		
		
		СтрокаТаблицаТовары = ТаблицаТовары.Добавить();
		
		СтрокаТаблицаТовары.Номенклатура = Номенклатура;
		СтрокаТаблицаТовары.Количество = 1;
		СтрокаТаблицаТовары.Цена = 0;
		
		Значение = Новый Структура("АдресПодобраннойНоменклатурыВХранилище, КоличествоДобавленныхСтрок", ПоместитьВоВременноеХранилище(ТаблицаТовары, УникальныйИдентификатор));
		
		ОбработкаВыбораПодборВставкаИзБуфераНаСервере(Значение, "Товары");
		
	Иначе
		
		СтрокаТовары = мСтрок[0];
		СтрокаТовары.Количество = СтрокаТовары.Количество + 1;
		
	КонецЕсли;

КонецПроцедуры

На этом всё.

Взаимодействие сканера с другими документами выполняется аналогичным образом.

17

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. muskul 23.11.18 05:08 Сейчас в теме
Разве по умолчанию ШК в БП 3.0 не работает во всех местах в которых должен по логике?
2. Dem1urg 291 23.11.18 07:15 Сейчас в теме
(1) Я же специально сделал скриншот с результатом поиска текста ScanData.
Работает в двух местах - поступление и розничная продажа.
Можете сами проверить.
3. muskul 23.11.18 08:54 Сейчас в теме
(2)Проверил, действительно, логика и 1с теперь редко пересекаются.
4. k0pai22 23.11.18 18:02 Сейчас в теме
(3) Нельзя просто взять и оптимизировать БП для всех видов торговли. Может кануть в лету немалая часть продаж УТ. Сам когда писал ШК для реализации в БП 3.0 был в недоумении, потом понял.
5. kembrik 3 23.11.18 18:47 Сейчас в теме
Ничто так не печалит меня, как штрихкод в Измерениях
6. Dem1urg 291 23.11.18 19:25 Сейчас в теме
(5) Почему? Это ж по сути вспомогательный регистр.
7. kembrik 3 24.11.18 14:13 Сейчас в теме
(6) Потому что мы не можем хранить в таком случае одинаковый штрихкод у разной номенклатуры. А это сплошь и рядом. У производителя иной раз сменилась упаковка, состав и комплектация изделия, а штрихкод там один и тот же. И без самостоятельной принудительной маркировки это потом не разгрести. Речь понятно не только про бухгалтерию, скорее про УТ. Вот и приходится хранить в допреквизите и перепиливать процедуру поиска.
8. Rustig 1201 27.11.18 18:48 Сейчас в теме
(7)
У производителя иной раз сменилась упаковка, состав и комплектация изделия, а штрихкод там один и тот же.

а как вам поможет допреквизит? и что за допреквизит вы добавляете?
пока не понятно, как в ситуации Товар1+ШК1 и Товар2+ШК1 - однозначно идентифицировать по ШК1 нужный Товар?...даже без учета конфигурации, на пальцах алгоритм расскажите
10. kembrik 3 03.12.18 12:40 Сейчас в теме
(8) 1. Штрихкод с коробки бьётся в допреквизит "Штрихкод производителя"
2. У номенклатуры жесткая иерархия в зависимости от сезона поставки
3. Периодически запускается регламентная обработка, которая сигнализирует, что у нескольких позиций одинаковый штрихкод у разных поставок, а собственный штрихкод ещё не присвоен
4. Присваивается собственный штрихкод каждой из задвоившейся номенклатуры, если ещё нет, после визуального контроля, отличается ли состав, комплектация товара и т.д. Если не отличается то такой же, как у прошлой поставки, если отличается - то новый. Как то так

Соответственно типовое "пиканье" учим искать и в регистре сведений номенклатуры и в допреквизитах, и отображать все варианты, а не единственное
11. Rustig 1201 03.12.18 18:54 Сейчас в теме
(10)
1. Штрихкод с коробки бьётся в допреквизит "Штрихкод производителя"

этот ШК к новой номенклатуре привязывается или к имеющейся старой?
по моему уже на этом этапе происходит визуальный контроль - отличается ли состав, комплектация товара и т.д

(10)
2. У номенклатуры жесткая иерархия в зависимости от сезона поставки

иерархия в зависимости от срока поставки - не хочу вас судить, но, имхо, в целом это плохая идея, плохо решенная задача - это первое мое мнение не видя решения и причин...


(10)
Периодически запускается регламентная обработка, которая сигнализирует, что у нескольких позиций одинаковый штрихкод у разных поставок, а собственный штрихкод ещё не присвоен

если в регистре сведений использовать только типовые измерения Товар + ШК, то регламентная процедура для разных позиций нормально отработает - и определит что у нескольких позиций одинаковый шк...
13. kembrik 3 04.12.18 14:43 Сейчас в теме
(11)
этот ШК к новой номенклатуре привязывается или к имеющейся старой?
по моему уже на этом этапе происходит визуальный контроль - отличается ли состав, комплектация товара и т.д


К новой. Товар ещё на таможне, но производитель уже прислал "Баркоды". Визуальный осмотр товара в контейнере особо не произведёшь, а приходовать уже пора


(11)
иерархия в зависимости от срока поставки - не хочу вас судить, но, имхо, в целом это плохая идея, плохо решенная задача - это первое мое мнение не видя решения и причин...


Сроки поставки укрупненные, например сейчас идёт поступление товара на сезон "Весна-лето 2019", чуть позже начнется "Осень-зима 2019-2020". Кроме иерархии справочника ессно заводится допреквизит сезона и т.д. Это новый товар, произведенный специально для этого сезона.


(11)
если в регистре сведений использовать только типовые измерения Товар + ШК, то регламентная процедура для разных позиций нормально отработает - и определит что у нескольких позиций одинаковый шк...


Я не знаю про какие вы конфигурации говорите - в последних типовых штрихкод это ЕДИНСТВЕННОЕ измерение. В том то и дело, отсюда и корень проблем
Прикрепленные файлы:
15. Rustig 1201 04.12.18 14:56 Сейчас в теме
(13) ясно, понял вас, спасибо за картинку - лучше один раз увидеть, чем сто раз услышать.
я привык, что в ут 10.3 несколько измерений : Номенклатура, Штрихкод, Серия, Тип ШК и еще какой-то....
12. Rustig 1201 03.12.18 18:55 Сейчас в теме
(10) в целом, непонятно все-таки за что вы критикуете "Штрихкод" в измерении...
14. kembrik 3 04.12.18 14:44 Сейчас в теме
(12) За то что кроме "Штрихкода" в измерении больше ничего нет. См. выше
9. Rustig 1201 27.11.18 18:49 Сейчас в теме
(0) интересная тема. спасибо!
16. user619273_alevtina 30.12.18 17:22 Сейчас в теме
Статья интересная, спасибо.
17. Xershi 734 12.02.19 16:27 Сейчас в теме
Добрый день, пытаюсь завести сканер ШК, но не выходит. https://forum.infostart.ru/forum72/topic210249/
Вы писали:
Для проверки нажимаем (в этой же форме) «Настроить» и «Тест устройства». Сканер я предварительно перевел в режим virtual COM и установил драйвер виртуального COM порта.

Но не написали как это сделать, если это скрин, с оборудованием в справочнике, то это сделано!
18. Dem1urg 291 12.02.19 21:07 Сейчас в теме
(17) Процедуры настройки сканера лежат за рамками публикации.
В каком режиме у вас сейчас работает сканер? Если запустить Блокнот и попытаться считать штрихкод что-нибудь происходит?
19. Xershi 734 12.02.19 21:13 Сейчас в теме
(18) это сразу работало. В теме уже нашли решение!
Можете почитать последние ответы. Там остались не понятки почему оно криво работало.
Оставьте свое сообщение

См. также

Чеки ККМ для расчетов с ИП по безналу. Новые обязательные реквизиты в чеке 32

Статья Программист Нет файла v8 v8::ОУ УТ11 УУ Windows Оптовая торговля Бесплатно (free) Практика программирования ККМ Разработка

Новые требования законодательства по пробитию чеков ККМ при расчетах с индивидуальными предпринимателями по безналу. Нюансы подключения интеграционной компоненты ДТО 10.5.0 на примере кассы ККТ АТОЛ 11Ф и конфигурации 1С УТ 11.4. Необходимые доработки типовой конфигурации УТ 11.4 для вывода на печать новых обязательных реквизитов: покупатель, ИНН, ГТД, страна происхождения.

22.07.2019    6313    ids79    16       

Отражение корректировки реализации или поступления при переходе на новую базу 5

Статья Бухгалтер Нет файла v8::БУ БП3.0 Россия БУ Оптовая торговля Бесплатно (free) Бухгалтерский учет

Для корректировки реализации/поступления необходимо выбрать документ-основание. Данная инструкция подходит для тех ситуаций, когда дата документа-основания меньше, чем дата ввода остатков.

06.02.2019    4980    malikova_julia    6       

Расширение конструктора мобильного рабочего места для варианта "клиент 1С+RDP" (для любых wi-fi терминалов). Экосистема решений Simple WMS 20

Статья Программист Бизнес-аналитик Руководитель проекта Нет файла v8::УФ УУ Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Бесплатно (free) Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Универсальные функции Мобильная разработка

Развитие проекта «Конструктор мобильного клиента на Android» https://infostart.ru/public/976636/ для устройств не на Андроиде (работающих в режиме RDP). В отличие от варианта Android работа на терминалах происходит в режиме 1С:Предприятие через RDP а конфигурации мобильных клиентов полностью совместимы для обоих версий. Т.е. конфигурация единая, создается один раз и ее может читать как Android -устройство, так и 1С-клиент на RDP без необходимости какой либо переделки.

05.02.2019    6504    informa1555    0       

Исправление отрицательных остатков по организациям в УТ 11.4, КА 2.4, ЕРП 2.4. Интеркампани, механизм формирования резервов 65

Статья Программист Нет файла v8 v8::УФ ERP2 УТ11 КА2 УУ Учет ТМЦ Бесплатно (free) Практика программирования Адаптация типовых решений

Подробно рассмотрены два способа исправления отрицательных остатков по организациям без использования подсистемы Интеркампани и с использованием. Описан механизм формирования резервов на уровне процедур общего модуля. Доработки механизма и исправление ошибок.

29.01.2019    14155    ids79    25       

Сложные схемы поступления товаров в УТ 11.4, КА 2.4, ЕРП 2.4 43

Статья Программист Бизнес-аналитик Нет файла v8 v8::УФ ERP2 УТ11 КА2 БУ УУ Учет ТМЦ Бесплатно (free) Бухгалтерский учет Управленческий учет (прочее)

Поступление товаров по схеме «Товары в пути», поступление неотфактурованного товара, настройки системы учета, новые объекты конфигурации, последовательность ввода документов, движения по регистрам накопления

31.12.2018    15879    ids79    33       

Партионный учет товаров в конфигурациях УТ, КА, ЕРП 156

Статья Программист Бизнес-аналитик Бухгалтер Нет файла v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Учет ТМЦ Бесплатно (free) Управленческий учет (прочее) Бухгалтерский учет

История развития, особенности реализации в текущих версиях ЕРП 2.4, КА 2.4, УТ 11.4, методы оценки стоимости запасов, примеры расчета стоимости списания

08.12.2018    24150    ids79    48       

Учет товаров по сериям в типовых конфигурациях УТ 11.4, КА 2.4, ЕРП 2.4 130

Статья Программист Бухгалтер Нет файла v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Учет ТМЦ Бесплатно (free) Бухгалтерский учет Управленческий учет (прочее)

Возможности и настройки подсистемы серийного учета, отражение данных по сериям в регистрах и отчетах системы, выявленные нюансы

02.12.2018    24198    ids79    98       

Обзор блока адресного хранения в программах 1С: УТ, ERP и КА 34

Статья Бизнес-аналитик Руководитель проекта Нет файла v8 ERP2 УТ11 КА2 Россия УУ Учет ТМЦ Бесплатно (free) Управление бизнес-процессами (BPM) Бухгалтерский учет

В статье мы подробно расскажем вам, как реализовано адресное хранение в типовых решениях 1С:Управление торговлей, 1С:ERP и 1С:Комплексная автоматизация.

29.11.2018    12007    alis112358    22       

Интеркампани, особенности учета в конфигурациях УТ 11.4, КА 2.4, ЕРП 2.4 82

Статья Программист Бизнес-аналитик Нет файла v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Учет ТМЦ Бесплатно (free) Бухгалтерский учет Управленческий учет (прочее)

Старая и новая методики учета «Интеркампани», недостатки применения старой методики, преимущества и особенности новой, выявленные нюансы.

21.11.2018    21408    ids79    76       

Штрих-кодирование без сканера с Barcode to PC 86

Статья no Нет файла v8 1cv8.cf Бесплатно (free) Сканер штрих-кода

Используйте свой телефон как сканер штрих-кода с бесплатной программой Barcode to PC.

12.11.2018    7271    BuriyLesha    14       

Контроль отрицательных остатков в конфигурациях: УТ 11.4, КА 2.4, ЕРП 2.4 121

Статья Программист Бизнес-аналитик Руководитель проекта Нет файла v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Учет ТМЦ Бесплатно (free) Бухгалтерский учет Управленческий учет (прочее)

Подробный разбор всех присутствующих в конфигурациях УТ 11, КА 2, ЕРП 2 вариантов контроля отрицательных остатков: по организациям, складам, оперативный контроль

08.11.2018    25779    ids79    70       

Контроль суммы задолженности при неоперативном проведении документа продажи (Реализации товаров и услуг) 17

Статья Программист Нет файла v8 КА1 УТ10 УПП1 УУ Дебиторская и кредиторская задолженность Оптовая торговля Бесплатно (free) Практика программирования

Когда требуется провести документ неоперативно в текущем или прошлых днях и быть уверенным, что не возникнет дебиторская задолженность, тогда вам подойдёт данное решение. Решение актуально для КА 1.1, УПП 1.3 и УТ 10.3.

15.06.2018    6764    rpgshnik    1       

История развития 1С:Торговли, что изменилось в архитектуре учета торговых и складских операций за 15 лет 66

Статья no Нет файла v8 Оптовая торговля, дистрибуция, логистика Россия УУ Оптовая торговля Розничная торговля Учет ТМЦ Ценообразование, анализ цен Бесплатно (free) Пользователю системы

В данном обзоре я хочу рассмотреть историю развития учета торговых и складских операций в 1С с точки зрения архитектуры конфигурации. Еще раз повторюсь, именно конфигурации, структуры данных, а не технологических возможностей платформы. Т.е. речь не про управляемые формы и обычные формы, не про преимущество СУБД перед dbf в расшаренной папке, а про справочники, их реквизиты и код, который этим управляет. Конечно, совсем абстрагироваться от изменений платформы не удастся, но я постараюсь.

23.04.2018    16737    monkbest    57       

Внедрение 1С:Управление торговлей 11 как системы управления складом. Интересные разработки. Часть 1. Общие моменты и приемка товаров 32

Статья Программист Нет файла v8 v8::ОУ УТ11 Оптовая торговля, дистрибуция, логистика Россия УУ Учет ТМЦ Бесплатно (free) Бухгалтерский учет

В статье описаны практические кейсы настройки типовой УТ11.4 как системы управления складом (WMS) в процессе приемки-размещения товаров на складе интернет-магазина.

20.11.2017    14672    papche    8       

Внешние печатные формы в Альфа-Авто 5 14

Статья Программист Бухгалтер Руководитель проекта Нет файла v8::ОУ 1cv8.cf Автомобили, автосервисы Россия УУ Windows Оптовая торговля Бесплатно (free) Пользователю системы Практика программирования

Расскажем пользователям о функционале внешних печатных форм в Альфа-Авто 5, о простых возможностях адаптации типового отраслевого решения для автобизнеса под нужды конкретного предприятия. Публикация по большей части предназначена для пользователей, заключительная часть может заинтересовать IT специалистов, сопровождающих описываемую конфигурацию.

01.06.2017    14543    miavolas    15       

Расширение конфигурации. Доработка ТТН 22

Статья Программист Нет файла v8::БУ v8::УФ БП3.0 Россия БУ Оптовая торговля Бесплатно (free) Практика программирования

Продолжаем работать с расширениями. В данной статье покажу, как облегчить процесс заполнения ТТН для пользователя.

18.05.2017    11337    niko11s    0       

Сканер штрихкодов на Android смартфоне для 1С 91

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Розничная торговля Бесплатно (free) Сканер штрих-кода

Как сделать сканер штрихкодов из обычного Android телефона и привязать его к 1С.

07.05.2017    44439    tjurikov_ivan    22       

УПП, формирование записей книги продаж: ускоряем заполнение при большом объеме реализаций 20

Статья Программист Нет файла v8 УТ10 УПП1 Россия БУ Оптовая торговля Производство готовой продукции (работ, услуг) НДС Бесплатно (free) Производительность и оптимизация (HighLoad)

В конце апреля 2017 года ко мне обратилась бухгалтер по НДС с жалобой на очень длительное заполнение документа "Формирование записей книги продаж" по реализации. По ее словам, заполнение документа могло продолжаться от 40 минут до часа за месяц... Разбираемся в ситуации.

01.05.2017    9544    spectre1978    7       

Настройка торгового оборудования в конфигурации "Управление торговлей" ред. 10.3 при работе в терминальном режиме 37

Статья Программист Нет файла v8::ОУ УТ10 Россия Розничная торговля Бесплатно (free) Сканер штрих-кода Терминал сбора данных Фискальный регистратор

У пользователей 1С:Управление торговлей, использующих терминальный доступ для работы в программе, могут возникнуть проблемы при подключении торгового оборудования. Эти проблемы связаны с тем, что в конфигурации УТ 10.3 настройки торгового оборудования хранятся с привязкой к имени компьютера, а работа в режиме терминального доступа означает, что у всех работающих с программой будет одно и тоже имя компьютера. В статье рассмотрим способы решения данной проблемы.

12.04.2017    25123    @lexandr    12       

Расчет себестоимости и его Откат в ERP: практика применения 66

Статья Программист Нет файла v8 ERP2 Россия УУ Закрытие периода Учет ТМЦ Бесплатно (free) Практика программирования

В системе erp отключен партионный учет, метод оценки по средней, учет по видам запаса отключен. Казалось бы, что может быть еще проще, но себестоимость упорно не закрывалась процедурой закрытия месяца

08.02.2017    37004    kristina    24       

Корректировки регистров партий. Надо ли? 28

Статья no Нет файла v8::ОУ УТ11 УУ Оптовая торговля Бесплатно (free) Бухгалтерский учет

Корректировки регистров, как "единственный" способ закрыть месяц, который не закрывается? Так ли это? Сказки про то, что закрывать без них не реально, особенно каждый день, особенно когда много документов и т.д. - просто отговорки и лень. И, кроме этого, - это опасно. Про это я и хочу поговорить.

28.01.2017    17037    LiliyaM    22       

Закрытие месяца (Управление торговлей 11) - решение проблемы ненулевой себестоимости при отсутствии товара 18

Статья Программист Нет файла v8::ОУ УТ11 Россия УУ Windows Оптовая торговля Бесплатно (free) Закрытие периода

Часто при запуске процедуры "Закрытие месяца" выскакивает ошибка следующего содержания: "По номенклатуре ... обнаружен некорректный остаток в регистре "Себестоимость товаров"" и обработка прекращается на пункте "Расчет себестоимости". Данная статья посвящена методам борьбы с указанной ошибкой.

12.12.2016    27056    Mortiferus    17       

Крик души консультанта 1С или как закрывать материальные счета при РАУЗ? 43

Статья Бухгалтер Нет файла v8 УПП1 Россия БУ Учет ТМЦ Бесплатно (free) Бухгалтерский учет

Проблема: при закрытии месяца по материальным счетам (43,10) остается сальдо в стоимостном выражении, хотя сальдо в количественном выражении равно 0.

30.11.2016    13474    iris_reda    35       

Методика пошагового перехода из решения для платформы 7.7 "Торговля и склад" на решение для платформы 8 "Управление торговлей" 12

Статья Программист Нет файла v7.7 v8 УТ10 1С7:ТиС Оптовая торговля, дистрибуция, логистика Россия БУ УУ Оптовая торговля Бесплатно (free) Перенос данных из 1С7.7 в 1C8.X

Данная статья предваряет публикацию подсистемы для одностороннего ONLINE обмена документами и справочниками между базами данных для процесса поэтапного перехода из "семерки" в "восьмерку" для случаев распределенной совместной работы большого количества пользователей, не допускающих резких скачкообразных внедрений с рисками остановки процессов продаж, поставок, доставок или складских сборок.

31.10.2016    12350    vugluscr1991    27       

Загрузка значений свойств номенклатуры в Альфа-Авто с использованием обработки загрузки данных из табличного документа 15

Статья Программист Руководитель проекта Нет файла v8 1cv8.cf Автомобили, автосервисы Россия УУ Windows Учет ТМЦ Бесплатно (free) Загрузка и выгрузка в Excel

В публикации будет рассмотрено использование встроенной в отраслевую конфигурацию Альфа-Авто обработки по загрузке данных из табличного документа для заполнения значений дополнительных свойств номенклатуры.

13.10.2016    14448    miavolas    15       

Дропшиппинг или "виртуальные" склады поставщиков в 1С 19

Статья Бухгалтер Пользователь Руководитель проекта Нет файла v8 УТ10 УУ Оптовая торговля Розничная торговля Учет ТМЦ Бесплатно (free) Техническое задание

Сейчас всё больше компаний работают по системе дропшиппинг (прямые поставки, когда поставщик отправляет товар непосредственно клиенту, а не продавцу) или продают товар со склада поставщика не закупая его себе на склад (под конкретные заказы покупателей). При этом за частую есть необходимость хранения остатков и цен поставщика, выгрузки их на сайты и другие информационные ресурсы, рассылки в своих прайс листах. В статье рассматриваются варианты отражения подобных операций в управленческих конфигурациях 1С без привязки к конкретной конфигурации. С некоторыми различиями данные схемы можно применить в Управлении торговлей 10 и 11, Рарус:Альфа-авто, Комплексной автоматизации, УПП и др. т.е. в целом в любой конфигурации с возможностью ведения управленческого учета и механизма заказов.

02.09.2016    23044    de0nis    16       

WMS (Управление торговлей 11.1, УТ 11.1) практика одного внедрения 74

Статья Бизнес-аналитик Нет файла v8 УТ10 Россия БУ НУ УУ Windows Учет ТМЦ Бесплатно (free) Управление проектом

Речь пойдет о внедрения WMS системы на базе типового функционала Управление торговлей 11.1 для автоматизации склада готовой продукции. Цель данной статьи - рассказать эволюцию принятия решения, предпроектного обследования. Описать аргументы именно той реализации, которая была выбрана в итоге. И, конечно, результаты внедрения. Кому интересно, прошу под кат …

08.06.2016    21752    Ulus    64       

Управление товарными запасами. Заказы поставщикам и/или снабжение с центрального склада. 20

Статья Программист Бизнес-аналитик Нет файла v8 v8::ОУ УТ10 Оптовая торговля, дистрибуция, логистика УУ Windows Финансовый учет и бюджетирование (FRP) Оптовая торговля Учет ТМЦ Бесплатно (free) Управленческий учет (прочее)

Разговор пойдет об управлении товарными запасами. В конце статьи представлены скриншоты программной реализации метода. Программа внедрена в Управлении Торговлей 10.3 и успешно используется в течение 2-х лет в областях закупок и снабжения филиалов. После внедрения точность прогнозов увеличилась, и трудозатраты персонала снизились в несколько раз.

17.02.2016    22263    windows98a    16       

Принципы учета номенклатуры в конфигурациях УТ11 и ERP. Ошибки расчета себестоимости 392

Статья Программист Бизнес-аналитик Бухгалтер Руководитель проекта Нет файла v8 ERP2 УТ11 КА2 УУ Windows Оптовая торговля Учет ТМЦ Бесплатно (free) Управленческий учет (прочее) Бухгалтерский учет

Основные регистры, используемые для учета номенклатуры в конфигурациях УТ11, КА2, ERP. Для чего используются все эти регистры, какие из них основные и какие вспомогательные. Основные ошибки в учете товаров и расчет себестоимости. Как проще находить и исправлять ошибки в учете.

06.01.2016    134176    ekaruk    66       

Штрихкодирование автозапчастей. Альфа-авто. 20

Статья Программист Нет файла v8 Автомобили, автосервисы УУ Windows Учет ТМЦ Бесплатно (free) Практика программирования

При запуске штрихкодирования в автозапчастях основной сложностью является заполнение самих штрихкодов. Так же т.к. различной номенклатуры очень много и постоянно могут появляться новые товарные позиции, то оклейка склада наклейками со своими штрихкодами становится проблематичной. Но..

10.12.2015    18203    de0nis    13       

Расчёт себестоимости в 1С УПП 1.3. Инструкция по подготовке 77

Статья Бухгалтер Нет файла v8 КА1 УПП1 Россия БУ НУ УУ Windows Закрытие периода Производство готовой продукции (работ, услуг) Учет ТМЦ Учетная политика Ценообразование, анализ цен Бесплатно (free) Управленческий учет (прочее) Бухгалтерский учет

Подготовка к Закрытию месяца и непосредственно Расчёту себестоимости — самый трудный процесс, методических материалов по которому до сих пор недостаточно. Помнить обо всех тонкостях трудно, особенно когда закрытие периода производится не каждый месяц, а раз в квартал.

23.11.2015    64347    Vikki-di    12       

Производство из давальческого сырья 29

Статья Бухгалтер Нет файла v8 КА1 УПП1 Россия БУ НУ УУ Windows Производство готовой продукции (работ, услуг) Учет ТМЦ Ценообразование, анализ цен Бесплатно (free) Управленческий учет (прочее) Бухгалтерский учет

Заказчик даёт нам материалы и полуфабрикаты, чтобы мы могли доработать их и вернуть готовые изделия. Наглядная инструкция по отражению работ с давальческим сырьём в 1С: УПП 1.3.

23.11.2015    30498    Vikki-di    9       

Контур.EDI изнутри, или история командной разработки тиражного продукта на 1С 174

Статья Программист Нет файла v8 Россия УУ Windows Оптовая торговля Бесплатно (free) Интеграция Практика программирования Математика и алгоритмы

“Система - больше, чем просто совокупность ее элементов”; “Несколько разработчиков - это еще не команда разработки”. Расскажу, как мы прочувствовали эти очевидные утверждения на своей шкуре.

17.11.2015    35952    skif47    88       

Корректировочный счет-фактура в 1С: Бухгалтерия 3.0. Как создать? Как обосновать? Что за собой повлечет? 17

Статья Бухгалтер Нет файла v8 БП2.0 Россия БУ Windows Оптовая торговля Производство готовой продукции (работ, услуг) НДС Бесплатно (free) Бухгалтерский учет

Хочу рассказать о корректировочных счетах-фактурах. Как их создать в программе 1С: Бухгалтерия 3.0. Какие проводки вы получите в том или ином случае. И какие отчеты придется пересдавать и в каком случае.

15.09.2015    36081    ameli-130412    3       

Производство в УПП 1.3. Шаг за шагом. Часть 1. 29

Статья Программист Бизнес-аналитик Пользователь Нет файла v8 УПП1 Россия УУ Windows Оптовая торговля Производство готовой продукции (работ, услуг) Бесплатно (free) Бухгалтерский учет

Рассмотрим основные вопросы управления производством на предприятии. Заказы покупателей, резервирование, планирование, сменно-суточное задания, лимитно-заборные карты, АРМы и т.д. Рекомендации подойдут как для небольшой организации, так и для крупной. Кроме того, все особенности и новые подходы, предложенные нами, мы будем подробно объяснять, и вы сможете использовать наши идеи в своей работе. Работаем мы с УПП 1.3, с незначительными (на наш взгляд) доработками. Если ваш интерес и поддержка будут нас радовать, то статья будет непрерывно пополняться. Наша попытка развить типовой функционал не единственная, но все же мы считаем, что мы добились неплохого результата, и хотим поделиться этим результатом с вами.

500 руб.

19.08.2015    25084    5       

Внедрение адресного склада в логистическом операторе 25

Статья Системный администратор Программист Бизнес-аналитик Пользователь Нет файла v8 v8::ОУ УТ11 Оптовая торговля, дистрибуция, логистика Россия УУ Windows Оптовая торговля Розничная торговля Учет ТМЦ УСН Бесплатно (free) Загрузка и выгрузка в Excel Бухгалтерский учет Рабочее место

Каких-то 10 лет назад бюджет внедрений адресных складов составлял десятки тысяч долларов и месяцы работ целой команды, а теперь - типовое решение от 1С вполне рабочее и без кастомизации: немного интеграции, немного консультирования – и в продуктив. Внедрение адресного склада, в массе внедрений 1С:Управление торговлей, ред. 11.1 (далее УТ), штука до сих пор довольно-таки редкая. Данная статья описывает опыт одного маленького, но свежего внедрения адресного склада в УТ (11.1.10) и может быть интересна как практический кейс.

1 стартмани

10.08.2015    18739    papche    12       

Интеграция 1С:Предприятие УТ 11.1.2 и 1С Битрикс. Настройка обмена товарами 162

Статья Системный администратор Нет файла v8 УТ10 Windows Оптовая торговля Розничная торговля Бесплатно (free) WEB

Большинство инструкций по интеграции 1С и Битрикс не заостряют внимание на моментах, на которые начинающий может потратить от нескольких часов до нескольких дней своего времени. Попробую максимально закрыть этот вопрос именно в плане быстрого старта (не ошибусь, если скажу – у многих есть желание посмотреть, как работает 1С Управление торговлей в связке с интернет магазином).

21.04.2015    73203    capitan    35       

Управление резервами товаров в УТ 11 и ERP. Особенности и нюансы 236

Статья Программист Бизнес-аналитик Нет файла v8 УТ10 ERP2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Windows Оптовая торговля Учет ТМЦ Бесплатно (free) Бухгалтерский учет

Система управления резервами является сердцем работы большой части торговых компаний. Данная статья сделана как обзор типовых механизмов резервирования и основных проблем, с которыми приходится сталкиваться при его использовании. Статья написана на примере торгового функционала. Но для производственного предприятия всё описанное ниже тоже актуально; просто в нём вместо потребности в готовой продукции по Заказам клиентов будет возникать потребность в материалах по Заказам на производство, а принципиально механизм резервов устроен точно так же.

25.11.2014    105252    FFelix    38       

Подключение сканера к 1С Предприятие 8.3 27

Статья Системный администратор Нет файла v8 1cv8.cf Россия Windows Бесплатно (free) Сканер штрих-кода

Подключение сканера к 1С Предприятие 8.3 (обычные и управляемые формы)

19.11.2014    59940    dchumak    27       

Популярные вопросы управления запасами в торговых организациях 88

Статья Бизнес-аналитик Пользователь Нет файла v8 УТ10 ERP2 Оптовая торговля, дистрибуция, логистика УУ Windows Оптовая торговля Учет ТМЦ Бесплатно (free) Управленческий учет (прочее)

В статье собрана информация о разных проблемах управления складскими запасами товаров, используемых в основной деятельности (продаваемых, или используемых для производства). Часть методов реализована в типовом функционале конфигураций «1С:Управление торговлей» и «1С:ERP», другая часть разрабатывалась для разных предприятий. Критерием отбора вопросов, описанных в статье, является возможность использования предложенных решений в качестве шаблона для внедрения на других предприятиях.

10.11.2014    40261    FFelix    16       

Мобильное приложение "Учет магазина склада" 12

Статья no Нет файла v8 Россия УУ Android Оптовая торговля Учет ТМЦ Бесплатно (free) Мобильная разработка

Простое и удобное мобильное приложение для учета в вашем магазине. Интересная особенность программы – простое создание сети розничных точек. Об этом в этой статье.

02.09.2014    18121    flyer    3       

Введение в планирование производства с использованием 1С:ERP (УП2). Обзор концепций составления графика 21

Статья Бизнес-аналитик Пользователь Нет файла v8 ERP2 УУ Windows Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Учет ТМЦ Учетная политика Ценообразование, анализ цен Бесплатно (free) Пользователю системы Управленческий учет (прочее)

Существует множество различных методологий планирования производства с точки зрения расчета потребностей в выпуске изделий и их компонент. В данной статье, которая является первой в серии материалов, посвященных модулю производственного планирования в новом решении "1С:ERP Управление предприятием 2.0", кратко рассматриваются наиболее употребительные концепции, поскольку это способствует лучшему пониманию предметной области.

11.07.2014    20957    itrp2013    1       

Будни автоматизации или "мне нужна программка для 3D упаковки" 179

Статья Программист Нет файла v8 1cv8.cf УУ Оптовая торговля Бесплатно (free) Практика программирования Математика и алгоритмы

Автоматизация отечественных предприятий, которой приходиться заниматься, это нужная и высокооплачиваемая, но довольно нервная работа. Выручает юмор. Например, при общении с требовательным клиентом можно вспомнить анекдот: "Держась руками за стену, на ногах еле стоит мужик. К нему пристает ребенок: "Ну, папа, пожалуйста, сделай мне кораблик!", папа отвечает: "Ага! - Сейчас все брошу и пойду делать тебе кораблик!". Про один такой сделанный для клиента "кораблик" и хочется рассказать. Надеюсь, совместное погружение в теплое ламповое (то есть клиентоориентированное) программирование доставит Вам положительные эмоции, да и задача попалась интересная. Поплыли?

24.03.2014    41734    ildarovich    114