Карточка-справка 0504417 с выводом плановых начислений

12.12.19

Учетные задачи - Печатные формы

В штатную Карточка справка 0504417 в 1С: Зарплате государственного учреждения добавлен вывод всех плановых начислений, за основу взята обработка https://infostart.ru/public/1025470/ и добавлен вывод плановых начислений.

Скачать исходный код

Наименование Файл Версия Размер
Карточка-справка 0504417 с выводом плановых начислений:
.erf 46,22Kb
28
.erf 1.0 46,22Kb 28 Скачать

В штатную Карточка справка 0504417 в 1с Зарплате государственного учреждения добавлен вывод всех плановых начислений, даже тех, которые введены не через документ Кадровое перемещение, а сделаны с помощью Изменение оплаты труда или Назначение/изменение плановых начислений.

P.S. за основу взята обработка //infostart.ru/public/1025470/ и добавлен вывод плановых начислений

Протестирована на ЗГУ 3.1.12.56.

См. также

Раздельный учет по ГОЗ (Гособоронзаказу) в 1С: Бухгалтерия 3.0

Бюджетный учет Обмен с ГосИС Бухгалтер Пользователь Бухгалтерский учет 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 1С:Управление холдингом Государственные, бюджетные структуры Россия Бухгалтерский учет Бюджетный учет Платные (руб)

Управляйте учетной политикой раздельного учета ГОЗ в 1С:Бухгалтерия 3.0 ПРОФ/КОРП и УХ 3.2. Отчеты по исполнению госконтрактов, расчетно-калькуляционные материалы и контроль операций для исполнения в срок. Готовое расширение подходит для всех бухгалтеров и руководителей производства, помогая вести правильный учет по гособоронзаказу в соответствии 275-ФЗ. Профессиональный консалтинг и регулярные обновления продукта.

28.08.2020    207701    1690    vvmanannikov    132    

851

Обновление для КА 1.1, ЗУП 2.5, БУХ 2.0: НДС, ЕФС-1, Расчет страховых взносов, Мобилизация, Статистика, Электронные трудовые книжки, 2-НДФЛ, Регламентированная отчетность, Кадровый учет, Прослеживаемость импортных товаров

Зарплата Регламентированный учет и отчетность Кадровый учет Обновление 1С Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Зарплата и Управление Персоналом 2.5 Бухгалтерский учет Налоговый учет Управленческий учет Акцизы ЕНВД ЕСН Земельный налог ИП, ПБОЮЛ, КФХ Налог на имущество Налог на прибыль НДС НДФЛ ФОМС, ЕФС Транспортный налог УСН ПСН (патентная система налогообложения) Платные (руб)

Обновления для конфигураций: КА 1.1; ЗУП 2.5; БУХ 2.0; КА 1.1 Комплексная автоматизация торговли алкогольной продукцией; КА 1.1 Комплексный учет сельскохозяйственного предприятия

19900 руб.

01.04.2020    141940    668    352    

233

Гособоронзаказ: учет и отчетность 1С БП3.0 КОРП + ПРОФ + БИТ.ФИНАНС

Бюджетный учет Обмен с ГосИС Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Государственные, бюджетные структуры Россия Бухгалтерский учет Платные (руб)

Доработка конфигурации 1С: Бухгалтерия предприятия, редакция 3.0. Предназначена для ведения раздельного учета и автоматизации заполнения отчетности исполнения контрактов ГОЗ в конфигурациях 1С БП КОРП, ПРОФ, БИТ.ФИНАНС.

30000 руб.

16.08.2019    88937    209    85    

129

Infostart PrintWizard - создание и редактирование печатных форм в 1С 8.3

Пакетная печать Печатные формы Инструментарий разработчика Программист Платформа 1С v8.3 Запросы 1С:Зарплата и кадры бюджетного учреждения 1С:Конвертация данных 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Платные (руб)

Инструмент, позволяющий абсолютно по-новому взглянуть на процесс разработки печатных форм. Благодаря конструктору можно значительно снизить затраты времени на разработку печатных форм, повысить качество и "прозрачность" разработки, а также навести порядок в многообразии корпоративных печатных форм.

18000 руб.

06.10.2023    9319    27    6    

49

Модуль Фонды: Простое управление финансами для УНФ, УТ 10/11, КА, УПП / ERP, КА, БП

Учет доходов и расходов БДР, БДДС Бюджетный учет Бизнес-аналитик Пользователь Руководитель проекта 8.3.14 Конфигурации 1cv8 1С:Управление торговлей 11 Беларусь Россия Казахстан Бюджетный учет Управленческий учет Платные (руб)

Как держать деньги под контролем с помощью 1С УНФ, УТ, КА, ERP или БП и 2 часов в неделю без внедрения бюджетирования и найма финансиста. Дополнение для 1С 8.3 Модуль реализован в виде конфигурации и рассчитан для собственников компаний с чистой прибылью до 10 млн руб. / мес. То есть, пока вам не рентабельно вести сложные модули типа «Бюджетирование», «Казначейство», но нужно знать, сколько платить на этой неделе и хватит ли средств, чтобы отложить в дивиденды, обучение сотрудников, закупку и ремонт оборудования

45000 руб.

20.07.2023    3932    5    0    

35

Перенос данных из Парус 8 в ЗГУ 3

Зарплата Внешние источники данных Бюджетный учет Системный администратор Программист Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 Государственные, бюджетные структуры Россия Бухгалтерский учет Бюджетный учет Платные (руб)

Обработка позволяет перенести кадровую информацию и данные по заработной плате, фактических удержаниях, НДФЛ, вычетах, страховых взносах из базы Парус 8 учреждений в конфигурацию 1С:Зарплата и кадры государственного учреждения ред. 3 (ЗГУ) и начать с ней работать с любого месяца года.

84000 руб.

19.08.2020    22892    19    1    

22

Перенос данных из Камин 3.5 (5.5) в ЗиКГУ 3.х

Перенос данных 1C Зарплата Бюджетный учет Программист Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 1С:Зарплата и Управление Персоналом 3.x Государственные, бюджетные структуры Россия Бюджетный учет Платные (руб)

Обработки для быстрого перехода с конфигураций «КАМИН:Расчет зарплаты для бюджетных учреждений 3.5» и «КАМИН:Зарплата для бюджетных учреждений 5.5» на конфигурацию «Зарплата и кадры государственного учреждения».

12000 руб.

28.07.2016    57681    146    141    

122
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. xslava2008 75 15.12.19 21:03 Сейчас в теме
Первая колонка "Оклад", начисление "Оплата по окладу" добавляется в другую ячейку. Нельзя их свести в одну?
2. belyavsky 11 16.12.19 03:59 Сейчас в теме
(1)на демо базе на ком можно воспроизвести?
3. xslava2008 75 16.12.19 07:40 Сейчас в теме
(2) Я этот вопрос уже решил. Теперь у меня возник другой. Бывает выводятся записи относящиеся к разным документам влияющих на плановые начисления но выводятся одни и те же данные. Хорошо бы отсечь такие строки.
5. пользователь 30.12.19 11:10
Сообщение было скрыто модератором.
...
4. xslava2008 75 16.12.19 07:45 Сейчас в теме
Просто у Вас первая колонка всегда "Оклад" и к ней плюсуется колонка относящаяся к окладу вместе со всеми плановыми начислениями, я у себя поправил по условию.
1)
//Слава
				Если ТипЗнч(ВидОсновногоНачисления)=Тип("ПланВидовРасчетаСсылка.Начисления") Тогда
					Если ВидОсновногоНачисления.Наименование="Оплата по окладу" Тогда
						ОбластьШапкаКарточки.Параметры["ВидРасчета" + НомерВидаНачисления] = "";
					КонецЕсли;
				КонецЕсли;	

2)
//Слава
				Если ТипЗнч(СтрокаНачисления.Начисление)=Тип("ПланВидовРасчетаСсылка.Начисления") Тогда
					Если СтрокаНачисления.Начисление.Наименование="Оплата по окладу" Тогда
						ОбластьСтрокаКадровыхДокументов.Параметры["РазмерВР1"] = Формат(СтрокаНачисления.Размер,"ЧДЦ=2"); ///так сумма                    						
					Иначе	
						ОбластьСтрокаКадровыхДокументов.Параметры["РазмерВР" + НомерНачисления] = Формат(СтрокаНачисления.Размер,"ЧДЦ=2"); ///так сумма                    						
					КонецЕсли;	
				Иначе
					ОбластьСтрокаКадровыхДокументов.Параметры["РазмерВР" + НомерНачисления] = Формат(СтрокаНачисления.Размер,"ЧДЦ=2"); ///так сумма                    						
				КонецЕсли;	
Показать

3)
//Слава
				Если ТипЗнч(ЭлементМассива)=Тип("ПланВидовРасчетаСсылка.Начисления") Тогда
					Если ЭлементМассива.Наименование="Оплата по окладу" Тогда
						НоваяСтрока.Код = 999;
					КонецЕсли;
				КонецЕсли;

Я понимаю что можно было бы изящнее, но мне надо было скорее. потом оптимизирую
6. dean2557 08.01.20 16:25 Сейчас в теме
Добрый день можете пожалуйста скинуть справку вашу на почту dean255@mail.ru. Тоже формируется неверно стандартная справка.Спасибо за ранее.
Оставьте свое сообщение