Проверка Приложения 1, отчета 6-НДФЛ, с 2021 года

13.12.21

Учетные задачи - Зарплата

Дополнительный отчет для проверки Приложения 1, отчета 6-НДФЛ, с 2021 года.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Проверка Приложения 1, отчета 6-НДФЛ, с 2021 года
.erf 18,23Kb
60
60
1 SM
Скачать Купить за 1 850 руб.

Проверка Приложения 1, отчета 6-НДФЛ, с 2021 года

Для проверки отчет должен быть создан и сохранен в программе.

Выполняются следующие проверки:

  • У сотрудника справка с нулевой ставкой. Данные строки скорее всего ошибочны и по ним нужно анализировать информацию детально или удалять вручную. Так же в одном из релизов ЗУП 3 это была ошибка отчета 6-НДФЛ.
  • В одном из месяцев сумма вычета больше суммы дохода (Сумма вычета 1). Редкая ошибка, может возникать когда вычет предоставили, а сумму заработка уменьшили. Проверяются стандартные вычеты на детей.
  • Суммы исчислено, удержано и перечислено не равны. Например, сумма еще не удержана, не сделана выплата.
  • Облагаемая сумма умноженная на ставку не равна сумме исчисленного НДФЛ. Облагаемая сумма умножается на ставку, таким образом получается расчетная сумма НДФЛ, которая сравнивается с суммой исчисленного НДФЛ указанного в справке. Ошибка выводится если разница больше 1 рубля.
  • Облагаемая сумма дохода в справке не равна сложенной сумме дохода помесячно. Проверяется сложенная сумма облагаемого дохода помесячно и итоговая сумма облагаемого дохода.

В отчет выводятся поля:

  • Номер справки
  • ФИО сотрудника
  • Ставка числом (13, 30 ...)
  • Сумма дохода - сумма дохода помесячно
  • Сумма вычета1 (помесячно) - сумма стандартных вычетов на детей или личный, который предоставляется помесячно
  • Сумма вычета 2 (прочие) - сумма вычета, например с материальной помощи, имущественные ...
  • Общая сумма дохода - итоговая сумма дохода указанная в справке
  • Облагаемая сумма дохода
  • Исчислено
  • Удержано
  • Перечислено

 

Порядок подключения:

Администрирование - Печатные формы, отчеты и обработки - Дополнительные внешние отчеты и обработки. Создать новый элемент и выбрать заранее сохраненный файл отчета из публикации.

Указать в каких разделах будет доступен отчет, а также пользователей, которые его смогут вызывать из данных разделов.

Протестировано на версии ЗУП 3.1.18.151 и ЗГУ 3.1.18.151.

6НДФЛ проверка контроль НДФЛ ЗУП ЗГУ

См. также

Зарплата Регламентированный учет и отчетность Кадровый учет Обновление 1С Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Зарплата и Управление Персоналом 2.5 Бухгалтерский учет Налоговый учет Управленческий учет Акцизы ЕНВД ЕСН Земельный налог ИП, ПБОЮЛ, КФХ Налог на имущество Налог на прибыль НДС НДФЛ ФОМС, ЕФС Транспортный налог УСН ПСН (патентная система налогообложения) Платные (руб)

Обновления для конфигураций: КА 1.1; ЗУП 2.5; БУХ 2.0; КА 1.1 Комплексная автоматизация торговли алкогольной продукцией; КА 1.1 Комплексный учет сельскохозяйственного предприятия

19900 руб.

01.04.2020    143401    673    352    

234

Анализ учета Закрытие периода Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Налоговый учет Налог на прибыль НДС Платные (руб)

Каждый бухгалтер не раз сталкивался с требованием от налоговой инспекции пояснить расхождения в показателях декларации по Налогу на прибыль («Доходы от реализации» + «Внереализационные доходы») и налоговой базой по НДС за год. Являются ли ошибкой подобные расхождения? Как пояснить налоговой их причину? Отчет «Анализ расхождений выручки НДС и Налога на прибыль в декларациях» для 1С (БП 3.0 ПРОФ и КОРП, КА 2, ЕRP) поможет найти все расхождения.

7200 руб.

21.10.2017    85658    282    171    

272

Зарплата Роли и права Системный администратор Бухгалтер Платформа 1С v8.3 Бухгалтерский учет Управление правами 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Молдова Россия Казахстан Бухгалтерский учет Платные (руб)

Расширение позволяет максимально полно ограничить доступ пользователей к данным по заработной плате, а именно закрывает доступ к документам начисления и выплаты заработной платы, не позволяет просматривать бухгалтерские отчеты по счету учета зарплаты а также убирает зарплатные проводки из журнала проводок. Расширение запрещает просматривать платежные документы на выплату зарплаты, так же не доступны регламентные отчеты в ПФР и ИФНС. Расширение предлагает готовые настроенные профили "Бухгалтер без зарплаты", "Только просмотр без зарплаты".

5700 руб.

27.05.2021    34550    227    89    

182

Регламентированный учет и отчетность Анализ учета Бюджетный учет Бизнес-аналитик Бухгалтер Пользователь Руководитель проекта Платформа 1С v8.3 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Налоговый учет Управленческий учет Платные (руб)

Расширение «Отчет ГОЗ» для 1С:Бухгалтерия 3.0 ПРОФ и КОРП позволяет автоматизировать ведение раздельного учета и подготовку отчетности для Торговых и Производственных организаций, участвующих в ГосОборонЗаказе. Эффективный инструмент ведения раздельного учета по гособоронзаказам для Торговых и Производственных компаний

94700 руб.

20.02.2024    1023    1    0    

5

Зарплата Программист Бизнес-аналитик Бухгалтер Платформа 1С v8.3 1С:Зарплата и кадры государственного учреждения 3 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Платные (руб)

При заполнении ведомости на выплату зарплаты вылазят задолженности прошлых периодов, которых быть не должно? Наша обработка позволяется убрать эти доходы прошлых периодов за пару секунд. Больше не нужно тратить часы на анализ каждого такого случая.

27600 руб.

14.09.2022    14076    69    26    

71

Перенос данных 1C Зарплата Бюджетный учет Программист Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 1С:Зарплата и Управление Персоналом 3.x Государственные, бюджетные структуры Россия Бюджетный учет Платные (руб)

Обработки для быстрого перехода с конфигураций «КАМИН:Расчет зарплаты для бюджетных учреждений 3.5» и «КАМИН:Зарплата для бюджетных учреждений 5.5» на конфигурацию «Зарплата и кадры государственного учреждения».

12000 руб.

28.07.2016    58070    149    141    

126

Зарплата Анализ продаж Бухгалтер Пользователь Оперативный учет 8.3.14 1С:Управление торговлей 11 Управленческий учет Платные (руб)

Мотивация сотрудников в 1С. Автоматизированный расчет управленческой заработной платы для любых должностей коммерческой организации. Для 1С: Управление торговлей 11.4.

12000 руб.

26.05.2021    13487    22    3    

19
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Kapitan911 305 20.12.21 10:20 Сейчас в теме
Хотел сделать доработку(в связи с ошибкой https://bugboard.v8.1c.ru/error/000117712) - приравнять суммы удержанного и перечисленного налога к исчисленному, добавил кнопку, процедуру, но почему то суммы остаются без изменений:
&НаСервере
Процедура ПриравнятьКакИсчисленныйНаСервере()
	
	Отчет6НДФЛ = Объект.РегОтчет.ПолучитьОбъект();
	ДанныеОтчета = Отчет6НДФЛ.ДанныеОтчета.Получить();
	ЕстьИзменения = Ложь;
	Для каждого стр из ДанныеОтчета.ДанныеМногоуровневыхРазделов.Приложение1.Строки Цикл  		
		Для каждого стр2 из стр.ДанныеМногострочныхЧастей.П000П1М1.Строки Цикл  
			
			Сотрудник = стр.Данные.П000П10000004 + " " + стр.Данные.П000П10000005 + " " + стр.Данные.П000П10000006; 
			ОбщаяСуммаДохода = стр2.Данные.П000П1М100002;
			ОблагаемаяСуммаДохода = стр2.Данные.П000П1М100003;
			Исчислено = стр2.Данные.П000П1М100004;
			Удержано = стр2.Данные.П000П1М100005; 
			Перечислено = стр2.Данные.П000П1М100007;

			Если Удержано <> Исчислено Тогда
				стр2.Данные.П000П1М100005 = Исчислено;
				ЕстьИзменения = Истина;
			КонецЕсли;
			
			Если Перечислено <> Исчислено Тогда
				стр2.Данные.П000П1М100007 = Исчислено;
				ЕстьИзменения = Истина;
			КонецЕсли;
			
		КонецЦикла;    	
	КонецЦикла;
	
	Если ЕстьИзменения = Истина Тогда
		Отчет6НДФЛ.Записать();
	КонецЕсли;
	
КонецПроцедуры
Показать
2. scanner1980 268 20.12.21 11:00 Сейчас в теме
возможно данные отчета поместить снова в хранилище?
Если ЕстьИзменения = Истина Тогда
        Отчет6НДФЛ.ДанныеОтчета = Новый ХранилищеЗначения(ДанныеОтчета);
        Отчет6НДФЛ.Записать();
КонецЕсли;
3. Kapitan911 305 20.12.21 12:29 Сейчас в теме
(2) Да, спасибо. Так получилось
4. Kapitan911 305 20.12.21 12:36 Сейчас в теме
По хорошему - прилепить бы кнопочку, которая бы закрывала РН РасчетыНалогоплательщиковСБюджетомПоНДФЛ (для удержанного НДФЛ) и соответственно делала недостающий приход/расход по РН РасчетыНалоговыхАгентовСБюджетомПоНДФЛ в рамках отчетного периода документом ПереносДанных.
На инфостарте есть подобные обработки типа "Закрытие долгов", РН РасчетыНалогоплательщиковСБюджетомПоНДФЛ он закрывают, но на перечисленный НДФЛ это не влияет, так как РН РасчетыНалоговыхАгентовСБюджетомПоНДФЛ надо не просто закрывать, а добавлять движения приход/расход
5. scanner1980 268 20.12.21 14:26 Сейчас в теме
(4) ЗУП (ЗГУ) 3 позволяет корректно вести учет исчисленного, удержанного и перечисленного НДФЛ. Корректировки конечно могут быть, но только в части некорректного ведения учета или ошибок в релизах и обычно делаются вручную. Как вариант давно нерешенный вопрос по распределению НДФЛ в ЗГУ по статьям в документе перерасчет НДФЛ.
6. rinik88 32 11.01.22 15:09 Сейчас в теме
полезная штука. +
scanner1980; +1 Ответить
7. neptunka 40 27.01.22 16:13 Сейчас в теме
очень помог+ Кнопку исправление добавила, ПриравнятьКакИсчисленныйНаСервере, тоже очень помогла. Спасибо огромное!
scanner1980; +1 Ответить
Оставьте свое сообщение