Проверка всех реквизитов работников для годовых отчетов (СЗВ-6, 2-НДФЛ) в ЗУП 2.5

02.03.16

Учетные задачи - Зарплата

Отчет объединяет в себе проверки всех реквизитов (ИНН, номер ПФР, соответствие адреса загруженному в 1С КЛАДР), которые производятся при проведении документов СЗВ-6 и 2-НДФЛ. ВСЕ проверки "выдернуты" из кода 1С и собраны в одном месте.

Скачать исходный код

Наименование Файл Версия Размер
ПроверкаРеквизитовРаботниковДляОтчетов.epf
.erf 19,72Kb
483
.erf 02.03.2016 19,72Kb 483 Скачать

 Отчет объединяет в себе проверки всех реквизитов (ИНН, номер ПФР, соответствие адреса загруженному в 1С КЛАДР), которые производятся при проведении документов СЗВ-6 и 2-НДФЛ. ВСЕ проверки "выдернуты" из кода 1С и собраны в одном месте.
 Может быть использован работниками отдела кадров для предварительной проверки правильности внесенных реквизитов, чтобы потом при формировании отчетов расчетным отделом выводилось меньше сообщений об ошибках по сотрудникам. Актуально для больших фирм, где корректировкой реквизитов работника занимается отдел кадров, а подготовкой инд.сведений в ПФР и налоговой - расчетный.
 Данные проверяются по сотрудникам, имеющим доход в указанном периоде (с возможностью отбора по организации).
 Есть возможность проверить сразу всех физ.лиц в базе данных, для этого надо указать "Проверять всех, независимо от дохода". Такой вариант больше подходит для внедрения ЗУП: для проверки данных после переноса из другой программы.
 По результатам отчета формируется таблица с подробным описанием найденных ошибок.

 История изменений: 

 Версия от 07.07.2010: добавлена возможность выбора реквизитов для проверки.

 Версия от 12.07.2010: добавлена возможность проверки всех физ.лиц в базе данных.

 Версия от 01.03.2011: отчет адаптирован для использования в версии ЗУП начиная с 2.5.31.4.

См. также

Обновление для КА 1.1, ЗУП 2.5, БУХ 2.0: НДС, ЕФС-1, Расчет страховых взносов, Мобилизация, Статистика, Электронные трудовые книжки, 2-НДФЛ, Регламентированная отчетность, Кадровый учет, Прослеживаемость импортных товаров

Зарплата Регламентированный учет и отчетность Кадровый учет Обновление 1С Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Зарплата и Управление Персоналом 2.5 Бухгалтерский учет Налоговый учет Управленческий учет Акцизы ЕНВД ЕСН Земельный налог ИП, ПБОЮЛ, КФХ Налог на имущество Налог на прибыль НДС НДФЛ ФОМС, ЕФС Транспортный налог УСН ПСН (патентная система налогообложения) Платные (руб)

Обновления для конфигураций: КА 1.1; ЗУП 2.5; БУХ 2.0; КА 1.1 Комплексная автоматизация торговли алкогольной продукцией; КА 1.1 Комплексный учет сельскохозяйственного предприятия

19900 руб.

01.04.2020    141940    668    352    

233

Анализ расхождений выручки НДС и Налога на прибыль в декларациях (БП 3.0 ПРОФ и КОРП, КА 2, ЕRP)

Анализ учета Закрытие периода Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Налоговый учет Налог на прибыль НДС Платные (руб)

Каждый бухгалтер не раз сталкивался с требованием от налоговой инспекции пояснить расхождения в показателях декларации по Налогу на прибыль («Доходы от реализации» + «Внереализационные доходы») и налоговой базой по НДС за год. Являются ли ошибкой подобные расхождения? Как пояснить налоговой их причину? Отчет «Анализ расхождений выручки НДС и Налога на прибыль в декларациях» поможет найти все расхождения.

7200 руб.

21.10.2017    84725    266    171    

262

Перенос данных из Парус 8 в ЗГУ 3

Зарплата Внешние источники данных Бюджетный учет Системный администратор Программист Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 Государственные, бюджетные структуры Россия Бухгалтерский учет Бюджетный учет Платные (руб)

Обработка позволяет перенести кадровую информацию и данные по заработной плате, фактических удержаниях, НДФЛ, вычетах, страховых взносах из базы Парус 8 учреждений в конфигурацию 1С:Зарплата и кадры государственного учреждения ред. 3 (ЗГУ) и начать с ней работать с любого месяца года.

84000 руб.

19.08.2020    22891    19    1    

22

Перенос данных из Камин 3.5 (5.5) в ЗиКГУ 3.х

Перенос данных 1C Зарплата Бюджетный учет Программист Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 1С:Зарплата и Управление Персоналом 3.x Государственные, бюджетные структуры Россия Бюджетный учет Платные (руб)

Обработки для быстрого перехода с конфигураций «КАМИН:Расчет зарплаты для бюджетных учреждений 3.5» и «КАМИН:Зарплата для бюджетных учреждений 5.5» на конфигурацию «Зарплата и кадры государственного учреждения».

12000 руб.

28.07.2016    57679    146    141    

122

Устранение начислений прошлых периодов из ведомостей: в банк, в кассу, на счета в ЗУП 3.1, КА, ЗиКГУ 3.1

Зарплата Программист Бизнес-аналитик Бухгалтер Платформа 1С v8.3 1С:Зарплата и кадры государственного учреждения 3 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Платные (руб)

При заполнении ведомости на выплату зарплаты вылазят задолженности прошлых периодов, которых быть не должно? Наша обработка позволяется убрать эти доходы прошлых периодов за пару секунд. Больше не нужно тратить часы на анализ каждого такого случая.

15600 руб.

14.09.2022    13422    64    26    

66

Перенос данных из Парус 7.хх в ЗГУ ред.3

Внешние источники данных Зарплата Бюджетный учет Программист Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры государственного учреждения 3 Государственные, бюджетные структуры Россия Бухгалтерский учет Бюджетный учет Платные (руб)

Обработка позволяет перенести кадровую информацию и данные по заработной плате, фактических удержаниях, НДФЛ, вычетах, страховых взносах из базы Парус 7.хх учреждений в конфигурацию 1С:Зарплата и кадры государственного учреждения ред. 3 (ЗГУ) и начать с ней работать с любого месяца года.

24000 руб.

24.04.2017    49084    97    163    

87

Исправление в 1С:ЗУП/ЗКГУ ошибок по НДФЛ и взаиморасчетам с сотрудниками на начало расчетного года.

Корректировка данных Зарплата Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет НДФЛ Платные (руб)

Обработка исправляет технические ошибки по НДФЛ, взаиморасчетам с сотрудниками в 1С:ЗУП (1С:ЗКГУ) на начало года. Фактически все ошибки, которые проявляются в ведомостях на выплату, расчетных листках, при заполнении ведомостей на выплату и отчетах 6-НДФЛ и т.д. нужно начинать исправлять с начала расчетного года. Это позволит быть уверенными, что после завершения расчетов предыдущего года, начали работать с «чистого листа» без ошибочных остатков.

4800 руб.

06.10.2023    2982    31    15    

39
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. cleaner_it 221 02.07.10 04:35 Сейчас в теме
Хороший отчет
krepsamorezik; +1 Ответить
2. MikleVV 25.02.11 21:42 Сейчас в теме
в ЗУП 2.5.31.4 8.2 ругаетсая:

----------------------------------------------------------------------------------
{Форма.Форма.Форма(377)}: Ошибка при вызове метода контекста (Выполнить)
ВыборкаФизЛиц = Запрос.Выполнить().Выбрать();
по причине:

по причине:
{(17, 30)}: Поле не найдено "Гражданство.НеЯвляетсяНалоговымРезидентомРФ"
КОГДА ЕСТЬNULL(Гражданство.<<?>>НеЯвляетсяНалоговымРезидентомРФ, ЛОЖЬ)
------------------------------------------------------------------------

Не планируете выход обработки под новые релизы?
3. Borisych 503 26.02.11 00:59 Сейчас в теме
Форма кривовата, кнопка справки без справки, но в общем полезная вещь
to (2) не адаптировал, просто исправил имя реквизита, помеченного на удаление фирмой 1С :
Прикрепленные файлы:
ПроверкаРеквизитовРаботниковПередПодготовкойРегламентированныхОтчетов.epf
6. chirs 06.04.11 08:54 Сейчас в теме
Borisych пишет:

Форма кривовата, кнопка справки без справки, но в общем полезная вещь

to (2) не адаптировал, просто исправил имя реквизита, помеченного на удаление фирмой 1С :

Какая нафиг справка ? какая нафиг красота ?
Отчет работает ! выводит результат - это самое главное !
Спасибо надо сказать, что человек потратил время на отчет, а потом еще и поделился им со всеми другими.
4. MikleVV 26.02.11 12:03 Сейчас в теме
5. BoneD 615 01.03.11 15:13 Сейчас в теме
Borisych пишет:
Форма кривовата, кнопка справки без справки

Не надоело еще Borisych ругать и минусовать за мои обработки? И сахар не сладкий и уксус не кислый... Я ведь не пишу, что Ваша 2-НДФЛ с рестром образца 2009 г. это изобретение велосипеда, т.к. 1С форму тоже сделала и выложила на сайте техподдержки.
7. Ted1982 68 16.09.11 15:09 Сейчас в теме
Интересная обработка. В поддерживаемых организациях приходится использовать дополнительные проверки, но данная обработка помогла (сэкономила время - просто добавил свои проверки)
8. lika11 26.12.11 12:30 Сейчас в теме
Нужная вещь-показывает все недочеты при оформлении сотрудников.Мне очень помогла.
9. rasswet 82 05.04.12 12:15 Сейчас в теме
Спасибо, на 2.5.48.1 работает. Правда с трудом нашел поиском.
10. taramaz 63 11.04.12 18:39 Сейчас в теме
2.5.48.1 да. Большое спасибо.
11. Amras 43 12.07.12 08:31 Сейчас в теме
Спасибо за обработку. Еще можно проверять код подразделения в паспорте РФ, примерно такую функцию добавить надо (почему ее в типовой конфе не придумали?):

Функция ПроверитьКодПодразделенияУдостоверенияЛичности(ДокументКодИМНС, Знач КодПодразделения , СтрОшибка) Экспорт
	
	// проверка
	Если ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС01
		ИЛИ ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС03 Тогда
		ТипДока = 1;
	ИначеЕсли ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС04
		ИЛИ ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС06
		ИЛИ ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС07
		ИЛИ ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС26
		ИЛИ ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС27 Тогда
		ТипДока = 2;
	ИначеЕсли ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС02
		ИЛИ ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС09
		ИЛИ ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС22 Тогда
		ТипДока = 3;
	ИначеЕсли ДокументКодИМНС = Справочники.ДокументыУдостоверяющиеЛичность.ИМНС21 Тогда
		ТипДока = 4;
	Иначе
		ТипДока = 5;
	КонецЕсли;
	
	СтрОшибка = "";
	
	КодПодразделения = СокрЛП(КодПодразделения);
	
	Если ТипДока = 4 Тогда // КодПодразделения - две группы цифр разделенные <->: новый паспорт
		
		Поз = Найти(КодПодразделения,"-");
		Если Поз=0 Тогда
			СтрОшибка = "В коде подразделения документа должно быть две группы цифр, разделенных <->!";
			Возврат Ложь;
		КонецЕсли;
		
		ПервЧасть = Лев(КодПодразделения,Поз-1);
		ВторЧасть = СокрЛП(Сред(КодПодразделения,Поз+1));
		
		Поз = Найти(ВторЧасть," ");
		Если Поз <> 0 Тогда
			СтрОшибка = "В коде подразделения документа должно быть только две группы цифр!";
			Возврат Ложь;
		КонецЕсли;
		
		Если (СтрДлина(ПервЧасть) <> 3) ИЛИ
			(ПустаяСтрока(РегламентированнаяОтчетность.ЗаменитьОдниСимволыДругими("0123456789",ПервЧасть,"          "))=0) Тогда
			СтрОшибка = "Первая группа символов кода подразделения документа должна содержать три цифры!";
			Возврат Ложь;
		КонецЕсли;
		
		Если (СтрДлина(ВторЧасть) <> 3) ИЛИ
			(ПустаяСтрока(РегламентированнаяОтчетность.ЗаменитьОдниСимволыДругими("0123456789",ВторЧасть,"          "))=0) Тогда
			СтрОшибка = "Вторая группа символов кода подразделения документа должна содержать три цифры!";
			Возврат Ложь;
		КонецЕсли;
	Иначе
		// Пока нет проверки других типов документов
	КонецЕсли;
	
	Возврат Истина;
КонецФункции
Показать


Покопаюсь еще в обработке, может какие идеи позаимствую для проверки данных.
12. Amras 43 12.07.12 09:45 Сейчас в теме
Хочу спросить разрешения автора, немного дополнил обработку, можно ли выложить почти все тоже самое, но малость с расширенной проверкой (?):
- Просроченный паспорт;
- Отбор по подразделениям;
- Проверка на код подразделения удостоверения личности.
13. BoneD 615 12.07.12 18:06 Сейчас в теме
(12) Ради бога, но она не особо "урожайная" на плюсы. Я её давно не расширяю, только скрытие настроек добавил недавно.
14. Amras 43 13.07.12 07:41 Сейчас в теме
(13) Не ради плюсов оно. Просто столкнулся с задачей формирования реестра для открытия счетов в банке, а там как раз нужно много проверок разных, и дабы сократить время, изменил этот отчет и отдал его в кадры, пусть проверяют. Им понравилось.
Оставьте свое сообщение