Доработка конфигурации Конвертация Данных (вер. 2.1.8.2)

25.02.24

Разработка - Инструментарий разработчика

Добавил в конфигурацию Конвертация Данных (вер. 2.1.8.2): 1) появляющиеся подсказки по обработчикам 2) аналог "Найти в списке" 3) историю переходов по объектам ПКО

Скачать исходный код

Наименование Файл Версия Размер
Информация об обработчиках_2.epf
.epf 220,39Kb
103
.epf 220,39Kb 103 Скачать
cf-шник для адаптации
.cf 8,00Mb
90
.cf 8,00Mb 90 Скачать

Собственную адаптацию конфигурации Конвертация Данных я проводил на уже доработанной конфигурации, взятой из статьи Totoro //infostart.ru/public/72813/. Поэтому мой cf-шник содержит разработки Tormozit и Totoro

Теперь отдельно о небольших моих доработках.

1) Добавил в конфигурацию измененную обработку "Информация об обработчиках_2", в которой изменил цветовое выделение слов в отличие от типовой. Изменил вызов обработки: теперь при открытии любого обработчика события появляется окно, информирующее о доступных параметрах обработчика.

Реализовано так: в процедурах "...АлгоритмыПриСменеСтраницы" прописал вызов обработки "Информация об обработчиках_2":

Процедура ПанельАлгоритмыПриСменеСтраницы(Элемент, ТекущаяСтраница)

   
ОбновитьПиктограммыАлгоритмов(мМассивОбработчиков, ЭлементыФормы.ПанельАлгоритмы, ЭлементыФормы);
   
//доработка+
   
ОткрытьОписаниеОбработчикаСобытия("ПравилаВыгрузкиДанных", ЭлементыФормы.ПанельАлгоритмы.ТекущаяСтраница.Имя, ЭтаФорма);

КонецПроцедуры
// ПанельАлгоритмыПриСменеСтраницы()

Процедура ОткрытьОписаниеОбработчикаСобытия имеет следующий код:

Процедура ОткрытьОписаниеОбработчикаСобытия(ИмяОбъекта, ИмяОбработчика, ФормаВладелец = Неопределено) Экспорт

   
ФормаПросмотра = Обработки.ИнформацияОбОбработчиках_2.ПолучитьФорму("Форма",ФормаВладелец);
   
//Если ФормаПросмотра.Открыта() Тогда
    //    ФормаПросмотра.Закрыть();
    //КонецЕсли;
   
ФормаПросмотра.РазделДляОткрытия = ИмяОбъекта + ИмяОбработчика;
   
ФормаПросмотра.Открыть();

КонецПроцедуры
// ОткрытьОписаниеОбработчиковСобытий()

2) Добавил в конфигурацию аналог "Найти объект в списке" - когда из любого окна обработчика события можно перейти в окно правил обмена,например, на соответствующий объект ПКО.

Реализовано по кнопке "Конвертация":

Процедура КоманднаяПанель1Действие4(Кнопка)

   
ОбщаяФорма = ПолучитьОбщуюФорму("ПравилаОбмена");
   
ОбщаяФорма.Конвертация = ЭтотОбъект.Владелец;
   
ОбщаяФорма.Открыть();

   
ОбщаяФорма.ЭлементыФормы.ПанельВерхняя.ТекущаяСтраница = ОбщаяФорма.ЭлементыФормы.ПанельВерхняя.Страницы.ПВД;
   
ОбщаяФорма.ЭлементыФормы.ПравилаВыгрузкиДанных.ТекущаяСтрока = Ссылка;

КонецПроцедуры

3) Добавил историю переходов по объектам ПКО - теперь не приходится искать объекты ПКО перелистыванием строк списка ПКО, достаточно выбрать объект ПКО в окне истории.

//ведение истории
Процедура ПравилаКонвертацииОбъектовПриАктивизацииСтроки(Элемент)

    Если
Элемент.ТекущиеДанные = Неопределено Тогда
        Возврат;
    КонецЕсли;

   
// доработка+ начало блока
   
Если НЕ Элемент.ТекущиеДанные.Ссылка.ЭтоГруппа И История.Найти(Элемент.ТекущиеДанные.Ссылка, "СсылкаПКО") = Неопределено Тогда
       
История.Добавить().СсылкаПКО = Элемент.ТекущиеДанные.Ссылка;
    КонецЕсли;

   
// доработка+ конец блока

   
...

КонецПроцедуры


//позиционирование на нужном ПКО
Процедура ИсторияПриАктивизацииСтроки(Элемент)
   
ЭлементыФормы.ПравилаКонвертацииОбъектов.ТекущаяСтрока = ЭлементыФормы.История.ТекущиеДанные.СсылкаПКО;
КонецПроцедуры

 
 См. также

1) [Расширение] УНФ. Список заказов + Структура подчиненности

2) [Расширение] УТ 11.4. Счет на оплату с факсимиле

3) [Расширение] БП 3.0. Список счетов/ Список реализаций + Связанные документы

Внешние обработки (не расширения!):

1) Список заказов поставщикам + структура подчиненности

2) Список заказов покупателей + структура подчиненности

3) Список реализаций со структурой подчиненности + реестр документов

4) Список заказов покупателей (Расширенная версия)

Другие публикации:

1) Удаление справочников для любых баз на управляемых формах

2) Удаление документов для любых баз на управляемых формах

3) Удаление чеков ККМ в Рознице 2.2

4) Загрузка товаров, штрихкодов, цен и остатков на УФ - Розница 2.2

5) Отчет Остатки и цены (прайс с остатками)

6) Как свернуть базу УТ 10.3

7) Как почистить характеристики в УТ 10.3

9) [Внешняя обработка] Ввод показателей план-факта БП 3.0

10) [Шаблоны] Договоры для 1с-ника

Из последнего опубликованного:

12) JSON -> Дерево значений

13) Анализ прав и ролей: поиск подходящего профиля

14) Оцифровка и визуализация склада

Всем добра!

Проверено на следующих конфигурациях и релизах:

  • 1С:Конвертация данных 2.0, релизы 2.1.8.2

КД 2 Конвертация данных

См. также

Infostart Toolkit: Инструменты разработчика 1С 8.3 на управляемых формах

Инструментарий разработчика Роли и права Запросы СКД Платформа 1С v8.3 Управляемые формы Запросы Система компоновки данных Конфигурации 1cv8 Платные (руб)

Набор инструментов программиста и специалиста 1С для всех конфигураций на управляемых формах. В состав входят инструменты: Консоль запросов, Консоль СКД, Консоль кода, Редактор объекта, Анализ прав доступа, Метаданные, Поиск ссылок, Сравнение объектов, Все функции, Подписки на события и др. Редактор запросов и кода с раскраской и контекстной подсказкой. Доработанный конструктор запросов тонкого клиента. Продукт хорошо оптимизирован и обладает самым широким функционалом среди всех инструментов, представленных на рынке.

10000 руб.

02.09.2020    129577    700    390    

749

Infostart PrintWizard - создание и редактирование печатных форм в 1С 8.3

Пакетная печать Печатные формы Инструментарий разработчика Платформа 1С v8.3 Запросы 1С:Зарплата и кадры бюджетного учреждения 1С:Конвертация данных 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Платные (руб)

Инструмент, позволяющий абсолютно по-новому взглянуть на процесс разработки печатных форм. Благодаря конструктору можно значительно снизить затраты времени на разработку печатных форм, повысить качество и "прозрачность" разработки, а также навести порядок в многообразии корпоративных печатных форм.

18000 руб.

06.10.2023    9032    25    6    

49

Infostart УДиФ: Управление данными и формами 1С

Инструменты администратора БД Инструментарий разработчика Роли и права Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Расширение позволяет без изменения кода конфигурации выполнять проверки при вводе данных, скрывать от пользователя недоступные ему данные, выполнять код в обработчиках. Не изменяет данные конфигурации, легко устанавливается практически на любую конфигурацию на управляемых формах.

10000 руб.

10.11.2023    5217    14    2    

39

PowerTools

Инструментарий разработчика Инструменты администратора БД Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Платные (руб)

Универсальный инструмент программиста для администрирования конфигураций. Сборник наиболее часто используемых обработок под единым интерфейсом.

3600 руб.

14.01.2013    179593    1091    0    

868

OneDebugger - инструмент для отладки кода без использования режима конфигуратора

Инструментарий разработчика Платформа 1С v8.3 Платные (руб)

Инструмент для написания и отладки кода в режиме «1С:Предприятие». Представляет собой консоль кода с возможностью пошаговой отладки, просмотра значений переменных любых типов, использования процедур и функций, просмотра стека вызовов, вычисления произвольных выражений на встроенном языке в контексте точки останова, синтаксического контроля и остановки по ошибке. В консоли используется удобный редактор кода с подсветкой, контекстной подсказкой, возможностью вызова конструкторов запроса и форматной строки.

5400 руб.

17.05.2024    3779    3    11    

27

Бустер Конвертации данных 3 (Infostart Toolkit)

Инструментарий разработчика 8.3.14 1С:Конвертация данных Россия Платные (руб)

Расширение для конфигурации “Конвертация данных 3”. Добавляет подсветку синтаксиса, детальную контекстную подсказку, глобальный поиск по коду.

15000 руб.

07.10.2021    15334    3    12    

38

Многопоточность. Универсальный «Менеджер потоков» 2.1

Инструментарий разработчика Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Восстановление партий или взаиморасчетов, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

5000 руб.

07.02.2018    100249    240    97    

299

1С HTML Шаблоны / HTML Templates

Инструментарий разработчика Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Быстрая и удобная обработка для работы с шаблонами HTML. Позволяет легко и быстро формировать код HTML.

2040 руб.

27.12.2017    28642    4    10    

17
Отзывы
0. RustIG 1631 24.12.11 21:35 Сейчас в теме
Добавил в конфигурацию Конвертация Данных (вер. 2.1.5.1):
1) появляющиеся подсказки по обработчикам
2) аналог "Найти в списке"
3) историю переходов по объектам ПКО


Перейти к публикации

21. RustIG 1631 27.11.18 15:31 Сейчас в теме
(20) сравнивать и обновлять надо только на версию 2.1.5.1.
Я кстати тестировал сравнить/объединить на версию 2.1.8.2 - у меня получилось.
22. RustIG 1631 27.11.18 15:39 Сейчас в теме
(20) на новую версию КД 3.0 обновлять нельзя!!!
Остальные комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
0. RustIG 1631 24.12.11 21:35 Сейчас в теме
Добавил в конфигурацию Конвертация Данных (вер. 2.1.5.1):
1) появляющиеся подсказки по обработчикам
2) аналог "Найти в списке"
3) историю переходов по объектам ПКО


Перейти к публикации

1. Поручик 4677 24.12.11 21:35 Сейчас в теме
(0) Вещь полезная. Для релиза КД 2.1.5.1 пойдёт?
2. RustIG 1631 24.12.11 21:38 Сейчас в теме
(1) у меня как раз релиз 2.1.5.1.
5. fomix 33 26.12.11 11:44 Сейчас в теме
(2) Что-то я не понял для чего эта штука в КД?! Может поподробнее опишете... Заранее спасибо!
6. RustIG 1631 26.12.11 13:14 Сейчас в теме
(5) Если вы работаете с КД вплотную, тогда вы сможете оценить полезность этих доработок: ускоряется навигация по объектам КД. А если соответственно не работаете вплотную, например, через раз или вообще чаще используете типовые сценарии обмена, тогда возможно не стоит тратить время на доработку КД.
10. KliMich 05.02.12 20:30 Сейчас в теме
(6)
Если вы работаете с КД вплотную, тогда вы сможете оценить полезность этих доработок: ускоряется навигация по объектам КД
Прямо в точку! Респект! Очень нужная доработка.

P.S. Как дополнение (может кому пригодиться), для КД типа 77 -> 82 использую
"Запись текста модуля ерт-файла из текстового файла" http://infostart.ru/public/78941/ от Абадонна (за что ему огромный респект)
3. ogeniv 25.12.11 11:07 Сейчас в теме
Интересная штука, подсказки и переход по объектам будут полезны
4. Kochevnic 25.12.11 18:54 Сейчас в теме
Спасибо! Попробуем на практике
7. Модератор раздела 23.01.12 17:45 Сейчас в теме
Хорошие доработки.
Пожалуйста, добавь в название и в описание инфу о конкретной версии КД, для которой подходит публикация.
2.1.5.1
8. Мощный 23.01.12 21:22 Сейчас в теме
Даж заманчиво, попробовать что ле ?
9. WendyH 28.01.12 08:30 Сейчас в теме
Тогда, желательно, в описании перечислить ВСЕ отличия от типовой. Измменения tormizit и Ваши.
11. Мощный 10.02.12 10:27 Сейчас в теме
Есть ли какая нибудь возможность настройки для выскакивающих при переходе на обработчики по свойствам описаний.. Наверное, иногла это и бывают удобным, но когда попрыгаешь по свойствам десятки, сотни раз, то тут вот количество клацеы увеличивается в два раза.. Зайти в свойства-выйти из описания.. Не предусмотрена ли у вас где-нибудь настройка для включения и отключения..
Конечно и сам могу отцепить, но м.быть есть настройка..
13. RustIG 1631 13.02.12 11:11 Сейчас в теме
(11), (12) добрый день, Мощный! видел все ваши сообщения, спасибо за обратную связь.
По поводу доработок, увы, на них нет времени. Все в ваших руках. Я даже в последнее время занимаюсь всеми задачами кроме связанных с КД. Поэтому специально переключаться на КД, доработку КД, новое выкладывание на ИС - нет планов. А вообще, разве нельзя через правую кнопку закрыть все соединяемые окна единоразово? Аналогичная ситуация с окнами возникает, когда вы открываете расшифровки в рег.отчетах в конфигурации по бухгалтерии. И в этих конфах нет настройки, которую вы просите. Так что, может "оно и не надо".
15. Мощный 13.02.12 19:30 Сейчас в теме
(13) Ок, траблы Ваши понятны, буду сам..
касаемо "нужно или не нужно" отвечу однозначно "нужно".. Переходы по свойствам даже за день в обьеме достигают нескольких сотен.. Можно конечно, сбрасывать через ESC, но предел терпения достигается слишком быстро.. увы..
12. Мощный 12.02.12 13:31 Сейчас в теме
И как же достучаться до автора
14. a4a 13.02.12 11:50 Сейчас в теме
Пытаюсь работать с конфигурацией "Конвертация данных", очень востребован ее функционал. Но не могу похвастать, что удается так сразу в ней разобраться как следует, а очень хочется. Поэтому очень приветствую разработку, усиливающую ее возможности. Спасибо!
16. AlexKoso 20 27.02.12 09:42 Сейчас в теме
Сначала накатил изменения, поюзал...и понял что ни к чему мне автоматически выскакивающее окно со справкой. В итоге в типовую обработку Информация об обработчика вставил макеты Рустема, а вызов справки сделал по Ctrl + F1. На том и спасибо :)
17. tehas 44 10.03.12 21:19 Сейчас в теме
Ща гляну, кстати ни кто не посоветует учебник с примерами по КД 2.1 желательно в электронном виде, а если у кого есть буду благодарен
19. AlexO 135 19.03.13 16:10 Сейчас в теме
(17) tehas,
кстати ни кто не посоветует учебник с примерами по КД 2.1

По КД нет учебников.
Есть куцая книжка Бояркина и немного инфы в инете.
Ну и да, различные веселые супер-пупер курсы.
24. StudentM 50 19.08.22 21:18 Сейчас в теме
(17) Добрый день, есть ещё электронная книга Ольги Кузнецовой на 73 стр. А4, по ней хорошо начинающим учиться. Яндекс в помощь: "Кузнецова Конвертация данных pdf".
18. tehas 44 08.08.12 11:16 Сейчас в теме
удобно, ни чего не скажешь )
20. dave2000 91 27.11.18 13:25 Сейчас в теме
Как её правильно обновлять? Просто сравнить/объединить на на свою КД?
21. RustIG 1631 27.11.18 15:31 Сейчас в теме
(20) сравнивать и обновлять надо только на версию 2.1.5.1.
Я кстати тестировал сравнить/объединить на версию 2.1.8.2 - у меня получилось.
22. RustIG 1631 27.11.18 15:39 Сейчас в теме
(20) на новую версию КД 3.0 обновлять нельзя!!!
23. alex_4x 86 09.06.20 09:59 Сейчас в теме
При юзании стандартной КД 2 у меня иногда возникает необходимость удалить реквизиты из объектов конфигурации. Сделать это можно без всяких доработок, но не очень удобно, особенно когда конфигураций похожих в одну базу загружено несколько.
Оставьте свое сообщение