Задачи по доработке типовых решений. ЗУП 3.1. Доработка выплаты аванса фиксированной суммой, проверка на отработанное время. Вывод предупреждения как в ЗУП 2.5

Публикация № 1165284

Учет и отчетность - Зарплата

ЗУП 3.1 Аванс фиксированной суммой доработка

Пример решения задачи, по учету отработанного времени за первую половину месяца, при выплате фиксированного аванса.

Разработано/протестировано на:

Версия конфигурации:  Зарплата и управление персоналом, редакция 3.1 (3.1.11.106)

Версия платформы: 1С: Предприятие 8.3 (8.3.12.1790)

Освещены вопросы:

  • Получения отработанного времени по сотруднику;
  • Работа с процедурой "ПоказатьВопрос" в обработчике "ПередЗаписью";
  • Работа с оповещениями пользователя при помощи БСП 3.0;

Описание задачи.

На предприятии ряду сотрудников аванс выплачивается фиксированной суммой, необходимо учитывать отработанное время за первую половину месяца и корректировать аванс согласно формуле:

([Сумма фиксированного аванса] / [Количество плановых дней по графику сотрудника]) * [Количество отработанных дней]

Если существуют отклонения по отработанному от планового времени, необходимо вывести предупреждение пользователю.

Командировка, как вид времени тоже включен в плановое отработанное время.

Теория.

В ЗУП 3.1 начисление аванса происходит тремя способами:

  • Расчетом за первую половину месяца;
  • Фиксированной суммой;
  • Процентом от тарифа;

При выплате фиксированной суммой – расчет производится без учета отработанного времени. Пользователю необходимо вручную выполнять корректировку суммы аванса.

Задать сумму фиксированного аванса можно в документе «Прием на работу», закладка «Оплата труда». Изменить сумму фиксированного аванса, а так же способ начисления можно в документах:  «Кадровый перевод», «Кадровый перевод списком», «Изменение оплаты труда», «Изменение аванса». Более подробно можно прочитать здесь.

По логике работы системы, гораздо правильней для учета отработанного времени использовать вид начисления «Расчетом за первую половину месяца», но исторически сложилось, что сумма выделенная сотруднику на аванс, рассчитывается каждому сотруднику индивидуально и не привязана к плановым начислениям сотрудника. Все изменения будем производить в документе «ВедомостьНаВыплатуЗарплатыВБанк».

Решение задачи.

Этап 1. Определим инструмент решения задачи и взаимодействие с пользователем.

На мой взгляд, для достижения поставленных целей можно воспользоваться следующими методами:

  • Внесение изменения непосредственно в конфигурацию;
  • Использовать механизм расширений;
  • Использовать внешнюю обработку заполнения табличных частей;

Внесение изменения непосредственно в конфигурацию, метод практически сразу отпал поскольку, конфигурация находится на поддержке и обновления в данной ситуации, будут вызывать, если не трудности, то дополнительные затраты времени;

Использовать механизм расширений, метод более гибкий, но к сожалению при наследовании объектов в расширении, придется заимствовать «ФормуДокумента», поскольку в работе необходимо будет совершать интерактивные действия с интерфейсом.

Использовать внешнюю обработку заполнения табличных частей, метод хорош тем, что нет необходимости вносить изменений ни в конфигурацию, ни в расширение, но пользователю, для запуска проверки, необходимо будет совершать дополнительные действия, т.е. нажать на кнопку с вероятностью в 99%, это когда-нибудь будет не сделано.

В данном случае задачу проще решить, используя механизм расширений. Возникает сразу ряд проблем…

Этап 2. Определим дополнительные ограничения на механизм доработки.

Первое что приходит в голову. Это момент проведения документа, поскольку вся проверка на корректность сумм аванса будет, происходит в момент записи/проведения документа, и в случае если будет выдано предупреждение, оно будет выведено в не модальном режиме, документ запишется в не зависимости от того, что ответит пользователь.

Подобные проблемы решаются различными способами, добавлением доп. реквизитов на форму, для хранения текущего флага записи документа и пр.

Но в данном случае лучше всего подойдет использование механизма общих настроек, конечно есть нюанс, связанный с тем что, для получения значений настроек необходимо обращаться к серверу, но поскольку по логике работы вся процедура проверки будет, происходит при записи документа, т.е. вся проверка происходит на сервере, а конечный список предупреждений будет просто передан клиенту, это не сильная нагрузка на систему, и конечно поддерживаются вне контекстные вызовы получение настроек из хранилища.

Схема работы следующая:

  • Создаем две общих настройки: ЗаписьДокументаПриНаличииОшибокПлановогоВремени и НеобходимаПроверкаПлановогоВремени, все они будут иметь тип Булево.
  • При создании документа на сервере, устанавливаем следующие значения настроек
ХранилищеОбщихНастроек.Сохранить("Расш1_ПроверкаПлановогоВремени", "ЗаписьДокументаПриНаличииОшибокПлановогоВремени", Ложь);
ХранилищеОбщихНастроек.Сохранить("Расш1_ПроверкаПлановогоВремени", "НеобходимаПроверкаПлановогоВремени", Истина);
  • Создаем процедуру возвращающую результат сравнения двух настроек:

ЗаписьДокументаПриНаличииОшибокПлановогоВремени ИЛИ НеобходимаПроверкаПлановогоВремени

Она будет возвращать значение в переменную Отказ, метода «ПередЗаписью» формы документа, две настройки и сравнение на ИЛИ, необходимы для тех случаев, если в документе не выбрана формы выплаты Аванс или если, к примеру, пользователь получил предупреждение о несоответствии сумм, поправил несколько строк и решил провести документ как есть.

  • Переопределяем процедуру модуля «ПередЗаписью», в ней мы проверяем, необходима ли проверка на плановое время через функцию описанную выше. Если проверка необходима, то выполняем функции сверки.

Этап 3.  Основные задачи по получению и обработки данных.

Первое что придется решить, это получение планового и отработанного времени сотрудника. Как всегда нюанс). Ведется ли табельный учет через документ «ТабельУчетаРабочегоВремени» или учет ведется методом отклонений от рабочего времени.  В зависимости от методов ведения учета придется обращаться к разным таблицам системы. В рассматриваемой задаче учет ведется методом отклонений.  

Для решения будем пользоваться методами общего модуля «УчетРабочегоВремениРасширенный», заполняем параметры и временные таблицы запроса используемого для получения отработанного и планового времени, но данный метод возвращает временную таблицу в целом по периоду, и по дням, соответственно к полученным таблицам необходимо применить сворачивания и отборы.

Второе и более тривиальное это интерактивная работа с пользователем вывод сообщений об ошибках и проведение/запись документа.

Для получения обратной связи от пользователя будем использовать функцию ПоказатьВопрос с обработкой оповещения.

Для вывода ошибок воспользуемся методами БСП 3.0, из общего модуля «ОбщегоНазначенияКлиентСервер»,  «ДобавитьОшибкуПользователю», «СообщитьОшибкиПользователю». Весь синтаксис методов далее будет понятен по коду…

Код, код, код…

Процедуры и функции постарался расположить в порядке вызова и логики работы.

Заимствуем в расширение форму документа «ВедомостьНаВыплатуЗарплатыВБанк» и приступаем…  Далее по тексту распишу только основные функции для сокращения статьи, более подробно можно просмотреть в расширении.

Переопределим процедуру формы документа «ПриСозданииНаСервере» и будем выполнять ее перед вызовом аналогичной процедуры конфигурации:

&НаСервере
Процедура Расш1_ПриСозданииНаСервереПеред(Отказ, СтандартнаяОбработка)
	
	//установим первоначальные значения
	ХранилищеОбщихНастроек.Сохранить("Расш1_ПроверкаПлановогоВремени", "ЗаписьДокументаПриНаличииОшибокПлановогоВремени", Ложь);
	ХранилищеОбщихНастроек.Сохранить("Расш1_ПроверкаПлановогоВремени", "НеобходимаПроверкаПлановогоВремени", Истина);
	
КонецПроцедуры

Затем переопределяем процедуру «ПередЗаписью» и будем выполнять ее перед основной:

&НаКлиенте
Процедура Расш1_ПередЗаписьюПеред(Отказ, ПараметрыЗаписи)
	
	Если ПолучитьЗначениеЗаписиДокумента() Тогда
		
		ПроверитьОплатуПоНормамВремениСотрудниковНаКлиенте();
		Отказ = ПолучитьЗначениеЗаписиДокумента();	
		
	КонецЕсли;
	
КонецПроцедуры

Распишем функцию ПолучитьЗначениеЗаписиДокумента:

&НаСервереБезКонтекста
Функция ПолучитьЗначениеЗаписиДокумента()
	
	//прочитаем значения
	ЗаписьДокументаПриНаличииОшибокПлановогоВремени = ХранилищеОбщихНастроек.Загрузить("Расш1_ПроверкаПлановогоВремени", "ЗаписьДокументаПриНаличииОшибокПлановогоВремени");
	НеобходимаПроверкаПлановогоВремени = ХранилищеОбщихНастроек.Загрузить("Расш1_ПроверкаПлановогоВремени", "НеобходимаПроверкаПлановогоВремени");
	
	Возврат ЗаписьДокументаПриНаличииОшибокПлановогоВремени ИЛИ НеобходимаПроверкаПлановогоВремени;
	
КонецФункции // ПолучитьЗначениеЗаписиДокумента()

Здесь все просто получаем значение из хранилища настроек и возвращаем результат сравнения.

Перейдем к основной процедуре. ПроверитьОплатуПоНормамВремениСотрудниковНаКлиенте.

&НаКлиенте
Процедура ПроверитьОплатуПоНормамВремениСотрудниковНаКлиенте()
	
	Если СпособВыплаты.Наименование = "Аванс" Тогда
		
		МассивПредупреждений = ПроверитьНормыРабочегоВремениПоСотрудникам();
		
		Если МассивПредупреждений.Количество() > 0 Тогда
			
			//добавим свои кнопки
			СписокКнопок = Новый СписокЗначений;
			СписокКнопок.Добавить("ПровестиИЗакрыть", "Провести и закрыть");
			СписокКнопок.Добавить("Записать", "Записать");
			СписокКнопок.Добавить("Нет", "Нет");
			
			Оповещение = Новый ОписаниеОповещения("ПослеОтветаНаВопрос", ЭтотОбъект);
			
			ПоказатьВопрос(Оповещение, "Обнаружены расхождения в подсчете сумм фиксированного аванса, связанных с отработанным временем. Записать документ?", СписокКнопок,
			
			0, , "Обратите внимание!");
			
			Ошибки = Неопределено;
			
			Для Каждого СтрокаПредупреждение Из МассивПредупреждений Цикл
				
				//найдем индекс строкис ошибкой
				ПараметрыОтбора = Новый Структура;
				ПараметрыОтбора.Вставить("ИдентификаторСтроки", СтрокаПредупреждение.ИдентификаторСтроки);
				
				НайденныеСтрокиСостава = Объект.Состав.НайтиСтроки(ПараметрыОтбора);
				
				Для Каждого НайденнаяСтрока Из НайденныеСтрокиСостава Цикл
					
					ФизЛицо = НайденнаяСтрока.ФизическоеЛицо.Наименование + ". ";
					СтрокаОтработано = "Отраб. Д: " + СтрокаПредупреждение.ОтработаноДней + ", Ч: " + СтрокаПредупреждение.ОтработаноЧасов + ". ";
					СтрокаПлан = "План. Д: " + СтрокаПредупреждение.НормаПоГрафикуДней + ", Ч: " + СтрокаПредупреждение.НормаПоГрафикуЧасов + ". ";
					СтрокаФормулаРасчета = "(" + СтрокаПредупреждение.Аванс + " / " + СтрокаПредупреждение.НормаПоГрафикуДней + ") * " + СтрокаПредупреждение.ОтработаноДней + " = " + Окр(СтрокаПредупреждение.РасчетнаяСуммаАванса,2); 
					СтрокаОписанияОшибки = Физлицо + СтрокаОтработано + СтрокаПлан + СтрокаФормулаРасчета;
					
					ОбщегоНазначенияКлиентСервер.ДобавитьОшибкуПользователю(Ошибки, "Объект.Состав[%1].КВыплатеСумма", СтрокаОписанияОшибки,, НайденнаяСтрока.НомерСтроки - 1);
					
				КонецЦикла;
				
			КонецЦикла;
			
		Иначе
			
			УстановитьЗначениеЗаписиДокумента(Ложь, Ложь);
			
		КонецЕсли;
		
		ОбщегоНазначенияКлиентСервер.СообщитьОшибкиПользователю(Ошибки);
		
	Иначе
		
		УстановитьЗначениеЗаписиДокумента(Ложь, Ложь);
		
	КонецЕсли;
	
КонецПроцедуры // ПроверитьОплатуПоНормамВремениСотрудниковНаКлиенте()

Кратко поясним. Процедура проверяет выбран ли вид оплаты «Аванс», если выбран то вызывает функцию ПроверитьНормыРабочегоВремениПоСотрудникам, которая возвращает массив предупреждений, если массив предупреждений не пуст, то все ошибки выводятся на форму а пользователю интерактивно предлагается действие.

Сама процедура ПроверитьНормыРабочегоВремениПоСотрудникам.

&НаСервере
Функция ПроверитьНормыРабочегоВремениПоСотрудникам()
	
	ХранилищеОбщихНастроек.Сохранить("Расш1_ПроверкаПлановогоВремени", "НеобходимаПроверкаПлановогоВремени", Ложь);	
	
	//получим таблицу значений с индентификатором строки и сотрудников
	ДокОбъект = РеквизитФормыВЗначение("Объект");
	ТаблицаСотрудников = ДокОбъект.Зарплата.Выгрузить(,"ИдентификаторСтроки, Сотрудник, КВыплате");
	
	//Добавим к таблице дополнительные колонки по авансу
	ТаблицаСотрудников.Колонки.Добавить("СпособРасчетаАванса", Новый ОписаниеТипов("ПеречислениеСсылка.СпособыРасчетаАванса"));
	ТаблицаСотрудников.Колонки.Добавить("Аванс", Новый ОписаниеТипов("Число"));
	
	ДополнитьТаблицуПлановымиАвансами(ТаблицаСотрудников);
	ОтобратьТаблицуПоОтбору(ТаблицаСотрудников, ВидСравнения.Равно, "СпособРасчетаАванса", Перечисления.СпособыРасчетаАванса.ФиксированнойСуммой);
	
	//Выборка по рабочего времени за весь период
	ДатаНачала = НачалоМесяца(Объект.Дата);
	ДатаОкончания = КонецМесяца(Объект.Дата);
	
	МассивСотрудников = ТаблицаСотрудников.ВыгрузитьКолонку("Сотрудник");
	
	МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;	
	СоздатьВТСотрудники(МенеджерВременныхТаблиц, МассивСотрудников, ДатаНачала);
	
	ПараметрыПолученияДанных = УчетРабочегоВремениРасширенный.ПараметрыДляЗапросВТДанныеУчетаВремениИСостоянийСотрудников();
	ПараметрыПолученияДанных.ДатаНачала = ДатаНачала;
	ПараметрыПолученияДанных.ДатаОкончания = КонецМесяца(ДатаНачала);
	
	ПараметрыПолученияДанных.МесяцДатаНачала = ДатаНачала;
	ПараметрыПолученияДанных.МесяцДатаОкончания = КонецМесяца(ДатаНачала);
	ПараметрыПолученияДанных.ДатаАктуальности = ТекущаяДата();
	
	УчетРабочегоВремениРасширенный.СоздатьВТДанныеУчетаВремениИСостоянийСотрудников(МенеджерВременныхТаблиц, Истина, ПараметрыПолученияДанных);
	ДанныеТабеляТ13 = МенеджерВременныхТаблиц.Таблицы.Найти("ВТДанныеУчетаВремениИСостоянийСотрудников").ПолучитьДанные().Выгрузить();
	ДанныеТабеляТ13.Сортировать("Дата");	
	
	ОтобратьТаблицуПоОтбору(ДанныеТабеляТ13,  ВидСравнения.МеньшеИлиРавно, "Дата", ДатаНачала +(86400*14));
	ДанныеТабеляТ13.Свернуть("Сотрудник, ВидУчетаВремени", "Дни, Часы");
	
	ОтобратьТаблицуПоОтбору(ДанныеТабеляТ13, ВидСравнения.ВСписке, "ВидУчетаВремени", ПолучитьРабочиеВидыВремени());	
	
	//получим общее количество отработанных часов
	ДанныеТабеляТ13.Свернуть("Сотрудник", "Дни, Часы");
	
	НормаПоГрафику = МенеджерВременныхТаблиц.Таблицы.Найти("ВТНормаВремени").ПолучитьДанные().Выгрузить();
	
	ОтобратьТаблицуПоОтбору(НормаПоГрафику, ВидСравнения.МеньшеИлиРавно, "Дата", ДатаНачала +(86400*14));	
	//ОтобратьДанныеПоПериоду(НормаПоГрафику, ДатаНачала);
	НормаПоГрафику.Свернуть("Сотрудник","ДниНорма, ЧасыНорма");
	
	ИтоговаяТаблица  = ПолучитьОбщуюТаблицуСОтработаннымИНормированнымВременем(ДанныеТабеляТ13, НормаПоГрафику, ТаблицаСотрудников);
	
	МассивПредупреждений = Новый Массив;
	
	Для Каждого СтрокаПредупреждение Из ИтоговаяТаблица Цикл
		
		СтруктураПредупреждения = Новый Структура;
		СтруктураПредупреждения.Вставить("Сотрудник", СтрокаПредупреждение.Сотрудник);
		СтруктураПредупреждения.Вставить("ОтработаноДней", СтрокаПредупреждение.ОтработаноДней);
		СтруктураПредупреждения.Вставить("ОтработаноЧасов", СтрокаПредупреждение.ОтработаноЧасов);
		СтруктураПредупреждения.Вставить("НормаПоГрафикуДней", СтрокаПредупреждение.НормаПоГрафикуДней);
		СтруктураПредупреждения.Вставить("НормаПоГрафикуЧасов", СтрокаПредупреждение.НормаПоГрафикуЧасов);
		СтруктураПредупреждения.Вставить("ИдентификаторСтроки", СтрокаПредупреждение.ИдентификаторСтроки);
		СтруктураПредупреждения.Вставить("КВыплате", СтрокаПредупреждение.КВыплате);
		СтруктураПредупреждения.Вставить("СпособРасчетаАванса", СтрокаПредупреждение.СпособРасчетаАванса);
		СтруктураПредупреждения.Вставить("Аванс", СтрокаПредупреждение.Аванс);
		
		РасчетнаяСуммаАванса = (СтрокаПредупреждение.Аванс / СтрокаПредупреждение.НормаПоГрафикуДней) * СтрокаПредупреждение.ОтработаноДней;
		
		СтруктураПредупреждения.Вставить("РасчетнаяСуммаАванса", РасчетнаяСуммаАванса);
		
		Если Цел(РасчетнаяСуммаАванса) <> Цел(СтрокаПредупреждение.КВыплате) Тогда  
			
			ХранилищеОбщихНастроек.Сохранить("Расш1_ПроверкаПлановогоВремени", "НеобходимаПроверкаПлановогоВремени", Истина);
			МассивПредупреждений.Добавить(СтруктураПредупреждения);
			
		КонецЕсли;
		
	КонецЦикла;
	
	Возврат МассивПредупреждений;
	
КонецФункции // ПроверитьНормыРабочегоВремениПоСотрудникам()

Так же дополнительно процедура для заполнения временной таблицы сотрудников. СоздатьВТСотрудники.

&НаСервереБезКонтекста
Процедура СоздатьВТСотрудники(МенеджерВременныхТаблиц, МассивСотрудников, Месяц, ДатаАктуальности = Неопределено, ДатаНачала = Неопределено, ДатаОкончания = Неопределено)
	
	ТаблицаСотрудники = Новый ТаблицаЗначений;
	ТаблицаСотрудники.Колонки.Добавить("Сотрудник", Новый ОписаниеТипов("СправочникСсылка.Сотрудники"));
	ТаблицаСотрудники.Колонки.Добавить("Месяц", Новый ОписаниеТипов("Дата"));
	ТаблицаСотрудники.Колонки.Добавить("ДатаАктуальности", Новый ОписаниеТипов("Дата"));
	ТаблицаСотрудники.Колонки.Добавить("ДатаНачала", Новый ОписаниеТипов("Дата"));
	ТаблицаСотрудники.Колонки.Добавить("ДатаОкончания", Новый ОписаниеТипов("Дата"));    
	
	Для Каждого Сотрудник Из МассивСотрудников Цикл
		СтрокаСотрудники = ТаблицаСотрудники.Добавить();
		СтрокаСотрудники.Сотрудник = Сотрудник;
	КонецЦикла;
	
	ТаблицаСотрудники.ЗаполнитьЗначения(Месяц, "Месяц");
	ТаблицаСотрудники.ЗаполнитьЗначения(?(ДатаАктуальности = Неопределено, ТекущаяДата(), ДатаАктуальности), "ДатаАктуальности");
	ТаблицаСотрудники.ЗаполнитьЗначения(?(ДатаНачала = Неопределено, Месяц, ДатаНачала), "ДатаНачала");
	ТаблицаСотрудники.ЗаполнитьЗначения(?(ДатаОкончания = Неопределено, КонецМесяца(Месяц), ДатаОкончания), "ДатаОкончания");
	
	Запрос = Новый Запрос(
	"ВЫБРАТЬ
	|    ТаблицаСотрудники.Сотрудник,
	|    ТаблицаСотрудники.Месяц,
	|    ТаблицаСотрудники.ДатаАктуальности,        
	|    ТаблицаСотрудники.ДатаНачала,
	|    ТаблицаСотрудники.ДатаОкончания
	|ПОМЕСТИТЬ ВТСотрудники
	|ИЗ
	|    &ТаблицаСотрудники КАК ТаблицаСотрудники");
	
	Запрос.МенеджерВременныхТаблиц = МенеджерВременныхТаблиц;
	Запрос.УстановитьПараметр("ТаблицаСотрудники", ТаблицаСотрудники);
	Запрос.Выполнить();
	
КонецПроцедуры

Кратко поясним. Механизм работы.

Получаем таблицу сотрудников из документа, нам будет необходим Сотрудник, ИдентификаторСтроки для подвязки предупреждения к строке табличной части с сотрудниками и КВыплате в ней содержится сумма аванса. Для дополнительного отбора по сотрудникам, чей аванс указан фиксированной суммой, дополним таблицу двумя колонками СпособРасчетаАванса и Аванс (сумма назначенная сотруднику в системе), заполняем данные колонки запросом к регистру сведений «ПлановыеАвансы».

Оставляем в таблице только тех сотрудников у которых аванс рассчитывается фиксированной суммой.

Получаем период аванса, в данном случае берем дату документа и получаем начало и конец месяца. Передаем список сотрудников и периоды отбора в запрос общего модуля УчетРабочегоВремениРасширенный, выгружаем две временные таблицы: ВТДанныеУчетаВремениИСостоянийСотрудников и ВТНормаВремени, в них хранятся данные по отработанному и по нормам времени на сотрудника.

Далее выполняем отбор по датам только за первую половину месяца т.е. по 15 число.  Сворачиваем таблицы по сотрудникам и суммируем отработанные дни и часы.

При помощи запроса формируем одну общую таблицу с сотрудниками отработанным/нормативным временем и фактической суммой выплаты и выплаты зарегистрированной в системе как плановой, если присутствуют расхождения устанавливаем флаг в общих настройках о том что необходима проверка планового времени, данные из таблицы передаем в массив структур и возвращаем на клиент.

На клиенте фомируем список ошибок пользователей и показываем их на форме. Далее обрабатываем результат ответа пользователя либо проводим, как есть либо отказываемся от записи, и он корректирует результат.

Статья не претендует на универсальное решение проблемы. Но надеюсь поможет. 

----

Мой блог с заметками здесь.

Написать мне telegram можно здесь.

Скачать файлы

Наименование Файл Версия Размер
Задачи по доработке типовых решений. ЗУП 3.1. Доработка выплаты аванса фиксированной суммой, проверка на отработанное время. Вывод предупреждения как в ЗУП 2.5.:

.cfe 37,87Kb
14
.cfe 37,87Kb 14 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Трудовой договор, Дополнительное соглашение к трудовому договору, Лист ознакомления, Договор о материальной ответственности, Договор о коммерческой тайне, Согласие на обработку персональных данных для ЗУП 3.1 Промо

Печатные формы документов Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Комплект печатных форм для отдела кадров для документов Прием на работу и Кадровый перевод: Трудовой договор, Доп. соглашение к трудовому договору, Лист ознакомления с локальными нормативными актами, Договор о полной материальной ответственности, Договор о неразглашении коммерческой тайны, Согласие на обработку персональных данных.

2 стартмани

12.03.2019    34204    191    Asenka    55    

Справка 2-НДФЛ для ЗУП 2.5 / ЗУП 3.1 (Приложение № 5 к Приказу ФНС России от 02.10.2018 № ММВ-7-11/566@)

Зарплата Справки Зарплата v8 v8::СПР ЗУП2.5 ЗУП3.x БУ НДФЛ Абонемент ($m)

Печатная форма Справки 2-НДФЛ для ЗУП 2.5 / ЗУП 3.1 Форма с 2019 года Приложение № 5 к Приказу ФНС России от 02.10.2018 № ММВ-7-11/566@

1 стартмани

10.01.2019    25199    140    prime9    20    

Отчет-сверка по НДФЛ для ЗУП 3.1

Бухгалтерские Анализ учета Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x Россия БУ НДФЛ Абонемент ($m)

Отчет для проверки правильности исчисления, удержания и перечисления НДФЛ в бюджет по сотрудникам и поиска причины расхождений.

2 стартмани

27.06.2018    23244    384    SanchoD    31    

Проверка и корректировка данных по выплате зарплаты

Закрытие периода Бухгалтерские Анализ учета Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x Россия БУ Госбюджет Абонемент ($m)

Обработка показывает остатки и движения взаиморасчетов с сотрудниками. Также обработка может откорректировать сумму остатков. Конфигурации: "Зарплата и управление персоналом" , релиз не ниже 3.1.2.105 и "Зарплата и кадры государственного учреждения" , релиз не ниже 3.1.2.105.

2 стартмани

08.06.2018    29703    184    APTEM_SLV    14    

Настройки отчета "Анализ начислений и удержаний" для ЗУП/ЗГУ 3.1 Промо

Бухгалтерские Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x НДФЛ ФОМС, ПФ, ФСС Абонемент ($m)

Несколько полезных настроек отчета "Анализ начислений и удержаний" для зарплаты редакции 3.1. В состав входят настройки: Свод в разрезе налогообложения, Сводные данные для статистики, Реестр пособий, Расчетная ведомость по зарплате, Свод в разрезе финансирования, Отклонения от режима работы, Свод по зарплате в разрезе ИФНС, Начисления с детализацией отсутствий, Лицевые счета сотрудников, Распределение отпусков, Сводка затрат

2 стартмани

03.05.2018    42654    293    the1    45    

Трудовой договор, Дополнительное соглашение, Материальная ответственность, Коллективная материальная ответственность, Кадровый перевод, Индексация, Т-53 для ЗУП 3 внешние (7 печатных форм). Создание ведомостей по каждому сотруднику одной кнопкой

Печатные формы документов Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

1. Комплект из 6 печатных форм для документов: Прием на работу, Индексация, Кадровый перевод, Кадровый перевод списком для ЗУП 3.1.11 и более ранних Трудовой договор, дополнительное соглашение, договор личной материальной ответственности, договор коллективной материальной ответственности, индексация, Ведомость Т-53 без лишних строк. Не требуется изменения конфигурации. Подключается через стандартное подключение внешних обработок. 2. Обработка для создания ведемостей из начисления зарплаты. 3. Расширение конфигурации для ЗУП 3.1.11 и КА 2.4.6 для редактирования стажа как в ЗУП 2.5 (Из трудовой деятельности сотрудника. Если ввели строки трудовой деятельности, то стаж считается до даты приема сотрудника).

1 стартмани

26.01.2018    51185    500    p.ugrumov    97    

Проверка данных после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1

Зарплата Бухгалтерский учет Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Описаны данные, которые необходимо проверить после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1. Описано, на что необходимо обратить внимание, где найти перенесенные данные, что НЕ переносится, где найти настройки.

1 стартмани

17.01.2018    32173    147    utrumar    3    

Справка о заработной плате и других доходах (измененная форма №46)

Справки Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 Россия БУ Абонемент ($m)

Форма разработана для автоматизированного формирования справки по форме № 46. Внешний отчет с возможностью пользовательских настроек.

3 стартмани

24.11.2017    44037    53    agospodarin    15    

Анализ НДФЛ и сверка данных учета при подготовке 2-НДФЛ (ЗИК 1.0, ЗУП 2.5, ЗГУ 3.1, ЗУП 3.1) Промо

Анализ учета Налоговые Бухгалтерские Зарплата Зарплата v8 v8::СПР v8::СКД КА1 ЗУП2.5 ЗКБУ УПП1 БУ НДФЛ Абонемент ($m)

Два в одном. Наглядная информация об исчисленном налоге, и налоге, учтенном в справках, о суммах начислений по своду и о доходах, включенных в справки. Все это в разрезе физических лиц, так что станет очевидно, какой сотрудник не включен в справки, у кого недоучтен доход, кому неверно предоставлен вычет, а у кого неверно исчислен, удержан или перечислен налог.

1 стартмани

28.01.2016    36768    162    the1    11    

Налоги и взносы (кратко) по подразделениям и сотрудникам. ЗУП 3

Бухгалтерские Зарплата Зарплата v8 v8::СПР ЗУП3.x Россия БУ НДФЛ ФОМС, ПФ, ФСС Абонемент ($m)

Отчет "Налоги и взносы (кратко)" в разрезе подразделений и сотрудников.

3 стартмани

13.11.2017    38641    174    tritonof    10    

Реестр регламентированных отчетов 6-НДФЛ по всем организациям и обособленным подразделениям. Контроль удержанного НДФЛ. ЗУП 3.1

Налоговые Регламентированная отчетность Бухгалтерские Зарплата Зарплата v8 v8::СПР ЗУП3.x Россия БУ НУ НДФЛ Абонемент ($m)

Отчет для проверки правильности данных во всех регламентированных отчетах 6-НДФЛ - по всем организациям и обособленным подразделениям. Анализируются: 1. Данные возвращенного налога в 6-НДФЛ должны быть равны возвращенному налогу из Регистра накопления "РасчетыНалогоплательщиковСБюджетомПоНДФЛ" с типом ВозвращеноНалоговымАгентом, за период отчета. (голубой цвет). 2. Удержанный налог из Регистра накопления "РасчетыНалогоплательщиковСБюджетомПоНДФЛ" с учетом возвратов и НДФЛ к уплате из Регистра накопления "РасчетыНалоговыхАгентовСБюджетомПоНДФЛ" - сомневаюсь - что это верно - может кто-нибудь прокомментирует? (зеленый цвет). 3. Удержанный налог в Разделе 1 (070) должен быть равен Удержанному налогу из Регистра накопления "РасчетыНалогоплательщиковСБюджетомПоНДФЛ" с типом Удержано (без учета возвращенного налога ). (золотой цвет). 4. Анализируется удержанный НДФЛ в отчете 6-НДФЛ Раздел 2 (140) и данные по удержанному налогу Регистра накопления "РасчетыНалогоплательщиковСБюджетомПоНДФЛ" с типом Удержано (без учета возвращенного налога ) по крайнему сроку уплаты. (бледно желтый цвет). 5. Контрольное соотношение 2.1: (070) - (090) д.б. - значит "недоплата" (ярко-розовый цвет), если > значит "переплата" (бледно-розовый цвет)).

2 стартмани

17.08.2017    27472    149    user_2010    49    

Краткий регистр налогового учета НДФЛ 2016 Промо

Бухгалтерские Налоговые Зарплата Зарплата v8 v8::БУ v8::СПР БП3.0 ЗУП3.x Россия БУ НДФЛ Абонемент ($m)

C 2016 года у ИФНС повысились требования к учету НДФЛ. Предлагаю вам отчет "Краткий регистр налогового учета НДФЛ", компактный, простой и информативный. Самое главное - от обычного "Регистр налогового учета НДФЛ" отличается размерами.

2 стартмани

18.04.2016    33515    26    Craig    6    

6-НДФЛ - Формирование, проверка, корректировка, перенос в типовой отчет. ЗУП 2.5 / УПП 1.3 / ЗиКБУ

Налоговые Бухгалтерские Зарплата Зарплата v8 v8::СПР ЗУП2.5 ЗКБУ УПП1 Россия БУ НДФЛ Абонемент ($m)

Формирование 6-НДФЛ по первичным документам (НЕ ПО РЕГИСТРАМ) для ЗУП 2.5 / УПП 1.3 / ЗиКБУ. Всё что требуется - это правильно заполнить даты выплаты дохода в документах начисления!

1 стартмани

27.07.2016    50374    585    madonov    190    

Формирование 6-НДФЛ в ЗУП 2.5

Регламентированная отчетность Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 1cv8.cf Россия БУ НДФЛ Абонемент ($m)

Формирование отчетности 6-НДФЛ на практическом примере.

1 стартмани

04.04.2016    77533    833    nsr17    41    

Откуда берутся данные 6-НДФЛ в ЗУП 2.5

Бухгалтерский учет Зарплата Зарплата v8 ЗУП2.5 Россия БУ НДФЛ Абонемент ($m)

Как заполняются данные 6-НДФЛ? Файл с картинками и описанием дополнений учета НДФЛ в ЗУП 2_5_99 по сравнению с прежними версиями.

1 стартмани

03.02.2016    178824    156    milov.aleksey    126    

Внешние печатные формы ЗУП, ЗиК БУ 8. (Т-1, Т-1А, Т-5, Т-5А, Т-6, Т-6А, Т-7, Т-8, Т-8А, Т-9, Т-9А, Т-10, Т-10А, Т-11, Т-11А, Трудовой договор, Постоянные начисления, Ввод постоянного начисления или удержания, Возврат на работу, Табель форма 0504421) Промо

Печатные формы документов Зарплата Управление персоналом (HRM) Учет рабочего времени Зарплата Управление персоналом (HRM) Учет рабочего времени v8 ЗУП2.5 ЗКБУ Россия БУ Госбюджет Абонемент ($m)

Внешние печатные формы (Т-1, Т-1А, Т-5, Т-5А, Т-6, Т-6А, Т-7, Т-8, Т-8А, Т-9, Т-9А, Т-10, Т-10А, Т-11, Т-11А, Трудовой договор, Постоянные начисления, Ввод постоянного начисления или удержания, Возврат на работу, Табель форма 0504421) Формы которые присутствуют в конфигурации типовые. Добавленные формы: Постоянные начисления, Ввод постоянного начисления или удержания, Возврат на работу.

1 стартмани

22.04.2012    60349    1647    Tokiy    55    

Конструктор трудовых договоров WORD для типовой конфигурации 1C: Зарплата и управление персоналом 3.1

Универсальные печатные формы Пакетная печать Печатные формы документов Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Внешняя печатная форма или обработка "Конструктор трудовых договоров на основе документов формата Word". Конструктор автоматически подставляет реквизиты в документ формата Word. Подходит для типовой конфигурации 1С: ЗУП 3.1.

1 стартмани

14.07.2015    65529    627    ni032mas    106    

Справка о начисленной зарплате

Справки Зарплата Зарплата v8 ЗУП2.5 ЗКБУ Россия БУ Абонемент ($m)

Справка о начисленной зарплате за выбранный период по месяцам

1 стартмани

26.05.2015    30110    56    ia57    4    

П-4 и П-4 (НЗ) для ЗУП 2.5 и УПП с отбором по подразделению и КПП

Статистические Статистики Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 ЗУП2.5 УПП1 Россия БУ ФОМС, ПФ, ФСС Абонемент ($m)

Статистические формы П-4 и П-4 (НЗ) для ЗУП с автозаполнением и отбором по подразделению и КПП

1 стартмани

21.05.2014    54885    1193    mikhailovaew    131    

Расчетная ведомость со страховыми взносами 2014 (ПФР по суммарному тарифу)

Зарплата Бухгалтерские Зарплата v8 ЗУП2.5 НУ ФОМС, ПФ, ФСС Абонемент ($m)

Добавлена колонка "ПФР по суммарному тарифу"

1 стартмани

26.02.2014    17991    110    vechiy    3    

Инструкции по работе в 1С ЗУП

Пользователю системы Бухгалтерский учет Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 ЗУП2.5 БУ УУ Абонемент ($m)

Инструкции Кадровика и Расчетчика. Ничего лишнего. Скрины из реальной базы. Обработка открытия (обычное приложение) + файлы в формате MS WORD *.doc (открывается во ВСЕХ версиях программы WORD!). 50+ страниц!

1 стартмани

25.12.2013    56214    540    vladim-kul    35    

Расчетная ведомость сравнительная (черно - белая, с возможностью подключения к другой базе)

Зарплата Бухгалтерские Зарплата v8 БУ Абонемент ($m)

Расчетная ведомость с возможностью подключения к другой базе для получения общего результата

1 стартмани

17.09.2013    18089    22    SinglCOOLer    15    

Свод начисленной заработной платы со страховыми взносами в ПФР

Бухгалтерские Зарплата Зарплата v8 КА1 ЗУП2.5 УПП1 БУ ФОМС, ПФ, ФСС Абонемент ($m)

Свод начисленной заработной платы со страховыми взносами в ПФР – Типовой отчет «Свод начисленной зарплаты организаций», где отдельным разделом выводятся начисленные налоги и взносы.

1 стартмани

13.08.2013    24987    301    zlakizla    25    

Как исправить сальдо по персонифицированному учету в Зарплата и Управление Персоналом (2.5.)

Зарплата Управление персоналом (HRM) Бухгалтерский учет Зарплата Управление персоналом (HRM) v8 ЗУП2.5 ЗКБУ Россия БУ ФОМС, ПФ, ФСС Абонемент ($m)

Изменение (ввод) сальдо по персонифицированному учету в случае нехватки данных, для формирования правильного сальдо по сотрудникам на начало периода.

1 стартмани

16.07.2013    14708    66    Alran    17    

Отчет по всем проведенным пачкам CЗВ-4 (2013)

Зарплата Бухгалтерские Зарплата v8 ЗУП2.5 Россия БУ ФОМС, ПФ, ФСС Абонемент ($m)

Отчет по всем проведенным пачкам CЗВ-4. Доработан под отчетность 2013г.

1 стартмани

09.07.2013    12875    100    dr_dom    10    

Реестр больничных листов и всех пособий за счет ФСС

Зарплата Бухгалтерские Специальные Зарплата v8 КА1 ЗУП2.5 ЗКБУ УПП1 Россия БУ Абонемент ($m)

Отчет позволяет сформировать рееестр больничных листов с разделением сумм и дней за счет ФСС и работодателя, разбивкой по видам расчетов оплаты б/л, причинам нетрудоспособности а также всех пособий за счет ФСС. Имеется возможность выбора формирования реестра по дате больничного или периоду начисления.

1 стартмани

27.06.2013    29600    312    Drozd80    12    

Реестр больничных с разделенными суммами ФСС и за счет работодателя

Зарплата Бухгалтерские Зарплата v8 ЗУП2.5 Россия БУ Абонемент ($m)

Отчет "Реестр больничных" с разделенными суммами ФСС и за счет работодателя. В отчет выводятся периоды больничных, отдельно суммы и количество дней за счет работодателя и за счет ФСС, процент больничного и общий результат. Также в подвале формируется итоговая таблица в разрезе причин нетрудоспособности. Работает в ЗУП и КА.

1 стартмани

04.06.2013    18096    197    Baksheev-Nikita    13    

Сведения о распределении численности работников по размерам заработной платы. Форма №1 от 14.12.12

Статистические Зарплата Зарплата v8 УПП1 Россия БУ УУ Абонемент ($m)

Сведения о распределении численности работников по размерам заработной платы. Форма №1 от 14.12.12 для сдачи за апрель 2013 г.

1 стартмани

18.05.2013    28140    305    CHELLL    29    

Конфигурация "Управление транспортным участком"

Зарплата Производство готовой продукции (работ, услуг) Управленческий учет (прочее) v8 Химическая промышленность Транспорт, автопарки, такси Россия УУ Абонемент ($m)

Конфигурация «Управление транспортным участком» предназначена для автоматизации транспортного подразделения производственных организаций. Особенностью данной разработки является объединение двух составляющих: учет ГСМ и расчет сдельных нарядов на оплату труда. С открытым кодом!

1 стартмани

13.05.2013    16988    213    Elv_Ra    10    

Отчет по уплаченным страховым взносам с разбивкой по сотрудникам и отчетным периодам с изменениями 2013 г.

Зарплата Бухгалтерские Налоговые Зарплата v8 КА1 БП2.0 ЗУП2.5 УПП1 БУ НУ ФОМС, ПФ, ФСС Абонемент ($m)

Изменения к публикации http://infostart.ru/public/179314/ с учетом изменения законодательства с 2013 г. Отчет показывает в разрезе каждого сотрудника начальное и конечное сальдо по страховым взносам (только по отчетным годам), сумму начисленных и уплаченных взносов за каждый отчетный период и переходящее сальдо между периодами. Отчет собирает данные с даты введения стр. взносов)

1 стартмани

22.04.2013    12543    467    nelena    20    

Печать справки с места работы со средним заработком для ЗБУ и ЗУП

Справки Зарплата Зарплата v8 КА1 ЗУП2.5 ЗКБУ Россия Абонемент ($m)

Обработка печати справки с места работы со средним заработком, налогами (по выбору) для конфигурации ЗГУ и ЗУП

1 стартмани

01.04.2013    14012    301    qzaam    10    

Отчет по уплаченным страховым взносам с разбивкой по сотрудникам и отчетным периодам

Зарплата Бухгалтерские Налоговые Зарплата v8 КА1 БП2.0 ЗУП2.5 УПП1 БУ НУ ФОМС, ПФ, ФСС Абонемент ($m)

Отчет показывает в разрезе каждого сотрудника начальное и конечное сальдо по страховым взносам (только по отчетным годам), сумму начисленных и уплаченных взносов за каждый отчетный период и переходящее сальдо между периодами. Отчет собирает данные с даты введения стр. взносов)

1 стартмани

24.03.2013    9053    315    nelena    8    

Справки о доходах

Справки Зарплата Зарплата v8 ЗКБУ Россия БУ Абонемент ($m)

Внешний отчет, позволяющий формировать справки о зарплате сотрудников.

3 стартмани

18.03.2013    38357    268    Liones23    12    

Отчет по зарплате

Зарплата Бухгалтерские Зарплата v8 УПП1 БУ УУ Абонемент ($m)

Наглядно, понятно, просто! Из отчета мы узнаем сколько: начислено, к выплате, выплачено, задолженность. По предприятию, в иерархии подразделений, по сотруднику(ам).

1 стартмани

27.02.2013    17389    112    imozg    7    

Внешняя печатная форма т-53 с ФИО

Печатные формы документов Зарплата Зарплата v8 ЗУП2.5 Россия БУ Абонемент ($m)

Внешняя печатная форма т-53 с ФИО. Для тех у кого перестала работать после выхода обновления 2.5.62.1

1 стартмани

22.02.2013    11313    84    nick_189    7    

Расчет остатков отпусков, среднего заработка и взносов по списку сотрудников. ЗУП 2.5

Бухгалтерские Зарплата Зарплата v8 v8::СПР ЗУП2.5 Россия БУ Абонемент ($m)

Данная обработка позволяет рассчитать средний заработок, остаток отпусков и взносы с сумм отпусков сотрудников на заданную дату.

1 стартмани

12.02.2013    20088    228    Kosmj    3    

Настроить ЗУП? Да легко!

Зарплата Управленческий учет (прочее) Бухгалтерский учет Зарплата v8 КА1 ЗУП2.5 ЗКБУ УПП1 Россия БУ НДФЛ Абонемент ($m)

Специалисты, внедряющие зарплатные решения, а также бухгалтера по зарплате не дадут соврать, что процесс настройки зарплатной программы - творческий. Еще бы, информации, которую нужно держать в голове не то что много, ее слишком много. Нужно обладать познаниями как в нюансах законодательства, так и представлять себе особенности работы программы. Возможно, именно поэтому зарплата считается одним из самых сложных участков учета, и многие молодые внедренцы боятся ее как огня. При этом зарплатчики всегда востребованы, так как если без автоматизации, например, торговли еще можно обойтись, то без автоматизации учета зарплаты никак.

1 стартмани

16.01.2013    42539    763    tomvlad    59    

Сводная расчетная ведомость "наоборот"

Зарплата Бухгалтерские Зарплата v8 КА1 ЗУП2.5 УПП1 Россия УУ ФОМС, ПФ, ФСС Абонемент ($m)

Расчетная ведомость сотрудников организаций за период с разбивкой по месяцам, годам и видам расчетов для ЗиУП, УПП и КА.

1 стартмани

09.12.2012    19876    364    Uncore    14