Задачи по доработке типовых решений. ЗУП 3.1. Доработка выплаты аванса фиксированной суммой, проверка на отработанное время. Вывод предупреждения как в ЗУП 2.5

Публикация № 1165284

Учет и отчетность - Зарплата

ЗУП 3.1 Аванс фиксированной суммой доработка

Пример решения задачи, по учету отработанного времени за первую половину месяца, при выплате фиксированного аванса.

Разработано/протестировано на:

Версия конфигурации:  Зарплата и управление персоналом, редакция 3.1 (3.1.11.106)

Версия платформы: 1С: Предприятие 8.3 (8.3.12.1790)

Освещены вопросы:

  • Получения отработанного времени по сотруднику;
  • Работа с процедурой "ПоказатьВопрос" в обработчике "ПередЗаписью";
  • Работа с оповещениями пользователя при помощи БСП 3.0;

Описание задачи.

На предприятии ряду сотрудников аванс выплачивается фиксированной суммой, необходимо учитывать отработанное время за первую половину месяца и корректировать аванс согласно формуле:

([Сумма фиксированного аванса] / [Количество плановых дней по графику сотрудника]) * [Количество отработанных дней]

Если существуют отклонения по отработанному от планового времени, необходимо вывести предупреждение пользователю.

Командировка, как вид времени тоже включен в плановое отработанное время.

Теория.

В ЗУП 3.1 начисление аванса происходит тремя способами:

  • Расчетом за первую половину месяца;
  • Фиксированной суммой;
  • Процентом от тарифа;

При выплате фиксированной суммой – расчет производится без учета отработанного времени. Пользователю необходимо вручную выполнять корректировку суммы аванса.

Задать сумму фиксированного аванса можно в документе «Прием на работу», закладка «Оплата труда». Изменить сумму фиксированного аванса, а так же способ начисления можно в документах:  «Кадровый перевод», «Кадровый перевод списком», «Изменение оплаты труда», «Изменение аванса». Более подробно можно прочитать здесь.

По логике работы системы, гораздо правильней для учета отработанного времени использовать вид начисления «Расчетом за первую половину месяца», но исторически сложилось, что сумма выделенная сотруднику на аванс, рассчитывается каждому сотруднику индивидуально и не привязана к плановым начислениям сотрудника. Все изменения будем производить в документе «ВедомостьНаВыплатуЗарплатыВБанк».

Решение задачи.

Этап 1. Определим инструмент решения задачи и взаимодействие с пользователем.

На мой взгляд, для достижения поставленных целей можно воспользоваться следующими методами:

  • Внесение изменения непосредственно в конфигурацию;
  • Использовать механизм расширений;
  • Использовать внешнюю обработку заполнения табличных частей;

Внесение изменения непосредственно в конфигурацию, метод практически сразу отпал поскольку, конфигурация находится на поддержке и обновления в данной ситуации, будут вызывать, если не трудности, то дополнительные затраты времени;

Использовать механизм расширений, метод более гибкий, но к сожалению при наследовании объектов в расширении, придется заимствовать «ФормуДокумента», поскольку в работе необходимо будет совершать интерактивные действия с интерфейсом.

Использовать внешнюю обработку заполнения табличных частей, метод хорош тем, что нет необходимости вносить изменений ни в конфигурацию, ни в расширение, но пользователю, для запуска проверки, необходимо будет совершать дополнительные действия, т.е. нажать на кнопку с вероятностью в 99%, это когда-нибудь будет не сделано.

В данном случае задачу проще решить, используя механизм расширений. Возникает сразу ряд проблем…

Этап 2. Определим дополнительные ограничения на механизм доработки.

Первое что приходит в голову. Это момент проведения документа, поскольку вся проверка на корректность сумм аванса будет, происходит в момент записи/проведения документа, и в случае если будет выдано предупреждение, оно будет выведено в не модальном режиме, документ запишется в не зависимости от того, что ответит пользователь.

Подобные проблемы решаются различными способами, добавлением доп. реквизитов на форму, для хранения текущего флага записи документа и пр.

Но в данном случае лучше всего подойдет использование механизма общих настроек, конечно есть нюанс, связанный с тем что, для получения значений настроек необходимо обращаться к серверу, но поскольку по логике работы вся процедура проверки будет, происходит при записи документа, т.е. вся проверка происходит на сервере, а конечный список предупреждений будет просто передан клиенту, это не сильная нагрузка на систему, и конечно поддерживаются вне контекстные вызовы получение настроек из хранилища.

Схема работы следующая:

  • Создаем две общих настройки: ЗаписьДокументаПриНаличииОшибокПлановогоВремени и НеобходимаПроверкаПлановогоВремени, все они будут иметь тип Булево.
  • При создании документа на сервере, устанавливаем следующие значения настроек
ХранилищеОбщихНастроек.Сохранить("Расш1_ПроверкаПлановогоВремени", "ЗаписьДокументаПриНаличииОшибокПлановогоВремени", Ложь);
ХранилищеОбщихНастроек.Сохранить("Расш1_ПроверкаПлановогоВремени", "НеобходимаПроверкаПлановогоВремени", Истина);
  • Создаем процедуру возвращающую результат сравнения двух настроек:

ЗаписьДокументаПриНаличииОшибокПлановогоВремени ИЛИ НеобходимаПроверкаПлановогоВремени

Она будет возвращать значение в переменную Отказ, метода «ПередЗаписью» формы документа, две настройки и сравнение на ИЛИ, необходимы для тех случаев, если в документе не выбрана формы выплаты Аванс или если, к примеру, пользователь получил предупреждение о несоответствии сумм, поправил несколько строк и решил провести документ как есть.

  • Переопределяем процедуру модуля «ПередЗаписью», в ней мы проверяем, необходима ли проверка на плановое время через функцию описанную выше. Если проверка необходима, то выполняем функции сверки.

Этап 3.  Основные задачи по получению и обработки данных.

Первое что придется решить, это получение планового и отработанного времени сотрудника. Как всегда нюанс). Ведется ли табельный учет через документ «ТабельУчетаРабочегоВремени» или учет ведется методом отклонений от рабочего времени.  В зависимости от методов ведения учета придется обращаться к разным таблицам системы. В рассматриваемой задаче учет ведется методом отклонений.  

Для решения будем пользоваться методами общего модуля «УчетРабочегоВремениРасширенный», заполняем параметры и временные таблицы запроса используемого для получения отработанного и планового времени, но данный метод возвращает временную таблицу в целом по периоду, и по дням, соответственно к полученным таблицам необходимо применить сворачивания и отборы.

Второе и более тривиальное это интерактивная работа с пользователем вывод сообщений об ошибках и проведение/запись документа.

Для получения обратной связи от пользователя будем использовать функцию ПоказатьВопрос с обработкой оповещения.

Для вывода ошибок воспользуемся методами БСП 3.0, из общего модуля «ОбщегоНазначенияКлиентСервер»,  «ДобавитьОшибкуПользователю», «СообщитьОшибкиПользователю». Весь синтаксис методов далее будет понятен по коду…

Код, код, код…

Процедуры и функции постарался расположить в порядке вызова и логики работы.

Заимствуем в расширение форму документа «ВедомостьНаВыплатуЗарплатыВБанк» и приступаем…  Далее по тексту распишу только основные функции для сокращения статьи, более подробно можно просмотреть в расширении.

Переопределим процедуру формы документа «ПриСозданииНаСервере» и будем выполнять ее перед вызовом аналогичной процедуры конфигурации:

&НаСервере
Процедура Расш1_ПриСозданииНаСервереПеред(Отказ, СтандартнаяОбработка)
	
	//установим первоначальные значения
	ХранилищеОбщихНастроек.Сохранить("Расш1_ПроверкаПлановогоВремени", "ЗаписьДокументаПриНаличииОшибокПлановогоВремени", Ложь);
	ХранилищеОбщихНастроек.Сохранить("Расш1_ПроверкаПлановогоВремени", "НеобходимаПроверкаПлановогоВремени", Истина);
	
КонецПроцедуры

Затем переопределяем процедуру «ПередЗаписью» и будем выполнять ее перед основной:

&НаКлиенте
Процедура Расш1_ПередЗаписьюПеред(Отказ, ПараметрыЗаписи)
	
	Если ПолучитьЗначениеЗаписиДокумента() Тогда
		
		ПроверитьОплатуПоНормамВремениСотрудниковНаКлиенте();
		Отказ = ПолучитьЗначениеЗаписиДокумента();	
		
	КонецЕсли;
	
КонецПроцедуры

Распишем функцию ПолучитьЗначениеЗаписиДокумента:

&НаСервереБезКонтекста
Функция ПолучитьЗначениеЗаписиДокумента()
	
	//прочитаем значения
	ЗаписьДокументаПриНаличииОшибокПлановогоВремени = ХранилищеОбщихНастроек.Загрузить("Расш1_ПроверкаПлановогоВремени", "ЗаписьДокументаПриНаличииОшибокПлановогоВремени");
	НеобходимаПроверкаПлановогоВремени = ХранилищеОбщихНастроек.Загрузить("Расш1_ПроверкаПлановогоВремени", "НеобходимаПроверкаПлановогоВремени");
	
	Возврат ЗаписьДокументаПриНаличииОшибокПлановогоВремени ИЛИ НеобходимаПроверкаПлановогоВремени;
	
КонецФункции // ПолучитьЗначениеЗаписиДокумента()

Здесь все просто получаем значение из хранилища настроек и возвращаем результат сравнения.

Перейдем к основной процедуре. ПроверитьОплатуПоНормамВремениСотрудниковНаКлиенте.

&НаКлиенте
Процедура ПроверитьОплатуПоНормамВремениСотрудниковНаКлиенте()
	
	Если СпособВыплаты.Наименование = "Аванс" Тогда
		
		МассивПредупреждений = ПроверитьНормыРабочегоВремениПоСотрудникам();
		
		Если МассивПредупреждений.Количество() > 0 Тогда
			
			//добавим свои кнопки
			СписокКнопок = Новый СписокЗначений;
			СписокКнопок.Добавить("ПровестиИЗакрыть", "Провести и закрыть");
			СписокКнопок.Добавить("Записать", "Записать");
			СписокКнопок.Добавить("Нет", "Нет");
			
			Оповещение = Новый ОписаниеОповещения("ПослеОтветаНаВопрос", ЭтотОбъект);
			
			ПоказатьВопрос(Оповещение, "Обнаружены расхождения в подсчете сумм фиксированного аванса, связанных с отработанным временем. Записать документ?", СписокКнопок,
			
			0, , "Обратите внимание!");
			
			Ошибки = Неопределено;
			
			Для Каждого СтрокаПредупреждение Из МассивПредупреждений Цикл
				
				//найдем индекс строкис ошибкой
				ПараметрыОтбора = Новый Структура;
				ПараметрыОтбора.Вставить("ИдентификаторСтроки", СтрокаПредупреждение.ИдентификаторСтроки);
				
				НайденныеСтрокиСостава = Объект.Состав.НайтиСтроки(ПараметрыОтбора);
				
				Для Каждого НайденнаяСтрока Из НайденныеСтрокиСостава Цикл
					
					ФизЛицо = НайденнаяСтрока.ФизическоеЛицо.Наименование + ". ";
					СтрокаОтработано = "Отраб. Д: " + СтрокаПредупреждение.ОтработаноДней + ", Ч: " + СтрокаПредупреждение.ОтработаноЧасов + ". ";
					СтрокаПлан = "План. Д: " + СтрокаПредупреждение.НормаПоГрафикуДней + ", Ч: " + СтрокаПредупреждение.НормаПоГрафикуЧасов + ". ";
					СтрокаФормулаРасчета = "(" + СтрокаПредупреждение.Аванс + " / " + СтрокаПредупреждение.НормаПоГрафикуДней + ") * " + СтрокаПредупреждение.ОтработаноДней + " = " + Окр(СтрокаПредупреждение.РасчетнаяСуммаАванса,2); 
					СтрокаОписанияОшибки = Физлицо + СтрокаОтработано + СтрокаПлан + СтрокаФормулаРасчета;
					
					ОбщегоНазначенияКлиентСервер.ДобавитьОшибкуПользователю(Ошибки, "Объект.Состав[%1].КВыплатеСумма", СтрокаОписанияОшибки,, НайденнаяСтрока.НомерСтроки - 1);
					
				КонецЦикла;
				
			КонецЦикла;
			
		Иначе
			
			УстановитьЗначениеЗаписиДокумента(Ложь, Ложь);
			
		КонецЕсли;
		
		ОбщегоНазначенияКлиентСервер.СообщитьОшибкиПользователю(Ошибки);
		
	Иначе
		
		УстановитьЗначениеЗаписиДокумента(Ложь, Ложь);
		
	КонецЕсли;
	
КонецПроцедуры // ПроверитьОплатуПоНормамВремениСотрудниковНаКлиенте()

Кратко поясним. Процедура проверяет выбран ли вид оплаты «Аванс», если выбран то вызывает функцию ПроверитьНормыРабочегоВремениПоСотрудникам, которая возвращает массив предупреждений, если массив предупреждений не пуст, то все ошибки выводятся на форму а пользователю интерактивно предлагается действие.

Сама процедура ПроверитьНормыРабочегоВремениПоСотрудникам.

&НаСервере
Функция ПроверитьНормыРабочегоВремениПоСотрудникам()
	
	ХранилищеОбщихНастроек.Сохранить("Расш1_ПроверкаПлановогоВремени", "НеобходимаПроверкаПлановогоВремени", Ложь);	
	
	//получим таблицу значений с индентификатором строки и сотрудников
	ДокОбъект = РеквизитФормыВЗначение("Объект");
	ТаблицаСотрудников = ДокОбъект.Зарплата.Выгрузить(,"ИдентификаторСтроки, Сотрудник, КВыплате");
	
	//Добавим к таблице дополнительные колонки по авансу
	ТаблицаСотрудников.Колонки.Добавить("СпособРасчетаАванса", Новый ОписаниеТипов("ПеречислениеСсылка.СпособыРасчетаАванса"));
	ТаблицаСотрудников.Колонки.Добавить("Аванс", Новый ОписаниеТипов("Число"));
	
	ДополнитьТаблицуПлановымиАвансами(ТаблицаСотрудников);
	ОтобратьТаблицуПоОтбору(ТаблицаСотрудников, ВидСравнения.Равно, "СпособРасчетаАванса", Перечисления.СпособыРасчетаАванса.ФиксированнойСуммой);
	
	//Выборка по рабочего времени за весь период
	ДатаНачала = НачалоМесяца(Объект.Дата);
	ДатаОкончания = КонецМесяца(Объект.Дата);
	
	МассивСотрудников = ТаблицаСотрудников.ВыгрузитьКолонку("Сотрудник");
	
	МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;	
	СоздатьВТСотрудники(МенеджерВременныхТаблиц, МассивСотрудников, ДатаНачала);
	
	ПараметрыПолученияДанных = УчетРабочегоВремениРасширенный.ПараметрыДляЗапросВТДанныеУчетаВремениИСостоянийСотрудников();
	ПараметрыПолученияДанных.ДатаНачала = ДатаНачала;
	ПараметрыПолученияДанных.ДатаОкончания = КонецМесяца(ДатаНачала);
	
	ПараметрыПолученияДанных.МесяцДатаНачала = ДатаНачала;
	ПараметрыПолученияДанных.МесяцДатаОкончания = КонецМесяца(ДатаНачала);
	ПараметрыПолученияДанных.ДатаАктуальности = ТекущаяДата();
	
	УчетРабочегоВремениРасширенный.СоздатьВТДанныеУчетаВремениИСостоянийСотрудников(МенеджерВременныхТаблиц, Истина, ПараметрыПолученияДанных);
	ДанныеТабеляТ13 = МенеджерВременныхТаблиц.Таблицы.Найти("ВТДанныеУчетаВремениИСостоянийСотрудников").ПолучитьДанные().Выгрузить();
	ДанныеТабеляТ13.Сортировать("Дата");	
	
	ОтобратьТаблицуПоОтбору(ДанныеТабеляТ13,  ВидСравнения.МеньшеИлиРавно, "Дата", ДатаНачала +(86400*14));
	ДанныеТабеляТ13.Свернуть("Сотрудник, ВидУчетаВремени", "Дни, Часы");
	
	ОтобратьТаблицуПоОтбору(ДанныеТабеляТ13, ВидСравнения.ВСписке, "ВидУчетаВремени", ПолучитьРабочиеВидыВремени());	
	
	//получим общее количество отработанных часов
	ДанныеТабеляТ13.Свернуть("Сотрудник", "Дни, Часы");
	
	НормаПоГрафику = МенеджерВременныхТаблиц.Таблицы.Найти("ВТНормаВремени").ПолучитьДанные().Выгрузить();
	
	ОтобратьТаблицуПоОтбору(НормаПоГрафику, ВидСравнения.МеньшеИлиРавно, "Дата", ДатаНачала +(86400*14));	
	//ОтобратьДанныеПоПериоду(НормаПоГрафику, ДатаНачала);
	НормаПоГрафику.Свернуть("Сотрудник","ДниНорма, ЧасыНорма");
	
	ИтоговаяТаблица  = ПолучитьОбщуюТаблицуСОтработаннымИНормированнымВременем(ДанныеТабеляТ13, НормаПоГрафику, ТаблицаСотрудников);
	
	МассивПредупреждений = Новый Массив;
	
	Для Каждого СтрокаПредупреждение Из ИтоговаяТаблица Цикл
		
		СтруктураПредупреждения = Новый Структура;
		СтруктураПредупреждения.Вставить("Сотрудник", СтрокаПредупреждение.Сотрудник);
		СтруктураПредупреждения.Вставить("ОтработаноДней", СтрокаПредупреждение.ОтработаноДней);
		СтруктураПредупреждения.Вставить("ОтработаноЧасов", СтрокаПредупреждение.ОтработаноЧасов);
		СтруктураПредупреждения.Вставить("НормаПоГрафикуДней", СтрокаПредупреждение.НормаПоГрафикуДней);
		СтруктураПредупреждения.Вставить("НормаПоГрафикуЧасов", СтрокаПредупреждение.НормаПоГрафикуЧасов);
		СтруктураПредупреждения.Вставить("ИдентификаторСтроки", СтрокаПредупреждение.ИдентификаторСтроки);
		СтруктураПредупреждения.Вставить("КВыплате", СтрокаПредупреждение.КВыплате);
		СтруктураПредупреждения.Вставить("СпособРасчетаАванса", СтрокаПредупреждение.СпособРасчетаАванса);
		СтруктураПредупреждения.Вставить("Аванс", СтрокаПредупреждение.Аванс);
		
		РасчетнаяСуммаАванса = (СтрокаПредупреждение.Аванс / СтрокаПредупреждение.НормаПоГрафикуДней) * СтрокаПредупреждение.ОтработаноДней;
		
		СтруктураПредупреждения.Вставить("РасчетнаяСуммаАванса", РасчетнаяСуммаАванса);
		
		Если Цел(РасчетнаяСуммаАванса) <> Цел(СтрокаПредупреждение.КВыплате) Тогда  
			
			ХранилищеОбщихНастроек.Сохранить("Расш1_ПроверкаПлановогоВремени", "НеобходимаПроверкаПлановогоВремени", Истина);
			МассивПредупреждений.Добавить(СтруктураПредупреждения);
			
		КонецЕсли;
		
	КонецЦикла;
	
	Возврат МассивПредупреждений;
	
КонецФункции // ПроверитьНормыРабочегоВремениПоСотрудникам()

Так же дополнительно процедура для заполнения временной таблицы сотрудников. СоздатьВТСотрудники.

&НаСервереБезКонтекста
Процедура СоздатьВТСотрудники(МенеджерВременныхТаблиц, МассивСотрудников, Месяц, ДатаАктуальности = Неопределено, ДатаНачала = Неопределено, ДатаОкончания = Неопределено)
	
	ТаблицаСотрудники = Новый ТаблицаЗначений;
	ТаблицаСотрудники.Колонки.Добавить("Сотрудник", Новый ОписаниеТипов("СправочникСсылка.Сотрудники"));
	ТаблицаСотрудники.Колонки.Добавить("Месяц", Новый ОписаниеТипов("Дата"));
	ТаблицаСотрудники.Колонки.Добавить("ДатаАктуальности", Новый ОписаниеТипов("Дата"));
	ТаблицаСотрудники.Колонки.Добавить("ДатаНачала", Новый ОписаниеТипов("Дата"));
	ТаблицаСотрудники.Колонки.Добавить("ДатаОкончания", Новый ОписаниеТипов("Дата"));    
	
	Для Каждого Сотрудник Из МассивСотрудников Цикл
		СтрокаСотрудники = ТаблицаСотрудники.Добавить();
		СтрокаСотрудники.Сотрудник = Сотрудник;
	КонецЦикла;
	
	ТаблицаСотрудники.ЗаполнитьЗначения(Месяц, "Месяц");
	ТаблицаСотрудники.ЗаполнитьЗначения(?(ДатаАктуальности = Неопределено, ТекущаяДата(), ДатаАктуальности), "ДатаАктуальности");
	ТаблицаСотрудники.ЗаполнитьЗначения(?(ДатаНачала = Неопределено, Месяц, ДатаНачала), "ДатаНачала");
	ТаблицаСотрудники.ЗаполнитьЗначения(?(ДатаОкончания = Неопределено, КонецМесяца(Месяц), ДатаОкончания), "ДатаОкончания");
	
	Запрос = Новый Запрос(
	"ВЫБРАТЬ
	|    ТаблицаСотрудники.Сотрудник,
	|    ТаблицаСотрудники.Месяц,
	|    ТаблицаСотрудники.ДатаАктуальности,        
	|    ТаблицаСотрудники.ДатаНачала,
	|    ТаблицаСотрудники.ДатаОкончания
	|ПОМЕСТИТЬ ВТСотрудники
	|ИЗ
	|    &ТаблицаСотрудники КАК ТаблицаСотрудники");
	
	Запрос.МенеджерВременныхТаблиц = МенеджерВременныхТаблиц;
	Запрос.УстановитьПараметр("ТаблицаСотрудники", ТаблицаСотрудники);
	Запрос.Выполнить();
	
КонецПроцедуры

Кратко поясним. Механизм работы.

Получаем таблицу сотрудников из документа, нам будет необходим Сотрудник, ИдентификаторСтроки для подвязки предупреждения к строке табличной части с сотрудниками и КВыплате в ней содержится сумма аванса. Для дополнительного отбора по сотрудникам, чей аванс указан фиксированной суммой, дополним таблицу двумя колонками СпособРасчетаАванса и Аванс (сумма назначенная сотруднику в системе), заполняем данные колонки запросом к регистру сведений «ПлановыеАвансы».

Оставляем в таблице только тех сотрудников у которых аванс рассчитывается фиксированной суммой.

Получаем период аванса, в данном случае берем дату документа и получаем начало и конец месяца. Передаем список сотрудников и периоды отбора в запрос общего модуля УчетРабочегоВремениРасширенный, выгружаем две временные таблицы: ВТДанныеУчетаВремениИСостоянийСотрудников и ВТНормаВремени, в них хранятся данные по отработанному и по нормам времени на сотрудника.

Далее выполняем отбор по датам только за первую половину месяца т.е. по 15 число.  Сворачиваем таблицы по сотрудникам и суммируем отработанные дни и часы.

При помощи запроса формируем одну общую таблицу с сотрудниками отработанным/нормативным временем и фактической суммой выплаты и выплаты зарегистрированной в системе как плановой, если присутствуют расхождения устанавливаем флаг в общих настройках о том что необходима проверка планового времени, данные из таблицы передаем в массив структур и возвращаем на клиент.

На клиенте фомируем список ошибок пользователей и показываем их на форме. Далее обрабатываем результат ответа пользователя либо проводим, как есть либо отказываемся от записи, и он корректирует результат.

Статья не претендует на универсальное решение проблемы. Но надеюсь поможет. 

----

Мой блог с заметками здесь.

Написать мне telegram можно здесь.

Скачать файлы

Наименование Файл Версия Размер
Задачи по доработке типовых решений. ЗУП 3.1. Доработка выплаты аванса фиксированной суммой, проверка на отработанное время. Вывод предупреждения как в ЗУП 2.5.:
.cfe 37,87Kb
09.12.19
3
.cfe 37,87Kb 3 Скачать

Специальные предложения

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение

См. также

Трудовой договор, Дополнительное соглашение, Лист ознакомления, Договор о материальной ответственности, Договор о коммерческой тайне, Согласие на обработку персональных данных для ЗУП 3.1

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП3.x Россия БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Печатные формы документов

Комплект печатных форм для отдела кадров для документов Прием на работу и Кадровый перевод: Трудовой договор, Доп. соглашение к трудовому договору, Лист ознакомления с локальными нормативными актами, Договор о полной материальной ответственности, Договор о неразглашении коммерческой тайны, Согласие на обработку персональных данных.

2 стартмани

12.03.2019    17536    100    Asenka    11       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Справка 2-НДФЛ для ЗУП 2.5 / ЗУП 3.1 (Приложение № 5 к Приказу ФНС России от 02.10.2018 № ММВ-7-11/566@)

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП2.5 ЗУП3.x БУ Зарплата НДФЛ Абонемент ($m) Справки

Печатная форма Справки 2-НДФЛ для ЗУП 2.5 / ЗУП 3.1 Форма с 2019 года Приложение № 5 к Приказу ФНС России от 02.10.2018 № ММВ-7-11/566@

1 стартмани

10.01.2019    13441    131    prime9    20       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Расчет Тарификации и зарплаты в средних общеобразовательных школах для ЗКГУ-3.1 (релиз 3.1.12.113)

Отчеты и формы Бухгалтер Архив с данными v8 v8::СПР ЗКГУ3.0 Государственные, бюджетные структуры Россия БУ Госбюджет Windows Зарплата Абонемент ($m) Бухгалтерия

Данная настройка конфигурации предназначена для расчета Тарификации педработников и расчета зарплаты в средних общеобразовательных учреждениях. Настройка сделана на базе Типовой конфигурации "Зарплата и кадры государственного учреждения" редакции 3.1.

2 стартмани

05.09.2018    13183    31    ivnik    8       

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Проверка и корректировка данных по выплате зарплаты

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v8 v8::СПР ЗКГУ3.0 ЗУП3.x Россия БУ Госбюджет Windows Зарплата Абонемент ($m) Закрытие периода Бухгалтерские Анализ учета

Обработка показывает остатки и движения взаиморасчетов с сотрудниками. Также обработка может откорректировать сумму остатков. Конфигурации: "Зарплата и управление персоналом" , релиз не ниже 3.1.2.105 и "Зарплата и кадры государственного учреждения" , релиз не ниже 3.1.2.105.

2 стартмани

08.06.2018    14674    116    APTEM_SLV    9       

Автоматическое заполнение графиков в ЗУП 3.1

Инструменты и обработки Бухгалтер Архив с данными v8 v8::СПР ЗУП3.x Россия БУ Зарплата Учет рабочего времени Абонемент ($m) Обработка справочников

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    12943    19    notserioussam    2       

Перенос документов, остатков и справочников КА 1.1 => КА 2 / УТ 11. Обновлено до КА 2.4.12.х и УТ 11.4.11.х! Промо

Более 130 компаний выполнили переход на КА 2 или УТ 11 с помощью нашей разработки! Позволяет перенести не только остатки и справочники (как типовая обработка), но и документы за нужный период времени. Предоставляем техподдержку, оперативно исправляем замечания, выпускаем обновления при выходе новых релизов программ 1С. Вы можете проверить разработку до покупки: сделаем бесплатный тестовый перенос из вашей базы КА 1.1 и предоставим доступ к базе-результату через веб-клиент!

29700 руб.

Настройки отчета "Анализ начислений и удержаний" для ЗУП/ЗГУ 3.1

Отчеты и формы Бухгалтер Архив с данными v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Зарплата НДФЛ ФОМС, ПФ, ФСС Абонемент ($m) Бухгалтерские

Несколько полезных настроек отчета "Анализ начислений и удержаний" для зарплаты редакции 3.1. В состав входят настройки: Свод в разрезе налогообложения, Сводные данные для статистики, Реестр пособий, Расчетная ведомость по зарплате, Свод в разрезе финансирования, Отклонения от режима работы, Свод по зарплате в разрезе ИФНС, Начисления с детализацией отсутствий, Лицевые счета сотрудников, Распределение отпусков, Сводка затрат

2 стартмани

03.05.2018    23227    267    the1    33       

Синхронизация (выгрузка) данных ЗУП 3.1 - БП 2.0, УПП 1.3

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ v8::СПР БП2.0 ЗУП3.x Россия БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Перенос данных из 1C8 в 1C8

Подобная выгрузка не была предусмотрена разработчиками 1С, поэтому и существует эта публикация. Поддерживается выгрузка оценочных обязательств и резервов отпусков. Непосредственная выгрузка в базу Бухгалтерии.

3 стартмани

22.03.2018    29926    552    diso    161       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1

Инструменты и обработки Системный администратор Программист Бухгалтер Документ XML v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Зарплата Абонемент ($m) Обмен через XML Перенос данных из 1C8 в 1C8

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1. Позволяют вести параллельную работу в базах ЗУП редакций 2,5 и 3.1.

10 стартмани

06.03.2018    28722    126    kostya_whiskas    23       

Трудовой договор, Дополнительное соглашение, Материальная ответственность, Коллективная материальная ответственность, Кадровый перевод, Индексация, Т-53 для ЗУП 3 внешние (7 печатных форм). Создание ведомостей по каждому сотруднику одной кнопкой

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП3.x БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Печатные формы документов

1. Комплект из 6 печатных форм для документов: Прием на работу, Индексация, Кадровый перевод, Кадровый перевод списком для ЗУП 3.1.11 и более ранних Трудовой договор, дополнительное соглашение, договор личной материальной ответственности, договор коллективной материальной ответственности, индексация, Ведомость Т-53 без лишних строк. Не требуется изменения конфигурации. Подключается через стандартное подключение внешних обработок. 2. Обработка для создания ведемостей из начисления зарплаты. 3. Расширение конфигурации для ЗУП 3.1.11 и КА 2.4.6 для редактирования стажа как в ЗУП 2.5 (Из трудовой деятельности сотрудника. Если ввели строки трудовой деятельности, то стаж считается до даты приема сотрудника).

1 стартмани

26.01.2018    33810    537    p.ugrumov    96       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

Проверка данных после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1

Отчеты и формы Бухгалтер Архив с данными v8 v8::СПР ЗУП3.x Россия БУ Зарплата Абонемент ($m) Бухгалтерский учет Перенос данных из 1C8 в 1C8

Описаны данные, которые необходимо проверить после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1. Описано, на что необходимо обратить внимание, где найти перенесенные данные, что НЕ переносится, где найти настройки.

1 стартмани

17.01.2018    20029    139    btydj    3       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.130.х, КА 2.4.11.х и ERP 2.4.11.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Инструкция по настройке загрузки из ФСС электронных листков нетрудоспособности ЭЛН в документ 1С Начисление по больничному листу

Статья Программист Бухгалтер Архив с данными v8 КА1 ЗУП2.5 УПП1 Россия БУ Зарплата ФОМС, ПФ, ФСС Абонемент ($m) Внешние источники данных

Клиент (страхователь) работает в программе "1С Зарплата и управление персоналом ред.2.5" сдает отчетность через Контур или СБИС и не собирается подключать 1С-Отчетность, при этом хочет загружать электронные больничные в программу 1С Зарплата. Подобная ситуация может быть и для других конфигураций в которых есть документ "Начисление по больничному листу", например Комплексная автоматизация 1.1, Управление производственным предприятием 1.3.

1 стартмани

28.11.2017    119348    198    rusmil    120       

Справка о заработной плате и других доходах (измененная форма №46)

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v8 v8::СПР ЗКГУ3.0 Россия БУ Зарплата Абонемент ($m) Справки

Форма разработана для автоматизированного формирования справки по форме № 46. Внешний отчет с возможностью пользовательских настроек.

3 стартмани

24.11.2017    26710    48    agospodarin    14       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Правила обмена ЗУП 3.1 - БП 2.0 и ЗУП 3.1 - УПП 1.3 (отражение, ведомости и справочники)

Инструменты и обработки Программист Документ XML v8 v8::БУ v8::СПР БП2.0 БП3.0 ЗУП3.x Россия БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Перенос данных из 1C8 в 1C8 Обмен через XML

Правила обмена для выгрузки документов "Отражение зарплаты в бухучете", "Ведомость в банк", "Ведомость в кассу", справочников "Сотрудники" и "Физические лица"

1 стартмани

01.08.2017    63602    1510    forseil    199       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Поиск и исправление ошибок при заполнении 6-НДФЛ в ЗУП 2.5, Бухгалтерии 2.0, УПП 1.3 версия от 28.08.2018

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ v8::СПР БП2.0 ЗУП2.5 УПП1 Россия БУ Зарплата НДФЛ Абонемент ($m) Регламентированная отчетность Бухгалтерские Анализ учета

Помощь в поиске и исправлении ошибок при заполнении отчёта 6-НДФЛ в ЗУП 2.5, Бухгалтерии 2.0 Просмотр всех записей регистров, имеющих отношение к учёту НДФЛ с детализаций до сотрудника и документа. Ручная корректировка основных регистров. Обновлённая версия от 02.07.2018г

3 стартмани

25.10.2016    28542    205    serge_msk    17       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

6-НДФЛ - Формирование, проверка, корректировка, перенос в типовой отчет. ЗУП 2.5 / УПП 1.3 / ЗиКБУ

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 v8::СПР ЗУП2.5 ЗКБУ УПП1 Россия БУ Зарплата НДФЛ Абонемент ($m) Налоговые Бухгалтерские

Формирование 6-НДФЛ по первичным документам (НЕ ПО РЕГИСТРАМ) для ЗУП 2.5 / УПП 1.3 / ЗиКБУ. Всё что требуется - это правильно заполнить даты выплаты дохода в документах начисления!

1 стартмани

27.07.2016    40358    599    madonov    189       

Перенос данных из ЗУП 2.5 в ЗУП 3.1

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::СПР ЗУП2.5 ЗУП3.x БУ Windows Зарплата Управление персоналом (HRM) Абонемент ($m) Перенос данных из 1C8 в 1C8

Данная обработка предназначена для переноса некоторых данных из ЗУП 2.5 в ЗУП 3.1 через COM-соединения. Обработка была написана потому, что типовые правила переноса не предоставляют возможности переносить данные по отдельности, а некоторые данные не переносят вовсе. Тестировалась на версии 3.1.10.78 (8.3.12.1790).

1 стартмани

26.05.2016    34650    688    yojeeg    70       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Краткий регистр налогового учета НДФЛ 2016

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v8 v8::БУ v8::СПР БП3.0 ЗУП3.x Россия БУ Windows Зарплата НДФЛ Абонемент ($m) Бухгалтерские Налоговые

C 2016 года у ИФНС повысились требования к учету НДФЛ. Предлагаю вам отчет "Краткий регистр налогового учета НДФЛ", компактный, простой и информативный. Самое главное - от обычного "Регистр налогового учета НДФЛ" отличается размерами.

2 стартмани

18.04.2016    24010    25    Craig    3       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Откуда берутся данные 6-НДФЛ в ЗУП 2.5

Отчеты и формы Бухгалтер Архив с данными v8 ЗУП2.5 Россия БУ Windows Зарплата НДФЛ Абонемент ($m) Бухгалтерский учет

Как заполняются данные 6-НДФЛ? Файл с картинками и описанием дополнений учета НДФЛ в ЗУП 2_5_99 по сравнению с прежними версиями.

1 стартмани

03.02.2016    169579    168    milov.aleksey    126