Обработка "Дни рождения сотрудников" для 8.1 (18/07/2009 добавлена возможность печати)

Отчеты - Разное

Информация о предстоящих ДР сотрудников в наглядном виде
18/07/2009 добавлена возможность печати

Обработка представляет в удобном наглядном виде информацию о днях рождения сотрудников.

Тестировалась на УПП.

Сотрудники, у которых в этом году намечается юбилей выделяются синим цветом.

При двойном щелчке на сотруднике открывается элемент справочника "Сотрудники".

18/07/2009 добавлена возможность печати.

Скачать файлы

Наименование Файл Версия Размер
ДниРожденияСотрудников (с возможностью печати)
.epf 15,23Kb
03.11.09
409
.epf 15,23Kb 409 Скачать

См. также

Комментарии
1. Анатолий (hame1e00n) 479 09.07.09 20:29 Сейчас в теме
Скачиваем, тестируем и комментируем. Спасибо тем, кто поставил плюсик))
2. Евгений Люлюк (Evg-Lylyk) 2021 09.07.09 20:43 Сейчас в теме
Цвета можно и не такие яркие ;)
3. Анатолий (hame1e00n) 479 09.07.09 20:49 Сейчас в теме
(2) Окей, можно исправить)
Evg-Lylyk; +1 Ответить
4. Юрий Тимофеев (Tatitutu) 3680 09.07.09 20:50 Сейчас в теме
(3) Плюс поставил - удобно. (Платформу укажи в описании)
hame1e00n; +1 Ответить
5. Анатолий (hame1e00n) 479 09.07.09 20:55 Сейчас в теме
(4) Указал вроде бы при добавлении, сейчас добавлю в описание
6. Юрий Тимофеев (Tatitutu) 3680 09.07.09 21:02 Сейчас в теме
Молодец. Вот теперь скачал.
7. Фаниль Исламов (fancy) 10.07.09 07:14 Сейчас в теме
Скачал, запустил, почему-то не нашел себя в списке работников...:(
9. Фаниль Исламов (fancy) 10.07.09 07:41 Сейчас в теме
Поправил первый запрос (когда указано подразделение и организация). Используем БП 1.6.13.3 - в ней в справочнике Сотрудники организаций нет реквизита Подразделение, зато есть ресурс Подразделение в регистре РаботникиОрганизаций. Теперь работает:)
hame1e00n; +1 Ответить
11. Анатолий (hame1e00n) 479 10.07.09 10:20 Сейчас в теме
(10) Спасибо за комментарий, буду иметь ввиду
12. Ольга Пошинова (Olyunchik) 10.07.09 12:01 Сейчас в теме
+!!! Удобно для назначения пенсии кадровикам.
hame1e00n; +1 Ответить
13. Александр Рытов (Арчибальд) 2661 10.07.09 12:25 Сейчас в теме
(12) Кадровикам пенсию не назначишь... Они сами кому хошь назначат...
14. Ольга Пошинова (Olyunchik) 10.07.09 12:37 Сейчас в теме
(13) ;=))) Я имела ввиду что им удобно. Уже оценили...
15. Анатолий (hame1e00n) 479 10.07.09 14:07 Сейчас в теме
(14) Спасибо, всегда приятно осознавать, что твой труд полезен людям :-)
16. Chin (ChinChin) 10.07.09 15:38 Сейчас в теме
Надеюсь данные на скриншотах не реальные, а то какая-никакая а конфиденциальная информация...
17. Анатолий (hame1e00n) 479 10.07.09 15:40 Сейчас в теме
(16) Конечно, на скриншотах, обработка, запущенная на УПП демо
18. Петр Дорошкевич (alfanika) 314 10.07.09 16:50 Сейчас в теме
Хорошая обработка. Плюс
hame1e00n; +1 Ответить
19. Олег Пономаренко (O-Planet) 6712 10.07.09 22:42 Сейчас в теме
Испугалсо, увидев на главной аватарку таких расцветок...
20. Анатолий (hame1e00n) 479 10.07.09 22:44 Сейчас в теме
(19) На вкус и цвет...))) Могу исправить, если будут еще высказываться замечания по этому поводу)
21. Дмитрий Бухалов (Re:аниматор) 395 11.07.09 08:51 Сейчас в теме
Если в справочнике Сотрудники организации представление сотрудника с инициалами, а физ. лицо с полными данными, то при клике на таблице выходит ошибка:
{Форма.Форма(439)}: Ошибка при вызове метода контекста (ПолучитьФорму): Элемент не выбран!
ЭлементСправочника.ПолучитьФорму().Открыть();
по причине:
Элемент не выбран!

код:
Процедура ТПВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)

ЭлементСправочника = Справочники.СотрудникиОрганизаций.НайтиПоНаименованию(ВыбраннаяСтрока.ФИО);
ЭлементСправочника.ПолучитьФорму().Открыть();

КонецПроцедуры

не совсем правильно искать по ФИО. проше в запросе ссылку тянуть в ТЗ, и скрытой сделать, но переход по данному реквизиту

еще:
Для Каждого ТекСтрока Из ТаблицаДанных Цикл
Если ТекСтрока.ДатаРождения = Дата(1, 1, 1) Тогда
ТаблицаДанных.Удалить(ТекСтрока);
КонецЕсли;
КонецЦикла;

можно заменить на
в запросах
И ФизическиеЛица.ДатаРождения <> &ПустаяДата

Запрос.УстановитьПараметр("ПустаяДата", Дата(1, 1, 1));

выборка сразу исключит пустые даты и не надо будет перебирать весь список и удалять физ. лиц с пустой датой рождения
25. Анатолий (hame1e00n) 479 11.07.09 12:08 Сейчас в теме
(21), (22), (23) спасибо, учтем. (24) плюсанул
26. Анатолий (hame1e00n) 479 11.07.09 12:28 Сейчас в теме
27. Дмитрий Бухалов (Re:аниматор) 395 11.07.09 14:43 Сейчас в теме
(26) запрос какой то сложный 3 таблицы, РегистрСведений.РаботникиОрганизаций, Справочник.СотрудникиОрганизаций, Справочник.ФизическиеЛица

проше сделать так:

"ВЫБРАТЬ
| РаботникиОрганизаций.Сотрудник КАК ФИО,
| РаботникиОрганизаций.Сотрудник.Физлицо.ДатаРождения КАК ДатаРождения
|ИЗ
| РегистрСведений.РаботникиОрганизаций.СрезПоследних КАК РаботникиОрганизаций
|ГДЕ
| (РаботникиОрганизаций.ПодразделениеОрганизации = &ПодразделениеОрганизации
| ИЛИ РаботникиОрганизаций.ПодразделениеОрганизации.Родитель = &ПодразделениеОрганизации)
| И РаботникиОрганизаций.Организация = &Организация
| И (НЕ РаботникиОрганизаций.ПричинаИзмененияСостояния В (&МассивЗапрещенныхСостояний))
|
|УПОРЯДОЧИТЬ ПО
| ДатаРождения
|АВТОУПОРЯДОЧИВАНИЕ"

одно и тоже =)
22. Дмитрий Бухалов (Re:аниматор) 395 11.07.09 08:53 Сейчас в теме
... да и запрос можно было сделать один, а в зависимости от условий подключать к тексту запроса условия, а так 4 по сути одинаковых запросов но с разными условиями
23. Дмитрий Бухалов (Re:аниматор) 395 11.07.09 08:59 Сейчас в теме
СотрудникиОрганизаций.Физлицо.Наименование КАК ФИО,
СотрудникиОрганизаций.Ссылка КАК Ссылка,

или вобще убрать ...КАК ФИО а оперировать с Ссылкой
...

ЭлементСправочника = ВыбраннаяСтрока.Ссылка.ПолучитьФорму().Открыть();
24. igor_gk (igor_gk) 46 11.07.09 11:25 Сейчас в теме
Ну цвета самому поправить можно... А вообще вещь полезная - мои быстрее поймут прелести работы в УПП :)
Плюс, плюс, плюс
А вот поставить плюс - не могу, "в минуса" загнали а оттуда плюсы не ставятся... Помогите из минусов вылезти - плюсаните, я в долгу не останусь :)
kivas; hame1e00n; +2 2 Ответить
28. Дмитрий Бухалов (Re:аниматор) 395 11.07.09 15:01 Сейчас в теме
а так можно все 4 запроса заменить на один:

Запрос.Текст = "ВЫБРАТЬ
| РаботникиОрганизаций.Сотрудник КАК ФИО,
| РаботникиОрганизаций.Сотрудник.Физлицо.ДатаРождения КАК ДатаРождения
|ИЗ
| РегистрСведений.РаботникиОрганизаций.СрезПоследних КАК РаботникиОрганизаций
|ГДЕ
| (НЕ РаботникиОрганизаций.ПричинаИзмененияСостояния В (&МассивЗапрещенныхСостояний))
| И РаботникиОрганизаций.Сотрудник.Физлицо.ДатаРождения <> ДАТАВРЕМЯ(1, 1, 1)";

Если Не Подразделение.Пустая() Тогда
ТекстЗапроса = ТекстЗапроса + Символы.ПС + " И РаботникиОрганизаций.ПодразделениеОрганизации В ИЕРАРХИИ (&Подразделение)";
Запрос.УстановитьПараметр("Подразделение", Подразделение);
КонецЕсли;

Если Не Организация.Пустая() Тогда
ТекстЗапроса = ТекстЗапроса + Символы.ПС + " И РаботникиОрганизаций.ОбособленноеПодразделение В ИЕРАРХИИ (&Организация)";
Запрос.УстановитьПараметр("Организация", Организация);
КонецЕсли;

Запрос.Текст = Запрос.Текст + "
|
|УПОРЯДОЧИТЬ ПО
| ДатаРождения
|АВТОУПОРЯДОЧИВАНИЕ";
hame1e00n; +1 Ответить
30. Анатолий (hame1e00n) 479 12.07.09 00:17 Сейчас в теме
(28), (29) Обновил обработку, теперь один запрос :-)
29. Дмитрий Бухалов (Re:аниматор) 395 11.07.09 15:04 Сейчас в теме
уточнее по фильтру Организация

Если Не Организация.Пустая() Тогда
ТекстЗапроса = ТекстЗапроса + Символы.ПС + " И РаботникиОрганизаций.ОбособленноеПодразделение = &Организация";
Запрос.УстановитьПараметр("Организация", Организация);
КонецЕсли;
hame1e00n; +1 Ответить
31. Maniac (Eugeneer) 13.07.09 10:10 Сейчас в теме
Реализация отвратительная. Ошибок много. Под УТ не работает, хотя написано для всех. "По идее" так не льзя. если уже и думаешь что будет работать надо тестировать. а если делал только на одной то тогда только и пиши что для одной конфигурации.
33. Анатолий (hame1e00n) 479 13.07.09 12:21 Сейчас в теме
(31) Уважаемый, какие конкретно ошибки Вы нашли?
Я не писал что она будет ОБЯЗАТЕЛЬНО работать на всех типовых конфигурациях, учитесь читать. Вот товарищ fancy пояснил, что исправить, чтобы работало на БП, респект ему, а ваша критика не конструктивна.
Насчет того что тестировалась только на УПП, я написал, смотрите описание в шапке.
32. Яков Коган (Yashazz) 2140 13.07.09 12:05 Сейчас в теме
Хотелось бы пользовательскую настройку цветов. И не "организацию" и "подразделение", а нормальный отбор.
34. Олег (Punisher) 14.07.09 10:56 Сейчас в теме
На Бухгалтерии Украины (работаит). ПРавда что-то с фильтрами по организациям, но я думаю подправить можно. За-то ярко раскрашено, что и не лень скачать ;)
hame1e00n; +1 Ответить
35. Роман Журавлев (Borodach) 144 17.07.09 21:08 Сейчас в теме
Это не будет работать в 1С "Управление торговлей". Укажите в описании, идея интересная, возможно пригодится.
hame1e00n; +1 Ответить
36. Анатолий (hame1e00n) 479 18.07.09 15:48 Сейчас в теме
Добавил возможность печати, скачиваем, комментируем...
38. Александр Глотов (_Xelon_) 5 24.07.09 14:48 Сейчас в теме
(36) За возможность печати особое спасибо. Удобно. Уже в офисе вывесил дни рождения :).
hame1e00n; +1 Ответить
37. Анна Аверкова (Nuta) 24.07.09 12:46 Сейчас в теме
Спасибо за обработку! Полезная штука.
hame1e00n; +1 Ответить
39. Анатолий (adm_tolik_in) 29.07.09 15:01 Сейчас в теме
40. Анатолий (hame1e00n) 479 29.07.09 18:57 Сейчас в теме
41. Ю П (julia-1-1) 31.07.09 18:01 Сейчас в теме
Спасибо! немного подправила и все отлично.
Еще если печать в день когда у какого-н. сотрудника ДР в печатной форме эта строка с белым шрифтом, т.е. ее не видно.
hame1e00n; +1 Ответить
42. Анатолий (hame1e00n) 479 31.07.09 19:25 Сейчас в теме
(41) Спасибо, исправил этот косячок))
43. Лев Мешалкин (lbm03) 13.08.09 13:24 Сейчас в теме
Здорово!Большое спасибо.Кадры будут довольны
44. Арсен (Арсенал) 21.09.09 18:34 Сейчас в теме
hame1e00n Привет, не могу скачать твою обработку-чтобы ее оценить, если можно то кинь другую ссылку на скачивание плиз!!!
45. sashavojak vojak (italmix) 06.10.09 19:20 Сейчас в теме
Сделайте пожалуйста:
1.Дни рождения работников клиентов.
2.Работает под УТП но с ошибками, нужно чтобы без ошибок
47. Анатолий (hame1e00n) 479 03.11.09 10:10 Сейчас в теме
(45) Какие именно ошибки возникают?
46. "Я" ("Я") 28.10.09 10:12 Сейчас в теме
скачала, все работает, при скачке расширение куда-то у файла пропало :)
добавила .epf :)
48. Alexandr Maloi (maloi_a) 10.11.09 13:41 Сейчас в теме
Подправил немного для УПП для Казахстана. Всё работает. Цвета тоже заменил.
49. Ольга Погожева (0127) 07.06.10 10:16 Сейчас в теме
)) Казалось бы ... мимо проходила столько раз... А сегодня понадобилась!СПАСИБО :{}
50. sound sound (sound) 524 26.10.10 16:18 Сейчас в теме
Цвета, конечно ... на любителя :) , а в целом неплохо
51. sound sound (sound) 524 26.10.10 18:02 Сейчас в теме
Предлагаю во все запросы добавить "РАЗРЕШЕННЫЕ", а то когда есть ограничение на уровне записей, как у меня, то лажа выходит
52. Елена (elena_77) 21.10.11 19:44 Сейчас в теме
На УПП работает. Кадры довольны.
53. Reals13 (Белка13) 21.03.13 16:15 Сейчас в теме
Немного доработала. Все здорово
Оставьте свое сообщение