Справка-расчет для ФСС (ЗУП 2.5)

Печать - Справки

В релизе 2.5.116.1 появился отчет "Справка-расчет для ФСС", который не заполняется. В публикации представлено исправление типового отчета.

В релизе 2.5.116.1 отчет "Справка-расчет для ФСС" не формируется, выводится процедура СформироватьПустографку(), вместо СформироватьМакет(Результат, ТаблицаЗначений).

Исправление заключается в следующем:

1. В процедуре Сформировать отчет - стр. 22 добавляем

// +ваша метка изменений
    Организация = Неопределено;
    
    Для каждого ЭлементОтбора Из НастройкиОтчета.Отбор.Элементы Цикл
        Если ЗначениеЗаполнено(ЭлементОтбора.ПравоеЗначение) И ТипЗнч(ЭлементОтбора.ПравоеЗначение) = Тип("СправочникСсылка.Организации") Тогда
            Организация = ЭлементОтбора.ПравоеЗначение;    
        КонецЕсли;
    КонецЦикла;     
// -ваша метка изменений

2. В этой же процедуре - строка 61

Если ТаблицаЗначений.Количество() > 0 Тогда
        СформироватьМакет(Результат, ТаблицаЗначений);
    Иначе
        // +ваша метка изменений
        //СформироватьПустографку(Результат);
        Если ЗначениеЗаполнено(Организация) Тогда
            НоваяСтрока = ТаблицаЗначений.Добавить();
            НоваяСтрока.Организация = Организация;
            
            СформироватьМакет(Результат, ТаблицаЗначений);
        Иначе
            СформироватьПустографку(Результат);    
        КонецЕсли;
        // -ваша метка изменений
    КонецЕсли;

Собственно сам исправленный отчет тоже прикладываю.

Скачать файлы

Наименование Файл Версия Размер
Справка-расчет для ФСС (ЗУП 2.5):
.erf 54,58Kb
28.03.17
25
.erf 1.0 54,58Kb 25 Скачать

См. также

Комментарии
1. Нина (user712699) 28.03.17 18:06 Сейчас в теме
Да, сегодня тоже сделали обновление релиза 2.5.116.1, и справка-расчет для ФСС не сформировалась. Но ведь должна!Перерыла весь интернет, нашла вашу публикацию. Сказала нашему программисту, он покопался в модуле, оказалось, что в настройке справки не заданы отборы. Включили в настройке отбор "Организация", затем выбрали при формировании справки организацию. И все сформировалось! Только не сформировались итоговые суммы в "Расшифровке расходов на цели социального страхования". Вот такая эта 1С!
Прикрепленные файлы:
igel9780; kyts; +2 Ответить
2. Андрей Филиппов (sempaii) 94 28.03.17 19:33 Сейчас в теме
(1) Нина, действительно сегодня тоже нашел этот способ. По поводу итоговых сумм - у нас они сформировались: Приложение 2, строки 1, 8, 10, 11. Но не заполнена колонка "в т.ч. за счет средств, финансируемых из федерального бюджета".
3. Сергей (serg76) 312 28.03.17 21:03 Сейчас в теме
Отослал этот "косяк" в техподдержку в день выхода релиза - первый ответ был:

Здравствуйте!
Ваше обращение зарегистрировано под номером SW1137902 / 2.
Пожалуйста, в тексте следующих обращений на эту же тему ссылайтесь на этот номер.

Направляем ответ отдела разработки:

Бланк автозаполняется при наличии задолженности по взносам за ФСС.

В 1С такие шутники в техподдержке сидят)) Пришлось писать второй раз с разжевыванием их ошибок и скринами. Кстати, в настройках отчета достаточно просто установить флажок "отбор" и бланк будет заполняться, сами отборы можно не задавать
ansonat; igel9780; Tolpinski; Sunderland; kyts; Conon1980; +6 Ответить
4. Aida V (miledi.80) 11.04.17 15:19 Сейчас в теме
Спасибо большое! Выручили.
5. Светлана Манкевич (Luchic) 9 04.05.17 16:40 Сейчас в теме
Оставьте свое сообщение