Печать Т-13 без контроля проведения для ЗУП 3.1

Печать - Печатные формы документов

Печатная форма

2
Дополнительная печатная форма Т-13 с возможностью вывода на печать без контроля проведения документа. Публикация будет полезна не только конечным пользователям, но и разработчикам. Привожу краткое описание того, как обойтись без процедуры ВывестиТабличныйДокументВКоллекцию() и не потерять в функциональности.

Дополнительная печатная форма Т-13 с возможностью вывода на печать без контроля проведения документа. Тестировалось на релизе 8.3.11.2924.

На предприятии учет ведется методом отклонений. Однако, появилась необходимость вводить  табели для сотрудников. Необходимость обусловлена внутрифирменным контролем. 

Проверка на проведенность документа происходит при вызове процедуры ВывестиТабличныйДокументВКоллекцию(). 

Для реализации данной задачи мне пришлось вместо  серверной функции, расположенной в модуле обработки внешней печатной формы:

Функция Печать(МассивОбъектов, 	КоллекцияПечатныхФорм, 	ОбъектыПечати, 	ПараметрыВывода) Экспорт
	
	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "УнифицированнаяФормаТ13") Тогда                                                           
		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "УнифицированнаяФормаТ13", "Табель учета рабочего времени (Т-13)", 
                    СформироватьПечатнуюФормуТ13(МассивОбъектов,ОбъектыПечати));
	КонецЕсли;
	
КонецФункции // Печать()

использовать клиентскую, разместив ее в модуле формы.

&НаКлиенте
Процедура Печать(ИдентификаторКоманды,ОбъектыНазначения) Экспорт
	
	ОбъектыПечати = Новый СписокЗначений;
	
	ТабДокумент = СформироватьПечатнуюФормуТ13(ОбъектыНазначения,ОбъектыПечати);
	
	МодульУправлениеПечатьюКлиент = ОбщегоНазначенияКлиент.ОбщийМодуль("УправлениеПечатьюКлиент");
	
	КоллекцияПечатныхФорм = МодульУправлениеПечатьюКлиент.НоваяКоллекцияПечатныхФорм("УнифицированнаяФормаТ13");
    ПечатнаяФорма = МодульУправлениеПечатьюКлиент.ОписаниеПечатнойФормы(КоллекцияПечатныхФорм, "УнифицированнаяФормаТ13");
    ПечатнаяФорма.СинонимМакета = "Табель учета рабочего времени (Т-13)";
    ПечатнаяФорма.ТабличныйДокумент = ТабДокумент;
    ПечатнаяФорма.ИмяФайлаПечатнойФормы = "УнифицированнаяФормаТ13";
    
    ОбластиОбъектов = Новый СписокЗначений;
    МодульУправлениеПечатьюКлиент.ПечатьДокументов(КоллекцияПечатныхФорм, ОбластиОбъектов);
	
		
КонецПроцедуры


Как видно из тела функции, процедура ВывестиТабличныйДокументВКоллекцию()  заменена на альтернативную ПечатьДокументов(). 

Конечно, можно было использовать ТабДокумент.Показать(), но в таком случае мы потеряем удобную форму вывода на печать табличного документа.

2

Скачать файлы

Наименование Файл Версия Размер
Печать Т-13 без контроля проведения:
.epf 12,10Kb
11.04.18
9
.epf 12,10Kb 9 Скачать

См. также

Специальные предложения

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение