ABC анализ продаж c иерархией по объекту анализа. УТП для Украины

24.03.20

Учетные задачи - Анализ продаж

Стандартный отчет УТП ABC Анализ Продаж не позволяет выводить группировки, например, товара. Данный отчет доработан, чтобы можно было выводить группировки.

Скачать исходный код

Наименование Файл Версия Размер
УТП для украина ABC Анализ Продаж c Иерархией по объекту анализа:
.erf 42,59Kb
5
.erf 1.0 42,59Kb 5 Скачать

Отчет проверялся на конфигурации "Управление торговым предприятием для Украины", редакция 1.2.3.1 1C8.3

Просто откройте внешнюю обработку, выберите объект анализа в настройках и расставьте коэффициенты для АВС анализа.

 

 

В стандартном отчете Объект анализа невозможно сгруппировать по иерархии.

 

 

В данном отчете добавлена данная возможность.

УТП ABCАнализПродаж

См. также

Автоматический заказ поставщику в 1С: загрузка прайсов и анализ цен поставщиков для УТ 10.3, УТ 11, КА2, УНФ, УПП, ERP, Розница 2

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    92087    116    40    

206

Управление мотивацией менеджеров для 1С:ERP 2.4 и 2.5, 1С:Комплексная автоматизация 2.4 и 2.5, 1С:Управление торговлей 11.4 и 11.5 - рейтинг продавцов, анализ выполнения планов продаж, расчет бонусов и премий сотрудников, система KPI персонала и т.п.

Анализ продаж Пользователь Руководитель проекта Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:CRM ПРОФ, КОРП Управленческий учет Платные (руб)

Расширение для линейки типовых конфигураций, которое позволяет построить систему мотивации для отдела продаж. Автоматизация расчета и анализ показателей работы менеджеров по учетным данным в вашей 1С. Построение системы KPI сотрудников. Расчет премиальной и бонусной частей вознаграждения персонала. Возможность наглядного отображения рассчитанных показателей в отчетах, типовом "мониторе целевых показателей" и в виджетах модуля 1С:CRM (если таковой у вас имеется).

33600 руб.

18.05.2021    21324    17    33    

20

RFM-анализ, повторные продажи - Анализ данных

Анализ продаж Пользователь Анализ и прогнозирование Конфигурации 1cv8 Управленческий учет Платные (руб)

Узнайте своих клиентов, разбудите их, получите прибыль. С помощью RFM-анализа и инструментов для рассылок из 1С добивайтесь повышения качества обслуживания и лояльности клиентов и, как следствие, повторных продаж.

11988 руб.

21.10.2020    12994    9    10    

14

Аналитика Маркетплейсов Wildberries и OZON через MS Excel (без API) для 1C

Логистика, склад и ТМЦ Маркетплейсы Анализ продаж Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление нашей фирмой 3.0 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Управленческий учет Платные (руб)

Расширение по анализу данных из Wildberries и OZON в 1С. Интегрируется с Wildberries и OZON посредством Excel-файлов, выгруженных из личного кабинета маркетплейса. Добавляет в программу специальные аналитические регистры, чтобы строить комплексные отчеты по продажам, остаткам и оборачиваемости товаров на маркетплейсах.

6000 руб.

18.08.2023    2737    8    1    

13

ABC анализ и XYZ анализ для 1С: Бухгалтерия предприятия 8 (ред. 3.0)

Оптовая торговля Анализ продаж Бизнес-аналитик Руководитель проекта Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Управленческий учет Платные (руб)

Классические инструменты ABC анализ и XYZ анализ для 1С:Бухгалтерии предприятия 8 (ред. 3.0). Простые и удобные в использовании управленческие отчеты помогут руководителю, менеджеру или аналитику быстро оценить товарные запасы, продажи в разрезе номенклатуры, номенклатурных групп, покупателей. Произвести классификацию ресурсов компании в зависимости от характера их потребления и точности прогнозирования изменений в их потребности в течение определенного временного цикла.

7080 руб.

21.05.2015    48061    28    9    

34

CRM подсистема для 1С (лиды, канбан доска, воронка продаж)

Анализ продаж Пользователь Управляемые формы Конфигурации 1cv8 Управленческий учет Платные (руб)

Встраиваемая в вашу базу 1С CRM подсистема, не влияющая на обновления. Регистрируйте обращения и запросы прямо в вашей основной программе. CRM подсистема для 1С (лиды, канбан доска, воронка продаж).

8900 руб.

14.01.2020    14464    12    0    

21
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. ice-net 19 24.04.20 14:17 Сейчас в теме
Ваша обработка не работает как надо:
1. Иерархия выводится всегда
2. Настройки группировок игнорируются
3. Настройки сортировки игнорируются
4. Если в группировках указать для любого поля Иерархия / только иерархия - отчет выводится некорректно
5. Если добавить другие группировки выше анализируемого объекта - отчет выводится некорректно

Реализовано путем фикс. запроса к результату построителя с последующим перебором и выводом по общим итогам, классу и анализируемого объекта, да еще и неэффективно...
2. nvovap 11 24.04.20 20:10 Сейчас в теме
Отчет работает точно так же как и стандартный отчет АБС анализ
Только в моем есть иерархия
3. ice-net 19 25.04.20 16:24 Сейчас в теме
(2)
1. Можно отключить иерархию в Вашем отчете?
2. Если добавить группировку выше объекта анализа, цифры есть, но детализации нет. пруф - фото

...
Вы берете результат типового отчета и полностью игнорировав настройки компоновщика выводите фиксированный рузельат.. Это вы называете точно так же?
....
|УПОРЯДОЧИТЬ ПО
	|	Класс," + ПараметрАнализа +",
	|	Объект
	|" + ПоказателиИтогиДляЗапроса +"
	|ПО
	|	ОБЩИЕ,
	|	Класс,
	|	Объект ИЕРАРХИЯ
	|АВТОУПОРЯДОЧИВАНИЕ";
	ТаблицаКлассовОбъектов.Колонки.Добавить("Объект2", ТипЗначения);
	Для каждого ТекСтрока из  ТаблицаКлассовОбъектов Цикл
		ТекСтрока.Объект2 = ТипЗначения.ПривестиЗначение(ТекСтрока.Объект);
	КонецЦикла;
	Запрос.Параметры.Вставить("ТаблицаКлассовОбъектов", ТаблицаКлассовОбъектов);
	РезультатЗапроса = Запрос.Выполнить();
	ВыборкаОбщийИтог = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
	ВыборкаОбщийИтог.Следующий();		
	ВыборкаКласс = ВыборкаОбщийИтог.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
	Пока ВыборкаКласс.Следующий() Цикл
		ВывестиСтрокуГруппировки(ВыборкаКласс, "Класс", Макет, ВыборкаКласс.Уровень(), Таб);
		ВыборкаОбъект = ВыборкаКласс.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
		Пока ВыборкаОбъект.Следующий() Цикл
			Если ВыборкаОбъект.ТипЗаписи() = ТипЗаписиЗапроса.ИтогПоИерархии Тогда
				ВывестиСтрокуГруппировки(ВыборкаОбъект, "Объект", Макет, ВыборкаОбъект.Уровень(), Таб, Неопределено, Неопределено, Истина);
			Иначе
				ВывестиСтрокуГруппировки(ВыборкаОбъект, "Объект", Макет, ВыборкаОбъект.Уровень(), Таб);
			КонецЕсли;				
		КонецЦикла;
	КонецЦикла;
Показать


Не вводите людей в заблужение
Прикрепленные файлы:
4. nvovap 11 26.04.20 21:58 Сейчас в теме
Спасибо за замечание, этот момент я исправлю!
Оставьте свое сообщение