Русаков Григорий | Директор | Аналитика. Проекты и решения

«Как создавать, продвигать приложение и конкурировать с фирмой 1С на протяжении 11 лет»

Рассказ о том, как с 2007 года мне (как директору и основному разработчику) удается продвигать на рынок отраслевое решение на базе «1С:Предприятие 8», как конкурировать с самой фирмой «1С», принимать не стандартные решения и продолжать продавать продукт. Речь пойдет о системе электронного документооборота СЭД «Корпоративный документооборот», имеющей тысячи пользователей. Основные тезисы выступления: 1. Риск выхода на пустой рынок в 2007 году – раз нет решений, то возможно они не востребованы рынком? Оказалось, что востребованы. Что приносит больше денег - слабое решение на пустом рынке или отличное решение, но на рынке с большой конкуренцией? 2. Как конкурировать с фирмой «1С» на её поле? Стараемся всегда идти на шаг впереди: переход на 8.2 раньше, переход на «Такси» раньше, графический редактор значительно раньше, push-уведомления для iOS раньше и т.д. Всё это были информационные поводы для новостей. Слабое место – отсутствие методических материалов и различных книг для клиентов, но у нас меньше объем кода (в отличие от типовых продуктов фирмы 1С), проще модифицировать под себя it-специалистам клиента; 3. Продажи падают – как удержать? Стоит ли переименовать продукт для отстройки от конкурента или оставить старое наименование? Добавить ли новые подсистемы – KPI и технической поддержки? Минимизация затрат на техническую поддержку клиентов с сохранением качества. Бесплатные пожизненные обновления. Апгрейды на другие продукты. Лучшие условия для партнеров; 4. Клиенты заявляют - «А мы хотим тут новую кнопку (иначе не купим)!» Как соблюсти баланс между усложнением решения и удовлетворением конкретного клиента? Плюсы развития продукта под реальные нужды предприятий, а не под гипотетические задачи; 5. Повышать или понижать цену? Что увеличит продажи продукта? 6. Куда развиваться после 11 лет? Создание на основе продукта отдельных подсистем для программ фирмы «1С». Сертификация встраиваемых модулей в программы «1С:УТ», «1С:УНФ», «1С:Документооборот» и другие; 7. А может сделать OpenSource? Плюсы и минусы продукта в OpenSource. Дополнительная информация: Сколько вышло больших обновлений (на 8.1 для 8.2 и 8.3 такси). Расскажем были ли возражения против платного перехода на новые редакции. Одно из интересных решений – графический редактор бизнес-процессов, позволяющий создавать произвольные процессы в пользовательском режиме (не в «Конфигураторе») создан в 2010 году, фирма «1С» создала аналогичный в 2017. Изначально продукт поставляется с полностью открытым кодом, без дополнительных ключей защиты. Есть ли плюсы в такой поставке или больше минусов – приходите и всё узнаете!

Дни рождения на сегодня и завтра

Отчеты - Разное

Очередной вариант оповещения о днях рождения сотрудников.

- Выводится список сотрудников у кого день рождения сегодня и завтра.
- Не указывается возраст, многих сильно беспокоит, когда другие сотрудники знают их возраст.
- Есть возможность отказаться от запуска при старте.

Очередной вариант оповещения о днях рождения сотрудников.

Особенности:

- Выводится список сотрудников у кого день рождения сегодня и завтра.
- Не указывается возраст, многих сильно беспокоит, когда другие сотрудники знают их возраст.
- Есть возможность отказаться от запуска при старте.

В течении дня дни рождения показываются только при первом запуске, чтобы не раздрожать при перезапуске 1С в течении дня. Но при желании посмотрерть у кого день рождения можно в любое время вызовом обработки из меню.

Подключение:

В глобальном модуле в процедуре ПриНачалеРаботыСистемы() добавить вызов
ОткрытьФорму("Обработка.ДеньРожденияСегодня", "ПоказатьДеньРожденияСегодня");

В интерфейсе в меню например "Сервис" добавить вызов обработки "ДеньРожденияСегодня". Пункт меню можно назвать "Сегодня день рождения празднуют".

Обязательно наличие справочника "Сотрудники". Обязательные реквизиты: "ДатаРождения", "ДатаУвольнения". Следующие реквизиты используются для вывода в табличной части, их можно изменить или убрать: "Должность", "Подразделение".

Скачать файлы

Наименование Файл Версия Размер
День рождения сегодня и завтра
.ert 21,00Kb
16.11.12
30
.ert 21,00Kb 30 Скачать

См. также

Комментарии
1. A (Kochevnic) 20.11.12 21:05 Сейчас в теме
Спасибо! Вроде пустячок, но вещь весьма полезная иногда
2. Алекс Петрухин (Alex_Pet) 21.11.12 04:30 Сейчас в теме
Согласен. Очень удобно, особенно при большом количестве работников.
3. nelse (nelse) 21.11.12 04:58 Сейчас в теме
Ерунда.
Если совсем на работе делать нечего... ого-го ещё сколько таких примочек придумать можно.
Хорошо устроился однако, автор.
4. Gashek Gashek (gashek) 21.11.12 10:19 Сейчас в теме
Так может быть он вечерами/ночами дома. Чего Вы на него сразу накинулись?
5. Юрий Гураль (yurigural) 7 21.11.12 15:33 Сейчас в теме
Нужны были стартмани, выдернул обработку из своей старой конфигурации, это самое простое что мог найти по быстрому. А в обще-то разных интересных идей предостаточно, только времени нет на все это, это минимум целый день нужно потратить чтоб подготовить публикацию.
6. Иваныч Иванов (Иваныч) 22 29.12.12 10:29 Сейчас в теме
(5)
Полностью согласен. Иногда многие вроде бы незначащие идеи бывают весьма полезны
7. Иваныч Иванов (Иваныч) 22 07.06.13 17:51 Сейчас в теме
я делал так:
СпрФизЛиц=СоздатьОбъект("Справочник.ФизЛица");
Есть=0;
Для год = -100 По 100 Цикл
Если СпрФизЛиц.ВыбратьЭлементыПоРеквизиту("ДатаРождения",Дата(ДатаГод(ТекущаяДата())-год,ДатаМесяц(ТекущаяДата()),ДатаЧисло(ТекущаяДата())),0,0)=1 Тогда
Если Есть=0 Тогда
Сообщить("Сегодня день рождения у:");
КонецЕсли;
Пока СпрФизЛиц.ПолучитьЭлемент()=1 Цикл
Сообщить(СпрФизЛиц.Наименование+" /"+СокрЛП(СпрФизЛиц.ПолнНаименование)+"/ "+СпрФизЛиц.ДатаРождения+" -- "+СпрФизЛиц.Телефоны);
КонецЦикла;
Есть=1;
КонецЕсли;
КонецЦикла;
Если Есть=1 Тогда
Предупреждение("Кажется у кое-кого сегодня День Рождения!!!"+РазделительСтрок+"Смотрите подробности в окне сообщений!");
КонецЕсли;

этот код вставил в конец процедуры ПриНачалеРаботыСистемы()
Оставьте свое сообщение