Анализ прибыли от продаж

Отчеты - Управленческие

В отчет выводится прибыль от продаж по всем типам документов из регистра "Товары на складах" в сравнении с ценами закупки и розницы (формально), а также движения по этому регистру.

Учитываются возвраты товаров и оплаты Расх. и Прих. кассовыми ордерами, а так же оплаты платежной картой. Для корректного формирования необходима заполненная аналитика документов оснований построчно в документах оплаты и возвратов от покупателей, а так же своевременные установки цен номенклатуры.

Тестировался на Рознице 2.2 версии 2.2.4.25 и последующих релизах.

Отчет делался под конкретную фирму, поэтому на универсальность не претендует, однако для простого учета с 2 видами цен вполне подойдет. Чтобы подставить свои виды цен, отредактируйте в модуле формы функцию ДобавитьЦеныДокументов() под себя.

Возможно, допишу этот отчет в будущем для универсальности, но пока "как есть". Буду рад, если кому-нибудь пригодится. Конструктивная критика приветствуется! Публикация первая

Скачать файлы

Наименование Файл Версия Размер
Анализ прибыли продаж:
.erf 15,34Kb
29.04.17
10
.erf 1.0 15,34Kb 10 Скачать

См. также

Комментарии
1. Newdjeen Klime (Newdjeen) 06.05.17 08:53 Сейчас в теме
Некорректно работает (не втягивает цены) в Рознице 2.2.5.27
2. Алексей Куликов (leks88) 8 07.05.17 22:46 Сейчас в теме
3. Newdjeen Klime (Newdjeen) 08.05.17 08:10 Сейчас в теме
(2)
РИБ по Магазину
Маркетинг: Виды цен:
Закупочная (Способ задания цены: Заполнять по данным ИБ при поступлении; СКД: Цены поступления)
РозничнаяМагазин1(Способ задания цены: Рассчитывать по другим видам цен; Правило расчета: [Закупочная] * 1.3)
Прикрепленные файлы:
4. Алексей Куликов (leks88) 8 08.05.17 16:49 Сейчас в теме
Чтобы подставить свои виды цен, отредактируйте в модуле формы функцию ДобавитьЦеныДокументов() под себя.

То есть:

&НаСервере
Функция ДобавитьЦеныДокументов()
	
	ДокументыДвижений = УстановитьТипДокументов();
	ДокументыДвижений.Колонки.Добавить("Закупка", Новый ОписаниеТипов("Число"));	
	ДокументыДвижений.Колонки.Добавить("Розница", Новый ОписаниеТипов("Число"));	
	
	Для каждого Стр Из ДокументыДвижений Цикл
		Если Стр.ТипОперации = "Продажа (оплачено)"
		ИЛИ Стр.ТипОперации = "Продажа (не оплачено)" 
		ИЛИ Стр.ТипОперации = "Продажа (частичная оплата)" Тогда
			Запрос = Новый Запрос;
			Запрос.УстановитьПараметр("Позиция",Стр.Номенклатура);
			Запрос.УстановитьПараметр("ДатаЦен",Стр.Документ.Дата);
			Запрос.Текст = 
			"ВЫБРАТЬ
			|	ЦеныНоменклатурыСрезПоследних.Цена КАК Закупка,
			|	ЦеныНоменклатурыСрезПоследних1.Цена КАК Розница
			|ИЗ
			|	РегистрСведений.ЦеныНоменклатуры.СрезПоследних(
			|			&ДатаЦен,
			|			Номенклатура = &Позиция
			|				И ВидЦены.Идентификатор = ""Закупка"") КАК ЦеныНоменклатурыСрезПоследних,
			|	РегистрСведений.ЦеныНоменклатуры.СрезПоследних(
			|			&ДатаЦен,
			|			Номенклатура = &Позиция
			|				И ВидЦены.Идентификатор = ""Розница"") КАК ЦеныНоменклатурыСрезПоследних1";
			Результат = Запрос.Выполнить().Выгрузить();
			Если НЕ Результат.Количество() = 0 Тогда
				Стр.Закупка = Результат[0].Закупка;
				Стр.Розница = Результат[0].Розница;
			КонецЕсли;
		КонецЕсли;
	КонецЦикла;
	
	Возврат ДокументыДвижений;
	
КонецФункции
Показать


Заменить
И ВидЦены.Идентификатор = ""Закупка"")

На "Идентификатор" Из ваших видов цен, к примеру:
И ВидЦены.Идентификатор = ""Закупочная"")


Так же поступить и с Розничным видом цен
5. Алексей Куликов (leks88) 8 08.05.17 16:51 Сейчас в теме
В данном случае используется "Индентификатор для формул". См. вложенную картинку
Прикрепленные файлы:
Оставьте свое сообщение