Мой пример интеграции с Viber

Публикация № 1101361

Разработка - Системная интеграция - Интеграция с WEB

Интеграция Viber Вибер Вайбер

Пример интеграции бота Viber и 1С.

Руководством была поставлена задача взаимодействия с клиентами через Viber.

Была старта работ была использована публикация: //infostart.ru/public/1061585/

 

Вот моё решение.

1. Необходимо зарегистрировать Viber бота, как это делать описывать не буду, есть куча статей

2. Получаем токен бота на из вашего кабинета https://partners.viber.com/account/----------------/info

3. Для получения данных от бота надо подключить вэб-хук. Возможности завести свой HTTPS пока нет. По этому я использовал https://webhook.site/ 

Нормально переадресацию смог настроить только с премиум доступом к сервису за 3.6$ в месяц, на мой взгляд не дорого/

Может можно и на бесплатном функционале сервиса, но смог только так разобраться.

 

На нём была настроена переадресация на мой HTTP сервис опубликованный из 1с

 
Настройка вэб-хука

а. Настройка редикректа

 Настройка редиректа

2. Структура вэб-сервиса

Структура вэб-сервиса

 

4. После публикации вэб-сервиса, подключаем вэб-хук к боту:

Процедура УстановитьВебхук(Токен, Вебхук)
	
	//Токен = "##################################################";
	//Вебхук ="https://webhook.site/########-####-####-####-############";	
	
	Если ПустаяСтрока(Токен) Тогда
		Сообщить("Укажите токен");
		Возврат;
	КонецЕсли; 

	
	Если ПустаяСтрока(Вебхук) Тогда
		Сообщить("Заполните вебхук");
		Возврат;
	КонецЕсли; 
	
	Сервер = "chatapi.viber.com";
	
	Статусы = Новый Массив; //ограничиваем события которые будут к нам прилетать по вэб-хуку.
	Статусы.Добавить("subscribed");
	Статусы.Добавить("unsubscribed");
	Статусы.Добавить("conversation_started");
	
	ТелоЗапроса = ПолучитьСтруктуруСообщения(Новый Структура("url, event_types", Вебхук, Статусы));
	
	Адрес 		= ПолучитьТекстЗапросаВайбер("set_webhook");
	Соединение 	= Новый HTTPСоединение(Сервер,,,,,,Новый ЗащищенноеСоединениеOpenSSL(Новый СертификатКлиентаWindows,Новый СертификатыУдостоверяющихЦентровWindows()));
	Запрос 		= Новый HTTPЗапрос(Адрес);
	Если ТелоЗапроса <> Неопределено Тогда
		Запрос.Заголовки.Вставить("X-Viber-Auth-Token",Токен);
		Запрос.Заголовки.Вставить("Content-Type","application/json");
		Запрос.УстановитьТелоИзСтроки(ТелоЗапроса,"UTF-8", ИспользованиеByteOrderMark.НеИспользовать);
		Ответ = Соединение.ОтправитьДляОбработки(Запрос);
	Иначе
		Ответ = Соединение.Получить(Запрос);
	КонецЕсли;
	
	Чтение = Новый ЧтениеJSON;
	ОтветСтрокой = Ответ.ПолучитьТелоКакСтроку(); 
	Чтение.УстановитьСтроку(ОтветСтрокой);
	Результат = ПрочитатьJSON(Чтение);
	
	Если Результат.status = 1 Тогда
		Сообщить("При установке вебхука произошла ошибка " +  ОтветСтрокой);
	ИначеЕсли Результат.status = 0 Тогда 
		Сообщить("Вебхук успешно установлен");	
	КонецЕсли; 
	
	Если Ответ.КодСостояния <> 200 Тогда
		Сообщить("При установке вебхука произошла ошибка " +  ОтветСтрокой);
	КонецЕсли; 
	

КонецПроцедуры

Функция ПолучитьСтруктуруСообщения(СтруктураПараметров = Неопределено)
	
	СтруктураНастроек = Новый Структура();
	
	Если СтруктураПараметров <> Неопределено Тогда
		Для Каждого стрПараметр Из СтруктураПараметров Цикл
			СтруктураНастроек.Вставить(стрПараметр.Ключ, стрПараметр.Значение);
		КонецЦикла;
	КонецЕсли; 
		
	ЗаписьJSON = Новый ЗаписьJSON;
	ЗаписьJSON.УстановитьСтроку();
	ЗаписатьJSON(ЗаписьJSON, СтруктураНастроек);
	Возврат ЗаписьJSON.Закрыть();
	
КонецФункции

Функция ПолучитьТекстЗапросаВайбер(ИмяКоманды) 
	
	Адрес = "/pa/";
	Адрес = Адрес + ИмяКоманды;
	Возврат Адрес;

КонецФункции

5. После подключения к вэб-хука в боте включится возможность отправки сообщений пользователем боту.

6. В процедуре вэб-сервиса создадим обработчик:


Функция Hookviber(Запрос)
	
	Ответ = Новый HTTPСервисОтвет(200);
	
	ПроцедурыViber.ОбработатьЗапрос(Запрос);
	
	Возврат Ответ;
	
КонецФункции

 

Пример: Получим список админов и отправим им сообщение:


Процедура ОтправитьСообщениеВПубличныйЧатАдминистраторам(Текст = Неопределено) Экспорт 
	Админы = ПолучитьСписокАДминистраторов();
	
	Для Каждого Получатель из Админы Цикл
		Структура = Новый Структура();
		Структура.Вставить("receiver", Получатель);
		sender = Новый Соответствие();
		sender.Вставить("name", "Чат-бот");
				
		Структура.Вставить("sender", sender);	
		Структура.Вставить("type", "text");
		Структура.Вставить("text", ?(Текст = Неопределено, "Добрый день!", Текст));
				
		ОтправитьЗапросНаСерверВайбера("send_message", Структура);
	КонецЦикла;
	
КонецПроцедуры 

Функция ПолучитьСписокАДминистраторов()

	Ответ = ОтправитьЗапросНаСерверВайбера("get_account_info");

	Админы = Новый Массив;

	Если ТипЗнч(Ответ) = Тип("Структура") Тогда
		Если Ответ.Свойство("members") Тогда
			Подписчики = Ответ.members;
			Для Каждого Подписчик Из Подписчики Цикл
				Если Подписчик.role = "admin" Тогда
					Админы.Добавить(Подписчик.id);
				Иначе 
					Продолжить;
				КонецЕсли; 
			КонецЦикла;
		КонецЕсли; 
	КонецЕсли;

	Возврат Админы;

КонецФункции

Функция ОтправитьЗапросНаСерверВайбера(ИмяКоманды, СтруктураПараметров = Неопределено)
	
	Сервер = "chatapi.viber.com";
	ТелоЗапроса = ПолучитьСтруктуруСообщения(СтруктураПараметров);	
	Адрес 		= ПолучитьТекстЗапросаВайбер(ИмяКоманды);
	Соединение 	= Новый HTTPСоединение(Сервер,,,,,, Новый ЗащищенноеСоединениеOpenSSL);
	Запрос 		= Новый HTTPЗапрос(Адрес);

	Если ТелоЗапроса <> Неопределено Тогда
		Запрос.Заголовки.Вставить("Content-Type","application/json");
		Запрос.Заголовки.Вставить("X-Viber-Auth-Token","Токен");
		Если СтрДлина(ТелоЗапроса) > 4 тогда
		Запрос.УстановитьТелоИзСтроки(ТелоЗапроса,"UTF-8", ИспользованиеByteOrderMark.НеИспользовать);
		КонецЕсли;
		Ответ = Соединение.ОтправитьДляОбработки(Запрос);
	Иначе
		Ответ = Соединение.Получить(Запрос);
	КонецЕсли;
	
	Чтение = Новый ЧтениеJSON;
	ОтветСтрокой = Ответ.ПолучитьТелоКакСтроку(); 
	Чтение.УстановитьСтроку(ОтветСтрокой);
	Результат = ПрочитатьJSON(Чтение);
	
	Возврат Результат;

КонецФункции


Пример: отправим администраторам запрос на согласование с кнопками в тексте


Процедура ЗапроситьСогласование() Экспорт 
	
	Админы = ПолучитьСписокАДминистраторов();
	
	Стр = ПолучитьСтруктуруЗапросаСогласование("Простое согласование");
	
	Для Каждого Админ из Админы Цикл
		Структура = Новый Структура();
		Структура.Вставить("receiver",  Админ);
		
		sender = Новый Соответствие();
		sender.Вставить("name", "Бот-Согласование");
			
		Стр.receiver = Админ;
		ОтправитьЗапросНаСерверВайбера("send_message", Стр);
	КонецЦикла;
	
	
КонецПроцедуры

Функция ПолучитьСтруктуруЗапросаСогласование(Текст)
	
	//Формируем структуру
	
	Структура = Новый Структура();
	Структура.Вставить("receiver", "");
	Структура.Вставить("min_api_version", 2);
	sender = Новый Соответствие();
	sender.Вставить("name", "Бот-Согласование");
			
	Структура.Вставить("sender", sender);	
	Структура.Вставить("type", "rich_media");
	
	rich_media = Новый Структура;
	
	rich_media.Вставить("Type", "rich_media");
	rich_media.Вставить("BgColor", "#FFFFFF");
	rich_media.Вставить("ButtonsGroupColumns", 6);
	rich_media.Вставить("ButtonsGroupRows", 7);
 	
	
	Кнопки = Новый Массив;
	
	Кнопка = Новый Структура;
	Кнопка.Вставить("Columns", 6);
	Кнопка.Вставить("Rows", 5);
	Кнопка.Вставить("ActionType", "none");
	Кнопка.Вставить("ActionBody", "text");
	Кнопка.Вставить("TextSize", "medium");
	Кнопка.Вставить("TextVAlign", "middle");
	Кнопка.Вставить("TextHAlign", "left");
	Кнопка.Вставить("Text", "[<b>" + Текст + "</b>]");
	Кнопки.Добавить(Кнопка);
	
	
	Кнопка = Новый Структура;
	Кнопка.Вставить("Columns", 6);
	Кнопка.Вставить("Rows", 1);
	Кнопка.Вставить("ActionType", "reply");
	Кнопка.Вставить("ActionBody", "Ok");
	Кнопка.Вставить("Text", "<font color=#000000>Согласовать</font>"); 
	Кнопка.Вставить("BgColor", "#00a86b");
	Кнопка.Вставить("TextSize", "large");
	Кнопка.Вставить("TextVAlign", "middle");
	Кнопка.Вставить("TextHAlign", "middle");
	Кнопки.Добавить(Кнопка);
	
	Кнопка = Новый Структура;
	Кнопка.Вставить("Columns", 6);
	Кнопка.Вставить("Rows", 1);
	Кнопка.Вставить("ActionType", "reply");
	Кнопка.Вставить("ActionBody", "No");
	Кнопка.Вставить("BgColor", "#ff4f00");
	Кнопка.Вставить("Text", "<font color=#000000>Отказать</font>");
	Кнопка.Вставить("TextSize", "large");
	Кнопка.Вставить("TextVAlign", "middle");
	Кнопка.Вставить("TextHAlign", "middle");
	Кнопки.Добавить(Кнопка);
	
	
	rich_media.Вставить("Buttons", Кнопки);
	
	Структура.Вставить("rich_media", rich_media);
	
	Возврат Структура;
	
КонецФункции

Пример: обработаем ответ на согласование.

Процедура ОбработатьЗапрос(Запрос) Экспорт 
	
	Попытка
		
		СтруктураДанных = ПрочитатьJSON(Запрос.ПолучитьТелоКакСтроку());
		
		Отправитель = СтруктураДанных.Получить("sender");
		Сообщение = СтруктураДанных.Получить("message");
			
		Если Сообщение<>Неопределено и Отправитель<>Неопределено Тогда

			ТипСообщения = Сообщение["type"];
			ТекстСообщения = "" + Сообщение["text"];

			Если ТекстСообщения = "Ok" или ТекстСообщения = "No" Тогда
				ОтправитьСообщениеВПубличныйЧатАдминистраторам("" + Отправитель["name"] + " выполнил согласование: " + ТекстСообщения);
			КонецЕсли;

		КонецЕсли;
		
	Исключение  
		ЗаписьЖурналаРегистрации("Ошибка обработки запроса из Viber", УровеньЖурналаРегистрации.Ошибка,,,"" + ОписаниеОшибки());
	КонецПопытки;
	
КонецПроцедуры

 

Как итог через 1с менеджеры отправляют на согласования различные запросы и получают ответы от руководителей, так же реализовал получение и отправку картинок. В примере оно есть. Для отправки картинки она должна быть видна из интернета. 

Работает сей функционал уже полгода, полет нормальный.

Тестировалось на платформе 8.3.16.1224.

Скачать файлы

Наименование Файл Версия Размер
Мой пример интеграции с Viber:

.cf 17,60Kb
6
.cf 17,60Kb 6 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Dnki 4 03.10.20 11:25 Сейчас в теме
Из фразы "менеджеры отправляют ... и получают ответы от руководителей" я понял, что механизм используется для сообщений внутри компании. А не с клиентами.
Вот несколько картинок, как это выглядит, не помешали бы. Интереснее было бы читать.
2. FirePyres 54 05.10.20 11:23 Сейчас в теме
В основном я хотел поделиться как я реализовал обратную связь от вайбера без прямого https.
3. pawellkrv 14 25.02.21 18:15 Сейчас в теме
Задолбался искать необходимый "учебник". Можешь дать ссылку как и где все это накопал? Скачал твою *.cf, с пол пинка заработало на отправку сообщений. WebHook у меня на PHP готовый взят и размещен Интернет сервере где крутиться сайт конторы. Вот как получать сообщения??? буду разбираться, нужен источник информации с хорошей теоретической составляющей. Ибо нет ничего лучше понимания!! :)
Хочу доделать GET метод. Низамов просит нереальные деньги :)
4. pawellkrv 14 03.03.21 15:38 Сейчас в теме
В этом посте много чего упущено но основа есть и это хорошо,
ссылка по теме Реализация для Telegram
поэтапная реализация с диагностикой
Оставьте свое сообщение

См. также

Интеграция с бонусной программой лояльности ManyBonus Промо

Управление взаимоотношениями с клиентами (СRM) Розничная торговля WEB v8 Розница УУ Абонемент ($m)

ManyBonus.com - бонусная программа лояльности на базе мессенджеров. Позволяет регистрировать клиента в программе лояльности через Telegram, Viber, VK, отправлять коды скидок в мессенджеры, получать уведомления при списании/начислении бонусных баллов, альтернатива сообщениям СМС.

3 стартмани

07.01.2021    2045    2    Anton64    0    

BIM: взаимодействие с платформой Autodesk Forge

WEB v8 Строительство Абонемент ($m)

Предлагаемый пример демонстрирует широкие возможности для взаимодействия «1С:Предприятие» с платформой Autodesk Forge и позволяет вам получить базовые представления о применения технологий информационного моделирования в строительстве. Поддерживаются все версии платформы от 8.3.12 и выше до 8.3.18.

1 стартмани

25.11.2020    12857    4    kandr    0    

Генератор маршрута по "документам отгрузки" в Google.Maps

Оптовая торговля Розничная торговля WEB v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Данная обработка будет полезна для построения маршрута по документам реализаций за выбранный период.

7 стартмани

08.11.2020    3790    7    quazare    16    

Чатбот WhatsApp

WEB v8 1cv8.cf Абонемент ($m)

Внешняя обработка для написания чат-бота WhatsApp

1 стартмани

21.10.2020    5308    22    ripreal1    18    

"Учет штрафов ГИБДД" с возможной загрузкой из открытых источников в интернет Расширение конфигурации 1С: Предприятие 8.3 Промо

Обработка документов WEB v8 v8::УФ 1cv8.cf Россия БУ УУ Абонемент ($m)

Расширение конфигурации Бухгалтерия предприятия, редакция 3.0 (при минимальных изменениях любой типовой конфигурации), позволяющее вести историю данных по штрафам ГИБДД для справочника транспортных средств компании. Бонусом поставляется внешняя обработка, способная загружать эти данные из открытых источников в интернет.

4 стартмани

30.12.2019    10800    17    capitan    11    

1С + react native

WEB v8 1cv8.cf Абонемент ($m)

Пример реализации клиента для 1С на react native.

1 стартмани

09.10.2020    5902    6    van_za    6    

Учимся создавать http сервис (часть третья). Передача нескольких параметров в http сервис

WEB Практика программирования v8 1cv8.cf Абонемент ($m)

Пошаговое руководство по созданию http сервиса (часть третья). Передача нескольких параметров в http сервис, a также формирование сложных JSON строк.

1 стартмани

02.10.2020    6653    2    hpi    16    

Подключаем WhatsApp к 1С

WEB v8 1cv8.cf Абонемент ($m)

Обработка для быстрого подключения WhatsApp к любой конфигурации 1С.

1 стартмани

30.09.2020    6078    29    andrew_shamin    55    

Внешняя компонента для работы по Web-socket протоколу x32 x64 Промо

Разработка внешних компонент WEB v8 Абонемент ($m)

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

1 стартмани

30.03.2018    29421    36    Ditron    86    

HTTP сервисы по OpenAPI спецификациям

Практика программирования WEB v8 1cv8.cf Абонемент ($m)

Начинаем путь разработки HTTP сервисов с создания спецификаций OpenAPI. Автодокументация сервисов формата Swagger UI без зависимостей. Настройка сервисов в режиме предприятия.

1 стартмани

29.06.2020    9998    6    shmalevoz    19    

Конструктор HTTP-соединений в 1С (обычные и управляемые формы)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Иногда возникают мысли о том, чтобы прикрутить сервисы, связанные с HTTP-соединениями, в 1С. Необходимо писать обработку и анализировать результат.

1 стартмани

02.06.2020    5745    25    Denr83    0    

DaJet QL - расширяемый язык запросов

Интеграция WEB v8 Абонемент ($m)

DaJet QL поддерживает практический полный синтаксис SQL Server 2005-2016. Кроме этого это расширяемый язык запросов. Обращение к объектам СУБД выполняется в терминах метаданных 1С. Доступ к возможностям этого языка запросов реализован в виде web api сервиса. Результаты запросов возвращаются в виде JSON.

1 стартмани

20.04.2020    8446    11    zhichkin    16    

Работа с релизами 1С и договорами ИТС Промо

WEB БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Работа с релизами 1С и партнерским кабинетом.

2 стартмани

15.08.2019    16119    52    RocKeR_13    34    

Обмен данными между OZON и 1С

Оптовая торговля WEB v8 v8::ОУ УТ11 УУ Абонемент ($m)

Данная подсистема позволяет загружать отправления «с моего склада» из OZON (в статусе «Ожидают сборки») в 1с Управление торговлей 11 по API. Так же есть возможность выгружать статусы отправлений «awaiting_deliver, т.е. Ожидает отгрузки» и «cancelled, т.е. Отменен» из 1с в OZON по API.

10 стартмани

09.04.2020    18087    170    vex2865    104    

Пример работы с Trello из 1С

WEB v8 1cv8.cf Россия УУ Абонемент ($m)

Небольшая конфигурация содержит примеры обмена с онлайн-сервисом Trello.

1 стартмани

15.02.2020    12831    47    terrorion    14    

Взаимодействие HTML (COM объект, WebKit) с 1С (обычные и управляемые формы)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Показан пример использования HTML (COM объект, WebKit) в 1С (8.3).

2 стартмани

18.01.2020    9556    27    Deniskinr83    0    

Проверка VAT номеров Промо

WEB v8 1cv8.cf Абонемент ($m)

Обработка для вызова сервиса проверка VAT номера.

1 стартмани

26.11.2018    14274    3    wtlz    1    

Google drive - менеджер файлов

WEB Внешние источники данных v8 1cv8.cf Россия Абонемент ($m)

Синхронизация с гугл диском легко и просто!

10 стартмани

05.12.2019    11427    35    zykov_vitaliy    26    

Автозаполнение адреса по КЛАДР в УПП при выгрузке контрагента с портала компании (API dadata)

WEB v8 1cv8.cf Абонемент ($m)

Заведение, согласование контрагентов организовано на портале компании. Далее по web-сервису контрагенты выгружаются в УПП (юр.адрес и факт.адрес выгружаются строкой). Задача автоматизировать заполнение адреса в УПП по КЛАДР.

1 стартмани

03.12.2019    7854    1    John_d    10    

Работа с Яндекс-картами в 1С (вывод меток, прокладка маршрута, отображение балуна, вывод меток в кластеры) (обычное и управляемое приложение)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Работа с Яндекс-картами в 1С (управляемое приложение). Обработка показывает, как можно найти адреса на карте Яндекс, проложить маршрут.

2 стартмани

20.11.2019    14307    131    Denr83    0    

Трекинг номеров РПО в Почте России Промо

WEB Оптовая торговля Оптовая торговля v8 Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Относительно недавно Почта России стандартизировала и описала сервисы получения информации о регистрируемом почтовом отправлении (РПО). Представляю вашему вниманию конфигурацию-обертку над сервисами Почты России. Она позволяет просто (http-запросы) и без изменений конфигурации подключить сервисы отслеживания к своим информационным системам.

2 стартмани

28.03.2016    28713    38    Smaylukk    3    

Пример взаимодействия HTML (COM объект, WebKit) с 1С (динамический отбор) (обычные и управляемые формы)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Показан пример использования WebKit в 1С (8.3).

2 стартмани

18.11.2019    11124    15    Denr83    0    

Яндекс сервисы [Расширение]

Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

Расширение для работы с Яндекс-сервисами (предиктор,переводчик,проверка орфографии)

1 стартмани

24.10.2019    12564    10    noprogrammer    12    

Telegram бот на 1С

WEB v8 1cv8.cf Абонемент ($m)

Telegram бот на 1С в виде внешней обработки, встраиваемой в типовые 1С 8.3.

1 стартмани

24.09.2019    18570    39    budidich    19    

Работа с картой. Кадастровый учет (Росреестр). Тематические карты Промо

WEB Рабочее место v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка для работы с картами в 1С. Получения изображения с публичной кадастровой карты России, построения тематических карт

5 стартмани

31.08.2017    20321    7    vipchep    0    

Выгрузка номенклатуры в социальную сеть Вконтакте

WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка для быстрой и легкой выгрузки товаров Вконтакт. Так просто еще не было)))

2 стартмани

14.08.2019    16866    55    kaliuzhnyi    48    

Путеводитель по истории релизов

WEB v8 1cv8.cf Абонемент ($m)

Отчет по истории выпуска релизов и анализа информации по обновлениям.

5 стартмани

13.08.2019    15220    13    YPermitin    18    

Подключение к сайту и отправка или получение данных по API (POST, GET...) (с описанием кода)

WEB v8 1cv8.cf Абонемент ($m)

Простая обработка по отправке или получение данных с любого сервера главное знать ресурс (выполняемую функцию) и тело запроса.

1 стартмани

12.08.2019    18390    33    MaxPowerr    5    

Работа с картами 1С 4 в 1: Яндекс, Google , 2ГИС, OpenStreetMap(OpenLayers) Промо

Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

С каждым годом становится все очевидно, что использование онлайн-сервисов намного упрощает жизнь. К сожалению по картографическим сервисам условия пока жестковаты. Но, ориентируясь на будущее, я решил показать возможности API выше указанных сервисов: Инициализация карты Поиск адреса на карте с текстовым представлением Геокодинг Обратная поиск адреса по ее координатами Взаимодействие с картами - прием координат установленного на карте метки Построение маршрутов по указанным точками Кластеризация меток на карте при увеличении масштаба Теперь также поддержка тонкого и веб-клиента

1 стартмани

28.12.2012    110041    2688    Smaylukk    359    

Конфигурация для обмена данными (интеграционная шина)

Внешние источники данных WEB v8 1cv8.cf Абонемент ($m)

Система позволяет организовать обмен данными, как с базами 1С, так и любыми другими приложениями. Система представляет собой отдельную конфигурацию. Система позволяет организовать гибкие возможности по настройке обмена. В качестве брокера сообщений, для передачи данных, используется отдельная самостоятельная конфигурация на 1С. Комплект поставки содержит файл расширения для "клиентской" части шины, данное расширение позволяет без снятия "ключа" организовать гибкий механизм обмена данными.

4 стартмани

08.07.2019    14837    33    miha-28    17    

Пример работы с viber из 1С, отправка сообщений из 1С в viber

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Обработка разработана для примера отправки сообщений в viber из 1С.

1 стартмани

16.05.2019    17306    92    Isa816    24    

Шаблон http-сервиса для вашего проекта

Внешние источники данных WEB Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Http-сервис для обмена данными в формате JSON. Обработчики этого сервиса находятся во внешней обработке, что позволяет дорабатывать его без изменения конфигурации. Также прилагаю пример мобильного приложения для работы с данным сервисом (получает номенклатуру и остатки на складе). Сервис очень быстро разворачивается и масштабируется под ваши задачи.

3 стартмани

04.05.2019    21419    78    MarkoSokolov    48    

Пример использования REST API Яндекс Диска Промо

WEB v8 1cv8.cf Абонемент ($m)

Пример использования REST API Яндекс Диска: чтение диска, добавление каталога, загрузка файла, скачивание файлов или каталогов, удаление файлов или каталогов.

1 стартмани

26.06.2018    28027    43    MKFreeUser    15    

1С и WebKit. Вариант взаимодействия

WEB v8 1cv8.cf Абонемент ($m)

В результате перехода на WebKit тип свойства Документ у поля, имеющего вид ПолеHTMLДокумента, изменился с COMОбъект на ВнешнийОбъект. Также изменилась DOM модель документа, доступная через это свойство.

2 стартмани

23.02.2019    33325    83    mi1man    57    

Строим маршруты на картах в 1С с помощью OpenStreetMap, OSRM и Leaflet

WEB v8 1cv8.cf Транспорт, автопарки, такси Абонемент ($m)

Краткая статья о том как вывести на карту (в 1С) маршруты с помощью OpenStreetMap, OSRM и Leaflet. По данной системе очень мало примеров, но так как OpenStreetMap является бесплатным сервисом и не требует никаких ключей и регистраций, и является довольно мощным механизмом, решил написать небольшую статью "как это сделать?". В первую очередь скажу, все намного проще, если вы используете последнюю версию платформы (8.3.14), где есть поддержка практически всех браузеров (IE 11, EDGE, Mozilla), но что делать если у нас не самая свежая платформа, где поддержка только IE 9?

2 стартмани

12.02.2019    29242    112    Ditron    94    

Яндекс карта в документе "Заказ клиента" на закладке "Доставка". (Расширение) УТ 11.4

Обработка документов WEB Оптовая торговля Оптовая торговля v8 УТ11 Россия УУ Абонемент ($m)

Показ яндекс карты в документе "Заказ клиента" на закладке "Доставка" и печать карты для курьера с контактными данными. (Расширение)

3 стартмани

05.02.2019    12145    12    ret    7    

Работа с публикациями "Инфостарт" Промо

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    23592    13    RocKeR_13    16    

Яндекс карты 2.1. Построение маршрута. Передача длины маршрута в реквизит формы

WEB v8 1cv8.cf Абонемент ($m)

Пригодится как пример использования Яндекс карты 2.1 для построения маршрута.

1 стартмани

24.01.2019    15980    81    John_d    33    

Веб-форма авторизации/регистрации/восстановления пароля для веб-клиента 1С с помощью HTML/CSS/PHP/HTTP-сервисов 1С

WEB v8 1cv8.cf Абонемент ($m)

Пришла в голову идея создать универсальную веб-форму входа в веб-клиент 1С на HTML/CSS/PHP/HTTP-сервисы 1С. Чтобы прямо как на нормальных сайтах. Заодно и для ознакомления с 1С с новой, для себя, стороны. Интересно было попробовать интеграцию PHP - 1С.

1 стартмани

08.11.2018    20327    28    Бэнни    21    

Загрузка чека онлайн-касс (загрузка товаров из чека)

Внешние источники данных WEB Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) из почтового сообщения, отправленного из приложения ФНС проверка чеков.

2 стартмани

08.10.2018    23624    39    echo77    73    

Конфигурация для просмотра публичных телеграм каналов Промо

WEB v8 Абонемент ($m)

Просмотр и каталогизация в более удобном виде публичных телеграм каналов, групп и чатов.

1 стартмани

02.06.2018    19402    11    DO_WHILE_LOOP    7    

SOAP для чайников

Обмен через XML WEB v8 1cv8.cf Абонемент ($m)

Немножко про SOAP сервис. И пример работы с подключением и получением данных по SOAP за 5 минут.

1 стартмани

05.09.2018    60595    51    dusha0020    19    

Класс-обработка “Работа с картами Яндекс”

Разработка внешних компонент WEB v8 Абонемент ($m)

Как показать точку или маршрут на карте Яндекс. Как получить координаты по строке адреса (геокодирование).

1 стартмани

01.08.2018    28049    214    RSConsulting    17    

Чтение сжатого gzip, deflate HTTP ответа сервера. Без ВК. Уменьши время загрузки и сократи трафик в 3 раза

WEB v8 1cv8.cf Абонемент ($m)

В платформе 1С:Предприятие не реализовано штатного механизма декодирования ответа веб серверов, в которых присутствует gzip сжатие. Некоторые использовали WinHttpRequest.5.1 , кто-то писал ВК. Друзья, хватит. Вот вам решение.

1 стартмани

08.06.2018    17483    87    Malfarion    16    

Обмен файловыми базами данных через Yandex диск Промо

WEB v8 Россия Абонемент ($m)

Выполнение операций обмена с Yandex диском для файловых БД, по протоколу WebDav, в автоматическом или ручном режимах.

1 стартмани

11.06.2018    18545    7    slimper    1