Пример связи 1С и мессенджера Telegram. Получение данных из 1С запросом из Telegram

Публикация № 419846

Разработка - Практика программирования

API Telegram HTTPСоединение JSON

В результате чтения публикации Вы получите готовую внешнюю обработку, позволяющую получать из 1С данные, запрашиваемые через Telegram.
В данной статье рассмотрим следующее:
Использование HTTPСоединение;
Чтение JSON для версии 1С 8.3.6 и выше, а также аналог JSON для версии 1С ниже 8.3.6;
Подключение обработчика ожидания;
Некоторые основные возможности API Telegram;
Как создать бота для Telegram;
Программное создание колонок дерева на управляемой форме;

1. Регистрация бота

            Для начала, зарегистрируем бота, получим его id - токен. В Telegram для этого создан специальный бот — @BotFather. Добавляем его в контакт. Получаем получаем список его команд, написав ему /start.

            Введите команду /newbot — бот попросит придумать имя нашему новому боту (оно должно оканчиваться на «bot»). BotFather предоставит токен бота и ссылку для добавления бота в контакты. Проверим полученный токен с помощью ссылки api.telegram.org/bot<TOKEN>/getMe 

            Этого, в принципе, достаточно.

2. Создание обработки в 1С

            Создадим внешнюю обработку. Добавим реквизиты обработки строковый переменной длины «Бот», «Токен», «Сервер».

            Т.к. обработку не будем привязывать к конкретной конфигурации, то список понимаемых команд будем хранить в табличной части обработки «ТаблицаПонимаемыхКоманд» (а так, в принципе, команды можно хранить в справочнике конфигурации).

            Реквизиты ТЧ строковые: «Имя», «ВыполняемоеДействие», «Параметр», «Описание»

Реквизиты ТЧ строковые: «Имя», «ВыполняемоеДействие», «Параметр», «Описание» 

 

Команды пользователя (те, которые он буде писать боту) по той же причине будем хранить в табличной части «КомандыПользователей» (если не делать обработку универсальной, то, конечно, предпочтительно использовать регистр сведений – далее, в листингах кода укажем примеры и для регистра сведений тоже).

Реквизиты ТЧ: числовые «chat_id», «date», булево «Выполнено» и строковый «Команда»

Реквизиты ТЧ: числовые «chat_id», «date», булево «Выполнено» и строковый «Команда» 

            Теперь создадим управляемую форму обработки, назначим ее основной и разместим реквизиты «Бот» и «Токен» (необязательно, но для наглядности):

Теперь создадим управляемую форму обработки, назначим ее основной и разместим реквизиты «Бот» и «Токен» 

Также создадим реквизит формы «Дерево» – тип «ДеревоЗначений». В нем будут отображаться чаты. Для наглядности выведем его на форму. Колонки дерева создадим программно (см.далее).

Для  события формы ПриСозданииНаСервере добавим процедуру:

&НаСервере

Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

           

            Объект.Бот = "@бот_bot";//Имя бота
            Объект.Токен = "111111111:ххххххххххххххххххххххCJw";//Ваш токен telegram
            Объект.Сервер = "api.telegram.org";
            //Заполнение таблицы команд бота
            НоваяКоманда = Объект.ТаблицаПонимаемыхКоманд.Добавить();
            НоваяКоманда.Имя = "/start";
            НоваяКоманда.ВыполняемоеДействие = "ВывестиПриветствие";
            НоваяКоманда.Параметр = "";
            НоваяКоманда.Описание = "начало работы";
            НоваяКоманда.Параметр = "";
            НоваяКоманда = Объект.ТаблицаПонимаемыхКоманд.Добавить();
            НоваяКоманда.Имя = "/help";
            НоваяКоманда.ВыполняемоеДействие = "ВывестиПодсказку";
            НоваяКоманда.Описание = "получение подсказки";
            НоваяКоманда.Параметр = "";
            НоваяКоманда = Объект.ТаблицаПонимаемыхКоманд.Добавить();
            НоваяКоманда.Имя = "/sys_info";
            НоваяКоманда.ВыполняемоеДействие = "СистемнаИнформация";
            НоваяКоманда.Описание = "системная инф-ция. Параметр через пробел:" +

                                                                                                          Символы.ПС + Символы.Таб + "ВерсияОС;ВерсияПриложения {по умолчанию};ИдентификаторКлиента;ИнформацияПрограммыПросмотра;ОперативнаяПамять;Процессор;ТипПлатформы.";
            НоваяКоманда.Параметр = "";
КонецПроцедуры

Создадим команду формы «ПоказатьСообщения», выведем ее на форму в виде кнопки и Обработчик команды

&НаКлиенте

Процедура ПоказатьСообщения(Команда = Неопределено)
            Ресурс = "bot" + Объект.Токен + "/getUpdates";
    Соединение  =  Новый HTTPСоединение(Объект.Сервер,443,,,,,Новый ЗащищенноеСоединениеOpenSSL());
            Запрос = Новый HTTPЗапрос(Ресурс);
            Ответ = Соединение.Получить(Запрос);
            ДвоичныеДанныеОтвета = Ответ.ПолучитьТелоКакДвоичныеДанные();
            ПрочитатьДвоичныеДанныеОтвета(ДвоичныеДанныеОтвета);
КонецПроцедуры

Обратите внимание, что для протокола «https» порт указывается 443

Если Вы используете версию 1С 8.3.6 и выше, то в процедура ПрочитатьДвоичныеДанныеОтвета() будем использовать новый объект ЧтениеJSON().

&НаСервере
Процедура ПрочитатьДвоичныеДанныеОтвета(ДвоичныеДанныеОтвета)
            ИмяФайла = ПолучитьИмяВременногоФайла("tgm");
            ДвоичныеДанныеОтвета.Записать(ИмяФайла);
            ДеревоЗн = Новый ДеревоЗначений();
            //{Для версии 1С 8.3.6 и выше
            ЧтениеJSON = Новый ЧтениеJSON();
            ЧтениеJSON.ОткрытьФайл(ИмяФайла);
            СформироватьДерево(ДеревоЗн, ДеревоЗн, ЧтениеJSON);
            ЧтениеJSON.Закрыть();
            //}

            //Создание колонок Реквизита формы типа ДанныеФормыДерево
            Если ЭтаФорма.Элементы.Дерево.ПодчиненныеЭлементы.Количество() = 0 Тогда
                МассивДобавляемыхРеквизитов = Новый Массив;
                Для Каждого Колонка Из ДеревоЗн.Колонки Цикл
                    МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы(Колонка.Имя, Колонка.ТипЗначения, "Дерево"));
                        КонецЦикла;
                        ИзменитьРеквизиты(МассивДобавляемыхРеквизитов);
            КонецЕсли;
            ////
    // Преобразование объекта прикладного типа ДеревоЗначений
    // в реквизит управляемой формы (данные формы)
    ЗначениеВРеквизитФормы(ДеревоЗн, "Дерево");
            //Создание колонок элемента формы типа ТаблицаФормы для отображения дерева
            //которое для наглядности разместили на форме дерево сообщений
            Если ЭтаФорма.Элементы.Дерево.ПодчиненныеЭлементы.Количество() = 0 Тогда
                Для Каждого Колонка Из ДеревоЗн.Колонки Цикл
                    НовыйЭлемент = Элементы.Добавить(Колонка.Имя, Тип("ПолеФормы"), Элементы.Дерево);
                    НовыйЭлемент.Вид = ВидПоляФормы.ПолеВвода;
                    НовыйЭлемент.ПутьКДанным = "Дерево." + Колонка.Имя;
                        КонецЦикла;
            КонецЕсли;
            ////
            ЗаполнитьРС(ДеревоЗн);
КонецПроцедуры

В процедуре ЗаполнитьРС() будем заполнять табличную часть «КомандыПользователей» (или же регистр сведений). (код процедуры далее).

Процедура ЗаполнитьСтруктуруИзОтветаJSON() заполняет дерево чатов:

//Рекурсивное заполнение дерева для версии 1С 8.3.6 и выше
&НаСервере
Процедура СформироватьДерево(Дерево, СтрДерево, ЧтениеJSON, Знач ИмяКолонки = Неопределено)
            ЧтениеJSON.Прочитать();
            TипJSON = ЧтениеJSON.ТипТекущегоЗначения;
            Если TипJSON = ТипЗначенияJSON.НачалоОбъекта ИЛИ TипJSON = ТипЗначенияJSON.НачалоМассива Тогда
                        НовСтр = СтрДерево.Строки.Добавить();
                        СформироватьДерево(Дерево, НовСтр, ЧтениеJSON);
            ИначеЕсли TипJSON = ТипЗначенияJSON.ИмяСвойства Тогда
                        СформироватьДерево(Дерево, СтрДерево, ЧтениеJSON, ЧтениеJSON.ТекущееЗначение);
            ИначеЕсли TипJSON = ТипЗначенияJSON.Число     ИЛИ TипJSON = ТипЗначенияJSON.Строка ИЛИ TипJSON = ТипЗначенияJSON.Булево  ИЛИ TипJSON = ТипЗначенияJSON.Null  Тогда
                        Если Дерево.Колонки.Найти(ИмяКолонки) = Неопределено Тогда
                                   Дерево.Колонки.Добавить(ИмяКолонки);
                        КонецЕсли;
                        СтрДерево[ИмяКолонки] = ЧтениеJSON.ТекущееЗначение;
                        СформироватьДерево(Дерево, СтрДерево, ЧтениеJSON);
            ИначеЕсли TипJSON = ТипЗначенияJSON.Комментарий Тогда
                        Если Дерево.Колонки.Найти("Комментарий") = Неопределено Тогда
                                   Дерево.Колонки.Добавить("Комментарий");
                        КонецЕсли;
                        СтрДерево.Комментарий = ЧтениеJSON.ТекущееЗначение;
                        СформироватьДерево(Дерево, СтрДерево, ЧтениеJSON);
            ИначеЕсли СтрДерево <> Неопределено Тогда
                        СформироватьДерево(Дерево, СтрДерево.Родитель, ЧтениеJSON);
            КонецЕсли;
КонецПроцедуры
//}

Если Вы используете версию 1С ниже 8.3.6 то процедура ПрочитатьДвоичныеДанныеОтвета() будет такой:

&НаСервере
Процедура ПрочитатьДвоичныеДанныеОтвета(ДвоичныеДанныеОтвета)
            ИмяФайла = ПолучитьИмяВременногоФайла("tgm");
            ДвоичныеДанныеОтвета.Записать(ИмяФайла);
            ДеревоЗн = Новый ДеревоЗначений();
            //{для версии 1С ниже 8.3.6 - раскомментируйте
            ЧтениеJSON = Новый ТекстовыйДокумент();
            ЧтениеJSON.Прочитать(ИмяФайла);
            Рез = ЗаполнитьСтруктуруИзОтветаJSON(ДеревоЗн, ДеревоЗн.Строки.Добавить(), ЧтениеJSON.ПолучитьТекст());
            //}
            //Создание колонок Реквизита формы типа ДанныеФормыДерево
            Если ЭтаФорма.Элементы.Дерево.ПодчиненныеЭлементы.Количество() = 0 Тогда
                МассивДобавляемыхРеквизитов = Новый Массив;
                Для Каждого Колонка Из ДеревоЗн.Колонки Цикл
                   МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы(Колонка.Имя, Колонка.ТипЗначения, "Дерево"));
                        КонецЦикла;
                        ИзменитьРеквизиты(МассивДобавляемыхРеквизитов);
            КонецЕсли;
            ////

    // Преобразование объекта прикладного типа ДеревоЗначений
    // в реквизит управляемой формы (данные формы)
    ЗначениеВРеквизитФормы(ДеревоЗн, "Дерево");
            //Создание колонок элемента формы типа ТаблицаФормы для отображения дерева
            //которое для наглядности разместили на форме дерево сообщений
            Если ЭтаФорма.Элементы.Дерево.ПодчиненныеЭлементы.Количество() = 0 Тогда
                Для Каждого Колонка Из ДеревоЗн.Колонки Цикл
                    НовыйЭлемент = Элементы.Добавить(Колонка.Имя, Тип("ПолеФормы"), Элементы.Дерево);
                    НовыйЭлемент.Вид = ВидПоляФормы.ПолеВвода;
                    НовыйЭлемент.ПутьКДанным = "Дерево." + Колонка.Имя;
                        КонецЦикла;
            КонецЕсли;
            ////
            ЗаполнитьРС(ДеревоЗн);
КонецПроцедуры

Как уже было сказано, в процедуре ЗаполнитьРС() будем заполнять табличную часть «КомандыПользователей» (или же регистр сведений). (код процедуры далее).

Процедура ЗаполнитьСтруктуруИзОтветаJSON() – это парсер JSON и рекурсивное заполнение дерева для версии ниже 1С 8.3.6:

//{Рекурсивное заполнение дерева для версии ниже 1С 8.3.6
&НаСервере
Функция ЗаполнитьСтруктуруИзОтветаJSON(Дерево, СтрДерево, Знач ТекстJSON) Экспорт
            Результат = Новый Структура;
            ТекстJSON = СтрЗаменить(ТекстJSON, "\""", """");
            ТекстJSON = СтрЗаменить(ТекстJSON, """", "");       
            Если Лев(ТекстJSON, 1) = "{" Тогда
                        ЗаполнитьДанныеИзОтветаJSON(Результат, ТекстJSON, "Структура", Дерево, СтрДерево);
            ИначеЕсли Лев(ТекстJSON, 1) = "[" Тогда
                        МассивДанных = Новый Массив;
                        ЗаполнитьДанныеИзОтветаJSON(МассивДанных, ТекстJSON, "Массив", Дерево, СтрДерево);
                        Результат.Вставить("Значение", МассивДанных);
            КонецЕсли;
            Возврат Результат;
КонецФункции

&НаСервере
Процедура ЗаполнитьДанныеИзОтветаJSON(Результат, ТекстJSON, ТипДанных, Дерево, СтрДерево)
            ТекстJSON = СокрЛП(Сред(ТекстJSON, 2));  
            НомерЗначения = 0;
            Пока ТекстJSON <> "" Цикл
                        ПервыйСимвол = Лев(ТекстJSON, 1);
                        Если ПервыйСимвол = "{" Тогда
                                   Значение = Новый Структура;
                                   НовСтр = СтрДерево.Строки.Добавить();
                                   ЗаполнитьДанныеИзОтветаJSON(Значение, ТекстJSON, "Структура", Дерево, НовСтр);
                                   Если ТипДанных = "Структура" Тогда
                                               Результат.Вставить("Значение" + ?(НомерЗначения = 0, "", НомерЗначения), Значение);
                                               НомерЗначения = НомерЗначения + 1;
                                   ИначеЕсли ТипДанных = "Массив" Тогда
                                               Результат.Добавить(Значение);
                                   КонецЕсли;
                        ИначеЕсли ПервыйСимвол = "[" Тогда
                                   Значение = Новый Массив;
                                   НовСтр = СтрДерево.Строки.Добавить();
                                   ЗаполнитьДанныеИзОтветаJSON(Значение, ТекстJSON, "Массив", Дерево, НовСтр);
                                   Если ТипДанных = "Структура" Тогда
                                               Результат.Вставить("Значение" + ?(НомерЗначения = 0, "", НомерЗначения), Значение);
                                               НомерЗначения = НомерЗначения + 1;
                                   Иначе
                                               Результат.Добавить(Значение);
                                   КонецЕсли;
                        ИначеЕсли ПервыйСимвол = "}" И ТипДанных = "Структура" Тогда
                                   ТекстJSON = СокрЛП(Сред(ТекстJSON, 2));
                                   Если Лев(ТекстJSON, 1) = "," Тогда
                                               ТекстJSON = СокрЛП(Сред(ТекстJSON, 2));
                                   КонецЕсли;
                                   Возврат;
                        ИначеЕсли ПервыйСимвол = "]" И ТипДанных = "Массив" Тогда
                                   ТекстJSON = СокрЛП(Сред(ТекстJSON, 2));
                                   Если Лев(ТекстJSON, 1) = "," Тогда
                                                ТекстJSON = СокрЛП(Сред(ТекстJSON, 2));
                                   КонецЕсли;
                                   Возврат;
                        Иначе
                                   Если ТипДанных = "Структура" Тогда
                                               Поз = Найти(ТекстJSON, ":");
                                               Если Поз = 0 Тогда
                                                          Прервать;
                                               КонецЕсли;
                                               ИмяЗначения = СокрЛП(Лев(ТекстJSON, Поз-1));
                                               ТекстJSON = СокрЛП(Сред(ТекстJSON, Поз+1));
                                               Если Лев(ТекстJSON, 1) = "{" Тогда
                                                           Значение = Новый Структура;
                                                           НовСтр = СтрДерево.Строки.Добавить();
                                                           ЗаполнитьДанныеИзОтветаJSON(Значение, ТекстJSON, "Структура", Дерево, НовСтр);
                                               ИначеЕсли Лев(ТекстJSON, 1) = "[" Тогда
                                                           Значение = Новый Массив;
                                                           НовСтр = СтрДерево.Строки.Добавить();
                                                           ЗаполнитьДанныеИзОтветаJSON(Значение, ТекстJSON, "Массив", Дерево, НовСтр);
                                               Иначе
                                                           Поз = 0;
                                                           Для Сч = 1 По СтрДлина(ТекстJSON) Цикл
                                                                       Символ = Сред(ТекстJSON, Сч, 1);
                                                                       Если Символ = "," ИЛИ Символ = "]" ИЛИ Символ = "}" Тогда
                                                                                  Поз = Сч;
                                                                                  Прервать;
                                                                       КонецЕсли;
                                                           КонецЦикла;
                                                           Если Поз = 0 Тогда
                                                                       Значение = ТекстJSON;
                                                                       ТекстJSON = "";
                                                           Иначе
                                                                       Значение = Лев(ТекстJSON, Поз-1);
                                                                       ТекстJSON = СокрЛП(Сред(ТекстJSON, Поз + ?(Сред(ТекстJSON, Поз, 1) = ",", 1, 0)));
                                                           КонецЕсли;
                                                           Значение = СокрЛП(Значение);
                                               КонецЕсли;
                                               Результат.Вставить(ИмяЗначения, Значение);
                                               Если Дерево.Колонки.Найти(ИмяЗначения) = Неопределено Тогда
                                                           Дерево.Колонки.Добавить(ИмяЗначения);
                                               КонецЕсли;
                                               Если ИмяЗначения = "text" Тогда
                                                           СтрДерево[ИмяЗначения] = ?(СтрДлина(Значение) > 1, Сред(Значение, 2), Значение);
                                               ИначеЕсли ИмяЗначения = "id" ИЛИ ИмяЗначения = "date" Тогда
                                                           СтрДерево[ИмяЗначения] = Число(Значение);
                                               Иначе
                                                           СтрДерево[ИмяЗначения] = Значение;
                                               КонецЕсли;
                                   ИначеЕсли ТипДанных = "Массив" Тогда
                                               Поз = 0;
                                               Для Сч = 1 По СтрДлина(ТекстJSON) Цикл
                                                           Символ = Сред(ТекстJSON, Сч, 1);
                                                           Если Символ = "," ИЛИ Символ = "]" ИЛИ Символ = "}" Тогда
                                                                       Поз = Сч;
                                                                       Прервать;
                                                           КонецЕсли;
                                               КонецЦикла;
                                               Если Поз = 0 Тогда
                                                           Значение = ТекстJSON;
                                                           ТекстJSON = "";
                                               Иначе
                                                           Значение = Лев(ТекстJSON, Поз-1);
                                                           ТекстJSON = СокрЛП(Сред(ТекстJSON, Поз + ?(Сред(ТекстJSON, Поз, 1) = ",", 1, 0)));
                                               КонецЕсли;
                                               Значение = СокрЛП(Значение);
                                               Результат.Добавить(Значение);
                                   КонецЕсли;
                        КонецЕсли;
            КонецЦикла;
КонецПроцедуры

Теперь опишем процедуру, заполняющую табличную часть «КомандыПользователей» либо регистр сведений:

&НаСервере
Процедура ЗаполнитьРС(ДеревоЗн)
            Для Каждого СтрОк Из ДеревоЗн.Строки Цикл//"Ок"
                        Для Каждого СтрНов Из СтрОк.Строки Цикл//
                                   Для Каждого СтрАп Из СтрНов.Строки Цикл//update_id
                                               Для Каждого СтрМесс Из СтрАп.Строки Цикл//message_id
                                                           date = СтрМесс.date;
                                                           Команда = СокрЛП(СтрМесс.text);
                                                           Параметр = "";  

                                                           ПозицияПараметра = Найти(Команда, " ");//СтрНайти(Команда, " ") не подходит, т.к. ищет в различных направлениях - не только с начала строки
                                                           Если ПозицияПараметра <> 0 Тогда
                                                                       Параметр = СокрЛП(Сред(Команда, ПозицияПараметра + 1));
                                                                       //{если версия ниже 1С 8.3.6 разкомментируйте
                                                                       //Параметр = ПереобразоватьЮникод(Параметр);
                                                                       //}
                                                                       Команда = Лев(Команда, ПозицияПараметра - 1);
                                                           КонецЕсли;
                                                           Если ЗначениеЗаполнено(Команда) Тогда
                                                                       МассивНайденныхКоманд = Объект.ТаблицаПонимаемыхКоманд.НайтиСтроки(Новый Структура("Имя", Команда));
                                                                       Если МассивНайденныхКоманд.Количество() > 0 Тогда
                                                                                  Для Каждого СтрИнфо Из СтрМесс.Строки Цикл//message_id
                                                                                              chat_id = СтрИнфо.id;
                                                                                              Если ЗначениеЗаполнено(chat_id) И chat_id > 0 Тогда
                                                                                                          //{Раскомментируйте, если используете регистр сведений КомандыПользователей
                                                                                                          //РС = РегистрыСведений.КомандыПользователей.СоздатьНаборЗаписей();
                                                                                                          //РС.Отбор.chat_id.Установить(chat_id);
                                                                                                          //РС.Отбор.date.Установить(date);
                                                                                                          //РС.Прочитать();
                                                                                                          //
                                                                                                          //Если РС.Количество() > 0 Тогда
                                                                                                          //        
                                                                                                          //         Для Каждого СтрРС Из РС Цикл
                                                                                                          //                     Если НЕ СтрРС.Выполнено Тогда
                                                                                                          //                                 СтрРС.Выполнено = ВыполнитьКомандуБота(СтрРС);
                                                                                                          //                     КонецЕсли;
                                                                                                          //         КонецЦикла;
                                                                                                          //        
                                                                                                          //         РС.Записать();
                                                                                                          //        
                                                                                                          //Иначе
                                                                                                          //         РСЗ = РегистрыСведений.КомандыПользователей.СоздатьМенеджерЗаписи();
                                                                                                          //         РСЗ.chat_id = chat_id;
                                                                                                          //         РСЗ.date = date;
                                                                                                          //         РСЗ.Команда = Команда;
                                                                                                          //         РСЗ.Выполнено = ВыполнитьКомандуБота(РСЗ);
                                                                                                          //         РСЗ.Записать();
                                                                                                          //        
                                                                                                          //КонецЕсли;
                                                                                                          //}
                                                                                                          //{а это закомментируйте, если используете РС КомандыПользователей
                                                                                                          РС = Объект.КомандыПользователей.НайтиСтроки(Новый Структура("chat_id, date", chat_id, date));
                                                                                                          Если РС.Количество() > 0 Тогда
                                                                                                                      Для Каждого СтрРС Из РС Цикл
                                                                                                                                 Если НЕ СтрРС.Выполнено Тогда
                                                                                                                                             СтрРС.Выполнено = ВыполнитьКомандуБота(СтрРС, Параметр);
                                                                                                                                 КонецЕсли;
                                                                                                                      КонецЦикла;
                                                                                                          Иначе
                                                                                                                      РСЗ = Объект.КомандыПользователей.Добавить();
                                                                                                                      РСЗ.chat_id = chat_id;
                                                                                                                      РСЗ.date = date;
                                                                                                                      РСЗ.Команда = Команда;
                                                                                                                      РСЗ.Выполнено = ВыполнитьКомандуБота(РСЗ, Параметр);
                                                                                                          КонецЕсли;
                                                                                                          //}
                                                                                                          прервать;
                                                                                              КонецЕсли;
                                                                                  КонецЦикла;
                                                                       Иначе
                                                                                  //команда не найдена
                                                                                  //можно вывести справку по командам
                                                                                  //...
                                                                       КонецЕсли;
                                                           КонецЕсли;
                                               КонецЦикла;
                                   КонецЦикла;
                        КонецЦикла;
            КонецЦикла
КонецПроцедуры

Если вы будете использовать регистр сведений (я назвал его «КомандыПользователей»), то закомментируйте/раскомментируйте соответствующие участки кода.

            Обратите внимание, что если версия ниже 1С 8.3.6, то в коде переменную Параметр надо преобразовать из Юникода (этот участок обозначен в коде в комментарии):

//{если версия ниже 1С 8.3.6 разкомментируйте
//Параметр = ПереобразоватьЮникод(Параметр);
//}
Для этого используем две функции Юникод – парсер (он нужен только для версии 1С ниже 8.3.6):
&НаСервере
Функция ПереобразоватьЮникод(Знач СтрокаВход)
            Строка = СтрокаВход;  
            // Создаем таблицу спецСимволов
            ТаблицаСимволов = Новый ТаблицаЗначений;
            ТаблицаСимволов.Колонки.Добавить("КодСимвола",Новый ОписаниеТипов("Строка", ,
                                                                                   Новый КвалификаторыСтроки(9, ДопустимаяДлина.Переменная)),,);
            ТаблицаСимволов.Колонки.Добавить("ЗначениеКода",Новый ОписаниеТипов("Строка", ,
                                                                                   Новый КвалификаторыСтроки(1, ДопустимаяДлина.Переменная)),,);
            Стр = ТаблицаСимволов.Добавить();
            Стр.КодСимвола = "\""";
            Стр.ЗначениеКода = """";
            Стр = ТаблицаСимволов.Добавить();
            Стр.КодСимвола = "\n";
            Стр.ЗначениеКода = Символы.ПС;
            Стр = ТаблицаСимволов.Добавить();
            Стр.КодСимвола = "\t";
            Стр.ЗначениеКода = Символы.Таб;
            Стр = ТаблицаСимволов.Добавить();
            Стр.КодСимвола = "\/";
            Стр.ЗначениеКода = "\";
            Стр = ТаблицаСимволов.Добавить();
            Стр.КодСимвола = "\u2013";
            Стр.ЗначениеКода = "–";
            Стр = ТаблицаСимволов.Добавить();
            Стр.КодСимвола = "\r";
            Стр.ЗначениеКода = Символы.ВК;  
            Стр = ТаблицаСимволов.Добавить();
            Стр.КодСимвола = "\u00bb";
            Стр.ЗначениеКода = """";
            Стр = ТаблицаСимволов.Добавить();
            Стр.КодСимвола = "\u00ab";
            Стр.ЗначениеКода = """";
            Для каждого Стр Из ТаблицаСимволов Цикл  // перебор спец символов

                        КодСимв = СокрЛП(Стр.КодСимвола);
                        ЗначениеСимвола = Стр.ЗначениеКода;
                        Строка = СтрЗаменить(Строка,КодСимв,ЗначениеСимвола);
            КонецЦикла;
            СтрокаСимволов ="абвгдеёжзийклмнопрстуфхцчшщъыьэюяАБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЪЫЬЭЮЯ"""; // набор декодируемых символов. Если вам нужны еще символы просто впишите их
            КоличествоСимв = СтрДлина(СтрокаСимволов);
            Счетчик = 0;
            Пока Счетчик <= КоличествоСимв Цикл   // кодировка в обычные символы
                        ТекСимвол = Сред(СтрокаСимволов,Счетчик,1);
                        ЮКод = ЮникодСимвола(ТекСимвол);
                        Строка = СтрЗаменить(Строка,НРег(ЮКод),ТекСимвол);
                        Строка = СтрЗаменить(Строка,ВРег(ЮКод),ТекСимвол);
                        Счетчик = Счетчик+1;
            КонецЦикла;
    Возврат Строка;
КонецФункции

 

&НаСервере
Функция ЮникодСимвола(знач Символ)
            пЧисло = КодСимвола(Символ,1); СимвСтр = "\u0000"; лЦифры = "123456789ABCDEF"; Рез = пЧисло; лСтр = "";
            Пока Рез > 0 Цикл
                        Ост = Рез % 16;
                        если ост < 10 Тогда  лСтр= ""+Ост+лСтр;
                        Иначе лСтр = Сред(лЦифры, Ост, 1) + лСтр; КонецЕсли;
                        Рез = Цел(Рез / 16);
            КонецЦикла;
            Возврат Лев(СимвСтр,6-СтрДлина(лСтр))+лСтр;
КонецФункции

//}

В процедуре ЗаполнитьРС() вызывается функция ВыполнитьКомандуБота(ЗаписьРегистра, Параметр), где ЗаписьРегистра – это строка табличной части ТаблицаПонимаемыхКоманд. Параметр – параметр команды (то, что написал боту пользователь).

&НаСервере
Функция ВыполнитьКомандуБота(ЗаписьРегистра, Параметр)
            Команда = ЗаписьРегистра.Команда;
            МассивНайденныхСтрок = Объект.ТаблицаПонимаемыхКоманд.НайтиСтроки(Новый Структура("Имя", Команда));//исправьте, если используете РС
            Если МассивНайденныхСтрок.Количество() > 0 Тогда
                        Для Каждого Стр Из МассивНайденныхСтрок Цикл
                                   Если Стр.ВыполняемоеДействие = "ВывестиПриветствие" Тогда
                                               //////ВывестиПриветствие(ЗаписьРегистра.chat_id);
                                   ИначеЕсли Стр.ВыполняемоеДействие = "ВывестиПодсказку" Тогда
                                               //////ВывестиПодсказку(ЗаписьРегистра.chat_id);
                                   ИначеЕсли  Стр.ВыполняемоеДействие = "СистемнаИнформация" Тогда
                                               //////ВывестиСистемнуюИнформацию(ЗаписьРегистра.chat_id, Параметр);
                                   Иначе
                                               //////ВывестиПодсказку(ЗаписьРегистра.chat_id);
                                   КонецЕсли;
                        КонецЦикла;
            Иначе
                        //////ВывестиПодсказку(ЗаписьРегистра.chat_id);
            КонецЕсли;
            возврат Истина;
КонецФункции

 

&НаСервере
Процедура СообщитьОбОшибке(chat_id, ТекстОшибки)
            Ресурс = "bot" + Объект.Токен + "/sendMessage?chat_id=" + СтрЗаменить(Формат(chat_id, "ЧДЦ=; ЧС=; ЧРГ=."), ".", "") + "&text=" + ТекстОшибки;
            Соединение  =  Новый HTTPСоединение(Объект.Сервер,443,,,,,Новый ЗащищенноеСоединениеOpenSSL());
            Запрос = Новый HTTPЗапрос(Ресурс);
            Ответ = Соединение.Получить(Запрос);
КонецПроцедуры

 

//Текстовое представление списка команд
&НаСервере
Функция СписокКоманд()
            СтрВозврата = "";
            Для Каждого Стр Из Объект.ТаблицаПонимаемыхКоманд Цикл
                        СтрВозврата = СтрВозврата + ?(СтрВозврата <> "", Символы.ПС, "") + Стр.Имя + " - " + Стр.Описание;
            КонецЦикла;
            возврат СтрВозврата;
КонецФункции

 

&НаСервере
Процедура ВывестиПриветствие(chat_id)
            Ресурс = "bot" + Объект.Токен + "/sendMessage?chat_id=" + СтрЗаменить(Формат(chat_id, "ЧДЦ=; ЧС=; ЧРГ=."), ".", "") + "&text= Здравствуйте!" +
            Символы.ПС + СписокКоманд() + Символы.ПС + "Удачи!";
            Соединение  =  Новый HTTPСоединение(Объект.Сервер,443,,,,,Новый ЗащищенноеСоединениеOpenSSL());
            Запрос = Новый HTTPЗапрос(Ресурс);
            Ответ = Соединение.Получить(Запрос);
КонецПроцедуры

 

&НаСервере
Процедура ВывестиПодсказку(chat_id)
            Ресурс = "bot" + Объект.Токен + "/sendMessage?chat_id=" + СтрЗаменить(Формат(chat_id, "ЧДЦ=; ЧС=; ЧРГ=."), ".", "") + "&text= " + СписокКоманд();
            Соединение  =  Новый HTTPСоединение(Объект.Сервер,443,,,,,Новый ЗащищенноеСоединениеOpenSSL());
            Запрос = Новый HTTPЗапрос(Ресурс);
            Ответ = Соединение.Получить(Запрос);
КонецПроцедуры

 

&НаСервере
Процедура ВывестиСистемнуюИнформацию(chat_id, Параметр)
            Параметр = ?(СокрЛП(Параметр) = "", "ВерсияПриложения", СокрЛП(Параметр));
            Инфо = Новый СистемнаяИнформация();
            Информация = "";
            Попытка
                        Информация = Инфо[Параметр];
            Исключение
                        Информация = ОписаниеОшибки();
            КонецПопытки;
            Ресурс = "bot" + Объект.Токен + "/sendMessage?chat_id=" + СтрЗаменить(Формат(chat_id, "ЧДЦ=; ЧС=; ЧРГ=."), ".", "") + "&text= " + Информация;
            Соединение  =  Новый HTTPСоединение(Объект.Сервер,443,,,,,Новый ЗащищенноеСоединениеOpenSSL());
            Запрос = Новый HTTPЗапрос(Ресурс);
            Ответ = Соединение.Получить(Запрос);
КонецПроцедуры

Здесь ВывестиСистемнуюИнформацию() – выводит информацию из базы данных1С. В нашем примере пользователю в Telegram бот может отправить информацию:

  • о версии операционной системы;
  • о версии используемого 1С:Предприятия 8 в формате <основная версия>.<младшая версия>.<релиз>.<дополнительный номер релиза>.(например, 8.2.9.200);
  • Уникальный идентификатор клиента. Для данного компьютера и данного пользователя операционной системы идентификатор один, вне зависимости от информационной базы и пользователя информационной базы;
  • о веб-браузере (userAgent);
  • о размере оперативной памяти;
  • Идентификатор процессора;
  • тип платформы, в рамках которой осуществляется работа.

Все, что мы сделали будет работать только тогда, когда пользователь нажмет кнопку «Показать сообщения».

Для того, чтобы все работало автоматом, лучше использовать фоновое задание. Но так как наша обработка не привязана к конкретной базе данных и к конкретной конфигурации. То подключим обработчик ожидания.

Сделаем так:

Создадим команду формы «ЗапускФоновыхЗаданий», разместим соответствующую кнопку на форме. Обработчик команды:

//Автоматическая работа

&НаКлиенте
Процедура АвтоматическаяРабота(Команда)
            ПодключитьОбработчикОжидания("Автомат",15);//Запуск каждые 15 секунд
КонецПроцедуры

&НаКлиенте
Процедура Автомат()
            ПоказатьСообщения();
КонецПроцедуры

////

Вот и все – обработка прилагается.

Отдельное спасибо пользователю Инфостарт igo1 -  перекодировка из Юникода (Unicode) в строку.

Основу для построения чата для версии 1С ниже 8.3.6 (парсер JSON) получил отсюда

 

UPD. В комментариях был задан вопрос "как отправлять файлы".

Вот текст процедуры, которая выполняет отчет "Продажи" (на СКД), сохраняет результат в Excel и отправляет в Telegram^

Процедура ОтправитьФайл(chat_id)
	
	Таб = Новый ТабличныйДокумент;
	
	Отчеты.Продажи.Создать().СкомпоноватьРезультат(Таб);
	
	ИмяФайла = ПолучитьИмяВременногоФайла("xlsx");
	
	Таб.Записать(ИмяФайла);
	
	СтрокаСоединения = "/bot" + Объект.Токен + "/sendDocument";
	
	Boundary = "----"+Строка(Новый УникальныйИдентификатор());
	
	//Определяем массив для процедуры ОбъединитьФайлы
	МассивФайловДляОбъединения = Новый Массив;
	
	//Формируем начальный фрагмент файла POST-запроса
	ИмяФайлаОтправкиНачало = ПолучитьИмяВременногоФайла("txt");
	ФайлОтправкиНачало = Новый ЗаписьТекста(ИмяФайлаОтправкиНачало, КодировкаТекста.UTF8);
	
	//Формируем конечный фрагмент файла POST-запроса
	ИмяФайлаОтправкиКонец = ПолучитьИмяВременногоФайла("txt");
	ФайлаОтправкиКонец = Новый ЗаписьТекста(ИмяФайлаОтправкиКонец, КодировкаТекста.UTF8);
	
	ТекстДляОтправки = "";
	
	ТекстДляОтправки = ТекстДляОтправки + "--"+Boundary + Символы.ПС;
	ТекстДляОтправки = ТекстДляОтправки + "Content-Disposition: form-data; name=""chat_id""" + Символы.ПС + Символы.ПС;
	ТекстДляОтправки = ТекстДляОтправки + chat_id + Символы.ПС;
	
	ТекстДляОтправки = ТекстДляОтправки + "--"+Boundary + Символы.ПС;
	ТекстДляОтправки = ТекстДляОтправки + "Content-Disposition: form-data; name=""document""; filename=""report.xlsx""" + Символы.ПС;
	
	ФайлОтправкиНачало.ЗаписатьСтроку(ТекстДляОтправки );
	ФайлОтправкиНачало.Закрыть();
	
	МассивФайловДляОбъединения.Добавить(ИмяФайлаОтправкиНачало);
	
	МассивФайловДляОбъединения.Добавить(СокрЛП(ИмяФайла));
	
	ТекстДляОтправки = "" + Символы.ПС;
	ТекстДляОтправки = ТекстДляОтправки + "--"+Boundary+"--";
	ФайлаОтправкиКонец.ЗаписатьСтроку(ТекстДляОтправки);
	ФайлаОтправкиКонец.Закрыть();
	МассивФайловДляОбъединения.Добавить(ИмяФайлаОтправкиКонец);
	
	ИмяФайлаОтправки = ПолучитьИмяВременногоФайла("txt");
	ОбъединитьФайлы(МассивФайловДляОбъединения, ИмяФайлаОтправки);
	
	HTTPЗапрос = Новый HTTPЗапрос;
	Заголовки = Новый Соответствие;
	
	HTTPЗапрос.Заголовки.Вставить("Connection", "keep-alive");
	HTTPЗапрос.Заголовки.Вставить("Content-Type", "multipart/form-data; boundary="+Boundary);
	
	HTTPЗапрос.УстановитьИмяФайлаТела(ИмяФайлаОтправки);
	HTTPЗапрос.АдресРесурса = СтрокаСоединения;
	
	ЗащищенноеСоединение = Новый ЗащищенноеСоединениеOpenSSL(Новый СертификатКлиентаWindows, Новый СертификатыУдостоверяющихЦентровWindows);
	HTTPСоединение = Новый HTTPСоединение(Объект.Сервер,,,,,, ЗащищенноеСоединение);
	
	Попытка
		ОтветHTTP = HTTPСоединение.ОтправитьДляОбработки(HTTPЗапрос);
	Исключение
		СообщитьОбОшибке(chat_id, ОписаниеОшибки());
	КонецПопытки;
КонецПроцедуры

Спасибо,  FSerg, отличие отправки фото от файла - API метод sendDocument.

Скачать файлы

Наименование Файл Версия Размер
Пример готовой обработки обмен между 1С и мессенджера Telegram

.epf 12,95Kb
18.11.15
492
.epf 12,95Kb 492 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. iolko 266 19.11.15 11:56 Сейчас в теме
2. Luchik 583 19.11.15 13:46 Сейчас в теме
(1) iolko, в публикации много чего не показано, например, как из 1С передавать файлы... или по команде из telegram запускать, допустим, выгрузку информационно базы - напишите, многим будет интересно
5. iolko 266 20.11.15 04:00 Сейчас в теме
(2) это да (про файлы) , в принципе вся логика уже готова, наверное в понедельник будет доступно, ну и подход к обработке сообщений, немного другой.
6. nomadon 394 20.11.15 11:29 Сейчас в теме
(5) iolko, (1) iolko, (2) посмотрите этот пример)) http://infostart.ru/public/416348/
9. iolko 266 22.11.15 17:28 Сейчас в теме
(6) nomadon, да понятно, что уже выдумато ))) но вот ни как не могу допонять как отправлять файлы.... вот ни как... может у кого есть идеи или примеры или толковое описание...
grin_64; yur4ik9408; +2 Ответить
162. user853472 25.02.18 23:32 Сейчас в теме
(1)
Доброго времени суток! Помогите отправить картинку с клавиатурой inline_keyboard.

Если убрать секцию с клавиатурой то все работает. Клавиатура нужна очень...шел третий день....

Пользуюсь кодом:
ддКартинка = Блюдо.Ссылка.ОсновноеИзображение.Хранилище.Получить().ПолучитьДвоичныеДанные();
				
				времКаталог = КаталогВременныхФайлов();
				времФайлКартинки = ПолучитьИмяВременногоФайла("jpg");
				имяВремяФайла = СтрЗаменить(времФайлКартинки,времКаталог,"");
								
				ддКартинка.Записать(времФайлКартинки);
				
				СтрокаСоединения = "/bot" + Константы.Токен.Получить() + "/sendPhoto";
				
				//Определяем массив для процедуры ОбъединитьФайлы 
				МассивФайловДляОбъединения = Новый Массив; 
				
				//Формируем начальный фрагмент файла POST-запроса 
				ИмяФайлаОтправкиНачало = ПолучитьИмяВременногоФайла("txt"); 
				ФайлОтправкиНачало = Новый ЗаписьТекста(ИмяФайлаОтправкиНачало, КодировкаТекста.UTF8); 
				
				//Формируем конечный фрагмент файла POST-запроса 
				ИмяФайлаОтправкиКонец = ПолучитьИмяВременногоФайла("txt"); 
				ФайлаОтправкиКонец = Новый ЗаписьТекста(ИмяФайлаОтправкиКонец, КодировкаТекста.UTF8);
				
				ТекстДляОтправки = "";
				
				Boundary = "----" + Строка(Новый УникальныйИдентификатор());
				
				// ЧАТ
				ТекстДляОтправки = ТекстДляОтправки + "--" + Boundary + Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + "Content-Disposition: form-data; name=""chat_id"""+ Символы.ПС + Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + СокрЛП(Формат(Клиент.Код,"ЧГ=0")) + Символы.ПС;
				
				// ПОДПИСЬ  
				Подпись = "Наименование: " + Блюдо.Ссылка.Наименование + Символы.ПС + "Цена: " + Блюдо.Ссылка.Цена;  
				
				ТекстДляОтправки = ТекстДляОтправки + "--" + Boundary + Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + "Content-Disposition: form-data; name=""caption""" + Символы.ПС + Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + СокрЛП(Подпись) + Символы.ПС;
				                                                         
				// ФОТО
				ТекстДляОтправки = ТекстДляОтправки + "--" +  Boundary + Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + "Content-Disposition: form-data; name=""photo""; filename=""" + имяВремяФайла + """" + Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + "Content-Type: image/jpg" + Символы.ПС;
				
				//КЛАВИАТУРА
				клСтруктура = Новый Структура;
				Строки = Новый Массив;
				Кнопки = Новый Массив;
				Кнопки.Добавить(Новый Структура("text, callback_data", "В корзину", Блюдо.Ссылка.Код));
				Строки.Добавить(Кнопки);	
				клСтруктура.Вставить("inline_keyboard",Строки);
				ЗаписьJSON = Новый ЗаписьJSON;
				ЗаписьJSON.УстановитьСтроку(Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет));  //Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет,,,ЭкранированиеСимволовJSON.СимволыВнеASCII)  
				ЗаписатьJSON(ЗаписьJSON,клСтруктура,,);
				Клавиатура = ЗаписьJSON.Закрыть();

				ТекстДляОтправки = ТекстДляОтправки + "--" +  Boundary + Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + "Content-Disposition: form-data; name=""reply_markup""" + Символы.ПС+ Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + СокрЛП(Клавиатура) + Символы.ПС; 				
				
				ФайлОтправкиНачало.ЗаписатьСтроку(ТекстДляОтправки);
				ФайлОтправкиНачало.Закрыть(); 
				
				МассивФайловДляОбъединения.Добавить(ИмяФайлаОтправкиНачало); 
				МассивФайловДляОбъединения.Добавить(времФайлКартинки); 
				
				ТекстДляОтправки = "";
				ТекстДляОтправки = ТекстДляОтправки + Символы.ПС  + "--" +  Boundary+"--";
				ФайлаОтправкиКонец.ЗаписатьСтроку(ТекстДляОтправки);
				ФайлаОтправкиКонец.Закрыть(); 
				МассивФайловДляОбъединения.Добавить(ИмяФайлаОтправкиКонец); 
				
				ИмяФайлаОтправки = ПолучитьИмяВременногоФайла("txt");
				
				ОбъединитьФайлы(МассивФайловДляОбъединения, ИмяФайлаОтправки);
				
				HTTPЗапрос = Новый HTTPЗапрос;
				HTTPЗапрос.Заголовки.Вставить("Connection", "keep-alive"); 
				HTTPЗапрос.Заголовки.Вставить("Content-Type", "multipart/form-data; boundary="+Boundary); 
				HTTPЗапрос.УстановитьИмяФайлаТела(ИмяФайлаОтправки);    
				HTTPЗапрос.АдресРесурса = СтрокаСоединения; 
				
				Результат = ОтправитьЗапросНаОбработкуВTelegramPOST(HTTPЗапрос);
Показать
163. user853472 25.02.18 23:33 Сейчас в теме
(1)

Доброго времени суток! Помогите отправить картинку с клавиатурой inline_keyboard.

Если убрать секцию с клавиатурой то все работает. Клавиатура нужна очень...шел третий день....

Пользуюсь кодом:
ддКартинка = Блюдо.Ссылка.ОсновноеИзображение.Хранилище.Получить().ПолучитьДвоичныеДанные();
				
				времКаталог = КаталогВременныхФайлов();
				времФайлКартинки = ПолучитьИмяВременногоФайла("jpg");
				имяВремяФайла = СтрЗаменить(времФайлКартинки,времКаталог,"");
								
				ддКартинка.Записать(времФайлКартинки);
				
				СтрокаСоединения = "/bot" + Константы.Токен.Получить() + "/sendPhoto";
				
				//Определяем массив для процедуры ОбъединитьФайлы 
				МассивФайловДляОбъединения = Новый Массив; 
				
				//Формируем начальный фрагмент файла POST-запроса 
				ИмяФайлаОтправкиНачало = ПолучитьИмяВременногоФайла("txt"); 
				ФайлОтправкиНачало = Новый ЗаписьТекста(ИмяФайлаОтправкиНачало, КодировкаТекста.UTF8); 
				
				//Формируем конечный фрагмент файла POST-запроса 
				ИмяФайлаОтправкиКонец = ПолучитьИмяВременногоФайла("txt"); 
				ФайлаОтправкиКонец = Новый ЗаписьТекста(ИмяФайлаОтправкиКонец, КодировкаТекста.UTF8);
				
				ТекстДляОтправки = "";
				
				Boundary = "----" + Строка(Новый УникальныйИдентификатор());
				
				// ЧАТ
				ТекстДляОтправки = ТекстДляОтправки + "--" + Boundary + Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + "Content-Disposition: form-data; name=""chat_id"""+ Символы.ПС + Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + СокрЛП(Формат(Клиент.Код,"ЧГ=0")) + Символы.ПС;
				
				// ПОДПИСЬ  
				Подпись = "Наименование: " + Блюдо.Ссылка.Наименование + Символы.ПС + "Цена: " + Блюдо.Ссылка.Цена;  
				
				ТекстДляОтправки = ТекстДляОтправки + "--" + Boundary + Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + "Content-Disposition: form-data; name=""caption""" + Символы.ПС + Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + СокрЛП(Подпись) + Символы.ПС;
				                                                         
				// ФОТО
				ТекстДляОтправки = ТекстДляОтправки + "--" +  Boundary + Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + "Content-Disposition: form-data; name=""photo""; filename=""" + имяВремяФайла + """" + Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + "Content-Type: image/jpg" + Символы.ПС;
				
				//КЛАВИАТУРА
				клСтруктура = Новый Структура;
				Строки = Новый Массив;
				Кнопки = Новый Массив;
				Кнопки.Добавить(Новый Структура("text, callback_data", "В корзину", Блюдо.Ссылка.Код));
				Строки.Добавить(Кнопки);	
				клСтруктура.Вставить("inline_keyboard",Строки);
				ЗаписьJSON = Новый ЗаписьJSON;
				ЗаписьJSON.УстановитьСтроку(Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет));  //Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет,,,ЭкранированиеСимволовJSON.СимволыВнеASCII)  
				ЗаписатьJSON(ЗаписьJSON,клСтруктура,,);
				Клавиатура = ЗаписьJSON.Закрыть();

				ТекстДляОтправки = ТекстДляОтправки + "--" +  Boundary + Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + "Content-Disposition: form-data; name=""reply_markup""" + Символы.ПС+ Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + СокрЛП(Клавиатура) + Символы.ПС; 				
				
				ФайлОтправкиНачало.ЗаписатьСтроку(ТекстДляОтправки);
				ФайлОтправкиНачало.Закрыть(); 
				
				МассивФайловДляОбъединения.Добавить(ИмяФайлаОтправкиНачало); 
				МассивФайловДляОбъединения.Добавить(времФайлКартинки); 
				
				ТекстДляОтправки = "";
				ТекстДляОтправки = ТекстДляОтправки + Символы.ПС  + "--" +  Boundary+"--";
				ФайлаОтправкиКонец.ЗаписатьСтроку(ТекстДляОтправки);
				ФайлаОтправкиКонец.Закрыть(); 
				МассивФайловДляОбъединения.Добавить(ИмяФайлаОтправкиКонец); 
				
				ИмяФайлаОтправки = ПолучитьИмяВременногоФайла("txt");
				
				ОбъединитьФайлы(МассивФайловДляОбъединения, ИмяФайлаОтправки);
				
				HTTPЗапрос = Новый HTTPЗапрос;
				HTTPЗапрос.Заголовки.Вставить("Connection", "keep-alive"); 
				HTTPЗапрос.Заголовки.Вставить("Content-Type", "multipart/form-data; boundary="+Boundary); 
				HTTPЗапрос.УстановитьИмяФайлаТела(ИмяФайлаОтправки);    
				HTTPЗапрос.АдресРесурса = СтрокаСоединения; 
				
				Результат = ОтправитьЗапросНаОбработкуВTelegramPOST(HTTPЗапрос);
Показать
170. user790109 8 11.03.18 18:40 Сейчас в теме
(163) у тебя не возникало ошибки в строке
ОбъединитьФайлы(МассивФайловДляОбъединения, ИмяФайлаОтправки);
? возникает ошибка типа Ошибка при вызове метода контекста (ОбъединитьФайлы)
ОбъединитьФайлы(МассивФайловДляОбъединения, ИмяФайлаОтправки);
по причине:
Ошибка сборки файла
по причине:
Ошибка совместного доступа к файлу 'C:\Users\Гуру\AppData\Local\Temp\v8_7B5A_12.txt'
174. user853472 19.03.18 20:33 Сейчас в теме
(170) нет не возникало.
Совместный доступ, значит уже кто-то/что-то юзает это файл
195. slavik_s 12.12.18 10:08 Сейчас в теме
(163) А зачем посылать клавиатуру в тот момент когда отсылаем картинку? В момент отправки картинки на сервер Телеграм, он возвращает уникальный номер картинки, поэтому в дальнейшем достаточно покупателю отсылать этот номер, а сервер находит вашу картинку и посылает её. Порядок работы нужно изменить. Сначала отсылаем ВСЕ КАРТИНКИ и получаем их номера из Телеграм и записываем их у себя в базу. А теперь имея номер картинки посылаем file_id и подпись под картинкой и необходимую клавиатуру, то есть манипулируем уже не картинками, а номерами file_id. Об этом же все написано в документации Телеграм Bot API.
3. Lapitskiy 985 19.11.15 17:18 Сейчас в теме
Ух, жесть какая-то :)
Все больше на ИС обработок скрещивания1С и прочего и прочего :)
Это замечательно, но напоминает анекдот о том, как британские ученые скрещивали слона и слона, не для пользы, а так просто, "позырить" :)
Hobbit_Jedi; inf012; romankoav; German; +4 10 Ответить
4. Luchik 583 19.11.15 17:29 Сейчас в теме
(3) Lapitskiy, ;) Можно и для
"позырить"
- я так частенько от наработок других программистов что-то интересное для себя нахожу, поэтому и сам готов поделиться...
Albert_2008; kamsky93; Aleks_Zorro; METAL; WanGoff; +5 Ответить
7. eskor 92 20.11.15 11:32 Сейчас в теме
Luchik, отличная статья, толково и не затянуто. Надо будет поэкспериментировать с Telegram, а то раньше все руки не доходили разобраться.
Спасибо, "плюс в репу"!!!
8. Luchik 583 20.11.15 13:33 Сейчас в теме
(7) eskor, очень приятно :) Спасибо!
10. Luchik 583 24.11.15 09:15 Сейчас в теме
Посмотри http://catalog.1cv7.md/public/387433/ там в комментарии FSerg сделал через ОбъединитьФайлы()
11. PLAstic 263 25.11.15 09:28 Сейчас в теме
198. mamont_d 04.02.19 14:06 Сейчас в теме
(11)а ты сам, резист или энлайт?
199. PLAstic 263 04.02.19 15:02 Сейчас в теме
(198) Кто за прогресс, за развитие науки и технологий, тот, кто и сам занимается этим развитием в 1С, не может быть резистом.
12. sound 531 25.11.15 09:40 Сейчас в теме
Телеграм это тема! Жаль что у меня сервер в закрытой сети, так бы тоже нашел применение. Автору респект за труды и статью.
13. proger1c81 25.11.15 10:56 Сейчас в теме
Поставил себе в избранное. Спасибо за труды.
Как здесь поставить лайк или плюсик за статью?
14. Luchik 583 25.11.15 11:02 Сейчас в теме
(13) proger1c81, Спасибо, достаточно добавления в Избранное :)
15. FSerg 66 27.11.15 11:03 Сейчас в теме
Класс!
Побежал прикручивать бота к 1С :)
16. TreeDogNight 18 30.11.15 15:23 Сейчас в теме
Спасибо за интересную и полезную статью!
К сожалению процедура ОтправитьФайл() не работает=( Всё проходит без ошибок, но и сообщения в телеграме не приходит... Подозреваю, что я передаю туда не правильный "chat_id". Можете пожалуйста объяснить, что из себя представляет этот "chat_id" ?
17. Luchik 583 30.11.15 16:35 Сейчас в теме
(16) TreeDogNight, chat_id это id пользователя - число. Все кто пишет боту получают chat_id. Напишите что-нибудь своему боту, а затем выполните https://api.telegram.org/ВАШТОКЕН/getUpdates в браузере - в ответе сможете найти chat_id (аналогичные действия выполнены в процедуре ПоказатьСообщения() )
TreeDogNight; +1 Ответить
63. DanilaDru 255 05.08.16 16:45 Сейчас в теме
(17) Вы сталкивались с тем что https://api.telegram.org/ТОКЕН/getUpdates возвращает только то что написал в бот создатель бота, а другие пользовтаели телеграмма не видны ?
18. TreeDogNight 18 01.12.15 06:36 Сейчас в теме
Получается chat_id я передаю правильный...
А на что кстати влияет filename?
ТекстДляОтправки = ТекстДляОтправки + "Content-Disposition: form-data; name=""document""; filename=""report.xlsx""" + Символы.ПС
19. TreeDogNight 18 01.12.15 06:45 Сейчас в теме
 ТекстДляОтправки = ТекстДляОтправки + chat_id + Символы.ПС;

Доработал это место, добавил формат
ТекстДляОтправки = ТекстДляОтправки + Формат(chat_id, "ЧГ=0") + Символы.ПС;

И всё заработало, файл пришел
97. Nicholas 750 11.03.17 14:47 Сейчас в теме
Столкнулся вот с такой ошибкой:

{Обработка.ТелеграммБот.Форма.Форма.Форма(19)}: Ошибка при вызове метода контекста (ПрочитатьДвоичныеДанныеОтвета)
ПрочитатьДвоичныеДанныеОтвета(ДвоичныеДанныеОтвета);
по причине:
Переполнение стека встроенного языка на сервере
по причине:

Обработка.ТелеграммБот.Форма.Форма.Форма : 32 : СформироватьДерево(ДеревоЗн, ДеревоЗн, ЧтениеJSON);
Обработка.ТелеграммБот.Форма.Форма.Форма : 71 : СформироватьДерево(Дерево, НовСтр, ЧтениеJSON);
Обработка.ТелеграммБот.Форма.Форма.Форма : 75 : СформироватьДерево(Дерево, СтрДерево, ЧтениеJSON, ЧтениеJSON.ТекущееЗначение);
Обработка.ТелеграммБот.Форма.Форма.Форма : 83 : СформироватьДерево(Дерево, СтрДерево, ЧтениеJSON);
...
Обработка.ТелеграммБот.Форма.Форма.Форма : 75 : СформироватьДерево(Дерево, СтрДерево, ЧтениеJSON, ЧтениеJSON.ТекущееЗначение);
Обработка.ТелеграммБот.Форма.Форма.Форма : 83 : СформироватьДерево(Дерево, СтрДерево, ЧтениеJSON);
Обработка.ТелеграммБот.Форма.Форма.Форма : 75 : СформироватьДерево(Дерево, СтрДерево, ЧтениеJSON, ЧтениеJSON.ТекущееЗначение);
Обработка.ТелеграммБот.Форма.Форма.Форма : 0
по причине:
Переполнение стека встроенного языка на сервере
98. Luchik 583 13.03.17 09:47 Сейчас в теме
(97)
Да, рекурсия имеет недостаток, связанный с возможностью переполнения стека. Используйте поуровневый обход дерева - пример здесь: http://infostart.ru/public/20797/
Nicholas; +1 Ответить
100. bloodydiman 1 22.03.17 10:22 Сейчас в теме
(97) Проблему решил следующим образом:

	ДеревоЗн = Новый ДеревоЗначений();	
	ЧтениеJSON = Новый ЧтениеJSON();
	ЧтениеJSON.ОткрытьФайл(ИмяФайла);
	СтрДерево = ДеревоЗн;
	Пока ЧтениеJSON.Прочитать() Цикл
		СтрДерево = СформироватьДерево(ДеревоЗн, СтрДерево, ЧтениеJSON,, Ложь);	
	КонецЦикла;
	ЧтениеJSON.Закрыть();

&НаСервере
Функция СформироватьДерево(ДеревоЗн, СтрДерево, ЧтениеJSON, Знач ИмяКолонки = Неопределено, Прочитать = Истина)
	
	Если Прочитать Тогда
		ЧтениеJSON.Прочитать();
	КонецЕсли;
	TипJSON = ЧтениеJSON.ТипТекущегоЗначения;
	Если TипJSON = ТипЗначенияJSON.НачалоОбъекта ИЛИ TипJSON = ТипЗначенияJSON.НачалоМассива Тогда
		НовСтр = СтрДерево.Строки.Добавить();
		Возврат СформироватьДерево(ДеревоЗн, НовСтр, ЧтениеJSON);
	ИначеЕсли TипJSON = ТипЗначенияJSON.ИмяСвойства Тогда
		Возврат СформироватьДерево(ДеревоЗн, СтрДерево, ЧтениеJSON, ЧтениеJSON.ТекущееЗначение);
	ИначеЕсли TипJSON = ТипЗначенияJSON.Число ИЛИ TипJSON = ТипЗначенияJSON.Строка ИЛИ TипJSON = ТипЗначенияJSON.Булево ИЛИ TипJSON = ТипЗначенияJSON.Null Тогда 
		Если ДеревоЗн.Колонки.Найти(ИмяКолонки) = Неопределено Тогда
			ДеревоЗн.Колонки.Добавить(ИмяКолонки);
		КонецЕсли;
		СтрДерево[ИмяКолонки] = ЧтениеJSON.ТекущееЗначение;
		Возврат СформироватьДерево(ДеревоЗн, СтрДерево, ЧтениеJSON);
	ИначеЕсли TипJSON = ТипЗначенияJSON.Комментарий Тогда
		Если ДеревоЗн.Колонки.Найти("Комментарий") = Неопределено Тогда
			ДеревоЗн.Колонки.Добавить("Комментарий");
		КонецЕсли;
		СтрДерево.Комментарий = ЧтениеJSON.ТекущееЗначение;
		Возврат СформироватьДерево(ДеревоЗн, СтрДерево, ЧтениеJSON);
	ИначеЕсли СтрДерево <> Неопределено Тогда
		Возврат СтрДерево.Родитель;
	//	СформироватьДерево(ДеревоЗн, СтрДерево.Родитель, ЧтениеJSON);
	КонецЕсли;
	
КонецФункции
Показать
101. Nicholas 750 22.03.17 11:32 Сейчас в теме
104. PLAstic 263 23.03.17 16:36 Сейчас в теме
(100) Я давал выше вариант, при котором никаких проблем нет. Уже несколько ботов сделал и они прекрасно работают.
20. eskor 92 02.12.15 11:01 Сейчас в теме
Парни, ткните носом - начал экспериментировать с ботом, но впоролся в отсутствие описания команд.
Например \getUpdate возвращает все сообщения в истории чата. Но на практике нужны только новые, на крайний случай нужна команда на стороне бота для очистки чата(ов). Можно конечно отсекать сообщения на стороне 1С, но это несерьезно, иначе придется пересоздавать бота с завидной регулярностью.
21. Luchik 583 02.12.15 11:17 Сейчас в теме
(20) eskor, Telegram хранит сообщения чата некоторое время, по истечении которого \getUpdate уже не вернет никаких сообщений. Поэтому хранить старые и, соответственно, отбирать только новые надо на стороне 1С (напрмер, использовать регистр сведений)
22. eskor 92 02.12.15 11:25 Сейчас в теме
(21) Спасибо за ответ. Просто вчера начал долбить командами, до сих пор они еще в чат всплывают.
Кстати, на платформе 8.2 не хотят работать конструкции HTTPЗапрос. Заменил на СОМ-объект, стало намного удобнее:
Ресурс = "/bot" + Токен + "/getUpdates";
	HTTP = Новый COMОбъект("WinHttp.WinHttpRequest.5.1");
	Попытка
		HTTP.Open("GET", "https://"+Сервер+Ресурс, Ложь);
		HTTP.Send();
	Исключение
		//Сообщить(ОписаниеОшибки());
	КонецПопытки;
	ВхТекст = HTTP.ResponseText;

	ПрочитатьДанныеОтвета(ВхТекст);
Показать

на выходе получаем чистый текст, который на сервер передается без "бубна".
kare; MCitrus; TreeDogNight; +3 Ответить
23. TreeDogNight 18 03.12.15 07:22 Сейчас в теме
(20) eskor, На сайте телеграма в разделе описания API нашёл описания всех команд и их параметры, в том числе и getUpdates

Вот только как передать эти параметры в http запрос, пока не понял...
24. eskor 92 03.12.15 10:24 Сейчас в теме
(23) TreeDogNight, это я видел, даже пытался в разных вариантах в браузере подергать, увы безрезультатно. Будем надеяться, что срок хранения сообщений не так велик, хотя иметь возможность чистить чаты надо, однозначно. Должна быть команда аналогичная клиентской, что-то типа /ClearHistory или /ClearChat, пока я ее не нашел.
UPD: очередные грабли нашел: никак не могу подобрать символ переноса строки, скорее всего из-за СОМ-объекта не срабатывает Символы.ПС, конструкция html /n тоже не сработала,
-аналогично.
25. TreeDogNight 18 05.12.15 10:09 Сейчас в теме
(24) eskor, У меня получилось настроить получение актуальных обновлений. Вот код:
&НаСервере
Функция ПолучитьОбновления(Смещение = 0, КоличествоОбновлений = 100, Таймаут = 0)

	КоличествоОбновлений = Мин(КоличествоОбновлений, 100);
	
	//Соберем параметры для запроса, если таковые имеются:
	ПараметрыЗапроса = "";
	Если Смещение > 0 Тогда 
		ПараметрыЗапроса = "?offset="+Формат(Смещение, "ЧГ=0");	
	КонецЕсли;
	
	Если Не КоличествоОбновлений = 100 Тогда 
		Если ЗначениеЗаполнено(ПараметрыЗапроса) Тогда 
			ПараметрыЗапроса = "&limit="+Формат(КоличествоОбновлений, "ЧГ=0");	
		Иначе 
			ПараметрыЗапроса = "?limit="+Формат(КоличествоОбновлений, "ЧГ=0");	
		КонецЕсли;
	КонецЕсли;
	
	Если Таймаут > 0 Тогда 
		Если ЗначениеЗаполнено(ПараметрыЗапроса) Тогда 
			ПараметрыЗапроса = "&timeout="+Формат(Таймаут, "ЧГ=0");	
		Иначе 
			ПараметрыЗапроса = "?timeout="+Формат(Таймаут, "ЧГ=0");	
		КонецЕсли;                                                                                                
	КонецЕсли;
	
	Ресурс 				 = "bot" + Объект.Токен + "/"+ИмяМетодаHTTP+ПараметрыЗапроса;
	Соединение  		 = Новый HTTPСоединение(Объект.Сервер,443,,,,,Новый ЗащищенноеСоединениеOpenSSL());
	Запрос 				 = Новый HTTPЗапрос(Ресурс);
	Ответ 				 = Соединение.Получить(Запрос);
	ДвоичныеДанныеОтвета = Ответ.ПолучитьТелоКакДвоичныеДанные(); 
	
	Возврат ДвоичныеДанныеОтвета;
	
КонецФункции
Показать
27. eskor 92 07.12.15 14:18 Сейчас в теме
(25) TreeDogNight, мы похоже с GET запросом колдуем, для проверки сообщений пойдет на ура, а вот отправку надо в POST запросе гнать, как раз параметры в справке намекают на это, похоже именно там расстановка переносов и прочие параметры.
Для моего кода это изменять тип и вставлять параметры в HTTP.Send(.......). В джейсона простейшее преобразование через 2 массива, в одном ищешь свой символ и по тому же индексу получаешь соответствие, только вот что и зачем?
TreeDogNight; +1 Ответить
30. iolko 266 09.12.15 07:22 Сейчас в теме
(25) TreeDogNight,
Вообще можно сделать так....
1) Берем GetUpdates - получаем ID всех обновлений.
Пишем в массив, берем максимум от массива - это последнее обновление, пишем хоть куда (регистр, спр, константа)
И все... дальше отправляем запрос
getUpdates?offers=(тут ID сообщения +1)&limit=1
в результате .. если результат > 0 то у нас есть новое сообщение.
При этом если результат = 0 и потом выполнить GetUpdates - то история Telegram очищается.
Это одна из реализаций.

Вторая
Опрашиваем через GetUpdates - пишем в регистр ID, текст, ChatID и статус - отвечено или нет
ну а потом просто сравниваем то что пришло и отвечено - игнорим, то что пришло и не отвечено отвечаем и пишем статус.

При этом из текстов API видно, что GetUpdates хранит историю максимум за 24 часа... так что мы не перегрузим проверку на сообщения.
От как то так, Всем УдачеФФ!!
Kireno; nightowl; METAL; eskor; TreeDogNight; +5 Ответить
31. TreeDogNight 18 09.12.15 07:46 Сейчас в теме
(30) iolko, Да, я как раз выбрал первый способ!
Теперь я задумался над авторизацией пользователя, для открытия доступа к командам бота.
Никто не знает, как можно пограммно провести аудентификацию пользователя?
33. iolko 266 09.12.15 08:58 Сейчас в теме
(31) TreeDogNight, Легко... если пользователь отправляет команду, допустим MyId - то отправляешь ему Его ID дальше ручками вносишь ее в спр пользователи.
а потом уже, чтобы отсеить ненужных проверяешь если ChatId есть в спр пользователей - велком , если нет ну не судьба тогда )))

Это первый вариант - при котором можно использовать первый вариант получения обновлений.

2 вариант - придумка для корпоративных систем (с которым нужно использовать второй вариант получения обновлений) - запрос на добавление, запоминаем ID и просим ввести адрес корпоративной почты, отправляем на этот адрес какой то сгенерированый ПИН, и ждем подтверждения.
Kireno; TreeDogNight; +2 Ответить
34. TreeDogNight 18 09.12.15 20:12 Сейчас в теме
(33) iolko, Интересные варианты реализации) Пока что решил просто сравнивать логин и пароль, с твердо прописанными в коде значениями=) А так, в сообщении выше, я имел виду аудентификацию в 1С уже существующих пользователей. На данный момент я склоняюсь к мнению, что осуществить это невозможно, так как пароль пользователя прочитать нельзя...
35. eskor 92 10.12.15 09:55 Сейчас в теме
(34) TreeDogNight, я пока эксперименты отложил, но в первом варианте сделал таблицу разрешенных пользователей и чатов, плюс лог всех входящих сообщений. Нужных добавляешь, остальные в игноре.
TreeDogNight; +1 Ответить
48. Vigor06 14.04.16 12:19 Сейчас в теме
(31) TreeDogNight, Ну и Вам адресую этот вопрос)

Есть ли варианты кроме перебора дерева с поиском значения message_id?
49. PLAstic 263 25.04.16 10:11 Сейчас в теме
(48) Vigor06, если сформулируешь вопрос точнее, вероятно, сможет помочь более широкий круг.
47. Vigor06 14.04.16 12:02 Сейчас в теме
(30) iolko, а можно чуть поподробнее,как полученные двоичные данные загнать массив?
36. vmannoor 20.12.15 22:44 Сейчас в теме
(24) eskor,
Можно использовать "%0D%0A" Вместо Символы.ПС
37. eskor 92 22.12.15 11:17 Сейчас в теме
(36) vmannoor, да, это оно. Теперь переносы расставляются корректно!!! Спасибо.
26. TreeDogNight 18 05.12.15 10:29 Сейчас в теме
Теперь у меня встал новый вопрос. Как вывести клавиатуру?

Как я понял, мы должны передать в метод sendMessage сериализованную JSON-структуру, но к сожалению примеров этой структуры нигде не приводится...
28. TreeDogNight 18 07.12.15 19:04 Сейчас в теме
Уже пробовал использовать запрос POST, сделал так:
Соединение  = Новый HTTPСоединение(Объект.Сервер,443,,,,,Новый ЗащищенноеСоединениеOpenSSL());		 
Заголовки   = Новый Соответствие;
Заголовки.Вставить("reply_markup", ТекстJSON);
Запрос	    = Новый HTTPЗапрос(Ресурс, Заголовки);
Ответ	    = Соединение.ОтправитьДляОбработки(Запрос);

Где ТекстJSON равен:
[
{
"Да": "Так точно!"
},
{
"Нет": "Никак нет"
}
]

Но к сожалению клавиатура не появилась... Либо текст JSON неправильно сформировали, либо его нужно сувать не в заголовки...
29. TreeDogNight 18 07.12.15 21:25 Сейчас в теме
Всё, наконец разобрался с этой клавиатурой!
Оказывается текст с параметрами нужно было приклеить к строке с ресурсмом и установить как тело запроса!
Вот код:
&НаСервереБезКонтекста
Функция ПолучитьКлавиатуру()

	ГлавныйМассив = Новый Массив;
	
	МассивКнопок = Новый Массив;
	МассивКнопок.Добавить("Так точно!");
	МассивКнопок.Добавить("Никак нет!");
	ГлавныйМассив.Добавить(МассивКнопок);
	
	МассивКнопок = Новый Массив;
	МассивКнопок.Добавить("Я подумаю...");
	ГлавныйМассив.Добавить(МассивКнопок);
	
	ПутьКФайлу = ПолучитьИмяВременногоФайла("txt"); 	
	
	Структура = Новый Структура;
	Структура.Вставить("keyboard"			, ГлавныйМассив);
	Структура.Вставить("one_time_keyboard"	, Истина);
	
	Файл = Новый ТекстовыйДокумент;
	Файл.Записать(ПутьКФайлу, "UTF-8");
	
	ЗаписьJSON = Новый ЗаписьJSON;
	ЗаписьJSON.ОткрытьФайл(ПутьКФайлу);
	ЗаписатьJSON(ЗаписьJSON, Структура);
	ЗаписьJSON.Закрыть();
	
	Файл.Прочитать(ПутьКФайлу, "UTF-8");
	
	ТекстJSON = Файл.ПолучитьТекст();
	ТекстJSON = СтрЗаменить(ТекстJSON, "Истина", "True");
	
	Возврат ТекстJSON;

КонецФункции

&НаСервере
Процедура ОтправитьСообщение(chat_id, ТекстСообщения, СтилизованныйТекст = Ложь, ОтображатьСсылки = Ложь, IDСообщенияДляОтвета = 0, Клавиатура = "")
	
	ПараметрыЗапроса = "?chat_id=" + Формат(chat_id, "ЧГ=0") + "&text=" + ТекстСообщения;
	
	Если СтилизованныйТекст = Истина Тогда 
		ПараметрыЗапроса = ПараметрыЗапроса + "&parse_mode=Markdown";	
	КонецЕсли;
	
	Если ОтображатьСсылки = Истина Тогда 
		ПараметрыЗапроса = ПараметрыЗапроса + "&disable_web_page_preview=True";	
	КонецЕсли;
	
	Если IDСообщенияДляОтвета > 0 Тогда 
		ПараметрыЗапроса = ПараметрыЗапроса + "&reply_to_message_id=" + Формат(IDСообщенияДляОтвета, "ЧГ=0");	
	КонецЕсли;
	
	Если Не ПустаяСтрока(Клавиатура) Тогда 
		ПараметрыЗапроса = ПараметрыЗапроса + "&reply_markup="+Клавиатура;	
	КонецЕсли;
			                                                    
	Ресурс 		= "bot" + Объект.Токен + "/sendMessage"+ПараметрыЗапроса;
	Соединение  = Новый HTTPСоединение(Объект.Сервер,443,,,,,Новый ЗащищенноеСоединениеOpenSSL());	      
	Запрос		= Новый HTTPЗапрос(Ресурс);
	Запрос.УстановитьТелоИзСтроки(ПараметрыЗапроса);
	Ответ		= Соединение.ОтправитьДляОбработки(Запрос);          
	
КонецПроцедуры
Показать
Kireno; maksa2005; mevgenym; AlX0id; JohnyDeath; ui69; rayastar; Renegade; Anchoret; madonov; METAL; WanGoff; _also; Luchik; eskor; +15 Ответить
161. user853472 25.02.18 22:11 Сейчас в теме
Подскажите как вывести фото с кнопками обратной связи?

Фото получается отослать, а вот вывести вместе с клавиатурой вообще никак....

////КЛАВИАТУРА
				клСтруктура = Новый Структура;
				мСтрок = Новый Массив;
				мКнопок = Новый Массив;
				мКнопок.Добавить(Новый Структура("text, callback_data", "В корзину", Блюдо.Ссылка.Код));
				мСтрок.Добавить(мКнопок);	
				клСтруктура.Вставить("inline_keyboard",мСтрок);
				ЗаписьJSON = Новый ЗаписьJSON;
				ЗаписьJSON.УстановитьСтроку();  //Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет,,,ЭкранированиеСимволовJSON.СимволыВнеASCII)  
				ЗаписатьJSON(ЗаписьJSON,клСтруктура,,);
				Клавиатура = ЗаписьJSON.Закрыть();
				
				ТекстДляОтправки = ТекстДляОтправки + "--" +  Boundary + Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + "Content-Disposition: form-data; name=""reply_markup""" + Символы.ПС + Символы.ПС;    
				ТекстДляОтправки = ТекстДляОтправки + СокрЛП(Клавиатура) + Символы.ПС;
Показать
32. iolko 266 09.12.15 07:53 Сейчас в теме
Легко... если пользователь отправляет команду, допустим MyId - то отправляешь ему Его ID дальше ручками вносишь ее в спр пользователи.
а потом уже, чтобы отсеить ненужных проверяешь если ChatId есть в спр пользователей - велком , если нет ну не судьба тогда )))
TreeDogNight; +1 Ответить
38. TreeDogNight 18 23.12.15 05:06 Сейчас в теме
 HTTPЗапрос.Заголовки.Вставить("Content-Type", "multipart/form-data; boundary="+Boundary);

Какой нужно указывать Content-Type если передаешь фото или видео?
39. iolko 266 21.01.16 17:16 Сейчас в теме
Всем придоброго. Не уверен, что модераторы пропустят отдельный пост, по этому отпишу так. С 1Си Telegram разобрался, отчеты, логи статусы и пр отсылает. Но вот решил дома прикрутить. Итог... возможности: Выключить комп, сделать снимок с камеры и передать, принять торрент файл и скачать его, запустить upnp сервак для того чтобы посмотреть его на smart tv.

Автору статьи - миль пардон, надеюсь не удалит комент. Если кому то нужны сорцы - пишите. Все на python. Скрипт в автозагрузке, работает на ура.
40. maxx 917 22.01.16 16:43 Сейчас в теме
Здорово. Но файл отправить всё-таки не получилось, по отладке отправляет, ошибок нет, но файл не приходит.

Всё-так получилось к функции отправки нужно ещё добавить:
Таб.Записать(ИмяФайла,ТипФайлаТабличногоДокумента.XLSX);


также обернуть число chat_id в обертку
 ТекстДляОтправки = ТекстДляОтправки + СтрЗаменить(Формат(chat_id, "ЧДЦ=; ЧС=; ЧРГ=."), ".", "") + Символы.ПС;
rayastar; +1 Ответить
42. PLAstic 263 09.03.16 11:08 Сейчас в теме
(40) maxx, ой, да, ещё вот это недоразумение
СтрЗаменить(Формат(chat_id, "ЧДЦ=; ЧС=; ЧРГ=."), ".", "")

надо исправить на следующее:
Формат(Выборка.chat_id, "ЧГ=")
41. PLAstic 263 02.03.16 16:17 Сейчас в теме
Небольшие оптимизации.

Можно получать из HTTPОтвет и просто текст, а не двоичные данные:

В процедуре ПоказатьСообщения текст
	ДвоичныеДанныеОтвета = Ответ.ПолучитьТелоКакДвоичныеДанные();

заменить на:
	ТекстовыеДанныеОтвета = Ответ.ПолучитьТелоКакСтроку();


Теперь можно вызывать процедуру ПрочитатьДвоичныеДанныеОтвета, передавая ей текстовую строку. Зачем? Чтобы не записывать эти двоичные данные в файл и не читать из него назад:

Процедура ПрочитатьДвоичныеДанныеОтвета(ДвоичныеДанныеОтвета)
            ИмяФайла = ПолучитьИмяВременногоФайла("tgm");
            ДвоичныеДанныеОтвета.Записать(ИмяФайла);
            ДеревоЗн = Новый ДеревоЗначений();
            //{Для версии 1С 8.3.6 и выше
            ЧтениеJSON = Новый ЧтениеJSON();
            ЧтениеJSON.ОткрытьФайл(ИмяФайла);

заменить на:
Процедура ПрочитатьДвоичныеДанныеОтвета(ТекстовыеДанныеОтвета)
	ДеревоЗн = Новый ДеревоЗначений();
	ЧтениеJSON = Новый ЧтениеJSON();
	ЧтениеJSON.УстановитьСтроку(ТекстовыеДанныеОтвета);


Испытал удивление от потэгового анализа JSON. Есть функция ПрочитатьJSON(), которая в структурированном виде считывает весь пакет:

	ЧтениеJSON = Новый ЧтениеJSON();
	ЧтениеJSON.УстановитьСтроку(ТекстовыеДанныеОтвета);
	Результат = ПрочитатьJSON(ЧтениеJSON);
	ЧтениеJSON.Закрыть();

	Если НЕ Результат.ok Тогда
		Возврат;
	КонецЕсли;

	СписокЗапросов = Результат.result;
	Для каждого Запрос Из СписокЗапросов Цикл
		...
	КонецЦикла;
Показать
mpeg1989; Anchoret; 7OH; drjc; biformatus; Luchik; +6 Ответить
43. Crush 10.03.16 12:13 Сейчас в теме
Спасибо! Изложено легко и понятно. Получилось с первого раза.
44. Dobermann86 30.03.16 07:40 Сейчас в теме
Кто нибудь подскажет как ботом получить файл(или фото) в 1С и дальше сохранить его на HDD?
45. Dobermann86 30.03.16 13:00 Сейчас в теме
//Определение имён файла и пути файла криво написано. Но это на скорую руку чтобы проверить.
//Сильное не пинайте. Если получится скачивать файлы тогда и оформлю.

//getfile - Определение пути файла по id_file
https://api.telegram.org/bot<Токен>/getfile?file_id=<ид_файла>;
//file - Прямая ссылка на файл
https://api.telegram.org/file/bot<Токен>/photo\/file_1.jpg
Процедура СкачатьФайл(id_file);
		////////////////////////////////////////////////////////////­///////////////// Определение пути к файлу
		Ресурс = "/bot" + Токен + "/getfile?file_id=" + id_file;
		Соединение  =  Новый HTTPСоединение(Сервер,443,,,,,Новый ЗащищенноеСоединениеOpenSSL());
		
		Запрос = Новый HTTPЗапрос(Ресурс);
		Ответ = Соединение.Получить(Запрос);
		
		ДДСО= Ответ.ПолучитьТелоКакСтроку();//ДвоичныеДанныеСтрокаОтвета 
		
		Если Найти(ДДСО,"photo\") Тогда
			ПутьКФалу = Сред(Сред(ДДСО, Найти(ДДСО,"""file_path""") +13 ,1024),0,СтрДлина(Сред(ДДСО, Найти(ДДСО,"""file_path""") +13 ,1024))-3);
			ИмяСохраненияДляФайла = Сред(Сред(Сред(ДДСО, Найти(ДДСО,"""file_path""") +13 ,1024),0,СтрДлина(Сред(ДДСО, Найти(ДДСО,"""file_path""") +13 ,1024))-3),8,1024);
		
                ИначеЕсли Найти(ДДСО,"document\") Тогда
			ПутьКФалу = Сред(Сред(ДДСО, Найти(ДДСО,"""file_path""") +13 ,1024),0,СтрДлина(Сред(ДДСО, Найти(ДДСО,"""file_path""") +13 ,1024))-3);
			ИмяСохраненияДляФайла = Сред(Сред(Сред(ДДСО, Найти(ДДСО,"""file_path""") +13 ,1024),0,СтрДлина(Сред(ДДСО, Найти(ДДСО,"""file_path""") +13 ,1024))-3),11,1024);

		КонецЕсли;

                ////////////////////////////////////////////////////////////­///////////////// Скачивание самого файла
		
		Ресурс = "/file/bot" + Токен + "/" + ПутьКФалу;

		Соединение  =  Новый HTTPСоединение(Сервер,443,,,,,Новый ЗащищенноеСоединениеOpenSSL());
		
		HTTPЗапрос = Новый HTTPЗапрос(Ресурс);
		
		//И вот тут ступор возвращаемые значения 404 и т.д.
		//с http дел не имел. Не знаю что думать.
	        //можно Соединение.Получить(HTTPЗапрос, "C:\" + ИмяСохраненияДляФайла); - но получается файл с ошибкой 404 в нутри
КонецПроцедуры;
Показать
50. PLAstic 263 25.04.16 10:25 Сейчас в теме
(45) Немного оптимизации:
1) надо получить file_path
2) надо принять файл с этим file_path

Сначала получаем всю инфу о файле. Например, это текстовый документ.
Информация о файле в сообщении получается так:
Документ = ДанныеЗапроса.message.document;

Далее строим запрос, имея file_id этого файла:
Ресурс = "bot" + Объект.Токен + "/getFile?file_id=" + Документ.file_id;

В ответ приходит JSON, который парсим стандартно:
Соединение = Новый HTTPСоединение(Объект.Сервер, 443,,,,, Новый ЗащищенноеСоединениеOpenSSL());
Запрос = Новый HTTPЗапрос(Ресурс);
Ответ = Соединение.Получить(Запрос);
ТекстовыеДанныеОтвета = Ответ.ПолучитьТелоКакСтроку();

ЧтениеJSON = Новый ЧтениеJSON();
ЧтениеJSON.УстановитьСтроку(ТекстовыеДанныеОтвета);
Результат = ПрочитатьJSON(ЧтениеJSON);
ЧтениеJSON.Закрыть();

Если НЕ Результат.ok Тогда
  Сообщить("Что-то пошло не так...");
  Возврат;
КонецЕсли;
ПутьКФайлу = Результат.result.file_path;
Показать

Теперь, имея file_path, полученный из структуры, как сказано в апи, "описывающей подготовленный к скачиванию файл", мы можем его скачать:
Ресурс = "file/bot" + Объект.Токен + "/" + ПутьКФайлу;
Соединение = Новый HTTPСоединение(Объект.Сервер, 443,,,,, Новый ЗащищенноеСоединениеOpenSSL());
Запрос = Новый HTTPЗапрос(Ресурс);
Ответ = Соединение.Получить(Запрос);
ТекстовыеДанныеОтвета = Ответ.ПолучитьТелоКакСтроку();

Обращаю внимание, что метод ПолучитьТелоКакСтроку() актуален только для текстовых файлов. В остальных случаях надо получать бинарные данные и записывать их в файл. В нашем же случае переменная ТекстовыеДанныеОтвета будет содержать текст файла.
artb; Renegade; drjc; +3 Ответить
126. rayastar 65 28.06.17 18:07 Сейчас в теме
46. Dobermann86 30.03.16 13:50 Сейчас в теме
Допетрил.
Процедура СкачатьФайл(id_file);
        ////////////////////////////////////////////////////////////­///////////////// Определение пути к файлу
        Ресурс = "/bot" + Токен + "/getfile?file_id=" + id_file;
        Соединение  =  Новый HTTPСоединение(Сервер,443,,,,,Новый ЗащищенноеСоединениеOpenSSL());
        
        Запрос = Новый HTTPЗапрос(Ресурс);
        Ответ = Соединение.Получить(Запрос);
        
        ДДСО= Ответ.ПолучитьТелоКакСтроку();//ДвоичныеДанныеСтрокаОтвета 
        
        Если Найти(ДДСО,"photo\") Тогда
            ПутьКФалу = Сред(Сред(ДДСО, Найти(ДДСО,"""file_path""") +13 ,1024),0,СтрДлина(Сред(ДДСО, Найти(ДДСО,"""file_path""") +13 ,1024))-3);
            ИмяСохраненияДляФайла = Сред(Сред(Сред(ДДСО, Найти(ДДСО,"""file_path""") +13 ,1024),0,СтрДлина(Сред(ДДСО, Найти(ДДСО,"""file_path""") +13 ,1024))-3),8,1024);
        
                ИначеЕсли Найти(ДДСО,"document\") Тогда
            ПутьКФалу = Сред(Сред(ДДСО, Найти(ДДСО,"""file_path""") +13 ,1024),0,СтрДлина(Сред(ДДСО, Найти(ДДСО,"""file_path""") +13 ,1024))-3);
            ИмяСохраненияДляФайла = Сред(Сред(Сред(ДДСО, Найти(ДДСО,"""file_path""") +13 ,1024),0,СтрДлина(Сред(ДДСО, Найти(ДДСО,"""file_path""") +13 ,1024))-3),11,1024);

        КонецЕсли;

                ////////////////////////////////////////////////////////////­///////////////// Скачивание самого файла
        
        Ресурс = "htpps://" + Сервер + "/file/bot" + Токен + "/" + СтрЗаменить(ПутьКФалу,"\","/");
           КопироватьФайл(Ресурс,"C:\" + ИмяСохраненияДляФайла); 

КонецПроцедуры;
Показать
rayastar; +1 Ответить
125. rayastar 65 28.06.17 16:58 Сейчас в теме
(46)
Ресурс = "htpps://" + Сервер + "/file/bot" + Токен + "/" + СтрЗаменить(ПутьКФалу,"\","/");
КопироватьФайл(Ресурс,"C:\" + ИмяСохраненияДляФайла);


Приветствую!
делаю по Вашему подобию, но возникает ошибка при скачивании:

{ВнешняяОбработка.Telegram.Форма.ФормаУпр.Форма(145)}: Ошибка при вызове метода контекста (КопироватьФайл): Ошибка копирования файлов: Неправильный путь к файлу 'htpps://api.telegram.org/file/bot***/documents/file_19.txt'. Схема не зарегистрирована

ругается вот здесь:
КопироватьФайл(Ресурс,"C:\" + ИмяСохраненияДляФайла);

в чем может быть проблема?
127. PLAstic 263 28.06.17 18:36 Сейчас в теме
(125) За такой код надо руки отрывать автору в (46). Что пытаетесь сделать?
51. =Kollega= 1 19.05.16 14:51 Сейчас в теме
Хорошая статья, доходчиво и понятно. Правда до всего практически дошел сам, курением над FAQ-ом и методом проб и ошибок. Единственное уточнение - файл в формате excel отправленный ботом, приходит немного битым. Excel, конечно его восстанавливает, но осадок остается.
Проблема в объединении файлов, а точнее в последнем файле-окончании. Мы открываем его в UTF-формате, что приводит к записи 3-х дополнительных байт идентификаторов формата. В итоге файл приходит именно с этими 3-мя лишними байтами. Для некоторых файлов может это и не критично и незаметно, но Excel 2012 ругается на поврежденный файл.
Проблему решил просто - окончание открываю в формате ANSI, а не UTF.
52. Vigor06 27.05.16 15:09 Сейчас в теме
(51) =Kollega=, о,это хорошая помощь!
Но у меня все равно экселька в таком виде приходит...


Сохраняю как xls, офис 2013й

Как победить можно?какие кодировки попробовать?
53. Vigor06 30.05.16 10:54 Сейчас в теме
(52) Vigor06, разобрался)
Строку
ТабДок.Записать(ИмяФайла,"xls");

заменил на
ТабДок.Записать(ИмяФайла,ТипФайлаТабличногоДокумента.XLS);
54. foralex2004 14.06.16 12:26 Сейчас в теме
Уважаемые форумчане.
Был бы признателен за пример чтения сервиса Telegram, когда ты не не являешься владельцем бота.
Т.е. тебе не известен токен бота.
Например я хочу считывать данные как пользователь у бота StrafyBot.
Спасибо.
55. PLAstic 263 16.06.16 23:36 Сейчас в теме
(54) foralex2004, Никак. Если бы можно было так легко читать сообщения, то какая тут приватность?
56. foralex2004 20.06.16 17:19 Сейчас в теме
Я же могу через WEB с ботом общаться, почему не могу посредством API?
Прикрепленные файлы:
57. eskor 92 20.06.16 17:48 Сейчас в теме
(56) foralex2004, читай описание. Здесь обсуждается управление СВОИМ ботом из 1С. Хочешь общаться с другим ботом - без проблем, получи его ID и заставь своего бота обращаться к другому.
58. Punk 22.06.16 15:15 Сейчас в теме
(57) eskor, Боты не могут видеть сообщения от других ботов. Сделано в целях защиты от бесконечной рекурсии. (По крайней мере в справке так написано)
61. eskor 92 22.06.16 23:02 Сейчас в теме
(58) Punk, я не скажу, что могут или не могут видеть, по моему это лишнее. Принципиально, каждый из респондентов имеет свой id, и на запрос бот отвечает тому же id. Сам ботов не "дружил", но что мешает проверить? Механика процессов простая, я сменил место работы, сейчас другие проекты и задачи, так что проверить не на чем.
59. Punk 22.06.16 15:30 Сейчас в теме
Доброго времени суток уважаемые форумчане!
Подскажите пожалуйста, если кто работал через webhook, как можно установить вебхук имея самоподписанный сертификат?
Или если конкретнее, как указать второй параметр certificate?

Делаю примерно так:

Сервер            = "api.telegram.org";
АдресБазы      = "https://<MойСервер>:8443/<МояБаза>/hs/<МойСервис>/";	
АдресВебХука = АдресБазы<ТокенБота>;	
Команда          = "setWebhook";
Ресурс             = "bot"<ТокенБота> + "/" + Команда + "?url=" + АдресВебХука + "&certificate=C:\ИмяСертификата.pem";	
	
Соединение = Новый HTTPСоединение(Сервер, 443,,,,,Новый ЗащищенноеСоединениеOpenSSL);
	
Запрос = Новый HTTPЗапрос(Ресурс); 
	
Ответ = Соединение.Получить(Запрос); 
Показать


В ответ приходит что вебхук успешно установлен, но сообщения на http-сервис не идут. :(
60. Luchik 583 22.06.16 16:25 Сейчас в теме
(59) Punk, В переменной Ресурс не надо указывать адрес к файлу сертификата, но указать сертификат в конструкторе Новый HTTPСоединение().
примерно так (сейчас не имею возможности посмотреть в синтакс-помощнике):
Сертификат = Новый СертификатКлиентаФайл("C:\ИмяСертификата.pem");//вторым параметром можно указать пароль файла клиентского сертификата
ssl = Новый ЗащищенноеСоединениеOpenSSL(Сертификат);
Соединение = Новый HTTPСоединение(Сервер, 443,,,,,ssl);
62. Punk 23.06.16 10:46 Сейчас в теме
(60) Сделал как вы сказали. Но увы, http сервис все равно молчит.
Пробовал указывать сертификат с паролем и без.
Тестовый Http сервис использует метод Post и просто создает новый элемент справочника.
При отправке запроса на данный сервис с помощью утилиты "Fiddler 4" получаем ответ с кодом 200 и имеем новый элемент справочника.

Может есть какие подводные камни о которых необходимо знать?
81. biformatus 26.08.16 19:08 Сейчас в теме
(59) Punk, Получилось в итоге? Как вообще получить pem сертификат. Сертификат вообще делал по статье http://infostart.ru/public/146288/.
137. Al-77 75 22.09.17 15:07 Сейчас в теме
(59) Добрый день. вы победили сертификаты ?
64. Luchik 583 07.08.16 13:11 Сейчас в теме
Предположу, что это может произойти по причине того, что история хранится за определенный период (т.е. сообщения пользователей остались в удаленном периоде)
65. DanilaDru 255 08.08.16 14:46 Сейчас в теме
(64) Спасибо, этот вопрос решил. Была история зачищена.

А кто-то решал задачу идентификации ? Вот пришёл мне от бота запрос, я вижу что это какой-то id пользователя телеграмма.

А как-то получалось достучаться до номера телефона ? Например я по номеру телефона понимаю что это за контрагент и даю ему текстовое представление по его заказам в системе.
66. Luchik 583 12.08.16 14:48 Сейчас в теме
(65) DanilaDru, идентификация у меня осуществляется по регистру сведений; Id, сотрудник. Получить номер телефона бот не может - прочитайте все возможные функции API Телеграма - https://core.telegram.org/
67. eskor 92 15.08.16 09:49 Сейчас в теме
(66) телефон получить не может, а вот имя и никнейм запросто, я так и запускал пользователей. Пишу в лог все обращения, нужным даю доступ.
68. PLAstic 263 16.08.16 12:05 Сейчас в теме
(65) DanilaDru, (67) eskor, мне кажется, удобнее было бы сделать так: клиент регается у бота (не важно, как конкретно: либо любое новое сообщение боту и бот предлагает зарегаться, или же специальная команда вроде /regme). Когда он регается у бота, то указывает свой ИНН, мыло или телефон - любую КИ, которая содержится у вас в базе и может использоваться для идентификации контрагента.
Далее вы этому заявленному, но не подтверждённому контрагенту, проверив его наличие по базе, шлёте сообщение вроде "Вы или кто-то от вашего имени пытается зарегаться у нашего бота. Если это вы, введите код подтверждения такой-то". Код подтверждения - например, 4хзначное число. Бот в это время, конечно, ожидает код подтверждения, записанный, например, в РС. Как только он его получает, привязываем ид пользователя телеграм к контрагенту в базе. Можно завести его видом КИ и привязывать как к контрагенту, так и его контактным лицам.
69. eskor 92 17.08.16 09:30 Сейчас в теме
(68) PLAstic, чисто технически реализовать легко. Возможно, где-то и есть надобность массовой регистрации. Конкретно в моем случае, бот использовался для получения оперативной информации. Соответственно, пользователей использующих бот было не больше 2х десятков и больше не планировалось. Я, конечно, упростил механизм управления доступом(для себя любимого), но дальше развиваться было некуда.
Для сторонних клиентов все равно придется использовать СМС шлюз, а следовательно смысл бота для сторонних пользователей является избыточным.
70. marat.coolls 17.08.16 12:07 Сейчас в теме
Не подскажите, как можно осуществить следующее. Боту пишут в телеграмм задание текстовое, а он сохраняет его в 1с в отдельный документ(задачи).
71. PLAstic 263 17.08.16 21:45 Сейчас в теме
(70) marat.coolls, Статья именно об этом. Пишете бота, который анализирует присылаемые сообщения и по какому-нибудь признаку выделяет из них задачи и записывает в базу 1С.
marat.coolls; +1 Ответить
72. marat.coolls 18.08.16 08:26 Сейчас в теме
(71) Я пробовал сделать все по инструкции. Но бот никак не реагирует на команды, да и приветствие не выводит. Токен и имя правильно написал, т.к 1с ка показывает когда я писал и мой ID. Но ни приветствия от бота, ни списка команд нет. В чем может быть проблема?
73. Luchik 583 18.08.16 09:28 Сейчас в теме
(72) marat.coolls, а регламентное задание точно выполняется?
74. marat.coolls 18.08.16 09:34 Сейчас в теме
(73) Через отладчик посмотрел, после заполнения дерева ничего не выполняется. Но код ведь тот же. В чем проблема не пойму , уже два дня мучаюсь.
75. eskor 92 18.08.16 09:51 Сейчас в теме
(74) marat.coolls, последовательность выполнения на стороне 1С:
1. Получить набор сообщений бота с хоста telegramm.
2. Обработать полученные данные.
3. Кому необходимо - отправить сообщения на хост telegramm.
Соответственно все форматы должны соответствовать.
Чудес не бывает, проверяй лучше.
76. marat.coolls 18.08.16 10:40 Сейчас в теме
(75) eskor, Тут все работает и автор все написал правильно? если да, то у меня тоже все соответствует. Потому что мой метод Ctrl+c Ctrl+v
77. PLAstic 263 18.08.16 16:00 Сейчас в теме
(76) marat.coolls, там есть ручная однократная проверка сообщений для бота и рег.задание. Попробуй ручками, что будет?
*я плохо помню оригинал из статьи, но в моей версии это точно есть и оно работает
78. eskor 92 19.08.16 09:00 Сейчас в теме
(76) marat.coolls, я использовал куски кода из примера, реализовывал на обычных формах, плюс навешивал кучу функций сверху из разряда регистрации обращений и выполнения, справочника на несколько ботов, справочника выполняемых функций и т.п. Запустил все это где-то в январе, с тех пор работает как часы, добавляю только функции в справочник и пользователей в доступ.
79. marat.coolls 19.08.16 10:16 Сейчас в теме
Я рад ,что у вас получилось. Но я спрашивал в чем может быть проблема в этом коде? Ведь у меня не работает. Я новичок. Не понимаю, что вы написали PLAstic
80. marat.coolls 19.08.16 14:37 Сейчас в теме
Как сделать, чтобы русские буквы тоже отображались в тексте?
82. Baser 5 14.09.16 03:35 Сейчас в теме
Эксперименты провожу. В строку для отправки добавил следующее:
&text=текст%20и%20прочая%20лабуда&reply_markup={"request_contact":"true","keyboard":[["lexcon2","true","firefox"],["Вторая%20строка"],["Третья%20Строка"]]}

В итоге появляются кнопки для быстрой отправки команд. (3 кнопки в верхней строке, и по одной в двух нижних).
Вопрос: что нужно передать и как, чтобы картинки появись в кнопках? (как в @fabrikabot)

Прикрепленные файлы:
Оставьте свое сообщение

См. также

Конвертация данных Парус 7, 10 - ЗУП 2.5, ЗИКБУ 1.0, КА 1.1, УПП Промо

Внешние источники данных Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 КА1 ЗУП2.5 УПП1 БГУ Россия БУ Госбюджет Абонемент ($m)

Перенос данных Парус 7, 10 - ЗУП 2.5, ЗИКБУ 1.0, КА 1.1, УПП Переносит данные сотрудника, физического лица и начисления за произвольный период

1 стартмани

10.06.2014    32813    38    kns77    81    

Вебхук. Путь Телеграма

Внешние источники данных Интеграция v8 Абонемент ($m)

Долгое (на самом деле нет) и нелегкое путешествие телеграма к неведомым (из за РКН) конфигурациям 1С. Памятка себе.

1 стартмани

03.10.2019    18359    platonov.e    26    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    25596    22    Stepa86    46    

Вам нравятся запросы в 1С?

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    21201    5    m-rv    88    

Загрузка данных из М-Аптеки+ в 1С:Бухгалтерия 8 (ред. 3.0) Промо

Внешние источники данных Файловые протоколы обмена, FTP v8 v8::БУ БП3.0 Фармацевтика, аптеки БУ Абонемент ($m)

Обработка для загрузки файлов выгрузки из программы для автоматизации аптек и аптечных сетей М-Аптека+ в 1С:Бухгалтерия 8, редакция 3.0.

11.07.2014    35379    31    1C_MApteka    37    

Мониторинг показателей систем 1С 8.3 с помощью Zabbix

Внешние источники данных Zabbix v8 1cv8.cf Абонемент ($m)

Опишу свой опыт мониторинга наших систем 1С с помощью Zabbix и ту пользу, которую можно извлечить из этого.

1 стартмани

05.10.2018    41551    58    akimych    48    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    22134    13    RocKeR_13    16    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    38779    56    dsdred    17    

Менеджер загрузки данных из весов с печатью этикеток Промо

Внешние источники данных Весы Учет ТМЦ Учет ТМЦ v8 УТ10 УПП1 Абонемент ($m)

Программное обеспечение "Менеджер загрузки данных из весов с печатью этикеток" предназначено для автоматического получения данных по сети Ethernet из весов МАССА-К моделей ВПМ и ТВ_Р3 (модификация MF) в режиме On-Line.

1 стартмани

20.12.2011    22948    4    hrip    10    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    28650    26    informa1555    26    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    49120    17    kalyaka    16    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар")

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    30891    86    m-rv    57    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    28245    71    vasvl123    9    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    31724    11    SITR-utyos    13    

Чтение и запись из таблиц гугл (google sheets) в табличный документ 1С (8.3, управляемые формы)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка на управляемой форме для 1С версии 8.3 для доступа к сервисам Google Sheets c использованием протокола авторизации OAuth 2.0. Выполняет получение списка листов таблицы гугл, чтение таблицы гугл в табличный документ 1С и запись из табличного документа 1С в таблицу гугл. Тестирование проводилось на платформе 1С:Предприятие 8.3 (8.3.11.2954).

1 стартмани

09.04.2018    40986    273    Ko1t    76    

[ВсеПросто] "Оперативный" информатор из 1С за 5 мин.

Практика программирования v8 Бесплатно (free)

Быть всегда в курсе дел, даже в дороге!

22.02.2018    26563    DarkAn    25    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    52187    35    ildarovich    41    

Заполняем по шаблону (по умолчанию)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    28718    19    mvxyz    17    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    27433    54    kwazi    6    

Паузы при исполнении кода (Sleep для 1С)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

1 стартмани

28.11.2017    47156    12    swimdog    42    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    33265    132    PLAstic    59    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    23179    21    sasha777666    63    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    132686    13    signum2009    48    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    31942    113    romasna    49    

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Возможности Google Cloud Vision в распознавании текста.

1 стартмани

08.02.2017    30096    127    kiv1c    18    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    37077    95    json    25    

Что нам стоит Push построить

Внешние источники данных v8 v8::Mobile Абонемент ($m)

Попробовал некоторое время назад, push сообщения, реализованные в платформе. Понравилось, но есть несколько минусов, на примере одной программы сообщений (не буду показывать пальцем), спустя некоторое время, сообщения переставали приходить онлайн, а на компьютере приходили моментально, при этом сами смартфоны звались флагманами. Читал позднее статью, где описывалось, что проблема на стороне смартфонов, что-то вроде технологий энергосбережения, но точно не помню. Также немалый минус доступно только для смартфонов.

1 стартмани

08.09.2016    28054    17    PloAl    8    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    48593    36    Demanoidos    60    

Подсистема обмена данными с порталом ИМНС по электронным счетам-фактурам (автоматический обмен)

Внешние источники данных WEB Инструментарий разработчика v8 1cv8.cf Беларусь БУ НДС Абонемент ($m)

Подсистема включает документы и обработки для автоматического обмена данными с порталом ИМНС через web-сервис. Присутствует возможность заполнения данными типовых операций за период, учёта входящих документов, учёта произвольных исходящих документов. Приложены обработки для запуска задания планировщика на автоматический обмен данными.

1 стартмани

28.07.2016    34058    19    c1nil    4    

 Интеграция 1С и C#. Обращение к 1С через COM. Создание номенклатуры и выполнение запроса к 1С из C# на примере интеграции с Союз-PLM (система информационной поддержки жизненного цикла изделий). Обработка «Загрузка заказа на сборку». (ERP)

Загрузка и выгрузка в Excel Внешние источники данных Интеграция v8 ERP2 Абонемент ($m)

Союз-PLM представляет собой полнофункциональный программный комплекс для решения  широкого спектра задач управления инженерной технической информацией наукоемких изделий и сложных инженерных объектов в области машиностроения, приборостроения, архитектуры, строительства. На практике, это управление конструкторской документацией, интегрированное с САПР, бизнес-процессы, файловый архив. Все это работает в SQL и шевелится с помощью скриптов на C#. Скрипты свободно  отлаживаются в MS Visual Studio. Подробнее смотрите на их сайте: http://www.programsoyuz.ru/products/system-soyuz-plm.html  Редактирование, конструирование и использование бизнес-процессов на порядок лучше систем на базе 1С из тех, что я изучил.

1 стартмани

25.07.2016    45848    5    milkers    2    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    58255    10    wowik    32    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    62684    184    rozer    65    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    59969    19    arakelyan    19    

Еще один способ расчета остатков на каждый день в запросе

Математика и алгоритмы Практика программирования v8 Абонемент ($m)

Предлагается новый способ расчета остатков на каждый день (час, минуту, секунду) в запросе. Способ не требует предварительного формирования таблицы дат и также подходит для расчета курсов валют, цен номенклатуры и других периодических сведений на каждую дату периода. На больших объемах данных предлагаемый способ может превосходить по быстродействию ранее известные методы из-за линейной (в лучшем случае) зависимости трудоемкости от длины периода.

1 стартмани

24.04.2016    35003    49    ildarovich    23    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    82237    160    igo1    54    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    18587    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    50682    53    yuraos    17    

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    56198    179    balanton    23    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    23660    8    Tatitutu    5    

Модуль для работы 1С (платформа 8.2 и выше) с внешними SOAP Web-сервисами

Внешние источники данных WEB Интеграция v8 1cv8.cf Абонемент ($m)

Модуль для работы 1С (платформа 8.2 и выше) с внешними Web-сервисами, реализованными по протоколу SOAP.

2 стартмани

15.02.2016    40289    84    lunjio    15    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    37449    20    milkers    4    

Оформление ветеринарных документов на продукты питания и грядущие глобальные изменения в 1С (часть 1)

Внешние источники данных Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 Сельское хозяйство и рыболовство Оптовая торговля, дистрибуция, логистика Пищевая промышленность УУ Абонемент ($m)

С 01 января 2016 года возможно оформление ветеринарно-сопроводительных документов в электронном виде. Что это означает для предприятий, производящих и торгующих подконтрольной продукцией?

3 стартмани

27.12.2015    62001    7    axxell    28    

Самый простой клиент ЕГАИС УТМ для розницы. $m

Внешние источники данных Рабочее место Розничная торговля Розничная торговля v8 1cv8.cf Россия УУ Абонемент ($m)

Данная обработка позволяет обеспечить приходную часть магазина розничной торговли алкоголем(ЕГАИС розница), или прочего предприятия. Эти действия становятся обязательными для розничного звена в городских поселениях с 01.01.2016 и будут достаточными до 01.07.2016. Предлагаю Вашему вниманию простое и доступное решение, которое позволяет отсрочить проблему интеграции ЕГАИС в розничное звено до указанной даты. (открытый код). Реализовано на открытой модели http://infostart.ru/public/402052/.

2 стартмани

14.12.2015    39557    45    Terrain25    47