Просмотр объектов очереди сообщений в 1С:Документооборот

29.01.24

Задачи пользователя - Адаптация типовых решений

В базах с бесшовной интеграцией с 1С:Документооборот есть Регистр сведений "Очередь сообщений в 1С:Документооборот". Для пользователя он мало информативен. Расширение позволяет просматривать сообщение в человеческом виде. И понимать проблему до объекта.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Расширение: Просмотр объектов очереди сообщений в 1С:Документоборот (Версия 01.08.2022):
.cfe 12,83Kb
27
27
2 SM
Скачать Купить за 2 150 руб.

Ценность в том, что можно видеть, с каким именно документом выдает проблему интеграция и перейти к фиксации ошибки на конкретных данных (в типовом варианте объект с ошибкой не виден).

Навигационная ссылка на регистр: e1cib/list/РегистрСведений.ОчередьСообщенийВ1СДокументооборот

Типовой вид:

 

 

Дополненный вид (закладка Дополнительно):

 

 

Листинг кода вывода данных XML:

&НаКлиенте
Процедура росд__СписокПриАктивизацииСтрокиПосле(Элемент)
	
	ТекстДанных.Очистить();
	
	ТекущиеДанные = Элементы._Список.ТекущиеДанные;
	
	Если ТекущиеДанные <> Неопределено Тогда
		ИмяВФ = ПолучитьИмяВременногоФайла("xml");
		росд_ПолучитьДанныеСообщения(ТекущиеДанные.Идентификатор, ТекущиеДанные.МоментВремени);
	КонецЕсли;
	
КонецПроцедуры

&НаСервере
Функция росд_ПолучитьДанныеСообщения(Идентификатор, МоментВремени)
	
	Данные = "";
	
	МЗ = РегистрыСведений.ОчередьСообщенийВ1СДокументооборот.СоздатьМенеджерЗаписи();
	МЗ.Идентификатор = Идентификатор;
	МЗ.МоментВремени = МоментВремени;
	МЗ.Прочитать();
	
	Если МЗ.Выбран() = Истина Тогда
		Данные = МЗ.Данные.Получить();
		ИмяВФ = ПолучитьИмяВременногоФайла("xml");
		Данные.Записать(ИмяВФ);
		ТекстДанных.Прочитать(ИмяВФ);
		УдалитьФайлы(ИмяВФ);
	КонецЕсли;
	
	Возврат Данные;
	
КонецФункции

Проверялось на:

1С:ERP Управление предприятием 2 (2.4.14.181)

1С:ERP Управление предприятием 2 (2.5.8.207)

 

 
 Как подключить расширение к базе 1С
 
 Другие публикации автора

Ссылка на компетенции по 1С:ERP - команда со знаниями, умениями и успешными проектами.

Проверено на следующих конфигурациях и релизах:

  • 1С:ERP Управление предприятием 2, релизы 2.5.15.103

Документооборот очередь сообщений бесшовная интеграция просмотр XML

См. также

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    5143    11    5    

20

Логистика, склад и ТМЦ Адаптация типовых решений Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3523    8    0    

27

Адаптация типовых решений Программист Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Абонемент ($m)

Каждый из нас сталкивается с ситуацией, когда какой-нибудь менеджер показывает свой Excel и рассказывает, как он что-то из 1С копирует в него, снабжает пояснениями, выделяет цветом и т.д. и т.п. Заканчивается все просьбой сделать вот чтобы также было в 1С. И оказывается такой человек (почти с гарантией) либо лучшим продажником, либо каким-то важным, за все отвечающим, - на ком все держится.

2 стартмани

22.04.2024    4718    dimanich70    15    

20

БСП (Библиотека стандартных подсистем) Адаптация типовых решений Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 Бесплатно (free)

Понадобилось в подменю "Создать на основании" добавить свою команду, которая открывает обработку. В процессе доработок появилась проблема двух подменю "Создать на основании". В статье о том, как решились проблемы.

01.03.2024    3586    dimanich70    8    

16

Адаптация типовых решений Программист Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Доработка типового отчета "Связанные документы" позволяет просто и быстро расширять состав объектов для построения структуры подчиненности документов, используя объекты основной конфигурации и любых расширений.

1 стартмани

27.10.2023    2780    21    avmartynov    14    

53

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2856    43    progmaster    8    

4
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. aximo 2055 02.08.22 13:52 Сейчас в теме
спасибо. понятно назначение
что-то делал подобное для фискальных операций в рознице - https://infostart.ru/public/1311937/
2. triviumfan 95 02.08.22 22:58 Сейчас в теме
Поидее он же чисто для служебного пользования, отладки, т.е. для программистов, ничего полезного для обычных пользователей он не скажет.
sapervodichka; +1 Ответить
3. sapervodichka 6865 02.08.22 23:09 Сейчас в теме
(2) так и есть (>_<) он для "необычных пользователей"
Maxim_Zuev; Torin; +2 Ответить
4. LomayaZakat 08.08.22 08:41 Сейчас в теме
Листинг под современные нужды:
&НаКлиенте
Процедура НЕО_СписокПриАктивизацииСтрокиПосле(Элемент)
	
	ТекстДанных.Очистить();
	ТекущиеДанные = Элементы.Список.ТекущиеДанные;
	
	Если ТекущиеДанные <> Неопределено Тогда
		ИмяВФ = ПолучитьИмяВременногоФайла("xml");
		ПолучитьДанныеСообщения(ТекущиеДанные.Идентификатор, ТекущиеДанные.ДатаСоздания);
	КонецЕсли; 
	
КонецПроцедуры   

&НаСервере
Процедура ПолучитьДанныеСообщения(Идентификатор, ДатаСоздания)
	
	Данные = "";
	
	НаборЗаписей = РегистрыСведений.ОчередьСообщенийВ1СДокументооборот.СоздатьНаборЗаписей();
	НаборЗаписей.Отбор.Идентификатор.Установить(Идентификатор);
	НаборЗаписей.Прочитать();
	
	Для Каждого Строка из НаборЗаписей Цикл
		Данные = Строка.Данные.Получить();
		ИмяВФ = ПолучитьИмяВременногоФайла("xml");
		Данные.Записать(ИмяВФ);
		ТекстДанных.Прочитать(ИмяВФ);
		УдалитьФайлы(ИмяВФ);
	КонецЦикла;
	
КонецПроцедуры
Показать
Оставьте свое сообщение